Subject: Re: [PWE3] Generic PW - Is there a need?

From: Luca Martini <[email-masked]>
Date: Fri, 10 Feb 2006 15:02:55 -0700

Stewart Bryant wrote:
> Gray, Eric wrote:
>
>> Danny,
>>
>>     As a clarification question, since it appears that the
>> intent is to carry multiple different types of traffic using
>> a generic pseudowire, is the intent to negotiate the carried
>> packet type, or would this be indicated by code points in the
>> pseudowire encapsulation format?
>>  
>>
> That is up to the WG to define.
>
> My preverence would be the latter - i.e. to indicate within
> the pw encap.
>
However the current architecture precludes this.
There is no was to indicate the packet content in the PW packet.
Are we to change the PWE3 architecture now ?
Luca

> - Stewart
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 13 Feb 2006 08:21:28 +0000

> However the current architecture precludes this.

Where does it say this in RFC3985?

> There is no was to indicate the packet content in the PW packet.

Agreed and that would need to be fixed if we proceed with this.

> Are we to change the PWE3 architecture now ?

See above.

- Stewart

---

From: Luca Martini <[email-masked]>
Date: Thu, 16 Feb 2006 11:36:42 -0700

> Where does it say this in RFC3985?
 in Figure 1.

          +---------------------------+
          |         Payload           |
          +---------------------------+
          |      Encapsulation        | <==== may be empty
          +---------------------------+
          |     PW Demultiplexer      |
          +---------------------------+
          |     PSN Convergence       | <==== may be empty
          +---------------------------+
          |           PSN             |
          +---------------------------+
          |         Data-Link         |
          +---------------------------+
          |          Physical         |
          +---------------------------+

                    Figure 1.  Logical Protocol Layering Model

and many other places - there is no "Protocol ID" , other then in the 
control protocol where we identify the protocol as the PW type.

Luca