Subject: RE: [PWE3] Generic PW - Is there a need?

From: "Florin Balus" <[email-masked]>
Date: Mon, 13 Feb 2006 10:06:34 -0500

Hi Luca,

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Luca Martini
>Sent: Friday, February 10, 2006 5:37 PM
>To: Danny McPherson
>Cc: pwe3 pwe3
>Subject: Re: [PWE3] Generic PW - Is there a need?
>
>
>Danny McPherson wrote:
>>
>> Folks,
>> We would like to start a discussion on whether the PWE3
>> WG should work on the definition of a generic packet PW.
>Danny,
>
>I believe that there is a need for the IP PW that we 
>originally defined, 
>However I have a problem with defining a true multiprotocol 
>PW. PWE3 WG has an existing architecture , and within this 
>architecture we 
>do not have a PID in the PW packet. This was a choice made in the 
>beginning to allow hardware implementations to be simpler. In MPLS we 
>can bind any meaning we want to a label. So , for example  we 
>dynamically bind  the meaning "ethernet packet" to label 44. Then we 
>know that is we receive label 44 we must decode an ethernet 
>header.
>

I believe there is a need for a multiprotocol PW as we want some flows
to share really the same path: i.e. I want the IP data packets to follow
the same path as the IS-IS protocol that provides the routing exchanges.
There could be also simplifications related to the fact that an
enterprise customer will not need to buy different PWs for each
encapsulation if the resulted connections go between the same 2 sites:
IPv4, IPv6, IS-IS etc... Think also about PWs as uplinks for Managed CE
<Virtual> Routing not only just for ACs...

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Luca Martini <[email-masked]>
Date: Thu, 16 Feb 2006 11:53:22 -0700

> <Virtual> Routing not only just for ACs...

Are you talking about having some kind of layer3 PW ?
what next ? a TCP PW , an UDP PW , and a Rip PW ?

The IS-IS case is a black sheep indeed , as we are using an non IP 
protocol to route IP.
As I explained before the answer for that is to use the true layer2 
protocol, not an IP PW.

Luca