Subject: RE: [PWE3] Generic PW - Is there a need?

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 13 Feb 2006 18:41:48 +0200

Florin and all,
One of my personal problems with a "generic packet PW" is that it is
suggested as a single "silver bullet" solution for many different problems.

I believe that one problem in this space is well defined in Himanshu's
work on ARP mediation. But I am not sure the other ones are equally
well defined.

So maybe we should start with a more accurate definition of the problem
space in order to understand whether it can and should be covered by a
single
solution.

Regards,
			Sasha

> -----Original Message-----
> From: Florin Balus [mailto:[email-masked]]
> Sent: Monday, February 13, 2006 5:07 PM
> To: Luca Martini; Danny McPherson
> Cc: pwe3 pwe3
> Subject: RE: [PWE3] Generic PW - Is there a need?
> 
> 
> Hi Luca,
> 
> >-----Original Message-----
> >From: [email-masked] [mailto:[email-masked]] On 
> >Behalf Of Luca Martini
> >Sent: Friday, February 10, 2006 5:37 PM
> >To: Danny McPherson
> >Cc: pwe3 pwe3
> >Subject: Re: [PWE3] Generic PW - Is there a need?
> >
> >
> >Danny McPherson wrote:
> >>
> >> Folks,
> >> We would like to start a discussion on whether the PWE3
> >> WG should work on the definition of a generic packet PW.
> >Danny,
> >
> >I believe that there is a need for the IP PW that we 
> >originally defined, 
> >However I have a problem with defining a true multiprotocol 
> >PW. PWE3 WG has an existing architecture , and within this 
> >architecture we 
> >do not have a PID in the PW packet. This was a choice made in the 
> >beginning to allow hardware implementations to be simpler. 
> In MPLS we 
> >can bind any meaning we want to a label. So , for example  we 
> >dynamically bind  the meaning "ethernet packet" to label 44. Then we 
> >know that is we receive label 44 we must decode an ethernet 
> >header.
> >
> 
> I believe there is a need for a multiprotocol PW as we want some flows
> to share really the same path: i.e. I want the IP data 
> packets to follow
> the same path as the IS-IS protocol that provides the routing 
> exchanges.
> There could be also simplifications related to the fact that an
> enterprise customer will not need to buy different PWs for each
> encapsulation if the resulted connections go between the same 2 sites:
> IPv4, IPv6, IS-IS etc... Think also about PWs as uplinks for 
> Managed CE
> <Virtual> Routing not only just for ACs...
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Scott W Brim <[email-masked]>
Date: Mon, 13 Feb 2006 11:52:41 -0500

> space in order to understand whether it can and should be covered by a

What would you say in the charter, then?