Subject: RE: [PWE3] BFD for MPLS PWs

From: "Sasha Vainshtein" <[email-masked]>
Date: Wed, 9 Aug 2006 18:00:23 +0200

Tom,
For the sake of clarity:

Did you intended to say 

	"except where the PW control plane is used to setup the control (a.k.a. "associated") channel?

In which case I fully agree with you.

Regards,
                    Sasha

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: Wednesday, August 09, 2006 4:45 PM
> To: Mustapha Aissaoui
> Cc: 'Luca Martini'; 'pwe3 WG ((((E-mail))))'; Sasha Vainshtein
> Subject: Re: [PWE3] BFD for MPLS PWs
> 
> 
> 
> 	The PW's control channel is orthogonal to
> the control plane used to setup the PW (if it
> exists) except where the control channel is used
> to setup the control channel.
> 
> 	--Tom
> 
> > Luca,
> > We already have code points 0x04 and 0x08 for the cases below. The  
> > only
> > justification I could find for not wanting to use an IP control  
> > channel for
> > BFD over a PW is because some implementation may not use an 
> IP control
> > plane, and thus no LDP.
> >
> > Mustapha.
> >
> >> -----Original Message-----
> >> From: Luca Martini [mailto:[email-masked]]
> >> Sent: Tuesday, August 08, 2006 7:16 PM
> >> To: Mustapha Aissaoui
> >> Cc: 'Thomas D. Nadeau'; 'pwe3 WG ((((E-mail))))'; 'Sasha 
> Vainshtein'
> >> Subject: Re: [PWE3] BFD for MPLS PWs
> >>
> >> Mustapha,
> >>
> >> I do not agree with your slightly wider statement "an IP
> >> control plane may not exist for these implementations". We
> >> never said this.
> >> What we said is that the Ip header is superfluous for this
> >> particular application.
> >> The PW status messaging is required by RFC4447 ( the WG
> >> insisted on the MUST at the time ), so the VCCV should always
> >> use PW status, and may use  BFD status additionally.
> >>
> >> Option 4 is therefore required.
> >>
> >> Luca
> >>
> >>
> >> Mustapha Aissaoui wrote:
> >>> Tom and Sasha,
> >>> I do not see the need to add a CV type for the following:
> >>> 4) BFD (without IP headers) + status
> >>>
> >>> The argument used so far was that an IP control plane may 
> not exist
> >>> for these implementations. Thus, we should restrict the new
> >>> encapsulation to work without PW status notifications only.
> >>>
> >>> Mustapha.
> >>>
> >>>> -----Original Message-----
> >>>> From: Thomas D. Nadeau [mailto:[email-masked]]
> >>>> Sent: Tuesday, August 01, 2006 1:51 PM
> >>>> To: Sasha Vainshtein
> >>>> Cc: pwe3 WG ((((E-mail))))
> >>>> Subject: Re: [PWE3] BFD for MPLS PWs
> >>>>
> >>>>
> >>>> On Aug 1, 2006, at 1:07 PM, Sasha Vainshtein wrote:
> >>>>
> >>>>> Tom,
> >>>>> I've snipped the long discussion to make your summary and
> >>>> my response
> >>>>> clearly readable:
> >>>>>
> >>>>> ... snipped ...
> >>>>>>  Lets forget about the LSP ping mode for a second.
> >>>>>> For BFD there are currently 2 options:
> >>>>>> 1) BFD
> >>>>>> or
> >>>>>> 2) BFD + status codes.
> >>>>>> What is being proposed are 4 options now:
> >>>>>>
> >>>>>> 1) BFD (with IP headers)
> >>>>>> 2) BFD (with IP headers) + status
> >>>>>> 3) BFD (without IP headers)
> >>>>>> 4) BFD (without IP headers) + status.
> >>>>>>
> >>>>>> The intent was for options 1/2 to function as-specified
> >> today. The
> >>>>>> latter two are the optimized modes that are useful for
> >> those using
> >>>>>> the latest MPLS CW.
> >>>>>>
> >>>>>> 	--Tom
> >>>>> [Sasha] This short text clarifies the proposal, it's a
> >> pity we ahve
> >>>>> not started from this point.
> >>>>>
> >>>>> Now my question:
> >>>>>
> >>>>> Would it be correct to say that, where applicable, the
> >> actual OA&M
> >>>>> functionality (i.e. ability to detect and trouble-shoot PW
> >>>>> connectivity
> >>>>> problems)  provided by
> >>>>> options (3) and (4) is exactly the same as one provided 
> by options
> >>>>> (1) and (2)
> >>>>> respectively, while applicability scope of options (1) 
> and (2) is
> >>>>> strictly wider than that of (3) and (4)?
> >>>> 	I don't see why this matters. All 4 have their place.
> >>>>
> >>>> 	--Tom
> >>>>
> >>>>
> >>>>> Regards,
> >>>>>                         Sasha
> >>>> _______________________________________________
> >>>> pwe3 mailing list
> >>>> [email-masked]
> >>>> https://www1.ietf.org/mailman/listinfo/pwe3
> >>>>
> >>>
> >>>
> >>> _______________________________________________
> >>> pwe3 mailing list
> >>> [email-masked]
> >>> https://www1.ietf.org/mailman/listinfo/pwe3
> >>
> >> _______________________________________________
> >> pwe3 mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/pwe3
> >>
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 9 Aug 2006 11:57:01 -0400

> In which case I fully agree with you.

	If (control plane is used to setup the PW)
		use it to set up the control channel;
	else // When it is not available...
		(manually establish the PW and
			manually establish the control channel);

	--Tom