Subject: RE: [PWE3] BFD for MPLS PWs

From: "Sasha Vainshtein" <[email-masked]>
Date: Wed, 30 Aug 2006 09:43:22 +0200

Tom and all,
Please see a couple of brief comments inline below.

I've snipped parts of the text that are not relevant for these comments.

Regards,
                     Sasha 

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2006 8:01 PM
> To: Danny Prairie (dprairie)
> Cc: George Swallow (swallow); Carlos Pignataro (cpignata); 
> Monique Morrow (mmorrow); [email-masked]; [email-masked]; Rahul 
> Agarwal (rahagarw); Stewart Bryant (stbryant)
> Subject: Re: [PWE3] BFD for MPLS PWs
> 
> 
> 
> 	Hi Danny,
> 
> 	Thanks for reviewing. Comments below.
> 
> > Just received this E-mail. I have a few comments on version 
> 10 of the
> > draft:
> >
> > 1. The following is stated in the draft:
> >
> >    4.3. TTL Expiry VCCV (Type 3)
> >
> >    The TTL of the PW label can be set to 1 to force the packet to be
> >    processed within the destination router's control plane. This is
> >    an inband control channel identification mechanism that is an
> >    alternate to section 4.1.
> >
> >    To use this type, the control word MUST be used.
> >
> > I was wondering the reason for the last statement? I would have  
> > expected
> > to see MUST NOT.
> 
> 	I think this is a typo; should be "MOST NOT".
>
[Sasha] This looks as replacing an original typo with another one.
And, BTW, why do you prohibit usage of the TTL expiry method for PWs that
use a CW? I agree that it is not the best choice, but there is nothing in it
that would not work (or not work) differently for PWs with and without PWs.
IMHO the appropriate form would be "SHOULD NOT".
... snipped ...
> 
> > 3. Why is it stated in the draft that use of router alert label is
> > preferred over TTL expiry? I would have assumed the 
> opposite. In fact,
> > the current code for XR picks TTL expiry over RA label.
> 
> 	That is a mistake I fixed in version 11 (to be published).
> The RA mode should be the least preferred mode.
>
[Sasha] Please not that the Router Alert mode would work for MS-PWs as well as for SS-PWs,
while setting TTL to 1 would only support SS-PWs (or a single segment of a MS-PW).
IMHO there is a difference between the logic used by the router to decide that a certain packet must be 
sent to the control plane and the functional preference of different methods to denote a VCCV packet,
As long as both mechanisms (TTL expiry and Router Alert) are supported, Router Alert seems preferable to me.
... snipped to the end ...

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 30 Aug 2006 08:48:28 -0400

> IMHO the appropriate form would be "SHOULD NOT".

	The idea is to make this protocol as easy to build
and deploy as possible, so we have tried to make appropriate
restrictions wherever possible. I can live with "SHOULD NOT".

> sent to the control plane and the functional preference of  
> different methods to denote a VCCV packet,
> As long as both mechanisms (TTL expiry and Router Alert) are  
> supported, Router Alert seems preferable to me.
	
	I disagree. In all cases, use of the RA mode MAY result
in data plane handling that differs from that of the PW. It is
only intended for use in special circumstances, and its use will
hopefully go away with time. In particular, it is useful in
cases where the CW is not supported by older hardware. But in
these cases, one has to be VERY careful to understand the
load-sharing behavior of a network to ensure that the VCCV
packets take the same path as the PW data.  For this reason,
it is IMHO the LEAST preferred mode.

	--Tom