Subject: Re: [PWE3] BFD for MPLS PWs

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 30 Aug 2006 10:43:21 -0400

On Aug 30, 2006, at 10:30 AM, Sasha Vainshtein wrote:

> Tom and all,
> Please see some responses inline below.
> Snipped the parts where we seem to be in full agreement.
>
> Regards,
>                  Sasha
>
>> -----Original Message-----
>> From: Thomas D. Nadeau [mailto:[email-masked]]
>> Sent: Wednesday, August 30, 2006 2:48 PM
>> To: Sasha Vainshtein
>> Cc: George Swallow (swallow); Carlos Pignataro (cpignata);
>> Monique Morrow (mmorrow); [email-masked]; [email-masked]; Rahul
>> Agarwal (rahagarw); Stewart Bryant (stbryant); Danny Prairie
>> (dprairie)
>> Subject: Re: [PWE3] BFD for MPLS PWs
>>
>>
>>
>> On Aug 30, 2006, at 3:43 AM, Sasha Vainshtein wrote:
>>
>>> Tom and all,
>>> Please see a couple of brief comments inline below.
>>>
>>> I've snipped parts of the text that are not relevant for these
>>> comments.
>>>
>>> Regards,
>>>                      Sasha
>>>
>>>> -----Original Message-----
>>>> From: Thomas D. Nadeau [mailto:[email-masked]]
>>>> Sent: Tuesday, August 29, 2006 8:01 PM
>>>> To: Danny Prairie (dprairie)
>>>> Cc: George Swallow (swallow); Carlos Pignataro (cpignata);
>>>> Monique Morrow (mmorrow); [email-masked]; [email-masked]; Rahul
>>>> Agarwal (rahagarw); Stewart Bryant (stbryant)
>>>> Subject: Re: [PWE3] BFD for MPLS PWs
> ... snipped...
>>>>
>>>>> 3. Why is it stated in the draft that use of router alert label is
>>>>> preferred over TTL expiry? I would have assumed the
>>>> opposite. In fact,
>>>>> the current code for XR picks TTL expiry over RA label.
>>>>
>>>> 	That is a mistake I fixed in version 11 (to be published).
>>>> The RA mode should be the least preferred mode.
>>>>
>>> [Sasha] Please not that the Router Alert mode would work for MS-PWs
>>> as well as for SS-PWs,
>>> while setting TTL to 1 would only support SS-PWs (or a single
>>> segment of a MS-PW).
>>> IMHO there is a difference between the logic used by the router to
>>> decide that a certain packet must be
>>> sent to the control plane and the functional preference of
>>> different methods to denote a VCCV packet,
>>> As long as both mechanisms (TTL expiry and Router Alert) are
>>> supported, Router Alert seems preferable to me.
>> 	
>> 	I disagree. In all cases, use of the RA mode MAY result
>> in data plane handling that differs from that of the PW. It is
>> only intended for use in special circumstances, and its use will
>> hopefully go away with time. In particular, it is useful in
>> cases where the CW is not supported by older hardware. But in
>> these cases, one has to be VERY careful to understand the
>> load-sharing behavior of a network to ensure that the VCCV
>> packets take the same path as the PW data.  For this reason,
>> it is IMHO the LEAST preferred mode.
>>
> [Sasha] Can you please explain what you mean by "older hardware"?
> MHO the problem is somewhat different. For better or worse, usage  
> of the CW has been defined as
> OPTIONAL in the following cases:
>
> o Ethernet PWs (RFC 4448)
> o ATM Cell PWs in the mandatory N:1 encapsulation mode (draft-ietf- 
> pwe3-atm-encap-11).
>
> To the best of my knowledge, there is substantial deployment of  
> both services, and, at least with
> Ethernet PWs, the deployed services do not use the CW.

	I would say "some deployed services" as I know of
many that do, specifically because they want VCCV to
function predictably.

> I have not noticed, so far, any intention in the WG to revoke these  
> documents in order to make
> usage of the CW mandatory. And retrofitting deployed services to  
> match new standards is problematic in any case.
>
> This is why we need, IMHO, alternative methods of carrying VCCV in  
> PWs for the foreseeable future.
>
> These methods are problematic, but let's look at these problems:
> o TTL expiry simply cannot work for end-to-end OAM of MS-PWs  
> (unless you know the number of hops and
>     can guarantee that it is constant). To me this makes it highly  
> problematic
> o RA may result in VCCV packets not going over the same path as  
> data packets. This will happen if:
>    - ECMP is employed (this is a real situation) AND
>    - ECMP uses hashing of the label stack (and not of the IP header  
> below the label stack).
>
> I am not sure if the latter is a real situation in the deployed  
> networks. If it is, the best solution would be to
> exclude reserved labels from the ECMP hashing (this has been  
> discussed many times in the MPLS WG).
>
> Hence, IMO, the comparison is between a 100% real and non-solvable  
> problem (TTL expiry) and a potential
> (possibly non-existing) and fixable problem.
>
> Which would you choose?

	I am not interested in providing band-aid
after band-aid solutions for cases where people want to have
their cake and eat it too, but don't want to bake the cake
at the right temperature first, and thus might or might
not get a cake to eat. If you want to do something, use the right
tool for the job. If you want OAM, IMHO you should use
the CW, all of the aforementioned problems go away and
things work as expected.

	--Tom

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Sasha Vainshtein" <[email-masked]>
Date: Wed, 30 Aug 2006 16:30:53 +0200

Tom and all,

Regards,
                 Sasha

... snipped...
[Sasha] Can you please explain what you mean by "older hardware"?
MHO the problem is somewhat different. For better or worse, usage of the CW has been defined as 
OPTIONAL in the following cases:

o Ethernet PWs (RFC 4448)
o ATM Cell PWs in the mandatory N:1 encapsulation mode (draft-ietf-pwe3-atm-encap-11).

To the best of my knowledge, there is substantial deployment of both services, and, at least with
Ethernet PWs, the deployed services do not use the CW.

I have not noticed, so far, any intention in the WG to revoke these documents in order to make
usage of the CW mandatory. And retrofitting deployed services to match new standards is
problematic in any case.

This is why we need, IMHO, alternative methods of carrying VCCV in PWs for the foreseeable future.

These methods are problematic, but let's look at these problems:
o TTL expiry simply cannot work for end-to-end OAM of MS-PWs (unless you know the number of hops and
    can guarantee that it is constant). To me this makes it highly problematic
o RA may result in VCCV packets not going over the same path as data packets. This will happen if:
   - ECMP is employed (this is a real situation) AND
   - ECMP uses hashing of the label stack (and not of the IP header below the label stack).

I am not sure if the latter is a real situation in the deployed networks. If it is, the best solution would be to
exclude reserved labels from the ECMP hashing (this has been discussed many times in the MPLS WG).

Hence, IMO, the comparison is between a 100% real and non-solvable problem (TTL expiry) and a potential
(possibly non-existing) and fixable problem.

Which would you choose?

> 	--Tom
> 
> 
> >>
> > ... snipped to the end ...
>

---

From: Luca Martini <[email-masked]>
Date: Wed, 30 Aug 2006 12:17:48 -0600

Sasha,
A comment  below.
Luca

> (possibly non-existing) and fixable problem.
The RA mode of course .

I think that the TTL expiry more has very little chance to work, as a 
lot of networks have policies about copying down the TTL value.

I think the RA mode should be preferred over the TTL expiry mode.

Luca