Subject: [PWE3] Fwd: New Liaison Statement, "IP protocol number for PW using RFC 4023"

From: Danny McPherson <[email-masked]>
Date: Mon, 21 Aug 2006 15:10:29 -0600

FYI...

-danny

Begin forwarded message:

> From: Georges Sebek (ITU-T SG 13) <[email-masked]>
> Date: August 21, 2006 10:07:27 AM MDT
> To: [email-masked], [email-masked], [email-masked], [email-masked]
> Cc: [email-masked], [email-masked],  
> [email-masked], [email-masked], [email-masked],  
> [email-masked], [email-masked]
> Subject: New Liaison Statement, "IP protocol number for PW using  
> RFC  4023"
> Reply-To: [email-masked], [email-masked]
>
>
> Title: IP protocol number for PW using RFC 4023
> Submission Date: 2006-08-21
> URL of the IETF Web page: https://datatracker.ietf.org/public/ 
> liaison_detail.cgi?detail_id=254
> Please reply by 2006-09-29
>
> From: Georges Sebek(ITU-T SG 13) <[email-masked]>
> To: IETF MPLS WG and PEW3 WG([email-masked], [email-masked],  
> [email-masked], [email-masked])
> Cc: [email-masked]
> [email-masked]
> [email-masked]
> [email-masked]
> Reponse Contact: [email-masked]
> [email-masked]
> Technical Contact: [email-masked]
> Purpose: For action
> Body:
> Attachment(s):
>      IP protocol number for PW using RFC 4023 (https:// 
> datatracker.ietf.org/documents/LIAISON/file351.pdf)
>
>
>

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 22 Aug 2006 15:30:19 +0200

Hi all, 

We have discussed the basic issue in the past.

Rahul brought it up at IETF58 (draft-raggarwa-pwe3-pw-over-ip)
and the majority there thought the technique obvious enough
not to require a WG draft.

Mark T has also discussed this
http://www.nanog.org/mtg-0402/pdf/townsley.pdf.

I believe that we should answer that protocol number 137
is satisfactory for a PW packet without an MPLS header.

Y(J)S

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 22 Aug 2006 14:51:08 -0400

Yaakov,

I agree that protocol number 137 is correct, but to be precise, the 
PW packet does have an MPLS header with a PW label, it just doesn't 
have a tunnel label, because that's been replaced by the IP header.

I added the MPLS WG on this reply since the liaison was sent to both 
WGs, and in fact I think the return liaison should be generated by 
the MPLS WG, since it was the source of RFC 4023.

Cheers,
Andy

----------

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 23 Aug 2006 08:45:16 +0200

Andy, 

As you know (as we have discussed this before),
by "without  MPLS header" I meant "without MPLS tunnel label"
but with a PW label.

Y(J)S

-----Original Message-----
From: Andrew G. Malis [mailto:[email-masked]] 
Sent: Tuesday, August 22, 2006 20:51
To: Yaakov Stein
Cc: Danny McPherson; pwe3 WG ((((((((E-mail)))))))); [email-masked]
Subject: RE: [PWE3] Fwd: New Liaison Statement, "IP protocol number for
PW using RFC 4023" 

Yaakov,

I agree that protocol number 137 is correct, but to be precise, the PW
packet does have an MPLS header with a PW label, it just doesn't have a
tunnel label, because that's been replaced by the IP header.

I added the MPLS WG on this reply since the liaison was sent to both
WGs, and in fact I think the return liaison should be generated by the
MPLS WG, since it was the source of RFC 4023.

Cheers,
Andy

----------

At 8/22/2006 15:30 +0200, Yaakov Stein wrote:
>Rahul brought it up at IETF58 (draft-raggarwa-pwe3-pw-over-ip) and the 
>majority there thought the technique obvious enough not to require a WG

>draft.
>I believe that we should answer that protocol number 137 is 
>satisfactory for a PW packet without an MPLS header.
>
>Y(J)S