Subject: [PWE3] One question on draft -Dynamic Placement of Multi-segment PWs

From: "Dutta, Pranjal" <[email-masked]>
Date: Thu, 10 Aug 2006 14:31:08 +0530

Hi All,

           The following is from section "7.2.3 Detailed Signaling
Procedures" 

in draft - Dynamic Placement of Multi Segment Pseudo Wires. In step iv.
in the 

forwarding direction of MS-PW setup, it is said that if a S-PE is unable
to set 

up the PSN Tunnel to next or previous hop, it MUST sent Label Withdraw
to previous

S-PE or T-PE. But till this point in forward direction after following
all steps 

i,ii,iii no label is assigned yet to previous hop S-PE or T-PE by "this"
S-PE. 

Then why do we need to send the label withdraw? Please help me
understand if I 

am missing something. 

"

For the forward direction:

        -i. Determine the next hop S-PE or T-PE according to the

            procedures above.

       -ii. Check that a PSN tunnel exists to the next hop S-PE or T-PE.

            If no tunnel exists to the next hop S-PE or T-PE the S-PE

            MAY attempt to setup a PSN tunnel.

      -iii. Check that a PSN tunnel exists to the previous hop. If no

            tunnel exists to the previous hop S-PE or T-PE the S-PE MAY

            attempt to setup a PSN tunnel.

 

Martini, et al.                                                [Page 12]

Internet Draft    draft-ietf-pwe3-dynamic-ms-pw-01.txt         June 2006

       -iv. If the S-PE cannot get enough PSN resources to setup the

            segment to the next or previous S-PE or T-PE, a label

            withdraw MUST be returned to the T-PE with a status message

            of "Resources Unavailable".  "

Thanks,

Pranjal

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Sasha Vainshtein" <[email-masked]>
Date: Thu, 10 Aug 2006 12:49:31 +0200

Pranjal and all,

I assume that the text should say "label RELEASE" (wrt to the label received from the previous S-PE or T-PE).

Could the authors of the draft confirm?

Regards,

                      Sasha

________________________________

From: Dutta, Pranjal [mailto:[email-masked]]
Sent: Thu 10/08/2006 12:01
To: [email-masked]
Subject: [PWE3] One question on draft -Dynamic Placement of Multi-segment PWs

Hi All,

           The following is from section "7.2.3 Detailed Signaling Procedures" 

in draft - Dynamic Placement of Multi Segment Pseudo Wires. In step iv. in the 

forwarding direction of MS-PW setup, it is said that if a S-PE is unable to set 

up the PSN Tunnel to next or previous hop, it MUST sent Label Withdraw to previous

S-PE or T-PE. But till this point in forward direction after following all steps 

i,ii,iii no label is assigned yet to previous hop S-PE or T-PE by "this" S-PE. 

Then why do we need to send the label withdraw? Please help me understand if I 

am missing something. 

"

            procedures above.

 

 

 

 

Thanks,

Pranjal

---

From: Luca Martini <[email-masked]>
Date: Thu, 10 Aug 2006 11:54:53 -0600

Yes you are correct it should read "Label release".
I will correct the text in the next version.
Thanks.
Luca

Dutta, Pranjal wrote:
>
> Hi All,
>
> The following is from section “7.2.3 Detailed Signaling Procedures”
>
> in draft – Dynamic Placement of Multi Segment Pseudo Wires. In step 
> iv. in the
>
> i,ii,iii no label is assigned yet to previous hop S-PE or T-PE by 
> “this” S-PE.
>
> “
> -iv. *If the S-PE cannot get enough PSN resources to setup the*
>
> * segment to the next or previous S-PE or T-PE, a label*
>
> * withdraw MUST be returned to the T-PE with a status message*
>
> * of "Resources Unavailable*". “
>
> Thanks,
>
> Pranjal
>
> ------------------------------------------------------------------------
>