Subject: RE: [PWE3] BFD for MPLS PWs

From: "Sasha Vainshtein" <[email-masked]>
Date: Tue, 1 Aug 2006 09:31:53 +0200

Tom and all,
Please see some comments inline below.
I've snipped parts of the original thread to make it readable.

Regards,
                   Sasha

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: Monday, July 31, 2006 10:48 PM
> To: Rahul Aggarwal
> Cc: Yaakov Stein; [email-masked]
> Subject: Re: [PWE3] BFD for MPLS PWs
> 
> 
> 
> > Hi Tom,
... snipped ...
> 
> 	The reasons that were explained during the meeting:
> 
> 	1) sending the IP/UDP header is redundant
> 		for SH PWs because the labels or outer l2tpv3 header
> 		ID the VCCV payload.
>
[Sasha] This is only correct if the PW uses a CW. Not all of them do.
> 
> 	2) If you include the 127/ dest. address, then it is 
> useless other
> 		than it prevents errant routing if the PW header
> 		is inadvertently stripped.  However, skipping the
> 		IP header altogether obviates both problems. It
> 		also makes each VCCV/BFD packet shorter.
>
[Sasha] Can you please explain how skipping the IP header  solves
the problem of the PW label being popped in an inappropriate place?
>
> 	2) sending the IP/UDP header is useless for MH PWs because
> 		the MH PW addressing scheme will not fit into
> 		an IPv4 address.  Instead, the outer PW encapsulation
> 		identifies the destination.
>
[Sasha] IMHO Nothing in the IP/UDP proposal prevents you from using IPv6 headers/addresses as
IPv4 and IPv6 packets are easily discriminated using the Version field.
To the best of my recollection, the IPv4 and IPv6 addressing schemes are explicitly
allowed for MS-PWs, and I have not seen any realistic alternative proposals.
I also do not think that the "outer PW encapsulation" defines the packet destination
in MS-PWs.
> 
> 	3) the secondary routing header lookup/processing is
> 		a waste of processing cycles since it should
> 		always result in the receiving PE. The outer
> 		header identifies the PW packet already.
>
[Sasha] Can you please explain how to you see LSP-Ping being used in VCCV without IP/UDP headers?
> 
> 	Conversations with everyone except yourself (I couldn't
> find you after PWE3) that objected to the removal of the UDP/IP
> header at the meeting, all agreed that this was okay assuming that
> we add two new CV types to explicitly identify when the header
> is and is not included for BFD messages so that we can support
> older implementations. I will have the text for this shortly
> and will send it out.
> 
> 	--Tom
> 
> 
> 
> > rahul
> >
> >> 	--Tom
> >>
> >>
> >>
> >>> Y(J)S
> >>>
> >>>
> >>> _______________________________________________
> >>> pwe3 mailing list
> >>> [email-masked]
> >>> https://www1.ietf.org/mailman/listinfo/pwe3
> >>
> >
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 1 Aug 2006 10:50:15 -0400

> [Sasha] This is only correct if the PW uses a CW. Not all of them do.

	If you do not use a PW header, then you cannot use
VCCV.

> the problem of the PW label being popped in an inappropriate place?

	If there is no routable IP header behind the PW header,
then there is no chance of doing the wrong thing. The dest. IP
address should be a 127/ address, which should make it un-routable
anyway.

> IPv4 and IPv6 packets are easily discriminated using the Version  

	That isn't my point. The point is that you do not need
to do the secondary address lookup if its not there.

> I also do not think that the "outer PW encapsulation" defines the  
> packet destination in MS-PWs.
>>

	I don't. This is only for the BFD payloads.

	--Tom