Subject: [PWE3] Releasing MS-PW segments individually

From: "David McWalter" <[email-masked]>
Date: Thu, 30 Nov 2006 14:55:33 -0000

Folks,

I have a question about releasing LDP-controlled MS-PWs.

When a MS-PW is being released, can segments be released individually, or must the Withdraw flow end-to-end before the Releases can start to flow back?

Here's a small example.  A and C are T-PE nodes and B is an S-PE node for a MS-PW.  PW1 and PW2 are SS-PWs which form a MS-PW from A to C.  LDP is the control protocol for both segments.

    PW1       PW2
A ------- B ------- C

When we're releasing the PW, B receives Label Withdraw from C, and forwards Label Withdraw on to A.  Now, B could send Label Release to C right away, or B could wait for A's Release before sending Release to C.

There's no guidance in the draft, so B can choose its behavior.  I feel that allowing individual segment release is faster and cleaner, so I'd like to see the draft allow that.

Does anyone see a need to mandate end-to-end release?  If so, I'd be interested to know what function requires it, and in that case we should add text to the effect 'B MUST wait for A's Release'.

Thanks very much,
David McWalter
[email-masked]

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 30 Nov 2006 15:16:22 +0000

> Does anyone see a need to mandate end-to-end release?  If so, I'd be interested to know what function requires it, and in that case we should add text to the effect 'B MUST wait for A's Release'.

Surely you MUST allow release from any point. If you get a
mid-point failure, the PW has to be shut down from the
failure adjacencies back towards the two ends.

- Stewart

---

From: "KOMPELLA Vach" <[email-masked]>
Date: Thu, 30 Nov 2006 10:12:54 -0600

David, Stewart,

>From the RFC 3036, Appendix A (the same text is in 3036bis):

A.1.5. Receive Label Withdraw

      LWd.1   Remove Label from forwarding/switching use.  (See Note 1.)

      LWd.2   Execute procedure Send_Message (MsgSource, Label Release,
              FEC, Label)

So, send the label release and then figure out based on DU or DoD,
Ordered or Independent control, what your next steps are.

-Vach

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]] 
> Sent: Thursday, November 30, 2006 7:16 AM
> To: David McWalter
> Cc: [email-masked]
> Subject: Re: [PWE3] Releasing MS-PW segments individually
> 
> David McWalter wrote:
> 
> > Folks,
> > 
> > When a MS-PW is being released, can segments be released 
> individually, or must the Withdraw flow end-to-end before the 
> Releases can start to flow back?
> > 
> > Here's a small example.  A and C are T-PE nodes and B is an 
> S-PE node for a MS-PW.  PW1 and PW2 are SS-PWs which form a 
> MS-PW from A to C.  LDP is the control protocol for both segments.
> > 
> >     PW1       PW2
> > A ------- B ------- C
> > 
> > When we're releasing the PW, B receives Label Withdraw from 
> C, and forwards Label Withdraw on to A.  Now, B could send 
> Label Release to C right away, or B could wait for A's 
> Release before sending Release to C.
> > 
> > There's no guidance in the draft, so B can choose its 
> behavior.  I feel that allowing individual segment release is 
> faster and cleaner, so I'd like to see the draft allow that.
> > 
> > Does anyone see a need to mandate end-to-end release?  If 
> so, I'd be interested to know what function requires it, and 
> in that case we should add text to the effect 'B MUST wait 
> for A's Release'.
> > 
>

---

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 30 Nov 2006 11:29:24 -0500

Here is my take on this.
1) when B gets label withdraw from C, it should
   first send label release to C

2) If PW status mechanism is used between B and A
   then B should send PW PW status (LDP notification)
   to A and not Label withdraw. Send label withdraw,
   only when MS-PW config on B is removed.
   
   If label-withdraw mechanism is used (as a means to 
   exchange status), then send label withdraw to A.

/himanshu

> From: David McWalter [mailto:[email-masked]]
> Sent: Thursday, November 30, 2006 9:56 AM
> To: [email-masked]
> Subject: [PWE3] Releasing MS-PW segments individually
> 
> 
> Folks,
> 
> Does anyone see a need to mandate end-to-end release?  If so, 
> I'd be interested to know what function requires it, and in 
> that case we should add text to the effect 'B MUST wait for 
> A's Release'.
> 
> Thanks very much,
> David McWalter
> [email-masked]
>