Subject: RE: [PWE3] Releasing MS-PW segments individually

From: "Dutta, Pranjal \(Pranjal\)" <[email-masked]>
Date: Fri, 1 Dec 2006 19:43:53 +0530

Hi,
    I feel the second point is important when multi-hop VCCV etc will be
used. If there is graceful teardown of the LSP by C (label withdraw),
and label is immediately released at B then it will be indicated as
failure to A.

-Pranjal

________________________________

From: Shah, Himanshu [mailto:[email-masked]]
Sent: Thu 11/30/2006 9:59 PM
To: David McWalter; [email-masked]
Subject: RE: [PWE3] Releasing MS-PW segments individually

Here is my take on this.
1) when B gets label withdraw from C, it should
   first send label release to C

2) If PW status mechanism is used between B and A
   then B should send PW PW status (LDP notification)
   to A and not Label withdraw. Send label withdraw,
   only when MS-PW config on B is removed.
  
   If label-withdraw mechanism is used (as a means to
   exchange status), then send label withdraw to A.

/himanshu

> -----Original Message-----
> From: David McWalter [mailto:[email-masked]]
> Sent: Thursday, November 30, 2006 9:56 AM
> To: [email-masked]
> Subject: [PWE3] Releasing MS-PW segments individually
>
>
> Folks,
>
> I have a question about releasing LDP-controlled MS-PWs.
>
> When a MS-PW is being released, can segments be released
> individually, or must the Withdraw flow end-to-end before the
> Releases can start to flow back?
>
> Here's a small example.  A and C are T-PE nodes and B is an
> S-PE node for a MS-PW.  PW1 and PW2 are SS-PWs which form a
> MS-PW from A to C.  LDP is the control protocol for both segments.
>
>     PW1       PW2
> A ------- B ------- C
>
> When we're releasing the PW, B receives Label Withdraw from
> C, and forwards Label Withdraw on to A.  Now, B could send
> Label Release to C right away, or B could wait for A's
> Release before sending Release to C.
>
> There's no guidance in the draft, so B can choose its
> behavior.  I feel that allowing individual segment release is
> faster and cleaner, so I'd like to see the draft allow that.
>
> Does anyone see a need to mandate end-to-end release?  If so,
> I'd be interested to know what function requires it, and in
> that case we should add text to the effect 'B MUST wait for
> A's Release'.
>
> Thanks very much,
> David McWalter
> [email-masked]
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "AISSAOUI Mustapha" <[email-masked]>
Date: Mon, 4 Dec 2006 11:15:50 -0600

Himanshu,
if PW status TLV has been signaled and supported on both segments of the
MS-PW, then there are only a couple of cases where node C withdraws its
advertised label to B. An admin shutdown or a deletion of the PW
configuration at C. Any other event should have C send a status message
instead. This is explained in RFC 4447 and
draft-ietf-pwe3-oam-msg-map-04.

Thus, if B received a label withdraw from C, it should send a release
back to C and should withdraw its label towards A. Remember that
according to draft-ietf-pwe3-segmented-pw-03.txt, the S-PE acts as a
passive and the T-PE is the active from a control plane perspective.
Thus, similar to when the PW is established initially, the S-PE will
need to propagate the withdrawal message after local processing.

Mustapha.  

> Sent: Thursday, November 30, 2006 11:29 AM
> individually, 
> > or must the Withdraw flow end-to-end before the Releases 
> can start to 
> > flow back?
> > 
> S-PE node 
> > for a MS-PW.  PW1 and PW2 are SS-PWs which form a MS-PW 
> from A to C.  
> > LDP is the control protocol for both segments.
> > 
> >     PW1       PW2
> > A ------- B ------- C
> > 
> > When we're releasing the PW, B receives Label Withdraw from C, and 
> > forwards Label Withdraw on to A.  Now, B could send Label 
> Release to C 
> > right away, or B could wait for A's Release before sending 
> Release to 
> > C.
> > 
> > There's no guidance in the draft, so B can choose its behavior.  I 
> > feel that allowing individual segment release is faster and 
> cleaner, 
> > so I'd like to see the draft allow that.
> > 
> > Does anyone see a need to mandate end-to-end release?  If 
> so, I'd be 
> > interested to know what function requires it, and in that case we 
> > should add text to the effect 'B MUST wait for A's Release'.
> > 
> > Thanks very much,
> > David McWalter
> > [email-masked]
> >

---

From: "Dutta, Pranjal \(Pranjal\)" <[email-masked]>
Date: Fri, 1 Dec 2006 15:18:00 +0530

Hi,
    I feel the second point is important when multi-hop VCCV etc are
used. If there is graceful teardown of the LSP by C (label withdraw),
and label is immediately released at B then it will be indicated as
failure to A.

-Pranjal 

-----Original Message-----
From: Shah, Himanshu [mailto:[email-masked]] 
Sent: Thursday, 30 November, 2006 9:59 PM
To: David McWalter; [email-masked]
Subject: RE: [PWE3] Releasing MS-PW segments individually

Here is my take on this.

/himanshu