Subject: [PWE3] New Liaison Statement, "Liaison Statement to IETF PWE3 WG on MS-PW over T-MPLS"

From: Greg Jones (ITU-T SG 15) <[email-masked]>
Date: Thu, 20 Sep 2007 15:21:00 -0400

Title: Liaison Statement to IETF PWE3 WG on MS-PW over T-MPLS
Submission Date: 2007-09-20
URL of the IETF Web page: https://datatracker.ietf.org/public/liaison_detail.cgi?detail_id=372 
Please reply by 2007-12-25

From: Greg Jones(ITU-T SG 15) <[email-masked]>
To: IETF PWE3 WG([email-masked],[email-masked])
Cc: [email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
Reponse Contact: [email-masked]
Technical Contact: [email-masked]
Purpose: For action 
Body: 
Attachment(s):
     Liaison Statement to IETF PWE3 WG on MS-PW over T-MPLS - body text (https://datatracker.ietf.org/documents/LIAISON/file486.doc)

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 25 Sep 2007 10:19:32 +0200

The attached liaison references MS-PWs and PWE work,
but redefines the basic PW encapsulation.

In particular, when a PW segment spans a T-MPLS network, 
the adaptation function "is not required to insert a PW label",
i.e. we have a PW packet with an MPLS label but the PW label
has been popped.

It is not clearly stated in the document whether a CW is used,
but since they require support of MH-VCCV, one can assume that this
is the case.

So, if I understand correctly, their encap has a CW
and then an MPLS header with S=1,
contrary to the standard PWE encap.

While I understand that they are restricting the functionality
to one PW per MPLS tunnel, there is a simple way to accomplish
this without messing up the encap. Namely, have ONLY a PW label
and no MPLS label. 

This will look the same as the encap they propose,
but the label, being a PW label, may be negotiated 
using the PW control protocol, rather than whatever they intend using
for their MPLS labels (apparently management plane).

Furthermore, the document explains the advantages of having
only one PW per tunnel (QoS). While correct, they do not mention
the disadvantage of having to have all internal T-MPLS routers know
about the individual PWs. I assume that they are thinking about
high-BW, relatively static, connections. Perhaps they should clearly
state that limitation.

Y(J)S

-----Original Message-----
From: Greg Jones (ITU-T SG 15) [mailto:[email-masked]] 
Sent: Thursday, September 20, 2007 9:21 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: [PWE3] New Liaison Statement, "Liaison Statement to IETF PWE3
WG on MS-PW over T-MPLS" 

Title: Liaison Statement to IETF PWE3 WG on MS-PW over T-MPLS Submission
Date: 2007-09-20 URL of the IETF Web page:
https://datatracker.ietf.org/public/liaison_detail.cgi?detail_id=372
Please reply by 2007-12-25

From: Greg Jones(ITU-T SG 15) <[email-masked]>
To: IETF PWE3 WG([email-masked],[email-masked])
Cc: [email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
Reponse Contact: [email-masked]
Technical Contact: [email-masked]
Purpose: For action
Body: 
Attachment(s):
     Liaison Statement to IETF PWE3 WG on MS-PW over T-MPLS - body text
(https://datatracker.ietf.org/documents/LIAISON/file486.doc)