Subject: RE: [PWE3] WG LC: draft-ietf-pwe3-mpls-transport-00.txt

From: <[email-masked]>
Date: Mon, 3 Sep 2007 11:19:20 +0100

Colleagues,

With a reserved label the signalling & OAM is already specified (i.e.
the existing MPLS OAM/signalling, LSP Ping, LDP, RSVP-TE etc.) as the
scenario is Operator X (client) MPLS over Operator Y (server) MPLS.  The
two MPLS layers are separate and individually managed by Operator X & Y
respectively.  We don't need any signalling/OAM for the reserved label,
it's just a breakpoint.

Think MACinMAC or VC-12 over VC-4 where the client & server layers
belong to different operators. 

Ben

Andrew G. Malis <mailto:[email-masked]> wrote:
> Neil,
> 
> Yes, that could also work, but we would need to specify the
> signaling and OAM when such a reserved label is used.
> 
> For an MPLS PW, life would be simpler, since we've already
> defined the signaling (RFC 4447) and OAM (VCCV).
> 
> Cheers,
> Andy
> 
> At 8/31/2007 07:10 PM +0100, [email-masked] wrote:
> 
> 
> 	Hi Andy,
> 
> 	So, to be clear here, are you suggesting we need to
> define a 'MPLS PW'?
> 
> 	An alternative solution would be to use a reserved
> label that carries the semantic 'this delimits stacked LSPs
> from 2 different MPLS layer networks'.  This would not
> require a PW at all, can be efficiently recursed, and allows
> the (*server*) interconnecting technologies between the 2
> MPLS networks to be of any type.
> 
> 	regards, Neil

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 03 Sep 2007 11:39:22 +0100

> belong to different operators. 
I have a deep distrust of the reserved label approach, because the load 
balancing behaviour
may well be different on OAM and data packets.

For better or worse there are LSRs out there that LB on the bottom 
label, and there are
others that do DPI, so the only OAM discrimination method that you can 
trust is one
that makes OAM pkts and payload pkts look identical wrt to any field 
that is likely
to be inspected by the forwarders.

Stewart