Subject: [PWE3] Is it mandatory to do a 'PW FEC Validation' for VCCV LSP Ping Echo Reply packet ?

From: "Raman Rangaswamy" <[email-masked]>
Date: Thu, 3 Apr 2008 11:24:45 +0530

Hi All,

A -------------- B

From the node A , 'VCCV LSP Ping request' is sent to B, 

which sends back 'VCCV LSP Ping reply' to A. 

Is it mandatory to do a PW FEC Validation at node A for the 

received echo reply packet?

Thanks
Raman

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Prabakaran Sampath" <[email-masked]>
Date: Thu, 3 Apr 2008 15:17:03 -0500

Hi Raman,

IMHO, such verifications make more sense, because there are chances that
the PW FEC may go wrong during transit.

Also, please refer the "draft-ietf-pwe3-segmented-pw-07.txt", Section
"9.5.3. Receiving an VCCV Echo Reply",
Which talks about the "ping" mode and "trace" mode. The draft says,    
<<<< In "ping" mode, the node may choose to ignore the target FEC128 in 
the echo reply and report only the return code to the operator. >>>>. 

It seems it may be an implementation choice too like how VCCV LSP Ping
reply operation was handled at the receiving node. 

Thanks,
Prabakaran T Sampath
Nortel Networks Inc., 5400 Hellyer Avenue, San Jose, CA 95138
Email: [email-masked], www.nortel.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Raman Rangaswamy
Sent: Wednesday, April 02, 2008 10:55 PM
To: [email-masked]
Subject: [PWE3] Is it mandatory to do a 'PW FEC Validation' for VCCV LSP
Ping Echo Reply packet ?

Hi All,

A -------------- B

Thanks
Raman

DISCLAIMER:
------------------------------------------------------------------------
-----------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and
intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its
affiliates. Any views or opinions presented in this email are solely
those of the author and may not necessarily reflect the opinions of HCL
or its affiliates.
Any form of reproduction, dissemination, copying, disclosure,
modification, distribution and / or publication of this message without
the prior written consent of the author of this e-mail is strictly
prohibited. If you have received this email in error please delete it
and notify the sender immediately. Before opening any mail and
attachments please check them for viruses and defect.

------------------------------------------------------------------------
-----------------------------------------------
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3