Subject: Re: [PWE3] PW type identification

From: Luca Martini <[email-masked]>
Date: Wed, 04 Jun 2008 14:46:29 -0600

Yaakov Stein wrote:
>  
>
>   
>> The current (incomplete and heuristic) logic in wireshark is based on
>>     
> the first nibble after the MPLS Label Stack, 
>   
>> treating the payload as IPv4 (if "4"), IPv6 (if "6"), PW-ACH (if "1")
>>     
> and Ethernet without FCS the rest of the cases. 
>
> Carlos, 
>
> There seems to be a whole in this logic.
> Although most MAC addresses will start with 0000,
> there are MAC addresses that start with 0001 too
> (and there is no reason that there will not be with 4 and 6 in the
> future).
>
>   
Last time I checked those were dead IEEE mac allocations. So it's 
unlikely they will ever be used.

Luca

> Y(J)S
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>   

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 10 Jun 2008 19:40:45 +0300

Luca, 

Even so, at some point the 0000 block will be finished,
and IEEE will start allocating from other blocks.

Y(J)S 

-----Original Message-----
From: Luca Martini [mailto:[email-masked]] 
Sent: Wednesday, June 04, 2008 11:46 PM
To: Yaakov Stein
Cc: Carlos Pignataro; [email-masked]
Subject: Re: [PWE3] PW type identification

Yaakov Stein wrote:
> Although most MAC addresses will start with 0000, there are MAC 
> addresses that start with 0001 too (and there is no reason that there 
> will not be with 4 and 6 in the future).
>
>   

Luca