Subject: Re: [PWE3] Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12

From: Yaakov Stein <[email-masked]>
Date: Wed, 14 Apr 2010 10:43:46 +0300

This disclosure (1311) quotes application US20080089227A1: Protecting multi-segment pseudowires
which may impact draft-ietf-pwe3-redundancy, and perhaps ICCP, MS-PW architecture, and MS-PW setup. 
There is no apparent connection with oam-msg-map - in fact the claims stress that
the triggers are failures of PSN elements (e.g. S-PEs) and are NOT from the ACs,
making any connection untenable. 

A previous disclosure by the same company (863) refers to 
    20080285466 : Interworking between MPLS/IP and Ethernet OAM mechanisms
which may impact mpls-eth-oam-iwk, but not oam-msg-map,
unless one interprets the first claim and its dependents much more broadly 
than supported by the background and description.

Can someone from the company claiming this IPR fix the information in these disclosures ?
At very least that company is required to disclose IPR is holds with respect to the appropriate drafts
(unless it is willing to risk forfeiting its rights with respect to these ...).

However, with respect to oam-msg-map I would like to request that it consider removing inappropriate disclosures.
Of course, if after consideration it believes that these disclosures ARE appropriate,
I would love to hear the reasoning.

Y(J)S

-----Original Message-----
From: IETF Secretariat [mailto:[email-masked]] 
Sent: Tuesday, April 13, 2010 18:46
To: [email-masked]; Yaakov Stein; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12

Dear Monique Morrow, Yaakov Stein, Luca Martini, Thomas Nadeau, Mustapha Aissaoui, David Allan, Peter Busschbach:

An IPR disclosure that pertains to your Internet-Draft entitled "Pseudowire (PW)
OAM Message Mapping" (draft-ietf-pwe3-oam-msg-map) was submitted to the IETF
Secretariat on 2010-04-07 and has been posted on the "IETF Page of Intellectual
Property Rights Disclosures" (https://datatracker.ietf.org/ipr/1311/). The title
of the IPR disclosure is "Cisco's Statement of IPR relating to
draft-ietf-pwe3-oam-msg-map-12."

The IETF Secretariat

---

From: Yaakov Stein <[email-masked]>
Date: Fri, 16 Apr 2010 10:53:07 +0300

In the IETF meta-discussions on the idea of discussing IPR are more liable to become ratholes than the IPR discussion itself.
Even worse is the meta-meta discussion on whether to restrict ourselves to using ASCII in the meta-discussion :)

IPR SHOULD be discussed by the WG, and this discussion is especially appropriate during the LC period of a standards track draft 
( we asked for a 2nd LC on this draft ) in order to understand any possible issues before passing on to the IESG.

In some WGs (e.g. codec) IPR issues are more important than others as their mission is to create technology
which is as IPR-free as possible. In codec's case they have even appointed someone specifically to check into IPR
(from a technical point of view - to make sure that disclosures have been made - not to "rule" on IPR). 

In PWE there have been a plethora of patents from the start, but everything has always been disclosed and discussed.
It would be unfortunate for things to become confused due to technical errors of disclosing with respect to the wrong drafts.

Y(J)S

-----Original Message-----
From: Donald Eastlake [mailto:[email-masked]] 
Sent: Thursday, April 15, 2010 21:57
To: Trowbridge, Stephen J (Steve)
Cc: Yaakov Stein; [email-masked]; [email-masked]; [email-masked]; Aissaoui, Mustapha (Mustapha); [email-masked]; Busschbach, Peter B (Peter); Secretariat; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [PWE3] Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12

There is no such rule in the IETF, although perhaps patent discussions
need some moderation to avoid becoming ratholes. To quote some pieces
of text from RFC 3669 (which I recommend you read in full):

"It's all right, and sometimes beneficial, to discuss IPR claims
      and gather information about possible prior art on the [working]
group list.
      The results of such discussion can be considered when deciding
      whether to develop a technology (but remember that neither the
      IETF nor any working group takes a stand on such claims as a body,
      and the group is not the best place to get legal advice)."

and

"Working group participants can evaluate IPR claims not only for
      their possible validity, but also for the risk of misjudging that
      validity."

Donald
=============================
 Donald E. Eastlake 3rd
 155 Beaver Street
 Milford, MA 01757 USA

On Wed, Apr 14, 2010 at 8:47 AM, Trowbridge, Stephen J (Steve)
<[email-masked]> wrote:
> Hi all,
> In IEEE we are admonished to never discuss the essentiality or validity of patent claims. I cannot believe this is considered an appropriate discussion in IETF.
> Regards,
> Steve
>
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
> Sent: Wednesday, April 14, 2010 1:44 AM
> To: [email-masked]; [email-masked]; [email-masked]; Aissaoui, Mustapha (Mustapha); [email-masked]; Busschbach, Peter B (Peter)
> Cc: [email-masked]; Secretariat; [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [PWE3] Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12
>
>
> This disclosure (1311) quotes application US20080089227A1: Protecting multi-segment pseudowires which may impact draft-ietf-pwe3-redundancy, and perhaps ICCP, MS-PW architecture, and MS-PW setup.
> There is no apparent connection with oam-msg-map - in fact the claims stress that the triggers are failures of PSN elements (e.g. S-PEs) and are NOT from the ACs, making any connection untenable.
>
>    20080285466 : Interworking between MPLS/IP and Ethernet OAM mechanisms which may impact mpls-eth-oam-iwk, but not oam-msg-map, unless one interprets the first claim and its dependents much more broadly than supported by the background and description.
>
> At very least that company is required to disclose IPR is holds with respect to the appropriate drafts (unless it is willing to risk forfeiting its rights with respect to these ...).
>
> Of course, if after consideration it believes that these disclosures ARE appropriate, I would love to hear the reasoning.
>
> Y(J)S
>
>
> An IPR disclosure that pertains to your Internet-Draft entitled "Pseudowire (PW) OAM Message Mapping" (draft-ietf-pwe3-oam-msg-map) was submitted to the IETF Secretariat on 2010-04-07 and has been posted on the "IETF Page of Intellectual Property Rights Disclosures" (https://datatracker.ietf.org/ipr/1311/). The title of the IPR disclosure is "Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12."
>
> The IETF Secretariat
>
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: IETF Secretariat <[email-masked]>
Date: Tue, 13 Apr 2010 08:45:59 -0700 (PDT)

The IETF Secretariat

---

From: "Trowbridge, Stephen J (Steve)" <[email-masked]>
Date: Wed, 14 Apr 2010 07:47:04 -0500

Hi all,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: Wednesday, April 14, 2010 1:44 AM
To: [email-masked]; [email-masked]; [email-masked]; Aissaoui, Mustapha (Mustapha); [email-masked]; Busschbach, Peter B (Peter)
Cc: [email-masked]; Secretariat; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [PWE3] Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12

Y(J)S

-----Original Message-----
From: IETF Secretariat [mailto:[email-masked]]
Sent: Tuesday, April 13, 2010 18:46
To: [email-masked]; Yaakov Stein; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12

The IETF Secretariat

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 15 Apr 2010 00:20:08 -0400

This was more a discussion of scope than validity.

Of course, having public discourse in a community of experts that 
disparrages the validity of a claim could bolster invalidation arguments. 
So I can see how this might be a disavored act in the IEEE community, which 
seems to be slanted towards rights holders (I speak as a long-term member 
of IEEE and as a consultant on IPR). Perhaps we'd all be better off if the 
IEEE were a little more critical of misguided claims? Regular raising of a 
hue and cry of "Bullshit!" would go a long way towards reducing the damage 
caused by unmerited patents.
 
--
Dean Willis

------- Original message -------
> From: Trowbridge, Stephen J (Steve) <[email-masked]>
> Cc: [email-masked], [email-masked], [email-masked], 
> [email-masked], [email-masked], [email-masked]
> Sent: 14.4.'10,  8:47
>
> Hi all,
> In IEEE we are admonished to never discuss the essentiality or validity 
> of patent claims. I cannot believe this is considered an appropriate 
> discussion in IETF.
> Regards,
> Steve
>
> To: [email-masked]; [email-masked]; [email-masked]; Aissaoui, 
> Mustapha (Mustapha); [email-masked]; Busschbach, Peter B 
> (Peter)
> Cc: [email-masked]; Secretariat; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [PWE3] Posting of IPR Disclosure related to Cisco's 
> Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12
>
>
> This disclosure (1311) quotes application US20080089227A1: Protecting 
> multi-segment pseudowires which may impact draft-ietf-pwe3-redundancy, and 
> perhaps ICCP, MS-PW architecture, and MS-PW setup.
> There is no apparent connection with oam-msg-map - in fact the claims 
> stress that the triggers are failures of PSN elements (e.g. S-PEs) and are 
> NOT from the ACs, making any connection untenable.
>
>     20080285466 : Interworking between MPLS/IP and Ethernet OAM 
> mechanisms which may impact mpls-eth-oam-iwk, but not oam-msg-map, unless 
> one interprets the first claim and its dependents much more broadly than 
> supported by the background and description.
>
> At very least that company is required to disclose IPR is holds with 
> respect to the appropriate drafts (unless it is willing to risk forfeiting 
> its rights with respect to these ...).
>
> However, with respect to oam-msg-map I would like to request that it 
> consider removing inappropriate disclosures.
> Of course, if after consideration it believes that these disclosures ARE 
> appropriate, I would love to hear the reasoning.
>
> Y(J)S
>
>
> To: [email-masked]; Yaakov Stein; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]
> Subject: Posting of IPR Disclosure related to Cisco's Statement of IPR 
> relating to draft-ietf-pwe3-oam-msg-map-12
>
> An IPR disclosure that pertains to your Internet-Draft entitled 
> "Pseudowire (PW) OAM Message Mapping" (draft-ietf-pwe3-oam-msg-map) was 
> submitted to the IETF Secretariat on 2010-04-07 and has been posted on the 
> "IETF Page of Intellectual Property Rights Disclosures" 
> (https://datatracker.ietf.org/ipr/1311/). The title of the IPR disclosure 
> is "Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12."
>
> The IETF Secretariat
>
>

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 15 Apr 2010 14:56:46 -0400

and

Donald