Subject: [PWE3] pwe3 redundancy drafts: draft-ietf-pwe3-redundancy-03

From: "Alon, Zehavit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 15 Dec 2010 11:13:16 +0100

Hello

One of the reference models depicted in draft-ietf-pwe3-redundancy-03
section 3 is the Multiple Multi-homed 

         |<-------------- Emulated Service ---------------->|
         |                                                  |
         |          |<------- Pseudo Wire ------>|          |
         |          |                            |          |
         |          |    |<-- PSN Tunnels-->|    |          |
         |          V    V                  V    V          |
         V    AC    +----+                  +----+     AC   V
   +-----+    |     |....|.......PW1........|....|     |    +-----+
   |     |----------| PE1|......   .........| PE3|----------|     |
   | CE1 |          +----+      \ /  PW3    +----+          | CE2 |
   |     |          +----+       X          +----+          |     |
   |     |          |    |....../ \..PW4....|    |          |     |
   |     |----------| PE2|                  | PE4|--------- |     |
   +-----+    |     |....|.....PW2..........|....|     |    +-----+
              AC    +----+                  +----+    AC
 
In the Figure illustrated above both CEs, CE1 and CE2 are dual-homed
with PEs, PE1, PE2 and PE3, PE4 respectively.
 
In the figure, are PE1 and PE2 distinct entities, each having its own
unique identity? 
Can both PE1 and PE2 be seen as a single entity externalizing the same
identity? 
 
Thanks for the clarification
Zehavit

---

From: "Aissaoui, Mustapha (Mustapha)" <[email-masked]>
Date: Wed, 15 Dec 2010 15:16:47 -0600

Hi Zehavit,
PE1 and PE2 have distincts identities in general. For the purpose of the dual-homing application however, they must appear as the same peer *within the context of the dual-homing protocol* used with the CE nodes,  example LAG.

Mustapha.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alon, Zehavit (NSN - IL/Hod HaSharon)
Sent: Wednesday, December 15, 2010 5:13 AM
To: [email-masked]
Subject: [PWE3] pwe3 redundancy drafts: draft-ietf-pwe3-redundancy-03

Hello

One of the reference models depicted in draft-ietf-pwe3-redundancy-03 section 3 is the Multiple Multi-homed

         |                                                  |

         |          |                            |          |

         |          V    V                  V    V          |

         V    AC    +----+                  +----+     AC   V

   |     |          +----+       X          +----+          |     |

              AC    +----+                  +----+    AC

In the Figure illustrated above both CEs, CE1 and CE2 are dual-homed with PEs, PE1, PE2 and PE3, PE4 respectively.

In the figure, are PE1 and PE2 distinct entities, each having its own unique identity?

Can both PE1 and PE2 be seen as a single entity externalizing the same identity?

Zehavit

---

From: "Alon, Zehavit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 16 Dec 2010 10:09:57 +0100

Hi Mustapha

Thank you for the prompt response.

So if I understand correctly, if the dual homing is based on LAG for
example, both systems must have the same LAG system ID (same
Actor_system and same Actor_System_Priority) so that the LAG will
"think" it works with a single partner.

Should both systems have also the same MAC? 

Thanks again

Zehavit

___________________________

Zehavit Alon

Phone:     +972-9-7751338; 

Cell:         +972-50-4422590;

Email:       [email-masked]

From: ext Aissaoui, Mustapha (Mustapha)
[mailto:[email-masked]] 
Sent: Wednesday, December 15, 2010 23:17
To: Alon, Zehavit (NSN - IL/Hod HaSharon); [email-masked]
Subject: RE: pwe3 redundancy drafts: draft-ietf-pwe3-redundancy-03

Hi Zehavit,

PE1 and PE2 have distincts identities in general. For the purpose of the
dual-homing application however, they must appear as the same peer
*within the context of the dual-homing protocol* used with the CE nodes,
example LAG.

Mustapha.  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Alon, Zehavit (NSN - IL/Hod HaSharon)
Sent: Wednesday, December 15, 2010 5:13 AM
To: [email-masked]
Subject: [PWE3] pwe3 redundancy drafts: draft-ietf-pwe3-redundancy-03

Hello

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 16 Dec 2010 10:15:28 +0100

Hi,

I would like to add another question, does it mean that the two PEs need
to be of the same vendor? 

If so, it seems to provide a hard restriction....

Best regards,

Nurit

From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Alon, Zehavit (NSN - IL/Hod HaSharon)
Sent: Thursday, December 16, 2010 11:10 AM
To: ext Aissaoui, Mustapha (Mustapha); [email-masked]
Subject: Re: [PWE3] pwe3 redundancy drafts:
draft-ietf-pwe3-redundancy-03

Hi Mustapha

Thanks again

Zehavit

Zehavit Alon

Phone:     +972-9-7751338; 

Cell:         +972-50-4422590;

 

Hi Zehavit,

Mustapha.  

Hello

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 16 Dec 2010 11:20:17 +0200

Alon,
Some LAG parameters advertized via the LACP really MUST be the same in both PEs.
Otherwise your dual-homing CE will not form a proper group.

My 2c,
     Sasha

________________________________
From: [email-masked] [[email-masked]] On Behalf Of Alon, Zehavit (NSN - IL/Hod HaSharon) [[email-masked]]
Sent: Thursday, December 16, 2010 11:09 AM
To: ext Aissaoui, Mustapha (Mustapha); [email-masked]
Subject: Re: [PWE3] pwe3 redundancy drafts: draft-ietf-pwe3-redundancy-03

Hi Mustapha

Thank you for the prompt response.
So if I understand correctly, if the dual homing is based on LAG for example, both systems must have the same LAG system ID (same Actor_system and same Actor_System_Priority) so that the LAG will "think" it works with a single partner.
Should both systems have also the same MAC?

Thanks again
Zehavit

Phone:     +972-9-7751338;
Cell:         +972-50-4422590;

From: ext Aissaoui, Mustapha (Mustapha) [mailto:[email-masked]]

Hi Zehavit,

Mustapha.

         |                                                  |

         |          |                            |          |

         |          V    V                  V    V          |

         V    AC    +----+                  +----+     AC   V

   |     |          +----+       X          +----+          |     |

              AC    +----+                  +----+    AC

Zehavit

---

From: "Alon, Zehavit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 16 Dec 2010 10:59:52 +0100

Hello Alexander.

Some LACP parameters need to be the same, I understand. But should both
PEs have the same MAC address?

Thanks

Zehavit

Zehavit Alon

Phone:     +972-9-7751338; 

Cell:         +972-50-4422590;

 

From: ext Alexander Vainshtein [mailto:[email-masked]]

Sent: Thursday, December 16, 2010 11:20
To: Alon, Zehavit (NSN - IL/Hod HaSharon); ext Aissaoui, Mustapha
(Mustapha); [email-masked]
Subject: RE: pwe3 redundancy drafts: draft-ietf-pwe3-redundancy-03

Alon,

Some LAG parameters advertized via the LACP really MUST be the same in
both PEs.

My 2c,

     Sasha

From: [email-masked] [[email-masked]] On Behalf Of Alon,
Zehavit (NSN - IL/Hod HaSharon) [[email-masked]]
Sent: Thursday, December 16, 2010 11:09 AM
To: ext Aissaoui, Mustapha (Mustapha); [email-masked]
Subject: Re: [PWE3] pwe3 redundancy drafts:
draft-ietf-pwe3-redundancy-03

Hi Mustapha

Thanks again

Zehavit

Zehavit Alon

Phone:     +972-9-7751338; 

Cell:         +972-50-4422590;

 

Hi Zehavit,

Mustapha.  

Hello

---

From: "Alon, Zehavit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 16 Dec 2010 11:08:40 +0100

Hi again

I understand that if we are implementing the dual homing using LAG, for
the LAG protocol, the two PEs should be configured to look like one PE,
since the LAG is not designed to work with two partners, but only with
one.

Assuming the dual homing is done with a different mechanism (NOT LAG),
should both PEs have the same identity from the network point of view?

Thanks 

Zehavit

Zehavit Alon

Phone:     +972-9-7751338; 

Cell:         +972-50-4422590;

 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Alon, Zehavit (NSN - IL/Hod HaSharon)
Sent: Thursday, December 16, 2010 12:00
To: ext Alexander Vainshtein; ext Aissaoui,Mustapha (Mustapha);
[email-masked]
Subject: Re: [PWE3] pwe3 redundancy drafts:
draft-ietf-pwe3-redundancy-03

Hello Alexander.

Thanks

Zehavit

Zehavit Alon

Phone:     +972-9-7751338; 

Cell:         +972-50-4422590;

 

Alon,

My 2c,

     Sasha

Hi Mustapha

Thanks again

Zehavit

Zehavit Alon

Phone:     +972-9-7751338; 

Cell:         +972-50-4422590;

 

Hi Zehavit,

Mustapha.  

Hello

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 16 Dec 2010 12:26:34 +0200

Zehavit,
MAC addresses are used to represent many different functions in LACP and LAG.

 *   Each port participating in LAG has its own unique MAC address (used as the sMAC of LACP frames)
 *   The Link Aggregation group (or a bundle) has its ID (the same for all the participating ports) which is also a MAC address
 *   Last but not least, if the system using LAG is an end station (a host in the IETF parlance), the bundle also has a MAC address (again common for all ports) that acts as the SMAC for all the user traffic transmitted via any of the ports of this LAG and is understood as "MAC address for me" when seen as DMAC in the user frames received from any of the ports of this LAG. This MAC address does not necessarily have to be the same as MAC address used as the  Link Aggregation group ID (which only appears in the payload of the LACP frames but not as SMAC or DMAC). PEs that support dual-homing are end stations and hence require this MAC address as well.

Hopefully these notes will be useful.

Regards,

     Sasha

________________________________
From: Alon, Zehavit (NSN - IL/Hod HaSharon) [[email-masked]]
Sent: Thursday, December 16, 2010 11:59 AM
To: Alexander Vainshtein; ext Aissaoui, Mustapha (Mustapha); [email-masked]
Subject: RE: pwe3 redundancy drafts: draft-ietf-pwe3-redundancy-03

Hello Alexander.

Some LACP parameters need to be the same, I understand. But should both PEs have the same MAC address?

Thanks
Zehavit

Phone:     +972-9-7751338;
Cell:         +972-50-4422590;

To: Alon, Zehavit (NSN - IL/Hod HaSharon); ext Aissaoui, Mustapha (Mustapha); [email-masked]

Alon,

My 2c,
     Sasha

Thanks again
Zehavit

Phone:     +972-9-7751338;
Cell:         +972-50-4422590;

Hi Zehavit,

Mustapha.

         |                                                  |

         |          |                            |          |

         |          V    V                  V    V          |

         V    AC    +----+                  +----+     AC   V

   |     |          +----+       X          +----+          |     |

              AC    +----+                  +----+    AC

Zehavit

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 16 Dec 2010 12:26:50 +0200

Zehavit,
Which network do you have in mind when you speak about "the same identity [[Sasha: of PEs]] from the network point of view"?

If you mean the PSN, these two PEs MUST have different network identity (Router IDs).

Regards,
     Sasha
________________________________
From: Alon, Zehavit (NSN - IL/Hod HaSharon) [[email-masked]]
Sent: Thursday, December 16, 2010 12:08 PM
To: Alon, Zehavit (NSN - IL/Hod HaSharon); Alexander Vainshtein; ext Aissaoui,Mustapha (Mustapha); [email-masked]
Subject: RE: [PWE3] pwe3 redundancy drafts: draft-ietf-pwe3-redundancy-03

Hi again

I understand that if we are implementing the dual homing using LAG, for the LAG protocol, the two PEs should be configured to look like one PE, since the LAG is not designed to work with two partners, but only with one.

Assuming the dual homing is done with a different mechanism (NOT LAG), should both PEs have the same identity from the network point of view?

Thanks
Zehavit

Phone:     +972-9-7751338;
Cell:         +972-50-4422590;

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Alon, Zehavit (NSN - IL/Hod HaSharon)
Sent: Thursday, December 16, 2010 12:00
To: ext Alexander Vainshtein; ext Aissaoui,Mustapha (Mustapha); [email-masked]
Subject: Re: [PWE3] pwe3 redundancy drafts: draft-ietf-pwe3-redundancy-03

Hello Alexander.

Thanks
Zehavit

Phone:     +972-9-7751338;
Cell:         +972-50-4422590;

Alon,

My 2c,
     Sasha

Thanks again
Zehavit

Phone:     +972-9-7751338;
Cell:         +972-50-4422590;

Hi Zehavit,

Mustapha.

         |                                                  |

         |          |                            |          |

         |          V    V                  V    V          |

         V    AC    +----+                  +----+     AC   V

   |     |          +----+       X          +----+          |     |

              AC    +----+                  +----+    AC

Zehavit