Subject: [PWE3] Question on draft-boutros-pwe3-mpls-tp-mac-wd-01

From: Greg Mirsky <[email-masked]>
Date: Tue, 17 May 2011 21:44:11 -0700

Dear Authors and All,
I have a question to the document presented. The question is related to
format of PW OAM message as defined in draft-ietf-pwe3-static-pw-status-03:

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |0 0 0 1|Version|   Reserved    | 0xZZ PW OAM Message           |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |         Refresh Timer         |  TLV Length   |A|   Flags     |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                                                               |
   ~                            TLVs                               ~
   |                                                               |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

TLV Length is 8 bits long and thus combined length of PW OAM TLVs can be
only 255 bytes long. That is sufficient for signalling PW Status message.
But the limit might force to send multiple PW OAM messages if the list of
specific MAC addresses to withdraw grows too long. Perhaps the format of PW
OAM message might be changed to use ACH TLV per RFC 5586, have Refresh Timer
and PW OAM Flag TLVs.

Regards,
Greg

---

From: [email-masked]
Date: Fri, 20 May 2011 10:50:16 +0800

Hi All,
Reusing PW OAM message could work, but I suggest to define another message 
type, e.g, MAC Withdraw message.
1. usually, PW OAM does not including MAC withdraw. By integrating MAC 
withdraw to PW OAM message will lead to some concept confusing.
2. the MAC withdraw message has different advertise behavior with PW OAM 
message, e.g, in H-VPLS network.
I think another message type would be much clear.

Regards
Lizhong

> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Tue, 17 May 2011 21:44:11 -0700
> From: Greg Mirsky <[email-masked]>
> To: "Siva Sivabalan(msiva)" <[email-masked]>,   Sami Boutros
>    <[email-masked]>,    Luca Martini <[email-masked]>, pwe3
>    <[email-masked]>
> Cc: [email-masked]
> Subject: [PWE3] Question on draft-boutros-pwe3-mpls-tp-mac-wd-01
> Message-ID: <BANLkTi=[email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"
> 
> Dear Authors and All,
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://www.ietf.org/mail-
> archive/web/pwe3/attachments/20110517/8f5802b2/attachment.htm>
> 
> ------------------------------
> 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.