Subject: [PWE3] Requesting additional feedback on draft-cohn-mpls-tp-pw-protection-01

From: "Daniel Cohn" <[email-masked]>
Date: Wed, 3 Aug 2011 10:23:50 +0300

Hi,

The authors would like to request additional feedback on the MPLS-TP
Linear Protection Applicability to MS-PW,
http://tools.ietf.org/html/draft-cohn-mpls-tp-pw-protection-01

Specifically, at the PWE3 meeting last week, there was a discussion on
whether the PW redundancy bit draft
(http://tools.ietf.org/html/draft-ietf-pwe3-redundancy-bit-04) can
comply with MPLS-TP requirements for PW protection.

We believe the answer to be clearly in the negative, and therefore would
like to require WG adoption of the above draft after comments on this
are addressed. 

This is a list of the TP requirements that in our opinion are not met by
the PW redundancy draft. 

Please do not interpret the below as negative criticism of the PW
redundancy draft - it is not. The question is not about the merits of
the PW redundancy protocol, but whether it complies with TP requirements
(which historically came after the PW redundancy draft)

1.- According to RFC 5654 (req 65), MPLS-TP MUST support 1+1 protection.
PW redundancy draft does not comply with this.

2.- According to RFC 5654 (req 76 and 83) MPLS-TP MUST support
management-plane triggers as defined in RFC 4427 - specifically lockout,
forced and manual switch. Although the OPTIONAL switchover coordination
mode in PW redundancy draft (6.3) implicitly support some management
triggers, it cannot support all triggers in RFC 4427. For example,
forced switch and lockout are not supported (see 6.3.2 - switchover
command is ignore if requested PW is not up)

3.- According to RFC 5654 (req 75), MPLS-TP MUST support OAM-based
triggers. PW redundancy draft exclusively relies on PW status bits
triggers.

4.- According to RFC 5654 (req 77), there MUST be a mechanism to
distinguish administrative recovery actions from recovery actions
initiated by other triggers. This is not supported by the PW redundancy
draft - the switchover request message does not specify what triggered
the action on the other endpoint.

5.- According to RFC 5654 (req 79), MPLS-TP protection mechanisms MUST
support priority logic to negotiate and accommodate coexisting requests
for protection-switching (e.g., administrative requests and requests due
to link/node failures). For example, PW redundancy mechanisms do not
specify priority between administrative triggers (e.g. forced/manual
switch) and failure triggers (e.g. SF or SD).

6.- According to RFC 5654 (req 73), MPLS-TP MUST support revertive and
non-revertive behavior. PW redundancy draft provides OPTIONAL support of
reversion, without explicit definitions of how the WTR timer is handled
(e.g. what happens if different timer values are configured in each
side, no administrative command to clear the WTR state), and without
provisioning mismatch indication (like R bit in linear protection
draft).

7.- According to RFC 5654 (req 58), MPLS-TP MUST support 50 ms recovery.
The linear protection draft supports several features that reduce the
recovery time, such as:

- 1-phase operation, while PW redundancy draft in the switchover
coordination mode is 2-phase (switch only after receiving confirmation
from remote endpoint)

- Rapid retransmission of PSC messages to overcome packet loss. In PW
redundancy, the loss of a single switchover coordination message will
result in recovery times significantly higher than 50 ms

8.- According to RFC 5654 (req 61), MPLS-TP MUST support coordination
with server layer protection protocols to avoid race conditions - linear
protection defines hold-off timer to comply with this requirement. PW
redundancy does not support this.

Looking forward for comments.

---

From: Mach Chen <[email-masked]>
Date: Fri, 19 Aug 2011 08:11:52 +0000

Hi,

According to Daniel's explanation, I think the idea (linear protection for PW) is straightforward , I support to progress it.

Best regards,
Mach

From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniel Cohn
Sent: Wednesday, August 03, 2011 3:24 PM
To: [email-masked]
Subject: [PWE3] Requesting additional feedback on draft-cohn-mpls-tp-pw-protection-01

Hi,

The authors would like to request additional feedback on the MPLS-TP Linear Protection Applicability to MS-PW, http://tools.ietf.org/html/draft-cohn-mpls-tp-pw-protection-01

Specifically, at the PWE3 meeting last week, there was a discussion on whether the PW redundancy bit draft (http://tools.ietf.org/html/draft-ietf-pwe3-redundancy-bit-04) can comply with MPLS-TP requirements for PW protection.
We believe the answer to be clearly in the negative, and therefore would like to require WG adoption of the above draft after comments on this are addressed.

This is a list of the TP requirements that in our opinion are not met by the PW redundancy draft.

Please do not interpret the below as negative criticism of the PW redundancy draft - it is not. The question is not about the merits of the PW redundancy protocol, but whether it complies with TP requirements (which historically came after the PW redundancy draft)

1.- According to RFC 5654 (req 65), MPLS-TP MUST support 1+1 protection. PW redundancy draft does not comply with this.

2.- According to RFC 5654 (req 76 and 83) MPLS-TP MUST support management-plane triggers as defined in RFC 4427 - specifically lockout, forced and manual switch. Although the OPTIONAL switchover coordination mode in PW redundancy draft (6.3) implicitly support some management triggers, it cannot support all triggers in RFC 4427. For example, forced switch and lockout are not supported (see 6.3.2 - switchover command is ignore if requested PW is not up)

3.- According to RFC 5654 (req 75), MPLS-TP MUST support OAM-based triggers. PW redundancy draft exclusively relies on PW status bits triggers.

4.- According to RFC 5654 (req 77), there MUST be a mechanism to distinguish administrative recovery actions from recovery actions initiated by other triggers. This is not supported by the PW redundancy draft - the switchover request message does not specify what triggered the action on the other endpoint.

5.- According to RFC 5654 (req 79), MPLS-TP protection mechanisms MUST support priority logic to negotiate and accommodate coexisting requests for protection-switching (e.g., administrative requests and requests due to link/node failures). For example, PW redundancy mechanisms do not specify priority between administrative triggers (e.g. forced/manual switch) and failure triggers (e.g. SF or SD).

6.- According to RFC 5654 (req 73), MPLS-TP MUST support revertive and non-revertive behavior. PW redundancy draft provides OPTIONAL support of reversion, without explicit definitions of how the WTR timer is handled (e.g. what happens if different timer values are configured in each side, no administrative command to clear the WTR state), and without provisioning mismatch indication (like R bit in linear protection draft).

7.- According to RFC 5654 (req 58), MPLS-TP MUST support 50 ms recovery. The linear protection draft supports several features that reduce the recovery time, such as:
- 1-phase operation, while PW redundancy draft in the switchover coordination mode is 2-phase (switch only after receiving confirmation from remote endpoint)
- Rapid retransmission of PSC messages to overcome packet loss. In PW redundancy, the loss of a single switchover coordination message will result in recovery times significantly higher than 50 ms

8.- According to RFC 5654 (req 61), MPLS-TP MUST support coordination with server layer protection protocols to avoid race conditions - linear protection defines hold-off timer to comply with this requirement. PW redundancy does not support this.