Subject: Re: [PWE3] IETF Last Call comment on draft-ietf-pwe3-gal-in-pw

From: [email-masked]
Date: Wed, 17 Aug 2011 11:46:09 +0800

Hi Sasha,
Do you mean different PW segments of one MS-PW could support different 
flow label capability? If in that case, flow LSE is not transparent to the 
label swap operation on S-PE, Flow Label Sub-TLV signalling is also not 
transitive, which is conflict with section 6 of draft-ietf-pwe3-fat-pw. If 
we want to do this, we have to change the draft-fat-pw.

Regards
Lizhong

> ------------------------------
> 
> Message: 5
> Date: Tue, 16 Aug 2011 20:02:20 +0300
> From: Alexander Vainshtein <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>,   Vladimir Kleiner
>    <[email-masked]>,   Idan Kaspit 
<[email-masked]>,
>    Mishael Wexler <[email-masked]>,   pwe3 <[email-masked]>,
>    Oren Gal <[email-masked]>,   John Shirron
>    <[email-masked]>,   Rotem Cohen <[email-masked]>
> Subject: Re: [PWE3] IETF Last Call comment on
>    draft-ietf-pwe3-gal-in-pw
> Message-ID:
>    <[email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"
> 
> Hi all,
> After having sent out my comments I've noticed that the specific 
> example to illustrate the need to combine GAL and "flow label" was 
inaccurate.
> 
> A more relevant example would look like following (I do not include 
> a diagram, but it can be easily provided if necessary)
> 
>  1.  A MS-PW:
>     *   Starts at an S-PE that resides at the edge of an MPLS-TP 
> domain (no ECMP)
>     *   Crosses this domain and enters an IP/MPLS domain with ECMP 
> enabled using a T-PE that resides at the age of these two domains
>     *   Leaves this domain and enters a 2nd MPLS-TP domain (using 
> the 2nd T-PE)
>     *   Terminates on another S-PE at the edge of the 2nd MPLS-TP domain
>  2.  The operator intends to improve traffic distribution in the 
> IP/MPLS domain, hence he enables insertion and discard of "flow 
> labels" at the two S-PEs. Note that:
>     *   This does not violate the MPLS-TP restriction on ECMP: ECMP 
> does not happen in he MPLS-TP domains
>     *   T-PEs do not even have to be aware of flow labels
>  3.  The operator also intends to operate some end-to-end OAM for 
> this MS-PW using "GAL-in-PW". This results in a conflict since both 
> GAL and "flow label" are defined (in the corresponding drafts) as 
> bottom of stack.
> 
> 
> 
> IMHO this describes a realistic scenario where the two drafts are in
> controversy.
> 
> Regards,
>      Sasha
> _____________________________

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 17 Aug 2011 06:50:10 +0300

Hi Lizhong,
No.  I mean that the flow label can be inserted by T-PE (and only by T-PE) even if some of the domains that are crossed by an MS-PW do not perform ECMP. In the case of an MPLS-TP domain, ECMP would be simply disabled. But in an IP/MPLS domain ECP can be enabled, and the hash would include flow labels.

Hopefully this clarifies my position.

Regards,
     Sasha

________________________________
From: [email-masked] [[email-masked]]
Sent: Wednesday, August 17, 2011 6:46 AM
To: Alexander Vainshtein
Cc: [email-masked]; [email-masked]; Vladimir Kleiner; Idan Kaspit; Mishael Wexler; Oren Gal; John Shirron; Rotem Cohen
Subject: Re: [PWE3] IETF Last Call comment on draft-ietf-pwe3-gal-in-pw

Hi Sasha,
Do you mean different PW segments of one MS-PW could support different flow label capability? If in that case, flow LSE is not transparent to the label swap operation on S-PE, Flow Label Sub-TLV signalling is also not transitive, which is conflict with section 6 of draft-ietf-pwe3-fat-pw. If we want to do this, we have to change the draft-fat-pw.

Regards
Lizhong

>    <[email-masked]>,   Idan Kaspit <[email-masked]>,
> example to illustrate the need to combine GAL and "flow label" was inaccurate.
>

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: [email-masked]
Date: Wed, 17 Aug 2011 12:13:42 +0800

Hi Sasha,
But in your example, you said: "The operator intends to improve traffic 
distribution in the IP/MPLS domain, hence he enables insertion and discard 
of "flow labels" at the two S-PEs". It seems that you want S-PE to insert 
and remove flow label.

Regards
Lizhong

Alexander Vainshtein <[email-masked]> wrote on 
2011-08-17 11:50:10:

> Hi Lizhong,
> No.  I mean that the flow label can be inserted by T-PE (and only by
> T-PE) even if some of the domains that are crossed by an MS-PW do 
> not perform ECMP. In the case of an MPLS-TP domain, ECMP would be 
> simply disabled. But in an IP/MPLS domain ECP can be enabled, and 
> the hash would include flow labels.
> 
> Cc: [email-masked]; [email-masked]; Vladimir Kleiner; Idan Kaspit; 
> Mishael Wexler; Oren Gal; John Shirron; Rotem Cohen

> 
> Hi Sasha, 
> Do you mean different PW segments of one MS-PW could support 
> different flow label capability? If in that case, flow LSE is not 
> transparent to the label swap operation on S-PE, Flow Label Sub-TLV 
> signalling is also not transitive, which is conflict with section 6 
> of draft-ietf-pwe3-fat-pw. If we want to do this, we have to change 
> the draft-fat-pw. 
> 
> Regards 
> Lizhong 
> 
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 17 Aug 2011 09:31:42 +0300

Lizhong,

Oops! This was a typo, T-PE intended there. Lots of thanks for catching it.

Only T-PEs can insert flow labels, and it is insertion by T-PEs which makes the scenario problematic, because it combines:

1.       ECMP in the "middle" IP/MPLS domain based on hashing of the label stack and hence requiring flow labels "end-to-end"

2.       End-to-end fate-sharing OAM which, if VCCV Type 1 is not available, would presumably require GAL to guarantee that OAM packets do not leak to remote CE.

Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, August 17, 2011 7:14 AM
To: Alexander Vainshtein
Cc: Idan Kaspit; John Shirron; Mishael Wexler; [email-masked]; Oren Gal; [email-masked]; Rotem Cohen; Vladimir Kleiner
Subject: RE: [PWE3] IETF Last Call comment on draft-ietf-pwe3-gal-in-pw

Hi Sasha,
But in your example, you said: "The operator intends to improve traffic distribution in the IP/MPLS domain, hence he enables insertion and discard of "flow labels" at the two S-PEs". It seems that you want S-PE to insert and remove flow label.

Regards
Lizhong