Subject: [PWE3] VCCV Type=3 break in draft-dong-pwe3-redundancy-spe

From: Lizhong Jin <[email-masked]>
Date: Wed, 16 Nov 2011 20:50:54 +0800

Hi,
I raised the VCCV Type=3 problem for draft-dong-pwe3-redundancy-spe. In
order to make it clear, I put it on the list.
If the standby PW has more/less S-PE hops than primary PW, then the VCCV
packets send to remote T-PE with VCCV Type=3 could not work. That is, in
figure 1 in the draft, the S-PE hop number may different for PW-Seg2 and
PW-Seg3.  If you set the TTL as sufficiently large, the primary/standby PW
with less S-PE hop would not receive the VCCV packet. Hope the problem is
clear.

Thanks
Lizhong

---

From: Jie Dong <[email-masked]>
Date: Wed, 16 Nov 2011 14:37:31 +0000

Hi Lizhong,

Thanks for your comment. 

For the scenario you described and if type 3 is used, the T-PE could first get the TTL hops by iteratively tracing the MS-PW. 

Also when the PW has switched to the standby pw segment, the S-PE information could be updated to the T-PE if thers is a control plane. 

And IMO for MS-PW it would be better to use CW or the method proposed in draft-nadeau-pwe3-vccv-2, as some T-PE may have no idea of the exact hops to the remote T-PE.

Regards,
Jie

________________________________________
From: [email-masked] [[email-masked]] on behalf of Lizhong Jin [[email-masked]]
Sent: Wednesday, November 16, 2011 20:50
To: Jie Dong
Cc: [email-masked]
Subject: [PWE3] VCCV Type=3 break in draft-dong-pwe3-redundancy-spe

Hi,
I raised the VCCV Type=3 problem for draft-dong-pwe3-redundancy-spe. In order to make it clear, I put it on the list.
If the standby PW has more/less S-PE hops than primary PW, then the VCCV packets send to remote T-PE with VCCV Type=3 could not work. That is, in figure 1 in the draft, the S-PE hop number may different for PW-Seg2 and PW-Seg3.  If you set the TTL as sufficiently large, the primary/standby PW with less S-PE hop would not receive the VCCV packet. Hope the problem is clear.

Thanks
Lizhong