Subject: [PWE3] Updates to WG milestones

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Thu, 24 Nov 2011 12:57:30 +0100

All,

We need to update the milestones that we have on the charter to reflect our current work items and the revised dates that we expect to complete them.

Please find below a list of the updates we propose for the milestones that are currently not marked as 'done'.

We have also added a few notes against some of the milestones.

Please can you send any comments to the PWE3 list before Friday 2nd December.

Regards,

Matthew & Andy

  Done - P2MP Requirements LC
  Done - PW Status signalling in static/MPLS-TP
  Sep 2011 - Security Considerations LC **propose delete due to lack of interest
  Sep 2011 - Congestion Considerations **propose delete
  Mar 2012 - Packet PW Requirements / solution
  Mar 2012 - Dynamic MS-PW LC
  Jul 2012 - P2MP PW Signaling (root initiated)
  Jul 2012 - Signaling extensions for MPLS-TP OAM
  Jul 2012 - Static MS-PW extensions   **new
  Jul 2012 - Typed Wildcard FEC   **new
  Jul 2012 - Static PW status reduction  **new
  Jul 2012 - Enhanced PW OAM
  Sept 2012 - Multisegment PW MIB **propose delete due to lack of interest
  Dec 2012 - P2MP PW Signaling (leaf initiated)

New milestones:

---

From: Thomas D Nadeau <[email-masked]>
Date: Thu, 24 Nov 2011 07:16:45 -0500

What does "enhance ow oam " mean?  Also some of the other items ad not necessarily clearly defined as to just what work will entail completing them.

Tom

On Nov 24, 2011, at 6:57 AM, "Bocci, Matthew (Matthew)" <matthew.bocci@alcatel-lucen malso t.com> wrote:

> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Thu, 24 Nov 2011 17:51:15 +0100

Tom,

This was for MPLS-TP. I think it should actually read 'VCCV extensions to
support MPLS-TP OAM'.

Matthew

On 24/11/2011 12:16, "Thomas D Nadeau" <[email-masked]> wrote:

>What does "enhance ow oam " mean?  Also some of the other items ad not
>necessarily clearly defined as to just what work will entail completing
>them.
>
>Tom
>
>
>
>On Nov 24, 2011, at 6:57 AM, "Bocci, Matthew (Matthew)"
><matthew.bocci@alcatel-lucen malso t.com> wrote:
>
>> All,
>> 
>> We need to update the milestones that we have on the charter to reflect
>>our current work items and the revised dates that we expect to complete
>>them.
>>

---

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 28 Nov 2011 11:43:53 -0500

Hi Mathew -
Comment on PW congestion consideration that is proposed for 'delete' from charter.

Was wondering if PW-QOS-signaling (http://tools.ietf.org/html/draft-shah-pwe3-pw-qos-signaling-02)
that proposed throttling from successor to predecessor PE (via feedback loop) is applicable to this charter??

Also, why proposed delete? No interest? p2mp difficulties?

Thanks,
himanshu

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Thursday, November 24, 2011 6:58 AM
To: [email-masked]
Subject: [PWE3] Updates to WG milestones

All,

Regards,

Matthew & Andy

New milestones:

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 28 Nov 2011 12:15:00 -0500

Dear Matthew, et al.,
How "Jul 2012 - Signaling extensions for MPLS-TP OAM" is applicable to the PWE3 WG? Is that a placeholder for PW OAM configuration extensions?

	Regards,
		Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Thursday, November 24, 2011 8:51 AM
To: Thomas D Nadeau
Cc: [email-masked]
Subject: Re: [PWE3] Updates to WG milestones

Tom,

This was for MPLS-TP. I think it should actually read 'VCCV extensions to support MPLS-TP OAM'.

Matthew

On 24/11/2011 12:16, "Thomas D Nadeau" <[email-masked]> wrote:

>> We need to update the milestones that we have on the charter to 
>>reflect our current work items and the revised dates that we expect to 
>>complete them.
>>

---

From: <[email-masked]>
Date: Mon, 28 Nov 2011 14:07:43 -0500

I don't see anything that looks like congestion control or cooperative behavior in
the face of congestion in that draft - IMHO, it looks like it's aimed at bandwidth
provisioning (committed rate + max burst rate/size).

OTOH, I think at least Yaakov Stein and I are going to try take another run at
producing a draft on congestion considerations (e.g., what happens when a fixed
bandwidth IP pseudowire is mixed with congestion responsive IP traffic so that
the two compete for limited forwarding capacity, and what should be done about
it?), but we both have problems with our day jobs distracting us from IETF work,
so this won't exactly be quick ;-).

If this comes together, we should have at least a -00 draft for Paris, so I'd ask
that the congestion considerations WG LC milestone be moved out to sometime next
summer (or even September 2011).

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

From: [email-masked] [mailto:[email-masked]] On Behalf Of Shah, Himanshu
Sent: Monday, November 28, 2011 11:44 AM
To: Bocci, Matthew (Matthew); [email-masked]
Subject: Re: [PWE3] Updates to WG milestones

Hi Mathew -

Thanks,
himanshu

All,

Regards,

Matthew & Andy

New milestones:

---

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 28 Nov 2011 14:21:50 -0500

The unsolicited LDP notifications from egress to ingress with 'adjusted' b/w info is meant to notify
the ingress  about the 'congestion' experience at egress based on traffic received from ingress over the PW.

May be it can be clarified a little better. It is meant for 'any' traffic and not specific to client IP traffic.

However, I believe eric rosen already has a draft in the area you are considering (http://tools.ietf.org/html/draft-rosen-pwe3-congestion-04)
for PW congestion.

Thanks,
himanshu

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, November 28, 2011 2:08 PM
To: Shah, Himanshu; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: Updates to WG milestones

Thanks,
--David

Hi Mathew -

Thanks,
himanshu

All,

Regards,

Matthew & Andy

New milestones:

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Tue, 29 Nov 2011 12:32:34 +0100

I believe that this milestone was primarily aimed at defining a general congestion framework, stating the problem and laying the foundation for any solutions.

We suggested removing the milestone because the original congestion framework lost momentum a long time ago and there was also an understanding wihtt he transport area that any special congestion considerations would be called out on a case by case basis in specific PWE3 drafts.

If there is interest in resurrecting this work, them I'm happy to leave the milestone in for now.

Matthew

On 28/11/2011 19:21, "Shah, Himanshu" <[email-masked]<mailto:[email-masked]>> wrote:

The unsolicited LDP notifications from egress to ingress with ‘adjusted’ b/w info is meant to notify
the ingress  about the ‘congestion’ experience at egress based on traffic received from ingress over the PW.

May be it can be clarified a little better. It is meant for ‘any’ traffic and not specific to client IP traffic.

Thanks,
himanshu

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Monday, November 28, 2011 2:08 PM
To: Shah, Himanshu; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: Updates to WG milestones

I don’t see anything that looks like congestion control or cooperative behavior in
the face of congestion in that draft - IMHO, it looks like it’s aimed at bandwidth
provisioning (committed rate + max burst rate/size).

so this won’t exactly be quick ;-).

If this comes together, we should have at least a -00 draft for Paris, so I’d ask
that the congestion considerations WG LC milestone be moved out to sometime next
summer (or even September 2011).

Thanks,
--David
[email-masked]<mailto:[email-masked]>        Mobile: +1 (978) 394-7754

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Shah, Himanshu
Sent: Monday, November 28, 2011 11:44 AM
To: Bocci, Matthew (Matthew); [email-masked]<mailto:[email-masked]>
Subject: Re: [PWE3] Updates to WG milestones

Hi Mathew –
Comment on PW congestion consideration that is proposed for ‘delete’ from charter.

Thanks,
himanshu

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Thursday, November 24, 2011 6:58 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [PWE3] Updates to WG milestones

All,

Regards,

Matthew & Andy

New milestones:

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 29 Nov 2011 12:06:28 +0000

On 28/11/2011 19:21, Shah, Himanshu wrote:
>
> /However, I believe eric rosen already has a draft in the area you are 
> considering (http://tools.ietf.org/html/draft-rosen-pwe3-congestion-04)/
>
> /for PW congestion./
>
> //
>
That draft died a long time ago.

Stewart (an author)

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Tue, 29 Nov 2011 13:28:54 +0100

Greg,

Yes. 

Matthew

On 28/11/2011 17:15, "Gregory Mirsky" <[email-masked]> wrote:

>Dear Matthew, et al.,
>How "Jul 2012 - Signaling extensions for MPLS-TP OAM" is applicable to
>the PWE3 WG? Is that a placeholder for PW OAM configuration extensions?
>
>	Regards,
>		Greg
>

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 29 Nov 2011 09:54:03 -0500

Surely.
My comment was related to 'new' work.
/himanshu

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Tuesday, November 29, 2011 7:06 AM
To: [email-masked]
Subject: Re: [PWE3] Updates to WG milestones

Stewart (an author)

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 29 Nov 2011 09:59:26 -0500

In my opinion,  PWs could benefit from general purpose flow control.
Let me circle back with my co-authors for interest in progressing this draft.
Till then, would appreciate if you could leave the milestone in for now..

Thanks,
himanshu

From: Bocci, Matthew (Matthew) [mailto:[email-masked]]
Sent: Tuesday, November 29, 2011 6:33 AM
To: Shah, Himanshu; [email-masked]; [email-masked]
Subject: Re: Updates to WG milestones

Matthew

Thanks,
himanshu

Thanks,
--David

Hi Mathew -

Thanks,
himanshu

All,

Regards,

Matthew & Andy

New milestones: