Subject: [PWE3] Reply to the question about "Why does SS-PW also need the explicit PW to PSN tunnel binding"

From: Mach Chen <[email-masked]>
Date: Wed, 16 Nov 2011 05:14:43 +0000

Hi,

Continue the discussion about "Why does SS-PW also need the explicit PW to PSN tunnel binding". 

The  draft is trying to satisfy the requirement that expects the bidirectional PW traffic to follow the same route in both directions. With the current mechanisms (binding to PSN tunnel locally and independently, no coordination between the PEs ), it cannot make sure that the both ends of a PW(no matter what SS-PW or MS-PW) to select and bind to the PSN tunnels with the same route especially when there are multiple PSN tunnels connecting the PEs. This is why this draft defines the explicit PW to PSN tunnel binding mechanisms.

Hope this could clarify the question.

Many thanks,
Mach

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 16 Nov 2011 07:29:48 +0200

Mach,
Could you please refer to the source of the requirement for "the bidirectional PW traffic to follow the same route in both directions"?

I do not recall any such either in the original PWE3 documents or in the MPLS-TP ones. 

I believe that I have asked once whether each PW (SS or MS) is a co-routed bi-directional LSP in the MPLS-TP terms, and Stewart has confirmed that it is.

If the requirement in question is just part of the draft itself, it is also OK, just say so...

Regards,
     Sasha

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Mach Chen [[email-masked]]
Sent: Wednesday, November 16, 2011 7:14 AM
To: [email-masked]
Subject: [PWE3] Reply to the question about "Why does SS-PW also need the explicit PW to PSN tunnel binding"

Hi,

Many thanks,
Mach
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: Mach Chen <[email-masked]>
Date: Wed, 16 Nov 2011 06:25:20 +0000

Hi Sasha,

Thanks for your prompt response!

IMHO, I think this (http://tools.ietf.org/html/rfc6373#section-5.3.2) could be treated as the requirement. 

Best regards,
Mach

________________________________________
发件人: Alexander Vainshtein [[email-masked]]
发送时间: 2011年11月16日 13:29
到: Mach Chen
Cc: [email-masked]; Stewart Bryant ([email-masked])
主题: RE: [PWE3] Reply to the question about "Why does SS-PW also need the explicit PW to PSN tunnel binding"

Mach,

Regards,
     Sasha

Hi,

Many thanks,
Mach

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Wed, 16 Nov 2011 11:13:05 +0100

Hi Mach,

Perhaps you could reference this requirement, directly, in the draft.

Also, you imply that this mechanism will work for FEC128. However, it is
not clear how this can work because the label mapping messages are sent
independently by each PE. I.e. One PE does not wait for the label mapping
from the far end before sending its label mapping. Please can you clarify?

Best regards,

Matthew

On 16/11/2011 06:25, "Mach Chen" <[email-masked]> wrote:

>Could you please refer to the source of the requirement for "the
>bidirectional PW traffic to follow the same route in both directions"?
>
>I believe that I have asked once whether each PW (SS or MS) is a
>co-routed bi-directional LSP in the MPLS-TP terms, and Stewart has
>confirmed that it is.
>
>The  draft is trying to satisfy the requirement that expects the
>bidirectional PW traffic to follow the same route in both directions.
>With the current mechanisms (binding to PSN tunnel locally and
>independently, no coordination between the PEs ), it cannot make sure
>that the both ends of a PW(no matter what SS-PW or MS-PW) to select and
>bind to the PSN tunnels with the same route especially when there are
>multiple PSN tunnels connecting the PEs. This is why this draft defines
>the explicit PW to PSN tunnel binding mechanisms.
>
>This e-mail message is intended for the recipient only and contains
>information which is CONFIDENTIAL and which may be proprietary to ECI
>Telecom. If you have received this transmission in error, please inform
>us by e-mail, phone or fax, and then delete the original and all copies
>thereof.
>

---

From: Mach Chen <[email-masked]>
Date: Wed, 16 Nov 2011 12:03:26 +0000

Hi Matthew,

Thanks for your reply!

Please see my reply inline with [Mach]...
________________________________________
发件人: [email-masked] [[email-masked]] 代表 Bocci, Matthew (Matthew) [[email-masked]]
发送时间: 2011年11月16日 18:13
到: Mach Chen; Alexander Vainshtein
Cc: [email-masked]; Stewart Bryant
主题: Re: [PWE3] 答复:  Reply to the question about "Why does SS-PW also need the explicit PW to PSN tunnel binding"

Hi Mach,

[Mach] Great idea, will do that.

[Mach]  We call this Active-Active mode in the draft, where both PEs assume the active roles and each independently sends the Label Mapping messages, and this only applies to SS-PW.  When a PE received a Label mapping message, it will check whether it is the Active or Passive PE(by comparing its Node ID with its peer's Node ID, the PE with higher Node ID will be the Active PE and determine the tunnel selection and binding, the other PE will be the passive PE). So, if it is the Passive PE and agrees the tunnel selection, it will send a Label release message to its peer to confirm the binding request. Otherwise, it will send a Label release message to its peer to reject the binding request. That means the Active PE will lead the tunnel selection and binding. These are the procedures defined in the draft.

Best regards,
Matthew

Best regards,

Matthew

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 16 Nov 2011 14:59:40 +0200

Mach,
Could you please explain how the Label Release message (which presumably releases the PW label binding) could be used to confirm something?
Once it reaches the peer PE, the previously received PW label binding is invalidated and PW goes down... Do I miss something?

Regards,
     Sasha

> -----Original Message-----
> From: Mach Chen [mailto:[email-masked]]
> Sent: Wednesday, November 16, 2011 2:03 PM
> To: Bocci, Matthew (Matthew); Alexander Vainshtein
> Subject: 答复: [PWE3] 答复: Reply to the question about "Why does SS-PW
> also need the explicit PW to PSN tunnel binding"
> 
> Hi Matthew,
> 
> Thanks for your reply!
> 
> 发件人: [email-masked] [[email-masked]] 代表 Bocci,
> Matthew (Matthew) [[email-masked]]
> 发送时间: 2011年11月16日 18:13
> 主题: Re: [PWE3] 答复:  Reply to the question about "Why does SS-PW also
> need the explicit PW to PSN tunnel binding"
> 
> Hi Mach,
> 
> [Mach]  We call this Active-Active mode in the draft, where both PEs assume
> the active roles and each independently sends the Label Mapping
> messages, and this only applies to SS-PW.  When a PE received a Label
> mapping message, it will check whether it is the Active or Passive PE(by
> comparing its Node ID with its peer's Node ID, the PE with higher Node ID
> will be the Active PE and determine the tunnel selection and binding, the
> other PE will be the passive PE). So, if it is the Passive PE and agrees the
> tunnel selection, it will send a Label release message to its peer to confirm
> the binding request. Otherwise, it will send a Label release message to its
> peer to reject the binding request. That means the Active PE will lead the
> tunnel selection and binding. These are the procedures defined in the draft.
> 
> 
> Best regards,
> Matthew
> 
> Best regards,
> 
> Matthew
> 
> >主题: RE: [PWE3] Reply to the question about "Why does SS-PW also need
> the
> >explicit PW to PSN tunnel binding"
> >
> >Mach,
> >From: [email-masked] [[email-masked]] On Behalf Of
> Mach
> >Chen [[email-masked]]
> >Subject: [PWE3] Reply to the question about "Why does SS-PW also need
> the
> >explicit PW to PSN tunnel binding"
> >
> >Hi,
> >

---

From: Mach Chen <[email-masked]>
Date: Wed, 16 Nov 2011 13:45:23 +0000

Hi Sasha,

You are right, the Label release message will not confirm the binding request, instead, it is used to reject the binding request when it disagrees the tunnel selection.  

There are two situations:

1. When passive PW sends label release message, it means it rejects the binding request, then the signaling is finished and the PW will not be established. This  probably happens when there are some local policy configured on the passive PE and the policy dose not allow to use the tunnel; or there is no candidate tunnels that satisfy the constraints.

2. When the Label release message is sent by the Active PE, it means that the passive PE had sent the Label mapping message to the Active PE before it received the Label message from the Active PE.   In this situation, the Active PE may have already sent out the Label mapping message and the message is still on the wire, or the Active PE has not sent the Label Mapping message to the passive PE yet and will send soon. In either case, there will be a Label mapping message sent from Active PE that will finally reach at the Passive PE. On receipt of the Label mapping message, the the Passive PE will reply a Label Mapping message to confirm(if it agree the tunnel selection) the binding request and the PW established. Or the passive PE will send a label release message to reject the binding request (situation 1).

Hope this can clarify the question.

Best regards,
Mach
________________________________________
发件人: [email-masked] [[email-masked]] 代表 Alexander Vainshtein [[email-masked]]
发送时间: 2011年11月16日 20:59
到: Mach Chen
Cc: [email-masked]; Stewart Bryant
主题: Re: [PWE3] 答复:  Reply to the question about "Why does SS-PW also need the explicit PW to PSN tunnel binding"

Mach,

Regards,
     Sasha