Subject: Re: [PWE3] CW usage in opposite directions for static PWs

From: Lizhong Jin<[email-masked]>
Date: Mon, 9 Apr 2012 15:18:02 +0800

Hi Yaakov,
Sorry, word mistake. It should not be OR, but AND operation. If one side 
support and the other side not, then CW will not be used. Then the result 
will be aligned with RFC4447.

Regards
Lizhong

> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Sun, 8 Apr 2012 15:28:52 +0000
> From: Yaakov Stein <[email-masked]>
> To: Lizhong Jin <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Subject: Re: [PWE3] CW usage in opposite directions for static PWs
> Message-ID:
>    <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
> 
> Lizhong
> 
> Of course each side needs to KNOW if the other side is using a CW or 
not;
> but, that does not mean they can not be asymmetric.
> 
> What do you mean by OR - that if either CAN use a CW then both MUST use?
> This is the opposite of 4447.
> 
> 
> Y(J)S
> 
> From: Lizhong Jin [mailto:[email-masked]]
> Sent: Saturday, April 07, 2012 05:58
> To: Yaakov Stein
> Cc: [email-masked]
> Subject: Re: [PWE3] CW usage in opposite directions for static PWs
> 
> Hi Yaakov,
> Thanks for the comments during the session of PWE3.
> For the static PW, the CW usage should be consisted, otherwise the 
> packet processing would be wrong. The CW nibble is not enough to 
> identify a ACH, and "PW label + CW nibble" is used to identify ACH. 
> IMO, the static PW CW capability could be got by "OR" operation of 
> both local and remote CW parameters.
> 
> Thanks
> Lizhong
> 
> ------------------------------
> 
> Date: Sun, 1 Apr 2012 12:44:56 +0000
> From: Yaakov Stein <[email-masked]<mailto:[email-masked]>>
> To: "[email-masked]<mailto:[email-masked]>" 
<[email-masked]<mailto:[email-masked]
> >>
> Subject: [PWE3] CW usage in opposite directions for static PWs
> Message-ID:
>        <[email-masked]<
> mailto:[email-masked]>>
> Content-Type: text/plain; charset="us-ascii"
> 
> At the meeting I promised to check when this issue in the subject 
> line was last discussed.
> 
> It was only a short while ago in Prague (see http://www.ietf.
> org/proceedings/80/slides/pwe3-3.pdf slides 9 - 11<http://www.ietf.
> org/proceedings/80/slides/pwe3-3.pdf%20slides%209%20-%2011>).
> 
> I recall a lively discussion after the presentation,
> but the minutes do not show resolution of the issue of whether a CW 
> MUST be used or not used
> in both directions for PWs not set up using the PWE3 control protocol.
> 
> Y(J)S
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://www.ietf.org/mail-
> archive/web/pwe3/attachments/20120408/488442e2/attachment.htm>
> 
> ------------------------------
> 
> ________

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 10 Apr 2012 07:38:58 +0000

Lizhong

OK, maybe I agree. But my point was that this requirement was not fully discussed.

Perhaps a statically configured PW should be able to use the CW in one direction while not using it in the other.

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Monday, April 09, 2012 10:18
To: [email-masked]; Yaakov Stein
Subject: Re: [PWE3] CW usage in opposite directions for static PWs

Hi Yaakov,
Sorry, word mistake. It should not be OR, but AND operation. If one side support and the other side not, then CW will not be used. Then the result will be aligned with RFC4447.

Regards
Lizhong

> Of course each side needs to KNOW if the other side is using a CW or not;
> To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]
> >>

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 10 Apr 2012 08:05:27 +0000

Yaakov, and all,
My reading of RFC 4447 is that in the case of a signaled PW the CW is either used or not used bi-directionally by a PW endpoint.
Further, as per RFC 6073, S-PEs in multi-segment PWs cannot strip, insert or manipulate the CW in any way.
Hence I think that the asymmetric usage of the CW must be prohibited in static PWs in order to assure interoperability of MS-PWs comprised of static and dynamic segments.

(On top of that, I do not see any advantage in allowing asymmetric usage of the CW, but this is a different story.)

Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: Tuesday, April 10, 2012 10:39 AM
To: Lizhong Jin; [email-masked]
Subject: Re: [PWE3] CW usage in opposite directions for static PWs

Lizhong

Y(J)S

Hi Yaakov,

Regards
Lizhong

> To: Lizhong Jin <[email-masked]<mailto:[email-masked]>>
> Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
>    <[email-masked]<mailto:[email-masked]>>
> From: Lizhong Jin [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
> Cc: [email-masked]<mailto:[email-masked]>
> From: Yaakov Stein <[email-masked]<mailto:[email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>>>
> To: "[email-masked]<mailto:[email-masked]><mailto:[email-masked]%3cmailto:[email-masked]%3e>" <[email-masked]<mailto:[email-masked]
<mailto:[email-masked]%3cmailto:[email-masked]%0b>> >>
>        <[email-masked]<
<mailto:[email-masked]%3c%0b>> mailto:[email-masked]>>
> org/proceedings/80/slides/pwe3-3.pdf slides 9 - 11<http://www.ietf.
<http://www.ietf.%0b>> org/proceedings/80/slides/pwe3-3.pdf%20slides%209%20-%2011>).
> URL: <http://www.ietf.org/mail-
<http://www.ietf.org/mail-%0b>> archive/web/pwe3/attachments/20120408/488442e2/attachment.htm>

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 10 Apr 2012 08:14:03 +0000

Sasha

The only scenario I can think of where it is really useful, is the asymmetric bandwidth and usage case.

Consider a bandwidth constrained upstream sending very small packets
(ack's and control signaling) where the CW may be significant overhead,
and a wide bandwidth downstream sending very large packets (e.g., video),
where the CW would be useful.

The mixed static-signaled MS-PW case is not really a constraint.
If the end-end MS-PW uses (or doesn't) the CW,
then the configuration of the static segment(s) would need to enforce that behavior,
along with all other parameters.
This has little to do with the general question of enforcing duplexing behavior.

Y(J)S

From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Tuesday, April 10, 2012 11:05
To: Yaakov Stein
Cc: Lizhong Jin; [email-masked]
Subject: RE: [PWE3] CW usage in opposite directions for static PWs

Yaakov, and all,

Regards,
     Sasha

Lizhong

Y(J)S

Hi Yaakov,

Regards
Lizhong

---

From: Lizhong Jin<[email-masked]>
Date: Tue, 10 Apr 2012 23:34:10 +0800

Hi Yaakov,
The use case below may work, but does not mean asymmetric CW for PW would 
work in all cases. One example is, when CW is used for packet 
fragmentation, if asymmetric CW is used, packet fragmentation may not be 
achieved in one direction, and lead to pack loss. Other examples would be 
OAM tools for PW. IMO, we could consider asymmetric CW as a special 
implemenation case.

Lizhong
 
------------------------
Yaakov Stein <[email-masked]> wrote 2012/04/10 16:14:03:

> My reading of RFC 4447 is that in the case of a signaled PW the CW 
> is either used or not used bi-directionally by a PW endpoint.
> Hence I think that the asymmetric usage of the CW must be prohibited
> in static PWs in order to assure interoperability of MS-PWs 
> comprised of static and dynamic segments.
> 
> (On top of that, I do not see any advantage in allowing asymmetric 
> usage of the CW, but this is a different story.)
> 
> Regards,
>      Sasha
> 
> Perhaps a statically configured PW should be able to use the CW in 
> one direction while not using it in the other.
> 
> Y(J)S
> 
> Sorry, word mistake. It should not be OR, but AND operation. If one 
> side support and the other side not, then CW will not be used. Then 
> the result will be aligned with RFC4447. 
> 
> Regards 
> Lizhong 
> 
not;
> This e-mail message is intended for the recipient only and contains 
> information which is CONFIDENTIAL and which may be proprietary to 
> ECI Telecom. If you have received this transmission in error, please
> inform us by e-mail, phone or fax, and then delete the original and 
> all copies thereof.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 10 Apr 2012 12:08:38 -0400

All,

This has been an extremely useful discussion.

<wg chair hat off>

Personally, I don't really see much utility in asymmetric CWs in a PW.

<wg chair hat on>

Once the WG comes to consensus on the issue one way or the other (and I
would like to hear some more opinions), we should consider document
revisions as necessary to make sure that the consensus is clearly reflected
in the RFCs.

Cheers,
Andy

On Tue, Apr 10, 2012 at 11:34 AM, Lizhong Jin <[email-masked]>wrote:

> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>
>

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 10 Apr 2012 17:14:01 +0100

On 10/04/2012 17:08, Andrew G. Malis wrote:
> Once the WG comes to consensus on the issue one way or the other (and 
> I would like to hear some more opinions), we should consider document 
> revisions as necessary to make sure that the consensus is clearly 
> reflected in the RFCs.
>
> Cheers,
> Andy

For LDP signaled PWs, I don't think there is any ambiguity, the CW 
handling is symmetric. Does anyone read it any other way?

Stewart

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 10 Apr 2012 19:58:46 +0000

Stewart,
You've written:

<quote>
<end quote>

This matches my reading exactly, and this is why I would oppose allowing asymmetric CW usage for static PWs: I do not think that it is healthy to allow operational static PWs that cannot be ever signaled.
(I do not object to having *non-operational* static PWs that, if signaled, would never be set up:-).

My 2c,
     Sasha
________________________________________
From: [email-masked] [[email-masked]] on behalf of Stewart Bryant [[email-masked]]
Sent: Tuesday, April 10, 2012 6:14 PM
To: Andrew G. Malis
Cc: Lizhong Jin; [email-masked]; Yaakov Stein
Subject: Re: [PWE3] CW usage in opposite directions for static PWs

Stewart

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 11 Apr 2012 07:50:59 +0000

Stewart

Of course the PWE3 control protocol is clear in enforcing the use of non-use in both directions.
Even there, I do not recall debate on the subject. It was "yeah, I guess that's OK".

In my slide deck a few years back I discussed the state of affairs for other methods of setting up PWs 

I am OK with a decision to enforce the symmetry,
but we need to discuss this and agree on it.
And perhaps there are other parameters that need similar discussion.
For example, can I set up a TDM PW with an E1 in one direction and a T1 in the other ?
What about a raw Ethernet PW in one direction and a tagged one in the opposite direction ?

If this is a general principle (as I suspect many people believe, but I don't recall was ever explicitly stated)
then this should be written up (and the implications considered).

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Tuesday, April 10, 2012 19:14
To: Andrew G. Malis
Cc: Lizhong Jin; [email-masked]; Yaakov Stein
Subject: Re: [PWE3] CW usage in opposite directions for static PWs

Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 11 Apr 2012 10:55:01 +0100

Yaakov

Why not come at this from a different direction.

Is there an application which requires asymmetry?

Stewart

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 11 Apr 2012 16:24:50 +0000

Stewart

My way of looking at it is different.

Are we sure that we want to rule out asymmetry ?

If we had BW reservation for PWs I would be sure that my answer would be no.

However, while I can't think of many concrete examples
(perhaps others on the list have some good ones)
I don't like ruling things out for no reason.

A wildly successful protocol (RFC 5+something) is one that can be used 
for cases that we didn't think about when we defined it.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Wednesday, April 11, 2012 12:55
To: Yaakov Stein
Cc: Lizhong Jin; [email-masked]
Subject: Re: [PWE3] CW usage in opposite directions for static PWs

Yaakov

Stewart