Subject: Re: [PWE3] CW usage in opposite directions for static PWs

From: Lizhong Jin <[email-masked]>
Date: Sat, 7 Apr 2012 10:58:12 +0800

Hi Yaakov,
Thanks for the comments during the session of PWE3.
For the static PW, the CW usage should be consisted, otherwise the packet
processing would be wrong. The CW nibble is not enough to identify a ACH,
and "PW label + CW nibble" is used to identify ACH. IMO, the static PW CW
capability could be got by "OR" operation of both local and remote CW
parameters.

Thanks
Lizhong

> ------------------------------
>
> Date: Sun, 1 Apr 2012 12:44:56 +0000
> From: Yaakov Stein <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Subject: [PWE3] CW usage in opposite directions for static PWs
> Message-ID:
>        <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
>
> At the meeting I promised to check when this issue in the subject line was
> last discussed.
>
> It was only a short while ago in Prague (see
> http://www.ietf.org/proceedings/80/slides/pwe3-3.pdf slides 9 - 11<
> http://www.ietf.org/proceedings/80/slides/pwe3-3.pdf%20slides%209%20-%2011
> >).
>
> I recall a lively discussion after the presentation,
> but the minutes do not show resolution of the issue of whether a CW MUST
> be used or not used
> in both directions for PWs not set up using the PWE3 control protocol.
>
> Y(J)S
>

---

From: Yaakov Stein <[email-masked]>
Date: Sun, 8 Apr 2012 15:28:52 +0000

Lizhong

Of course each side needs to KNOW if the other side is using a CW or not;
but, that does not mean they can not be asymmetric.

What do you mean by OR - that if either CAN use a CW then both MUST use?
This is the opposite of 4447.

Y(J)S

From: Lizhong Jin [mailto:[email-masked]]
Sent: Saturday, April 07, 2012 05:58
To: Yaakov Stein
Cc: [email-masked]
Subject: Re: [PWE3] CW usage in opposite directions for static PWs

Hi Yaakov,
Thanks for the comments during the session of PWE3.
For the static PW, the CW usage should be consisted, otherwise the packet processing would be wrong. The CW nibble is not enough to identify a ACH, and "PW label + CW nibble" is used to identify ACH. IMO, the static PW CW capability could be got by "OR" operation of both local and remote CW parameters.

Thanks
Lizhong

Date: Sun, 1 Apr 2012 12:44:56 +0000
From: Yaakov Stein <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [PWE3] CW usage in opposite directions for static PWs
Message-ID:
       <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset="us-ascii"

At the meeting I promised to check when this issue in the subject line was last discussed.

It was only a short while ago in Prague (see http://www.ietf.org/proceedings/80/slides/pwe3-3.pdf slides 9 - 11<http://www.ietf.org/proceedings/80/slides/pwe3-3.pdf%20slides%209%20-%2011>).

I recall a lively discussion after the presentation,
but the minutes do not show resolution of the issue of whether a CW MUST be used or not used
in both directions for PWs not set up using the PWE3 control protocol.

Y(J)S