Subject: [PWE3] Updates to goals and milestones

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Fri, 4 May 2012 12:38:44 +0200

All,

Please find below a proposed list of updates to the WG goals and milestones that was presented in Paris, with one modification pushing the P2MP Requirements LC back to Dec 2012.

Please post any comments to the list before Friday 11th May.

Matthew

 Done     - PWE3 WG started, organize editing teams.

  Done     - Hold interim meeting, including discussion of priority of service-specific documents and consider pruning some deliverables

  Done     - Accept drafts of service-specific documents as WG items

  Done     - PW Requirements Document Last Call

  Done     - TDM Circuit Documents Last Call

  Done     - ATM Documents Last Call

  Done     - Ethernet Documents Last Call

  Done     - Fragmentation LC

  Done     - TDM Requirements LC

  Done     - SONET Documents Last Call

  Done     - TDM Documents Last Call

  Done     - Frame Relay Documents Last Call

  Done     - FCS retention Last Call

  Done     - Multi-Segment PW Requirements LC

  Done     - VCCV LC

  Done     - PWE3 Services MIBs LC

  Done     - PPP/HDLC PW LC

  Done     - Wildcard FEC LC

  Done     - TDM Signaling LC

  Done- Multi-Segment Architecture LC

  Done     - Basic Pseudowire MIBs LC

  Done - PW OAM Mapping LC

  Done - Multi-Segment PW LC

  Done - PW Protection and Restoration Requirements LC

  Done - PW Protection and Restoration Architecture

  Done - Generic Associated Channel Header LC

  Done - PW Protection and Restoration LC

  Done - Fiber Channel Encap LC

  Done- Multipath PW LC

  Done  - Packet PW Requirements / solution

  Dec  2012 - P2MP Requirements LC

  Done  – PW Status signalling in static/MPLS-TP

  July 2012 - Dynamic MS PW LC

  Sept 2012 - Enhanced PW OAM

  Sept 2011 – Signaling extensions for MPLS-TP OAM

  Dec 2012 - Multisegment PW MIB

  Dec 2012 - Security Considerations LC

  Dec 2012 – Congestion Considerations

 Dec  2012 - P2MP PW Signaling (root initiated)

 Dec 2012 – P2MP PW Signaling (leaf initiated)

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 4 May 2012 07:37:37 -0400

Matthew,

In Paris there was discussion (and subsequent followup) about a VCCV-bis document. I am not sure if a formal consensus call was issued on that, but I wonder if it needs to be captured as a milestone (or how it relates to "Enhanced PW OAM"). 

Thumb typed by Carlos Pignataro.
Excuze typofraphicak errows

On May 4, 2012, at 6:39 AM, "Bocci, Matthew (Matthew)" <[email-masked]> wrote:

> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 4 May 2012 15:53:55 -0400

Dear Matthew, Carlos, et al.,
I agree with Carlos that updates to VCCV Control Channels resulting from discussion of GAL as Type 4 VCCV CC, perhaps as RFC5085bis, can be captured in Milestones. But I think that this work not necessarily tied with CV capability extension that, I think, referenced as "Enhanced PW OAM".

    Regards,
        Greg
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Friday, May 04, 2012 4:38 AM
To: Bocci, Matthew (Matthew)
Cc: [email-masked]
Subject: Re: [PWE3] Updates to goals and milestones

Matthew,

On May 4, 2012, at 6:39 AM, "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>> wrote:

All,

Matthew

  Done     - Fragmentation LC

  Done     - VCCV LC

  Done     - PPP/HDLC PW LC

  Done     - Wildcard FEC LC

  Done     - TDM Signaling LC

  Done - PW OAM Mapping LC

  Done- Multipath PW LC

  Done  - PW Status signalling in static/MPLS-TP

  Sept 2011 - Signaling extensions for MPLS-TP OAM

  Dec 2012 - Congestion Considerations

 Dec 2012 - P2MP PW Signaling (leaf initiated)

_______________________________________________
pwe3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Tue, 8 May 2012 12:19:22 +0200

Greg, Carlos,

I think this milestone started life as referring to any PW OAM extensions required for MPLS-TP. However, it has become very ambiguous. There are really a number of objectives that we should capture, including at least the following:

 *   Additional VCCV Channel Type using the GAL
 *   VCCV capability negotiation for MPLS-TP OAM tools.
 *   Rationalisation of VCCV (RFC5085bis)

I think we could replace this milestone with milestones for the above.

Regards

Matthew

On 04/05/2012 20:53, "Gregory Mirsky" <[email-masked]<mailto:[email-masked]>> wrote:

    Regards,
        Greg
________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Friday, May 04, 2012 4:38 AM
To: Bocci, Matthew (Matthew)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [PWE3] Updates to goals and milestones

Matthew,

All,

Matthew

  Done     - Fragmentation LC

  Done     - VCCV LC

  Done     - PPP/HDLC PW LC

  Done     - Wildcard FEC LC

  Done     - TDM Signaling LC

  Done - PW OAM Mapping LC

  Done- Multipath PW LC

  Dec  2012- P2MP Requirements LC

  Sept 2012- Enhanced PW OAM

  Dec 2012- Multisegment PW MIB

  Dec 2012- Security Considerations LC

  Dec 2012– Congestion Considerations

 Dec  2012- P2MP PW Signaling (root initiated)

 Dec 2012– P2MP PW Signaling (leaf initiated)

---

From: Thomas D Nadeau <[email-masked]>
Date: Tue, 8 May 2012 07:50:06 -0400

Agreed.

On May 8, 2012, at 6:19 AM, "Bocci, Matthew (Matthew)" <[email-masked]> wrote:

> Additional VCCV Channel Type using the GAL
> VCCV capability negotiation for MPLS-TP OAM tools.
> Rationalisation of VCCV (RFC5085bis)
> 
> On 04/05/2012 20:53, "Gregory Mirsky" <[email-masked]> wrote:
>

---

From: Carlos Pignataro <[email-masked]>
Date: Tue, 8 May 2012 09:49:33 -0400

Matthew,

I agree, sounds like a good approach.

Thanks,

-- Carlos.

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 8 May 2012 14:03:53 +0000

Matthew

What if a single document (5085-bis) solves all these problems ?
Would you still want 3 milestones ?

Does "rationalization of VCCV" include unifying the BFD portion in RFC 5885
with the rest of the modes (thus obsoleting 5085 and 5885) ?

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Tuesday, May 08, 2012 13:19
To: Gregory Mirsky; Carlos Pignataro (cpignata)
Cc: [email-masked]
Subject: Re: [PWE3] Updates to goals and milestones

Greg, Carlos,

Regards

Matthew

    Regards,
        Greg

Matthew

  Done     - Fragmentation LC

  Done     - VCCV LC

  Done     - PPP/HDLC PW LC

  Done     - Wildcard FEC LC

  Done     - TDM Signaling LC

  Done - PW OAM Mapping LC

  Done- Multipath PW LC

  Dec 2012- Congestion Considerations

 Dec 2012- P2MP PW Signaling (leaf initiated)
_______________________________________________
pwe3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Tue, 8 May 2012 16:38:26 +0200

Yakov,

We currently have two separate drafts covering the first two bullets, but I am not sure that the milestones should be interpreted as a mapping to separate drafts.

I believe the WG has only discussed VCCV 'rationalisation' in terms of reducing the number of channel types. Do you think we should fold RFC5885 into the bis?

Regards

Matthew

On 08/05/2012 15:03, "Yaakov Stein" <[email-masked]<mailto:[email-masked]>> wrote:

Matthew

Y(J)S

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)

Greg, Carlos,

Regards

Matthew

    Regards,
        Greg
From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)

Matthew

  Done     - Fragmentation LC

  Done     - VCCV LC

  Done     - PPP/HDLC PW LC

  Done     - Wildcard FEC LC

  Done     - TDM Signaling LC

  Done - PW OAM Mapping LC

  Done- Multipath PW LC

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 8 May 2012 10:45:39 -0400

Hi Matthew,
concur with Carlos, it's the right way.

    Regards,
        Greg
________________________________
From: Carlos Pignataro [mailto:[email-masked]]
Sent: Tuesday, May 08, 2012 6:50 AM
To: Bocci, Matthew (Matthew)
Cc: Gregory Mirsky; [email-masked]
Subject: Re: [PWE3] Updates to goals and milestones

Matthew,

Thanks,

-- Carlos.

Greg, Carlos,

Regards

Matthew

    Regards,
        Greg

Matthew,

All,

Matthew

  Done     - Fragmentation LC

  Done     - VCCV LC

  Done     - PPP/HDLC PW LC

  Done     - Wildcard FEC LC

  Done     - TDM Signaling LC

  Done - PW OAM Mapping LC

  Done- Multipath PW LC

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 8 May 2012 11:14:17 -0400

> Would you still want 3 milestones ?

	I do not see any issue with having 3 milestones that can be possibly addressed by 1 document. There is no hard/fast rule that I am aware of, requiring specific documents to target one and only 1 chartered element.

	--Tom

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 8 May 2012 12:56:51 -0400

Dear Yaakov,
at fix terminology along the way - from Connectivity Verification to Continuity Check.

    Regards,
        Greg

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: Tuesday, May 08, 2012 7:04 AM
To: Bocci, Matthew (Matthew)
Cc: [email-masked]
Subject: Re: [PWE3] Updates to goals and milestones

Matthew

Y(J)S

Greg, Carlos,

Regards

Matthew

    Regards,
        Greg

Matthew

  Done     - Fragmentation LC

  Done     - VCCV LC

  Done     - PPP/HDLC PW LC

  Done     - Wildcard FEC LC

  Done     - TDM Signaling LC

  Done - PW OAM Mapping LC

  Done- Multipath PW LC