Subject: Re: [PWE3] Danny McPherson's Rtg-Dir review of draft-ietf-pwe3-p2mp-pw-requirements

From: Jounay Frédéric <[email-masked]>
Date: Tue, 1 Apr 2014 10:12:26 +0200

Hi Adrian, Danny, All,

Thank you for this new review.
Please find below [FJ] how we intend to address the comments in a new version
If all co-authors agree, we will update with Yuji the new version

BR,
Fred  

-----Original Message-----
From: pwe3 [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Monday, 31 March 2014 18:28
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [PWE3] Danny McPherson's Rtg-Dir review of draft-ietf-pwe3-p2mp-pw-requirements

draft-ietf-pwe3-p2mp-pw-requirements

Hello,
I have been selected as the Routing Directorate reviewer for this draft.

The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request.  The purpose of the review is to provide assistance to the Routing ADs.
For more information about the Routing Directorate, please see

http://www.ietf.org/iesg/directorate/routing.html

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other comments that you receive, and strive to resolve them through discussion or by updating the draft as appropriate.  
 
Document: http://tools.ietf.org/html/draft-ietf-pwe3-p2mp-pw-requirements-07

Reviewer: Danny McPherson
Review Date: March 31, 2014
Intended Status: Informational

Document Overview: This document presents a set of requirements and a framework for providing a P2MP PWs over MPLS PSNs.  A P2MP PW is a mechanism that emulates the essential attributes of a P2MP telecommunications service such as a P2MP ATM VC over a PSN.  The I-D describes the general architecture for P2MP PWs with a reference model, discusses data encapsulation, and outlines specific requirements for setup and maintenance of P2MP PWs, with a focus only on Single-Segment PWs.  This version was lasted updated in February of 2014, although it has existed as a PWE3 WG document since March 2009, and as an individual contribution (draft-jounay-pwe3-p2mp-pw-requirements) since February of 2007.  Among other applications, it provides primitives that can be employed for Virtual Private LAN and Virtual Private Multicast services, such as those specified in the L2VPN WG.

I have no substantial concerns with this document.  There are several comments and nits below. 

1. I am not sure if from an IPR perspective the claims regarding IPR that apparently no longer apply to this version of the document need to be explicitly acknowledged as such by the relevant co-authors?

Nits
===

General:

1. Only single-segment PWs are addressed, not multi-segment PWs.  I understand why this is the case currently although I wonder if the requirement akin to "a single NMS" such as provided in S.4 should be conveyed forward?  I suppose it should simply be out of scope.
[FJ] Indeed this section was meaningful when MS-PW was considered. I don't see the added value of this chapter in the case SS-PW. I'd suggest to remove the section 4 "Manageability considerations" 

2. In order to align with descriptive text in S3.1 it might be useful if the Reference Model in Figure 1 depicted where root and leaf PEs reside in the topology, and perhaps also that multiple CEs could be downstream from a single leaf PE (the latter point Farrel made in his AD review as well, IIRC).
[FJ] I agree with the proposal to show 2  CEs behinf one Leaf PE, as described in http://tools.ietf.org/html/draft-ietf-pwe3-p2mp-pw-requirements-00 . 
I'd suggest we add ROOT and LEAF, as follows
                                     |<-----------P2MP PW -------------->|
                      Native  |                                                                    |  Native
      ROOT   Service  |    |<----P2MP PSN tunnel --->|     |  Service        LEAF
         V            (AC)    V    V                                                    V    V   (AC)               V

---
S 3.2: 

-
A single P2MP PSN tunnel MUST be able to serve more than one P2MP PW traffic in an aggregated way, i.e., multiplexing

-
"not destined to Leaf PE at the service layer." reads a bit odd and ambiguous, might use a bit of expansion.  
[FJ] we might rephrase it.
"but using this P2MP LSP would imply non-Leaf PEs (i.e. not part of the P2MP PW) to
   receive unwanted traffic"

---
S 3.4.6: 

-
"In the example depicted below, a standby P2MP PW is used to protect the active P2MP."  -- might consider adding a "PW" after the last P2MP in this sentence.
[FJ] agreed
"In the example depicted below, a standby P2MP PW is used to protect the active P2MP PW."  

-
It might be useful to identify the "leaf" and "root" layer in Figure 3 & 4 as well.
[FJ] agreed to add ROOT at the top and LEAF at the bottom of the figures. (I'd prefer this solution than adding new acronyms in the Terminology section.

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 1 Apr 2014 07:36:34 -0400

Fred,

Thanks! Also don't forget to address Adrian's comments from March 13,
and Brian Carpenter's comments from March 18.

Cheers,
Andy