Subject: RE: [PWOT] mpls-in-ip

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 28 Feb 2001 17:12:45 +0200

Tom,
	I have doubts regarding your presumtions:
	1)	An MPLS LSP may be multipoint-to-point as opposed to all the
rest of of the pseudo-wire examples in 		your message
	2)	IP per se is can be hardly considered as transport since it
does not allow for demuxing between an
		indefinitely large number of logical application instances
within the downstream host. BTW, this is why 		- IMHO - in order to
treat MPLS as transport you usually require a stack of two labels while ATM
provides transport capabilities inherently by using VPI/VCI
	I would also like to understand what exactly you mean by
"MPLS-in-IP". (I have not read you draft yet, sorry).

______________________________________________
With best regards,
Sasha Vainshtein
mailto: [email-masked]
phone: +972-3-7659993 (office)
fax:      +972-3-6487779 (office)

>>-----Original Message-----
>>From: tom worster [mailto:[email-masked]]
>>Sent: Tuesday, February 27, 2001 6:38 PM
>>To: PWOT Email List (E-mail); CEOT Email List (E-mail)
>>Subject: [PWOT] mpls-in-ip
>>
>>
>>i'd like to ask the to-be-working group three questions 
>>relating to this draft (it should show in the repository
>>soon, a url is given below):
>>
>>1) is an mpls lsp an example of a "pseudo-wire?"
>>
>>2) can ip be regarded as "transport?"
>>
>>3) should mpls-in-ip be a standards track work item for
>>pwot?
>>
>>in which the terms pseudo-wire and transport express the 
>>scope of the wg.
>>
>>my opinions are.
>>
>>1) yes. if an atm connection, frame relay connection, 
>>ds1 or oc3 are considered pseudo-wires then i think
>>an mpls lsp can reasonably be considered a pseudo-wire.
>>
>>2) yes. the usage of "transport" in the pwot group seems 
>>to be more general than other uses. if mpls (which is a
>>sub-ip protocol) is a transport protocol along side tcp,
>>udp, rtp (which are all super-ip), etc., then i don't
>>see why ip can't also be regarded as providing transport.
>>
>>3) if i'm right on the above two points then i think
>>pwot would the right place to write a standard 
>>encapsulation of mpls in ip, should the ietf want such 
>>as standard.
>>
>>
>>http://thefsb.org/draft-worster-mpls-in-ip-03.txt
>>
>>c u
>>fsb
>>
>>_______________________________________________
>>pwot mailing list
>>[email-masked]
>>http://www.ietf.org/mailman/listinfo/pwot
>>

_______________________________________________
pwot mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/pwot

---

From: "tom worster" <[email-masked]>
Date: Wed, 28 Feb 2001 11:40:36 -0500

From: Sasha Vainshtein [mailto:[email-masked]]
> rest of of the pseudo-wire examples in 		your message

in mpls-in-ip no label switching occurs between 
encapsulator and decapsulator. so i don't see
that p2mp and mp2p lsr requirements affect the
encapsulation.

> provides transport capabilities inherently by using VPI/VCI

if such multiplexing is, in the opinion of the wg, a
necessary characteristic of "transport" then i would
argue that mpls-in-ip is a good example of signalled 
multi-protocol transport tunnels for ip core networks.

c u
fsb