Subject: [PWOT] Re: comment on latest draft-martini-l2circuit-encap-mpls-01.txt

From: Dan Tappan <[email-masked]>
Date: Mon, 19 Mar 2001 19:08:28 -0500

[ moved to the right working group list]

At 04:34 PM 3/16/2001 -0500, you wrote:
>Hello Luca,
>
>Sorry for the late comment, I didn't know of this draft until recently.
>I see the addition of the control word and algorithm for handling
>sequence numbers on send and receive side.
>
>It seems that sequence check on receive side does not handle the
>wrap around correctly, i.e. finds the out-of-sequence little too late.
>
>For example if the max was 64,
>
>sender                   receiver's expected Seq
>
>62          ->           62, next: 62+1=63
>64          ->           63, 64>=63 packet in order. Next: 64+1=1, wrapped
>63          ->           1, 63>=1 packet in order. Next: 63+1=64
>1           ->           64, 1 !>=64. packet out-of-order, drop, next:1+1=2
>
>As shown above, out-of-order packet already forwarded!

In general with a circular sequence number space you need to include the 
concept of a 'window' - the maximum sequence number that is reasonable to 
receive. This got left out of the definition in the draft. My inclination 
would be to define the window to 1/2 the sequence space (it could be made 
arbitrarily smaller, but there may not be any point). So, in your example 
above:
- 63 > 1 + window, so discard
- 1 == 1, in sequence

_______________________________________________
pwot mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/pwot

---

From: Stephen Casner <[email-masked]>
Date: Mon, 19 Mar 2001 18:25:29 -0800 (PST)

RTP already addresses this issue.  See Appendix 1 in RFC 1889 for an
implementation suggestion for header validation through sequence
number sequencing.
							-- Steve