Subject: [PWE3] Question/Suggestion: pwEnetPortIfIndex in the pwe3-enet-mib

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Thu, 1 Sep 2005 12:44:10 -0400

Hi ! Currently, the type/syntax associated with pwEnetPortIfIndex (in the
pwEnetTable) is 
defined to be "InterfaceIndexOrZero". This assumes that the
Ethernet-port/virtual interfaces 
associated with the PW is modeled as a ifIndex.

Can/Should this be changed to be an arbitrary (unsigned) index? (which may
or may not be 
an ifIndex based on vendor's implementation).

Thanks,
sanjay

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 1 Sep 2005 15:04:40 -0400

On Sep 1, 2005, at 12:44 PM, Choudhury, Sanjaya wrote:

> or may not be an ifIndex based on vendor's implementation).

     An arbitrary (unsigned) index is available in the
form of the pwIndex. The point of the IfIndexOrZero is
to allow for IfIndex correspondence, but to assign 0
simply if not.  There seem to be an equal number of
implementations that do and do not assign IfIndexes.

     --Tom