Subject: RE: [PWE3] AAL5 N:1 cells mode issue

From: "D, Ganesh (Ganesh)" <[email-masked]>
Date: Thu, 29 Sep 2005 17:11:43 +0530

Hello all,

I feel the second option is better.
[cell length] - set it to *cell number* if the packet contains more than one
cell 
[cell length] - set it to *1* if the packet contains just one cell.

And strongly feel that there should be a option to specify how many cells
are concatenated.

-ganeshd
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Jixiong Dong
Sent: Thursday, September 29, 2005 3:57 PM
To: Sasha Vainshtein
Cc: [email-masked]; 'Mustapha Aissaoui'; [email-masked];
[email-masked]
Subject: Re: [PWE3] AAL5 N:1 cells mode issue

Sasha,

We can use cell length to implement the function of the byte length. As you
said, there are three cases:
[byte length] - always set it to 0
[byte length] - set it to 0 if the packet contains more than one cell 
[byte length] - set it to 56 if the packet contains just one cell.

When we use cell length, it looks like the below:
[cell length] - always set it to 0
[cell length] - set it to *cell number* if the packet contains more than one
cell 
[cell length] - set it to *1* if the packet contains just one cell.

Best regards,
Dong

----- Original Message ----- 
From: "Sasha Vainshtein" <[email-masked]>
To: "'Jixiong Dong'" <[email-masked]>
Cc: <[email-masked]>; "'Mustapha Aissaoui'" <[email-masked]>;
<[email-masked]>
Sent: Thursday, September 29, 2005 6:09 PM
Subject: RE: [PWE3] AAL5 N:1 cells mode issue

> Dong,
> 
> Quoting from draft-ietf-pwe3-cw-05.txt:
> 
> <quote>
>           If the entire packet length is less than 64 bytes, the length 
>           field MUST be set to the length of the PW payload plus the 
>           length of the control word. Otherwise it MUST be set to zero. 
> <end quote>
> 
> In other words, for N:1 ATM Cell PWs it allows to distinguish 
> between packets carrying a single cell and packets carrying
> more than one (concatenated) cell.

 - always set it to 0
> > > - save it to 0 if the packet contains more than one cell, 
> > and set it to 56
> > > if the packet
> > >   contains just one cell.

> With this kind of resolution (One or more),I would not call this
> "an indication (of) how many ATM cells are contained".
> 
> Regards,
> Sasha
> > -----Original Message-----
> > From: Jixiong Dong [mailto:[email-masked]]
> > Sent: Thursday, September 29, 2005 12:04 PM
> > To: Sasha Vainshtein
> > Cc: [email-masked]; 'Mustapha Aissaoui'; [email-masked]
> > Subject: Re: [PWE3] AAL5 N:1 cells mode issue
> > 
> > 
> > Sasha,
> > 
> > So the length field indicates how many ATM cells are contained.
> > 
> > Best Regards,
> > Dong
> > 
> > ----- Original Message ----- 
> > From: "Sasha Vainshtein" <[email-masked]>
> > To: "'Jixiong Dong'" <[email-masked]>
> > Cc: <[email-masked]>; "'Mustapha Aissaoui'" 
> > <[email-masked]>; <[email-masked]>
> > Sent: Thursday, September 29, 2005 5:52 PM
> > Subject: RE: [PWE3] AAL5 N:1 cells mode issue
> > 
> > 
> > > Dong,
> > > Please note that, with just 6 bits allocated for the Length field,
> > > you have actually two options:
> > > 
> > > - always set it to 0
> > > - save it to 0 if the packet contains more than one cell, 
> > and set it to 56
> > > if the packet
> > >   contains just one cell.
> > > 
> > > IMHO the 2nd option does not add any meaningful functionality.
> > > 
> > > Regards,
> > > Sasha
> > > 
> > > > -----Original Message-----
> > > > From: Jixiong Dong [mailto:[email-masked]]
> > > > Sent: Thursday, September 29, 2005 11:30 AM
> > > > To: Sasha Vainshtein
> > > > Cc: [email-masked]; 'Mustapha Aissaoui'; 
> > [email-masked]
> > > > Subject: Re: [PWE3] AAL5 N:1 cells mode issue
> > > > 
> > > > 
> > > > Sasha,
> > > > 
> > > > Yes, the tunnel label + pw label + ATM payload will exceed 64 
> > > > bytes when you use ATM N-to-1 mode. But why we don't reserve 
> > > > the length function and you may process it or not process it. 
> > > > Thus we can solve the problem introduced by Ganesh in the PW 
> > > > module. Another advantage is that it can be used to check the 
> > > > length of PW packet.
> > > > 
> > > > Best Regards,
> > > > Dong
> > > > 
> > > > ----- Original Message ----- 
> > > > From: "Sasha Vainshtein" <[email-masked]>
> > > > To: "'Jixiong Dong'" <[email-masked]>
> > > > Cc: <[email-masked]>; "'Mustapha Aissaoui'" 
> > > > <[email-masked]>; 
> > > > <[email-masked]>; "D, Ganesh (Ganesh)" 
> > > > <[email-masked]>
> > > > Sent: Thursday, September 29, 2005 5:14 PM
> > > > Subject: RE: [PWE3] AAL5 N:1 cells mode issue
> > > > 
> > > > 
> > > > > Dong,
> > > > > You have correctly noticed that the length field in the
> > > > > control word is used to indicate potential padding
> > > > > added to a short PW packet if it crosses an Ethernet-based
> > > > > hop in the PSN. (This is why only 6 bits are allocated for
> > > > > this field!)
> > > > > 
> > > > > Now, the shortest possible packet in the ATM N:1 
> > > > encapsulation always
> > > > > includes at least 52 bytes of one cell (you cannot have 
> > less than
> > > > > one cell!) + 4 bytes of the CW + 4 bytes of the PW label.
> > > > > Hence the minimal amount of data in an Ethernet frame containing
> > > > > the shortest possible packet of an ATM N:1 PW is 60 
> > bytes, and this,
> > > > > of course, never will be padded.
> > > > > 
> > > > > Hopefully this helps.
> > > > > 
> > > > > Rgeards,
> > > > > Sasha
> > > > > 
> > > > > 
> > > > > > -----Original Message-----
> > > > > > From: Jixiong Dong [mailto:[email-masked]]
> > > > > > Sent: Thursday, September 29, 2005 9:36 AM
> > > > > > To: D, Ganesh (Ganesh)
> > > > > > Cc: [email-masked]; 'Mustapha Aissaoui'; 
> > > > [email-masked]
> > > > > > Subject: Re: [PWE3] AAL5 N:1 cells mode issue
> > > > > > 
> > > > > > 
> > > > > > Ganesh,
> > > > > > 
> > > > > > If you know the packet length, you will determine how many 
> > > > > > cells in the PW payload. You can get the packet length from 
> > > > > > the underlying PSN or the Layer 2 packet process(e.g. 
> > > > > > ethernet packet process), however, this function is out of 
> > > > > > the scope of PWE3. As you know, the control word is optional 
> > > > > > in some applications.
> > > > > > 
> > > > > > The length field in control word is mainly used to indicate 
> > > > > > the payload padding field. However, the length field is also 
> > > > > > used to indicate the length of PW payload. It is the simplest 
> > > > > > way. I suggest we don't need to limit the use cases of length 
> > > > > > field. Could anybody tell me why the length field must be set 
> > > > > > to 0 in the ATM N-to-1 mode? We may provide two ways 
> > to be choose.
> > > > > > 
> > > > > > Dong
> > > > > > 
> > > > > > ----- Original Message ----- 
> > > > > > From: "D, Ganesh (Ganesh)" <[email-masked]>
> > > > > > To: "'Mustapha Aissaoui'" <[email-masked]>; 
> > > > > > <[email-masked]>
> > > > > > Cc: <[email-masked]>
> > > > > > Sent: Wednesday, September 28, 2005 11:01 PM
> > > > > > Subject: RE: [PWE3] AAL5 N:1 cells mode issue
> > > > > > 
> > > > > > 
> > > > > > > Hello Mustapha and Matthew,
> > > > > > > 
> > > > > > > Thanks a lot for the replay.
> > > > > > > 
> > > > > > > I agree with you and i also thought of going for timer, or 
> > > > > > monitor for
> > > > > > > EOF(end of frame).
> > > > > > > But the problem i face here is. To my understanding once a 
> > > > > > PW is configured
> > > > > > > and if TX and RX agrees to have say 20 cell concatenation, 
> > > > > > it is a MUST that
> > > > > > > all the PW pkt have 20 cells.  And the Rx will simply 
> > > > > > divide the payload
> > > > > > > data by 20 and retrieve the cells.
> > > > > > > 
> > > > > > > If i send any thing less than 20 ( say 15 cells) there is 
> > > > > > no means in
> > > > > > > PW-control-word to mention that it has 15 cells not 20.
> > > > > > > 
> > > > > > > Matthew,
> > > > > > > By using "sub-TLV" PW end points will(say) negotiate for 20 
> > > > > > cells. Now you
> > > > > > > mentioned that it is just a MTU so you can transmit 15 
> > > > > > cells too. But in Rx
> > > > > > > side how do i know it has 15 cells?. Do i have to divide 
> > > > > > the PW-pkt pay load
> > > > > > > by 48 and get the number of cells? 
> > > > > > > 
> > > > > > > Is there any disconnect in my understanding? or is it a 
> > > > > > rite concern?.
> > > > > > > 
> > > > > > > -ganeshd 
> > > > > > > 
> > > > > > > -----Original Message-----
> > > > > > > From: Mustapha Aissaoui 
> > [mailto:[email-masked]]
> > > > > > > Sent: Wednesday, September 28, 2005 7:33 PM
> > > > > > > To: [email-masked]; 'D, Ganesh (Ganesh)'
> > > > > > > Cc: [email-masked]
> > > > > > > Subject: RE: [PWE3] AAL5 N:1 cells mode issue
> > > > > > > 
> > > > > > > 
> > > > > > > Ganesh,
> > > > > > > One more suggestion below.
> > > > > > > 
> > > > > > > Mustapha.
> > > > > > > 
> > > > > > > > -----Original Message-----
> > > > > > > > From: [email-masked] 
> > [mailto:[email-masked]] On
> > > > > > > > Behalf Of [email-masked]
> > > > > > > > Sent: Wednesday, September 28, 2005 7:38 AM
> > > > > > > > To: D, Ganesh (Ganesh)
> > > > > > > > Cc: [email-masked]; [email-masked]'
> > > > > > > > Subject: Re: [PWE3] AAL5 N:1 cells mode issue
> > > > > > > >
> > > > > > > > Ganesh,
> > > > > > > >
> > > > > > > > Please see below.
> > > > > > > >
> > > > > > > > Matthew
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > |---------+--------------------------->
> > > > > > > > |         |           "D, Ganesh      |
> > > > > > > > |         |           (Ganesh)"       |
> > > > > > > > |         |           <ganeshd@lucent.|
> > > > > > > > |         |           com>            |
> > > > > > > > |         |           Sent by:        |
> > > > > > > > |         |           pwe3-bounces@iet|
> > > > > > > > |         |           f.org           |
> > > > > > > > |         |                           |
> > > > > > > > |         |                           |
> > > > > > > > |         |           28/09/2005 11:12|
> > > > > > > > |---------+--------------------------->
> > > > > > > >
> > > > > > > > 
> > >-------------------------------------------------------------
> > > > > > > > 
> > > > > > 
> > > > 
> > ------------------------------------------------------------------|
> > > > > > > >   |
> > > > > > > >                                                           
> > > > > >           |
> > > > > > > >   |        To:      "[email-masked]'" <[email-masked]>
> > > > > > > >                                                           
> > > > > >           |
> > > > > > > >   |        cc:
> > > > > > > >                                                           
> > > > > >           |
> > > > > > > >   |        Subject: [PWE3] AAL5 N:1 cells mode issue
> > > > > > > >                                                           
> > > > > >           |
> > > > > > > >
> > > > > > > > 
> > >-------------------------------------------------------------
> > > > > > > > 
> > > > > > 
> > > > 
> > ------------------------------------------------------------------|
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > > hello all,
> > > > > > > > >
> > > > > > > > > I am facing peculiar problem.
> > > > > > > > >
> > > > > > > > > I am planning to use N:1 cell mode as specified in
> > > > > > > > > "draft-ietf-pwe3-atm-encap-09" for AAL5 cell 
> > > > > > encapsulation. I will
> > > > > > > > > have
> > > > > > > > 25
> > > > > > > > > cells concatenation with in a Ethernet pkt. i.e. one
> > > > > > > > Ethernet pkt will
> > > > > > > > > have 25 AAL5 cells of same VPI/VCI. I know that this is 
> > > > > > inefficient
> > > > > > > > > and draft also talks about better ways like 1:1 and AAL5
> > > > > > > > frame mode,
> > > > > > > > > but I am limited by resource and forced to do so.
> > > > > > > > >
> > > > > > > > > Question 1. Is correct to have more than one 
> > cell of same
> > > > > > > > VPI/VCI in a
> > > > > > > > > PW pkt.
> > > > > > > >
> > > > > > > > MB> N:1 mode can be used to carry a single VCC (so each 
> > > > > > cell hase the
> > > > > > > > MB> same
> > > > > > > > VCI/VPI) if you use cell concatenation, but as you say you
> > > > > > > > have to repeat the VCI/VPI field in the encap for 
> > each cell.
> > > > > > > >
> > > > > > > > >
> > > > > > > > > Question 2. If a AAL5 communication ends and produces a
> > > > > > > > frame of say 4
> > > > > > > > > cells. And in PW pkt preparation process, full 
> > 25 cells are
> > > > > > > > not filled
> > > > > > > > > what i will be doing?. I can't send it, as 
> > PW-pkt is less
> > > > > > > > than 25 cells.
> > > > > > > > I
> > > > > > > > > cant keep waiting for next AAL5 frame because it may 
> > > > > > come or it may
> > > > > > > > > not come, if i wait for long time it will leak 
> > my buffers.
> > > > > > > >
> > > > > > > > MB> There is a sub-TLV in the interface parameters 
> > > > called "Maximum
> > > > > > > > MB> Number
> > > > > > > > of concatenated ATM cells sub-TLV". This is a 
> > maximum number
> > > > > > > > that the sending PE can concatenate, not a 
> > minimum. You can
> > > > > > > > use implementation specific constraints e.g. 
> > related to QoS,
> > > > > > > > or the PTI bits, to decide when to stop 
> > concatenating cells,
> > > > > > > > and send a PW packet.
> > > > > > > 
> > > > > > > MA> you may choose to abort the concatenation process once 
> > > > > > the EOM cell
> > > > > > > (last cell of an AAL5 PDU) is received. This way, you 
> > > > > > always attempt to send
> > > > > > > a complete Ethernet frame in a PW packet. Also, you will 
> > > > > > probably need to
> > > > > > > configure a timer to abort the concatenation process beyond 
> > > > > > a maximum delay
> > > > > > > limit. You cannot wait forever for the EOM cell or the 
> > > > > > maximum number of
> > > > > > > concat cells.
> > > > > > > 
> > > > > > > 
> > > > > > > _______________________________________________
> > > > > > > pwe3 mailing list
> > > > > > > [email-masked]
> > > > > > > https://www1.ietf.org/mailman/listinfo/pwe3
> > > > > > 
> > > > > > _______________________________________________
> > > > > > pwe3 mailing list
> > > > > > [email-masked]
> > > > > > https://www1.ietf.org/mailman/listinfo/pwe3
> > > > > >
> > > > 
> > > > _______________________________________________
> > > > pwe3 mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/pwe3
> > > >
> >

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Sasha Vainshtein <[email-masked]>
Date: Thu, 29 Sep 2005 14:44:38 +0300

Dong,
I do not see the need for that since the actual number of the cells in
a received ATM Cell N:1 PW packet can be easily deduced from its Layer 
2 size. And since the payload size of correctly formed packets goes in
steps of 52 bytes, this also provides a reasonable tool for detecting
malformed packets.

Regards,
				Sasha

> Sent: Thursday, September 29, 2005 12:27 PM
> To: Sasha Vainshtein
> Cc: [email-masked]; [email-masked]; 
> 'Mustapha Aissaoui'; [email-masked]
> We can use cell length to implement the function of the byte 
> length. As you said, there are three cases:
> [cell length] - set it to *cell number* if the packet 
> contains more than one cell