Subject: [PWE3] AAL5 N:1 cells mode issue

From: "D, Ganesh (Ganesh)" <[email-masked]>
Date: Wed, 28 Sep 2005 15:42:08 +0530

> hello all,
> 
> I am facing peculiar problem.
> 
> I am planning to use N:1 cell mode as specified in
> "draft-ietf-pwe3-atm-encap-09" for AAL5 cell encapsulation. I will have 25
> cells concatenation with in a Ethernet pkt. i.e. one Ethernet pkt will
> have 25 AAL5 cells of same VPI/VCI. I know that this is inefficient and
> draft also talks about better ways like 1:1 and AAL5 frame mode, but I am
> limited by resource and forced to do so.
> 
> Question 1. Is correct to have more than one cell of same VPI/VCI in a PW
> pkt.
>  
> Question 2. If a AAL5 communication ends and produces a frame of say 4
> cells. And in PW pkt preparation process, full 25 cells are not filled
> what i will be doing?. I can't send it, as PW-pkt is less than 25 cells. I
> cant keep waiting for next AAL5 frame because it may come or it may not
> come, if i wait for long time it will leak my buffers.
> 
> I highly appreciate your response to this.
>     
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: [email-masked]
Date: Wed, 28 Sep 2005 12:37:48 +0100

Ganesh,

Please see below.

Matthew

|---------+--------------------------->
|         |           "D, Ganesh      |
|         |           (Ganesh)"       |
|         |           <ganeshd@lucent.|
|         |           com>            |
|         |           Sent by:        |
|         |           pwe3-bounces@iet|
|         |           f.org           |
|         |                           |
|         |                           |
|         |           28/09/2005 11:12|
|---------+--------------------------->
  >-------------------------------------------------------------------------------------------------------------------------------|
  |                                                                                                                               |
  |        To:      "[email-masked]'" <[email-masked]>                                                                             |
  |        cc:                                                                                                                    |
  |        Subject: [PWE3] AAL5 N:1 cells mode issue                                                                              |
  >-------------------------------------------------------------------------------------------------------------------------------|

> Question 1. Is correct to have more than one cell of same VPI/VCI in a PW

MB> N:1 mode can be used to carry a single VCC (so each cell hase the same
VCI/VPI) if you use cell concatenation, but as you say you have to repeat
the VCI/VPI field in the encap for each cell.

> come, if i wait for long time it will leak my buffers.

MB> There is a sub-TLV in the interface parameters called "Maximum Number
of concatenated ATM cells sub-TLV". This is a maximum number that the
sending PE can concatenate, not a minimum. You can use implementation
specific constraints e.g. related to QoS, or the PTI bits, to decide when
to stop concatenating cells, and send a PW packet.

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Wed, 28 Sep 2005 10:02:35 -0400

Ganesh,
One more suggestion below.

Mustapha.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Wednesday, September 28, 2005 7:38 AM
> To: D, Ganesh (Ganesh)
> Cc: [email-masked]; [email-masked]'
> Subject: Re: [PWE3] AAL5 N:1 cells mode issue
>
> Ganesh,
>
> Please see below.
>
> Matthew
>
>
>
> >-------------------------------------------------------------
> ------------------------------------------------------------------|
>   |
>                                                                     |
>   |        cc:
>                                                                     |
> >-------------------------------------------------------------
> ------------------------------------------------------------------|
>
>
>
>
> > hello all,
> >
> > "draft-ietf-pwe3-atm-encap-09" for AAL5 cell encapsulation. I will
> > have
> 25
> > have 25 AAL5 cells of same VPI/VCI. I know that this is inefficient
> > and draft also talks about better ways like 1:1 and AAL5
> frame mode,
> > but I am limited by resource and forced to do so.
> >
> > Question 1. Is correct to have more than one cell of same
> VPI/VCI in a
> > PW pkt.
>
> MB> N:1 mode can be used to carry a single VCC (so each cell hase the
> MB> same
> VCI/VPI) if you use cell concatenation, but as you say you
> have to repeat the VCI/VPI field in the encap for each cell.
>
> >
> > what i will be doing?. I can't send it, as PW-pkt is less
> than 25 cells.
> I
> > cant keep waiting for next AAL5 frame because it may come or it may
> > not come, if i wait for long time it will leak my buffers.
>
> MB> There is a sub-TLV in the interface parameters called "Maximum
> MB> Number
> of concatenated ATM cells sub-TLV". This is a maximum number
> that the sending PE can concatenate, not a minimum. You can
> use implementation specific constraints e.g. related to QoS,
> or the PTI bits, to decide when to stop concatenating cells,
> and send a PW packet.

MA> you may choose to abort the concatenation process once the EOM cell
(last cell of an AAL5 PDU) is received. This way, you always attempt to send
a complete Ethernet frame in a PW packet. Also, you will probably need to
configure a timer to abort the concatenation process beyond a maximum delay
limit. You cannot wait forever for the EOM cell or the maximum number of
concat cells.