Subject: RE: [PWE3] RSVP MS-PW ? HOW?

From: "Gray, Eric" <[email-masked]>
Date: Thu, 1 Dec 2005 12:10:19 -0500

Shahram,

	I don't think we should expect Luca to solve the problem
you point out.  He needs only to demonstrate that it can be
solved, somehow.

	However, in doing that, I suspect that we're going to 
find many of the concerns addressed over the last several years 
in the CCAMP working group are going to rear their ugly heads 
again.  Concerns about shared-risk, for instance.

	I think many people are already aware of what addressing
these concerns using LDP is going to lead to.  One question we
might ask is - how real are these concerns now and how real will 
they be in the future.  I suspect that argument that they are 
not real now is likely to lull us into going further down the 
path so many would like to avoid - i.e. - the path that starts 
with significant LDP deployment and ends with a significant need 
to add GMPLS-like functionality to LDP.

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Shahram Davari
--> Sent: Thursday, December 01, 2005 10:41 AM
--> To: 'Luca Martini'; Nurit Sprecher
--> Cc: PWE3 WG (E-mail)
--> Subject: RE: [PWE3] RSVP MS-PW ? HOW?
--> 
--> Hi Luca,
--> 
--> >From your statements (shown below), I get the impression that
--> your definition of PW TE is different from many others. 
--> 
--> It seems that your definition of PW TE is that the U-PE selects
--> the S-PEs that the PW should travel through, and since you think
--> in most cases there is only a single set of S-PEs that the PW
--> can travel through, then there is no need for PW TE. 
--> 
--> In my opinion there are two problems with such 
--> assumption/definition:
--> 
--> 1) It is not wise to assume that there is only a single 
--> S-PE route (note: a route consists of a set of concatenated 
--> S-PEs) for a PW. You at least need two routes for backup 
--> against any S-PE or domain failure, if not for any other reason.
--> 
--> 2) There could be many MPLS tunnels between any two S-PE. 
--> How can one of these
--> S-PEs decide which tunnel to use for a specific PW? You 
--> need a signaling that
--> includes BW requirements of the PW and permits an upstream 
--> S-PE to select one of
--> the MPLS tunnels to a downstream S-PE. 
--> 
--> I think you should convince the WG how you propose to solve 
--> these two problems.
--> 
--> Thanks,
--> Shahram
--> 
--> 
--> 
--> > Yes, of course , but this is not traffic engineering of the 
--> > pseudo wire. 
--> > All you are describing is transporting opaque information in 
--> > a signaling 
--> > protocol  to properly request the correct resources from 
--> the MPLS PSN.
--> 
--> 
--> > I was not talking about selecting the tunnel here. I was 
--> > talking about 
--> > selecting the S-PE.
--> 
--> > > Traffic engineering of PW would mean that S-PEs are 
--> > selected based on 
--> > > available bandwidth to reach them.
--> > >
--> 
--> 
--> >Please look at the architecture document. there is no "best" route 
--> >selection as there is only one route in most cases. 
--> 
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Luca Martini <[email-masked]>
Date: Thu, 01 Dec 2005 15:48:54 -0700

> again.  Concerns about shared-risk, for instance.
Agreed !

> to add GMPLS-like functionality to LDP.
Yes, But why  can't we confine that functionality to the PSN ?
( where we have nice solutions with GMPLS....etc.. )

Luca