Subject: RE: [PWE3] RSVP MS-PW ? HOW?

From: Shahram Davari <[email-masked]>
Date: Thu, 1 Dec 2005 07:41:06 -0800

Hi Luca,

>From your statements (shown below), I get the impression that
your definition of PW TE is different from many others. 

It seems that your definition of PW TE is that the U-PE selects
the S-PEs that the PW should travel through, and since you think
in most cases there is only a single set of S-PEs that the PW
can travel through, then there is no need for PW TE. 

In my opinion there are two problems with such assumption/definition:

1) It is not wise to assume that there is only a single S-PE route (note: a route consists of a set of concatenated S-PEs) for a PW. You at least need two routes for backup against any S-PE or domain failure, if not for any other reason.

2) There could be many MPLS tunnels between any two S-PE. How can one of these
S-PEs decide which tunnel to use for a specific PW? You need a signaling that
includes BW requirements of the PW and permits an upstream S-PE to select one of
the MPLS tunnels to a downstream S-PE. 

I think you should convince the WG how you propose to solve these two problems.

Thanks,
Shahram

> Yes, of course , but this is not traffic engineering of the 
> pseudo wire. 
> All you are describing is transporting opaque information in 
> a signaling 
> protocol  to properly request the correct resources from the MPLS PSN.

> I was not talking about selecting the tunnel here. I was 
> talking about 
> selecting the S-PE.

> > Traffic engineering of PW would mean that S-PEs are 
> selected based on 
> > available bandwidth to reach them.
> >

>Please look at the architecture document. there is no "best" route 
>selection as there is only one route in most cases. 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Luca Martini <[email-masked]>
Date: Thu, 01 Dec 2005 11:50:26 -0700

> can travel through, then there is no need for PW TE. 
The sample topologies are described in the ms-pw architecture document. 
There certainly is more then a single set of S-PEs, but the number of 
hops in a SP is limited, and the topology complexity is also limited.
> 1) It is not wise to assume that there is only a single S-PE route (note: a route consists of a set of concatenated S-PEs) for a PW. You at least need two routes for backup against any S-PE or doma…
yes.

> the MPLS tunnels to a downstream S-PE. 
agreed.

> I think you should convince the WG how you propose to solve these two problems.
yes, however nothing mentioned above is a true traffic engineering function.

Luca

---

From: Jixiong Dong <[email-masked]>
Date: Fri, 02 Dec 2005 18:20:39 +0800

Some comments see in-line.

Best Regards,
Dong

----- Original Message ----- 
From: "Luca Martini" <[email-masked]>
To: "Shahram Davari" <[email-masked]>
Cc: "PWE3 WG (E-mail)" <[email-masked]>; "Nurit Sprecher" <[email-masked]>
Sent: Friday, December 02, 2005 2:50 AM
Subject: Re: [PWE3] RSVP MS-PW ? HOW?

> yes, however nothing mentioned above is a true traffic engineering function.
[Dong] Refer to RFC 2702, the basic TE parameters including the following attributes:
   - Traffic parameter attributes(bandwidth...)
   - Generic Path selection and maintenance attributes
   - Priority attribute
   - Preemption attribute
   - Resilience attribute
   - Policing  attribute
We can use the above TE attributes to select tunnel and S-PE to reach the target T-PE.
Don't you think they are true TE function? If no, what's your TE function?