Subject: RE: [PWE3] for VPWS, Can PE learn mac from AC side?

From: "Florin Balus" <[email-masked]>
Date: Wed, 11 Jan 2006 08:42:58 -0500

That is why VPLS technology was developped: in that case you will have a VSI performing the learning and bridging function... Before hitting the PW infrastructure that will transport the frame between VSIs.

See draft-ietf-l2vpn-vpls-ldp... 

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Fengger
>Sent: Tuesday, January 10, 2006 8:22 PM
>To: 'Ali Sajassi (sajassi)'; 'Stewart Bryant (stbryant)'
>Cc: [email-masked]
>Subject: ??: [PWE3] for VPWS, Can PE learn mac from AC side?
>
>
>But for VPWS, can there be such case that the PW is vlan based 
>and the vlan includes more than one customer-facing ports on 
>the PE? If there is, then the learning and bridging must be 
>done on the AC side of the PE.
>
>-Fengger
>
>-----邮件原件-----
>发件人: Ali Sajassi (sajassi) [mailto:[email-masked]] 
>发送时间: 2006年1月11日 4:31
>收件人: Stewart Bryant (stbryant); Fengger
>抄送: [email-masked]
>主题: RE: [PWE3] for VPWS, Can PE learn mac from AC side?
>
>
>VPWS service is based on P2P VCs and there is no need for MAC 
>address learning by PEs for a P2P operation (e.g., MAC address 
>learning is needed for multipoint service such as VPLS).
>
>-Ali 
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Stewart Bryant (stbryant)
>> Sent: Tuesday, January 10, 2006 5:25 AM
>> To: Fengger
>> Cc: [email-masked]
>> Subject: Re: [PWE3] for VPWS, Can PE learn mac from AC side?
>> 
>> Fengger wrote:
>> 
>> > All,
>> >
>> > For VPWS, the draft specifies that PE doesn't need to learn
>> mac from
>> > PW. But it doesn't specify if the PE needs to learn mac from AC.
>> >
>> > So my question is, MUST the PE support the capability to learn mac
>> > from AC? Or it's optional? Or it doesn't need to do so?
>> >
>> > Thanks and BR
>> >
>> > Fengger
>> >
>> Fengger
>> 
>> As far a PWE3 is concerned there is no need to learn
>> anything, we are just a transport.
>> 
>> However this question should be addressed to the L2VPN WG for
>> the authorative answer on what VPWS requires.
>> 
>> - Stewart
>> 
>> >-------------------------------------------------------------
>> ----------
>> >-
>> >
>> >_______________________________________________
>> >pwe3 mailing list
>> >[email-masked]
>> >https://www1.ietf.org/mailman/listinfo/pwe3
>> >  
>> >
>> 
>> _______________________________________________
>> pwe3 mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/pwe3
>> 
>
>
>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3
>
>

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Ali Sajassi \(sajassi\)" <[email-masked]>
Date: Wed, 11 Jan 2006 11:58:39 -0800

But in your example, this is no longer a VPWS service but instead a subset of VPLS functionality. VPWS service is related to P2P service end to end (from AC to AC). Indeed the functionality that you are describing in your example is the one for MTU-s device for H-VPLS (take a look at the corresponding draft).

-Ali

> From: Fengger [mailto:[email-masked]] 
> Sent: Tuesday, January 10, 2006 5:22 PM
> To: Ali Sajassi (sajassi); Stewart Bryant (stbryant)
> Cc: [email-masked]
> Subject: 答复: [PWE3] for VPWS, Can PE learn mac from AC side?
> 
> But for VPWS, can there be such case that the PW is vlan 
> based and the vlan includes more than one customer-facing 
> ports on the PE? If there is, then the learning and bridging 
> must be done on the AC side of the PE.
> 
> -Fengger
> 
> -----邮件原件-----
> VPWS service is based on P2P VCs and there is no need for MAC address
> learning by PEs for a P2P operation (e.g., MAC address learning is
> needed for multipoint service such as VPLS).
> 
> -Ali 
>