Subject: [PWE3] Need for CRC-10 computation for OAM message mapping

From: "Yaakov Stein" <[email-masked]>
Date: Fri, 6 Jan 2006 13:24:21 +0200

Hi everyone
 
In section 11.1.2 of the message-mapping draft it is specified that
for inband ATM OAM over PW 
  "On entry to the AC forward defect state, PE1 MUST 
  commence insertion of ATM AIS cells into the corresponding PW."

ATM OAM cells require calculation of CRC-10, 
usually performed by hardware or a network processor 
when the cell is sent to the network.

Unfortunately, this computation is somewhat intensive for 
software IWF implementations.

I propose making the CRC-10 computation optional for these
OAM cells (being set to zero when not computed).

Since these ATM cells are being sent over the PW
they will be received by the IWF on the other side.
No native ATM network element will see them before the IWF,
so nothing is broken by suppression of the computation.

They will, of course, be protected by whatever mechanisms in effect for
the PSN.

If they later need to be forwarded to an ATM network, 
the CRC can be added upon their insertion to the ATM network,
where presumably the computation can be done in hardware.

Y(J)S

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 06 Jan 2006 16:58:07 +0100

Hello Yaakov,

> when the cell is sent to the network.

The structure of an OAM AIS cell is always:

10 6A 6A 6A 6A 6A 6A 6A 6A 6A
6A 6A 6A 6A 6A 6A 6A 6A 6A 6A
6A 6A 6A 6A 6A 6A 6A 6A 6A 6A
6A 6A 6A 6A 6A 6A 6A 6A 6A 6A
6A 6A 6A 6A 6A 6A 03 B9

Where 10 indicates OAM AIS
and CRC10 = 3B9

So it is not necessary to calculate the CRC-10 for
each OAM AIS cell.

Cheers, Huub.

-- 
================================================================
              http://members.chello.nl/hhelvoort/
================================================================
Always remember that you are unique...just like everyone else...