Subject: RE: [PWE3] Generic PW - Is there a need?

From: "Nurit Sprecher" <[email-masked]>
Date: Mon, 30 Jan 2006 21:11:24 +0200

In addition to the below, what is the type of the transport layer (i.e. PSN)? Is it necessarily MPLS?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Gray, Eric
Sent: Monday, January 30, 2006 20:53
To: 'Danny McPherson'
Cc: 'pwe3'
Subject: RE: [PWE3] Generic PW - Is there a need?

Danny,

        As a clarification question, since it appears that the
intent is to carry multiple different types of traffic using
a generic pseudowire, is the intent to negotiate the carried
packet type, or would this be indicated by code points in the
pseudowire encapsulation format?

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]]
--> On Behalf Of Danny McPherson
--> Sent: Monday, January 30, 2006 12:51 PM
--> To: pwe3 pwe3
--> Subject: [PWE3] Generic PW - Is there a need?
-->
-->
--> Folks,
--> We would like to start a discussion on whether the PWE3
--> WG should work on the definition of a generic packet PW.
-->
--> The driver for this work is threefold:
-->
--> 1) The need for a PW to support the IPLS work in the L2VPN
--> WG
-->
--> 2) The need to provide an MPLS PW to satisfy the same need
--> as the IP PW proposed in the L2TPext WG
-->
--> 3) The need to provide PW to transport MPLS PWs
-->
--> This type of PW is generally needed where it is required to
--> interconnect ACs with two (actually or potentially) disparate
--> Layer 2 protocols.
-->
--> Generally one would use a Layer 3 service to provide this,
--> but the use of a Layer 2 service allows greater decoupling
--> between the client and transport networks.
-->
--> The types of packets that need to be carried over a generic
--> packet PW are know to be (are there others?):
-->
--> IPv4
--> IPv6
--> IS-IS
--> MPLS
--> Compressed IP
-->
--> In all cases the payload would be carried over a PW with a CW
--> to allow ECMP suppression and the discrimination of different
--> packet types multiplexied over the PW, for example IPv4 packets
--> and IS-IS protocol packets. Because a CW was used the EoS bit
--> would need to be set in the transport label stack, as well as in
--> the client label stack.
-->
--> A generic PW would be supported by its own OAM mechanism
--> (VCCV) which would be different from any client OAM
--> mechanism.
-->
--> One application for the service would be a SP transit domain
--> in which it was desired that there was no interaction between
--> the client and transport network protocols (e.g., MPLS LSP
--> transport services w/no LDP interaction between the transport
--> and client networks).
-->
--> The work within PWE3 would be a short encapsulation specification
--> and applicability statement.
-->
--> Where the generic packet PW payload was MPLS the PW would be
--> transparent to the MPLS client layer and not an extension of the
--> MPLS heirachy. This would need to be made clear in the
--> applicability statement.
-->
--> Do folks here have comments either way on the utility, application
--> and/or requirement for this (i.e., if you're in favor or
--> against please
--> make it known to the list)?
-->
--> Thanks!
-->
--> -danny & Stewart
-->
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
-->

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Danny McPherson <[email-masked]>
Date: Mon, 30 Jan 2006 12:24:07 -0700

> (i.e. PSN)? Is it necessarily MPLS?

Nope, it'd surely be any PSN over which PWs could be carried
(e.g., MPLS, IP).  I'm not sure why we'd scope it one way or
another, if that's what you're asking?

-danny

---

From: [email-masked]
Date: Mon, 30 Jan 2006 19:27:36 +0000

If the intent is to carry MPLS PWs in another generic PW, doesn't the
generic PW become the PSN tunnel?

Matthew

                      "Nurit Sprecher"                                                                                                            
                      <nurit.sprecher@SeabridgeNe         To:      "Gray, Eric" <[email-masked]>, "Danny McPherson" <[email-masked]>        
                      tworks.com>                         cc:      pwe3 <[email-masked]>, Nurit Sprecher <[email-masked]>    
                      Sent by:                            Subject: RE: [PWE3] Generic PW - Is there a need?                                       
                      [email-masked]                                                                                                       

                      30/01/2006 19:11                                                                                                            

In addition to the below, what is the type of the transport layer (i.e.
PSN)? Is it necessarily MPLS?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Gray, Eric
Sent: Monday, January 30, 2006 20:53
To: 'Danny McPherson'
Cc: 'pwe3'
Subject: RE: [PWE3] Generic PW - Is there a need?

Danny,

--
Eric

---

From: Scott W Brim <[email-masked]>
Date: Mon, 30 Jan 2006 14:44:02 -0500

> generic PW become the PSN tunnel?

The content is opaque.  It might be more MPLS, but to us it's just
payload.  We still have our PWs and PSN tunnels.