Subject: RE: [PWE3] Need for CRC-10 computation for OAM message mapping

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 9 Jan 2006 13:50:27 +0200

Yaakov and all,

When it comes to insertion of ATM OAM cells into ATM PWs by the PE,
draft-ietf-pwe3-oam-msg-map-03.txt limits this to F4/F5 AIS cells in the
case
of the ATM AC entering its fordarf defect state (Section 11.1.2)

It explicitly prohibitsinsertion of F4/F5 RDI cells into the PW since it
declares the reverse AC defect state as invalid for the PE  operating in the
inband 
ATM OAM mode.

And when it comes to insertion of ATM OAM cells into the local ATM AC,
CRC-10 generation is, of course, mandatory.

Why should we care about the situations (like insertion of F4/f5 RDI, CC or
LB
cells into the PW) that do not exist?

Regards,
			Sasha

> -----Original Message-----
> From: Xixiang Li [mailto:[email-masked]]
> Sent: Monday, January 09, 2006 1:26 PM
> To: Yaakov Stein; Huub van Helvoort
> Cc: pwe3
> Subject: Re: [PWE3] Need for CRC-10 computation for OAM 
> message mapping
> 
> 
> Hello Huub, Yaakov,
> 
> Maybe the CRC-10 of fix-fields plusing CRC-10 of variable 
> field will be perfect, 
> then only the variable fields need to be computed. 
> 
> Regards,
> Eric (Li Xixiang)
> 
> 
> ----- Original Message ----- 
> From: "Yaakov Stein" <[email-masked]>
> To: "Huub van Helvoort" <[email-masked]>
> Cc: "pwe3" <[email-masked]>
> Sent: Monday, January 09, 2006 7:01 PM
> Subject: RE: [PWE3] Need for CRC-10 computation for OAM 
> message mapping
> 
> 
> Huub
> 
> Thanks for the suggestion.
> 
> I already thought about precomputing as you suggest, 
> but when you start doing OAM interworking, you will
> find that AIS is not enough.
> 
> We want to be able (at least) to send all the fault management
> cells, i.e. AIS, RDI, CC (that's already three) 
> and LB (which can't be precomputed, since it depends
> on where the LB is desired).
> 
> Then we have the performance management cells as well.
> 
> I only asked regarding the AIS since that is what is specified
> right now in the message mapping draft.
> 
> Y(J)S
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of
> Huub van Helvoort
> Sent: Friday, January 06, 2006 17:58
> To: Yaakov Stein
> Cc: pwe3
> Subject: Re: [PWE3] Need for CRC-10 computation for OAM 
> message mapping
> 
> Hello Yaakov,
> 
> You wrote:
> 
> > In section 11.1.2 of the message-mapping draft it is specified that 
> > for inband ATM OAM over PW
> >   "On entry to the AC forward defect state, PE1 MUST 
> >   commence insertion of ATM AIS cells into the corresponding PW."
> > 
> > ATM OAM cells require calculation of CRC-10, usually performed by 
> > hardware or a network processor when the cell is sent to 
> the network.
> 
> The structure of an OAM AIS cell is always:
> 
> 10 6A 6A 6A 6A 6A 6A 6A 6A 6A
> 6A 6A 6A 6A 6A 6A 6A 6A 6A 6A
> 6A 6A 6A 6A 6A 6A 6A 6A 6A 6A
> 6A 6A 6A 6A 6A 6A 6A 6A 6A 6A
> 6A 6A 6A 6A 6A 6A 03 B9
> 
> Where 10 indicates OAM AIS
> and CRC10 = 3B9
> 
> So it is not necessary to calculate the CRC-10 for each OAM AIS cell.
> 
> Cheers, Huub.
> 
> --
> ================================================================
>               http://members.chello.nl/hhelvoort/
> ================================================================
> Always remember that you are unique...just like everyone else...
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Tue, 10 Jan 2006 12:27:11 -0500

Yaakov,
In section 11.1.2, one cannot send a zero CRC in the AIS cells. The remote
PE in the cell mode operation does not process the AIS cell but passes it on
to the ATM AC. I do not see how you can get around a computation (or
pre-computation) of the CRC field at the generation point.

Mustapha.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sasha Vainshtein
Sent: Monday, January 09, 2006 6:50 AM
To: Yaakov Stein
Cc: pwe3
Subject: RE: [PWE3] Need for CRC-10 computation for OAM message mapping

Yaakov and all,

When it comes to insertion of ATM OAM cells into ATM PWs by the PE,
draft-ietf-pwe3-oam-msg-map-03.txt limits this to F4/F5 AIS cells in the
case of the ATM AC entering its fordarf defect state (Section 11.1.2)

inband ATM OAM mode.

Why should we care about the situations (like insertion of F4/f5 RDI, CC or
LB cells into the PW) that do not exist?

Regards,
			Sasha

> Subject: Re: [PWE3] Need for CRC-10 computation for OAM message
> mapping
>
>
> Hello Huub, Yaakov,
>
> Maybe the CRC-10 of fix-fields plusing CRC-10 of variable field will
> be perfect, then only the variable fields need to be computed.
>
> Regards,
> Eric (Li Xixiang)
>
>
> Subject: RE: [PWE3] Need for CRC-10 computation for OAM message
> mapping
>
>
> Huub
>
> I already thought about precomputing as you suggest, but when you
> start doing OAM interworking, you will find that AIS is not enough.
>
> We want to be able (at least) to send all the fault management cells,
> i.e. AIS, RDI, CC (that's already three) and LB (which can't be
> precomputed, since it depends on where the LB is desired).
>
> I only asked regarding the AIS since that is what is specified right
> now in the message mapping draft.
>
> Y(J)S
>
>
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Huub van Helvoort
> Subject: Re: [PWE3] Need for CRC-10 computation for OAM message
> mapping
>
> Hello Yaakov,
>
> You wrote:
>