Subject: RE: [PWE3] Generic PW - Is there a need?

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 30 Jan 2006 20:52:48 +0200

Danny, 

> We would like to start a discussion on whether the PWE3 WG should work
on the definition of a generic packet PW.

I think this work fills a real need, e.g. for interconnecting router
ports.

I support, agreeing that there may be questions about the meaning in
some
circumstances; but like all our work, it should be used when useful
and avoided when wrong.

Y(J)S

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Gray, Eric" <[email-masked]>
Date: Mon, 30 Jan 2006 14:29:16 -0500

Danny,

	In this case, the work within the PWE3 working group MAY 
include protocol extensions to support negotiation, as well as 
"a short encapsulation specification and applicability statement."

	I thought this might be the case, since Luca already did
some work on pseudowire type code-points and I was not sure what
else we were talking about.

	That said, I agree that this could be useful work.

--
Eric

--> -----Original Message-----
--> From: Danny McPherson [mailto:[email-masked]] 
--> Sent: Monday, January 30, 2006 2:22 PM
--> To: Gray, Eric
--> Cc: 'pwe3'
--> Subject: Re: [PWE3] Generic PW - Is there a need?
--> 
--> 
--> On Jan 30, 2006, at 11:52 AM, Gray, Eric wrote:
--> 
--> > Danny,
--> >
--> > 	As a clarification question, since it appears that the
--> > intent is to carry multiple different types of traffic using
--> > a generic pseudowire, is the intent to negotiate the carried
--> > packet type, or would this be indicated by code points in the
--> > pseudowire encapsulation format?
--> 
--> While the message I sent suggested this MAY be conveyed
--> via code points in the PW CW, it's something the WG will need
--> to decide -- as I suspect there are instances where negotiating
--> the type would be desirable [necessary?].
--> 
--> -danny
-->

---

From: "Nurit Sprecher" <[email-masked]>
Date: Mon, 30 Jan 2006 21:36:25 +0200

I am glad to see that any PSN technology will be supported and there is no restriction.
>From some reason I could understand from your mail that you are talking about MPLS. 
Thanks for the clarification.

-----Original Message-----
From: Danny McPherson [mailto:[email-masked]]
Sent: Monday, January 30, 2006 21:24
To: Nurit Sprecher
Cc: pwe3 pwe3
Subject: Re: [PWE3] Generic PW - Is there a need?

On Jan 30, 2006, at 12:11 PM, Nurit Sprecher wrote:

> In addition to the below, what is the type of the transport layer
> (i.e. PSN)? Is it necessarily MPLS?

Nope, it'd surely be any PSN over which PWs could be carried
(e.g., MPLS, IP).  I'm not sure why we'd scope it one way or
another, if that's what you're asking?

-danny

---

From: "Nurit Sprecher" <[email-masked]>
Date: Mon, 30 Jan 2006 21:40:20 +0200

Is it?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, January 30, 2006 21:28
To: Nurit Sprecher
Cc: Danny McPherson; Gray, Eric; Nurit Sprecher; pwe3; [email-masked]
Subject: RE: [PWE3] Generic PW - Is there a need?

If the intent is to carry MPLS PWs in another generic PW, doesn't the
generic PW become the PSN tunnel?

Matthew

                      "Nurit Sprecher"                                                                                                           
                      <nurit.sprecher@SeabridgeNe         To:      "Gray, Eric" <[email-masked]>, "Danny McPherson" <[email-masked]>       
                      tworks.com>                         cc:      pwe3 <[email-masked]>, Nurit Sprecher <[email-masked]>   
                      Sent by:                            Subject: RE: [PWE3] Generic PW - Is there a need?                                      
                      [email-masked]                                                                                                      

                      30/01/2006 19:11                                                                                                           

In addition to the below, what is the type of the transport layer (i.e.
PSN)? Is it necessarily MPLS?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Gray, Eric
Sent: Monday, January 30, 2006 20:53
To: 'Danny McPherson'
Cc: 'pwe3'
Subject: RE: [PWE3] Generic PW - Is there a need?

Danny,

        As a clarification question, since it appears that the
intent is to carry multiple different types of traffic using
a generic pseudowire, is the intent to negotiate the carried
packet type, or would this be indicated by code points in the
pseudowire encapsulation format?

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]]
--> On Behalf Of Danny McPherson
--> Sent: Monday, January 30, 2006 12:51 PM
--> To: pwe3 pwe3
--> Subject: [PWE3] Generic PW - Is there a need?
-->
-->
--> Folks,
--> We would like to start a discussion on whether the PWE3
--> WG should work on the definition of a generic packet PW.
-->
--> The driver for this work is threefold:
-->
--> 1) The need for a PW to support the IPLS work in the L2VPN
--> WG
-->
--> 2) The need to provide an MPLS PW to satisfy the same need
--> as the IP PW proposed in the L2TPext WG
-->
--> 3) The need to provide PW to transport MPLS PWs
-->
--> This type of PW is generally needed where it is required to
--> interconnect ACs with two (actually or potentially) disparate
--> Layer 2 protocols.
-->
--> Generally one would use a Layer 3 service to provide this,
--> but the use of a Layer 2 service allows greater decoupling
--> between the client and transport networks.
-->
--> The types of packets that need to be carried over a generic
--> packet PW are know to be (are there others?):
-->
--> IPv4
--> IPv6
--> IS-IS
--> MPLS
--> Compressed IP
-->
--> In all cases the payload would be carried over a PW with a CW
--> to allow ECMP suppression and the discrimination of different
--> packet types multiplexied over the PW, for example IPv4 packets
--> and IS-IS protocol packets. Because a CW was used the EoS bit
--> would need to be set in the transport label stack, as well as in
--> the client label stack.
-->
--> A generic PW would be supported by its own OAM mechanism
--> (VCCV) which would be different from any client OAM
--> mechanism.
-->
--> One application for the service would be a SP transit domain
--> in which it was desired that there was no interaction between
--> the client and transport network protocols (e.g., MPLS LSP
--> transport services w/no LDP interaction between the transport
--> and client networks).
-->
--> The work within PWE3 would be a short encapsulation specification
--> and applicability statement.
-->
--> Where the generic packet PW payload was MPLS the PW would be
--> transparent to the MPLS client layer and not an extension of the
--> MPLS heirachy. This would need to be made clear in the
--> applicability statement.
-->
--> Do folks here have comments either way on the utility, application
--> and/or requirement for this (i.e., if you're in favor or
--> against please
--> make it known to the list)?
-->
--> Thanks!
-->
--> -danny & Stewart
-->
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
-->

---

From: "Nurit Sprecher" <[email-masked]>
Date: Mon, 30 Jan 2006 22:12:11 +0200

Great. I am in favor of this work.

-----Original Message-----
From: Scott W Brim [mailto:[email-masked]]
Sent: Monday, January 30, 2006 21:44
To: [email-masked]
Cc: Nurit Sprecher; [email-masked]; pwe3; Danny McPherson
Subject: Re: [PWE3] Generic PW - Is there a need?

> generic PW become the PSN tunnel?

The content is opaque.  It might be more MPLS, but to us it's just
payload.  We still have our PWs and PSN tunnels.

---

From: "Florin Balus" <[email-masked]>
Date: Mon, 30 Jan 2006 15:25:08 -0500

I am in favor of this work... We submitted some time ago a draft on IP
PW where we actually provided support for both IP and IS-IS frames as
required below - see enclosed...

>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Danny McPherson
>Sent: Monday, January 30, 2006 12:51 PM
>To: pwe3 pwe3
>Subject: [PWE3] Generic PW - Is there a need?
>
>
>
>Folks,
>We would like to start a discussion on whether the PWE3
>WG should work on the definition of a generic packet PW.
>
>The driver for this work is threefold:
>
>1) The need for a PW to support the IPLS work in the L2VPN
>WG
>
>2) The need to provide an MPLS PW to satisfy the same need
>as the IP PW proposed in the L2TPext WG
>
>3) The need to provide PW to transport MPLS PWs
>
>This type of PW is generally needed where it is required to 
>interconnect ACs with two (actually or potentially) disparate 
>Layer 2 protocols.
>
>Generally one would use a Layer 3 service to provide this,
>but the use of a Layer 2 service allows greater decoupling 
>between the client and transport networks.
>
>The types of packets that need to be carried over a generic 
>packet PW are know to be (are there others?):
>
>IPv4
>IPv6
>IS-IS
>MPLS
>Compressed IP
>
>In all cases the payload would be carried over a PW with a CW 
>to allow ECMP suppression and the discrimination of different 
>packet types multiplexied over the PW, for example IPv4 
>packets and IS-IS protocol packets. Because a CW was used the 
>EoS bit would need to be set in the transport label stack, as 
>well as in the client label stack.
>
>A generic PW would be supported by its own OAM mechanism
>(VCCV) which would be different from any client OAM
>mechanism.
>
>One application for the service would be a SP transit domain
>in which it was desired that there was no interaction between 
>the client and transport network protocols (e.g., MPLS LSP 
>transport services w/no LDP interaction between the transport 
>and client networks).
>
>The work within PWE3 would be a short encapsulation 
>specification and applicability statement.
>
>Where the generic packet PW payload was MPLS the PW would be 
>transparent to the MPLS client layer and not an extension of 
>the MPLS heirachy. This would need to be made clear in the 
>applicability statement.
>
>Do folks here have comments either way on the utility, 
>application and/or requirement for this (i.e., if you're in 
>favor or against please make it known to the list)?
>
>Thanks!
>
>-danny & Stewart 
>

---

From: "Ali Sajassi \(sajassi\)" <[email-masked]>
Date: Mon, 30 Jan 2006 13:07:19 -0800

I support this work if it is done within the scope (and for
applications) mentioned below.

-Ali 

> Sent: Monday, January 30, 2006 9:51 AM
> To: pwe3 pwe3
> We would like to start a discussion on whether the PWE3 WG 
> should work on the definition of a generic packet PW.
> 
> 1) The need for a PW to support the IPLS work in the L2VPN WG
> 
> 2) The need to provide an MPLS PW to satisfy the same need as 
> the IP PW proposed in the L2TPext WG
> 
> (VCCV) which would be different from any client OAM mechanism.
>

---

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 30 Jan 2006 16:27:00 -0500

Yes. Note the following.

1) Luca has IP Layer 2 transport as IP PW (0x0b)
2) The florin draft proposes use of CW as a possibility 
   to include IS-IS

I am assuming the new proposal is to create a generic PW with
a different PW type value which allows through encapsulation,
payload identification of,
- IP
- IS-IS
- MPLS
- PW  (i.e PW in PW)
- PW type itself (so that PW Control signaling just
  signals generic PW and the PW type is part of encapsulation
  This would help single-sided flavor of arp-mediation in L2VPN 
  too)

etc. (some were mentioned in Danny's email, others I am 
assuming we must do anyway)

If this is true, that might be a better way to go. 

/himanshu

> From: Florin Balus [mailto:[email-masked]]
> Sent: Monday, January 30, 2006 3:53 PM
> To: Danny McPherson; Shah, Himanshu; [email-masked];
> Mircea Pisica BT
> Absolutely Danny... I got help from Mircea, Himanshu and Mustapha on
> this draft and I know some of them were interested in working on it
> again some time ago.
> Mircea, Mustapha, Himanshu,
> Still interested to resubmit? I will be in Paris next week for MPLS
> World Congress 06. Let me know if u are coming to the 
> conference and we
> can talk about it.
> Regards,
> Florin
> 
> >Sent: Monday, January 30, 2006 3:45 PM
> >To: Balus, Florin [CAR:6955:EXCH]
> >On Jan 30, 2006, at 1:25 PM, Florin Balus wrote:
> >
> >>
> >Florin,
> >Thanks and I indeed do recall this draft.  Once input is 
> >collected if you're interested we can update this draft and 
> >use it as a basis for the work.
> >
> >I was planning to help edit on this document if you'd like and 
> >we can fold all the text into this and attempt to move it 
> >forward in the WG?
> >
> >Does that work?
> >
> >-danny
> >
> >
> >
>

---

From: Shahram Davari <[email-masked]>
Date: Tue, 31 Jan 2006 07:54:22 -0800

Stewart,
 
1) Is the idea to preserve the adaptation methods already defined for PWs such as ATM PW, FR PW, CES PW, etc, and only add a protocol ID?
2) Won't such new protocol (even if the adaptation is unchanged from currently defined PW) be essentially non-compatible with currently defined PW RFCs?
 
Thanks,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Stewart Bryant
Sent: Tuesday, January 31, 2006 9:54 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [PWE3] Generic PW - Is there a need?

[email-masked] <mailto:[email-masked]>  wrote:

Danny,

It is not entirely clear to me what the proposal you are making is or

the motivation behind it.

Are you stating that to support IPLS, transport of MPLS PWs over a PW

etc. that a new control word format/encapsulation is required and this

document will specify such a control word format?  If so, what is

deficient/missing in the current control word formats?

You need a standard method to multiplex a number of protocols over the 
PW. It's not always the case that the only protocol that needs to be
carried is IP. You might want to carry IP + ISIS, or IP + MPLS etc.
We could do this by defining a canonical data-link type, or by
adding a PID to the PW. How we do it is a WG decision.

Or is it to just essentially combine several PW types into a single

document rather than a document per PW type?

No, we think that there is a need to carry multiple types over the same PW.

- Stewart

Or am I completely missing the point?

Thanks

Ben

[email-masked] <mailto:[email-masked]>    <mailto:[email-masked]> <mailto:[email-masked]> wrote:

Folks,

interconnect ACs with two (actually or potentially) disparate Layer 2

protocols. 

IPv4

IPv6

IS-IS

MPLS

Compressed IP

transport services w/no LDP interaction between the transport and

client networks). 

applicability statement. 

Thanks!

-danny & Stewart

pwe3 mailing list

[email-masked] <mailto:[email-masked]> 

https://www1.ietf.org/mailman/listinfo/pwe3 <https://www1.ietf.org/mailman/listinfo/pwe3> 

pwe3 mailing list

[email-masked] <mailto:[email-masked]> 

https://www1.ietf.org/mailman/listinfo/pwe3 <https://www1.ietf.org/mailman/listinfo/pwe3>