Subject: RE: [PWE3] Need for CRC-10 computation for OAM message mapping

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 9 Jan 2006 13:01:01 +0200

Huub

Thanks for the suggestion.

I already thought about precomputing as you suggest, 
but when you start doing OAM interworking, you will
find that AIS is not enough.

We want to be able (at least) to send all the fault management
cells, i.e. AIS, RDI, CC (that's already three) 
and LB (which can't be precomputed, since it depends
on where the LB is desired).

Then we have the performance management cells as well.

I only asked regarding the AIS since that is what is specified
right now in the message mapping draft.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Huub van Helvoort
Sent: Friday, January 06, 2006 17:58
To: Yaakov Stein
Cc: pwe3
Subject: Re: [PWE3] Need for CRC-10 computation for OAM message mapping

Hello Yaakov,

You wrote:

> In section 11.1.2 of the message-mapping draft it is specified that 
> for inband ATM OAM over PW
>   "On entry to the AC forward defect state, PE1 MUST 
>   commence insertion of ATM AIS cells into the corresponding PW."
> 
> ATM OAM cells require calculation of CRC-10, usually performed by 
> hardware or a network processor when the cell is sent to the network.

The structure of an OAM AIS cell is always:

10 6A 6A 6A 6A 6A 6A 6A 6A 6A
6A 6A 6A 6A 6A 6A 6A 6A 6A 6A
6A 6A 6A 6A 6A 6A 6A 6A 6A 6A
6A 6A 6A 6A 6A 6A 6A 6A 6A 6A
6A 6A 6A 6A 6A 6A 03 B9

Where 10 indicates OAM AIS
and CRC10 = 3B9

So it is not necessary to calculate the CRC-10 for each OAM AIS cell.

Cheers, Huub.

--
================================================================
              http://members.chello.nl/hhelvoort/
================================================================
Always remember that you are unique...just like everyone else...

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Xixiang Li <[email-masked]>
Date: Mon, 09 Jan 2006 19:26:23 +0800

Hello Huub, Yaakov,

Maybe the CRC-10 of fix-fields plusing CRC-10 of variable field will be perfect, 
then only the variable fields need to be computed. 

Regards,
Eric (Li Xixiang)

----- Original Message ----- 
From: "Yaakov Stein" <[email-masked]>
To: "Huub van Helvoort" <[email-masked]>
Cc: "pwe3" <[email-masked]>
Sent: Monday, January 09, 2006 7:01 PM
Subject: RE: [PWE3] Need for CRC-10 computation for OAM message mapping

Huub

Y(J)S

-----Original Message-----

Hello Yaakov,

Cheers, Huub.

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 09 Jan 2006 14:48:07 +0100

Hello Yaakov,

> right now in the message mapping draft.

In this case the PW acts as a server for the ATM cell stream,
anything problem detected at the ingress will be reported for
fault handling and localisation. The only signal required to be
sent to the egress and the ATM termination are ATM OAM AIS cells
to indicate that a fault has been detected and is reported, no
further actions are required.

Any other performance and fault handling is PW related and
should be handled by PW OAM.

Cheers, Huub.