Subject: [Qirg] Current state of the art

From: Wojciech Kozlowski <[email-masked]>
Date: Sun, 08 Apr 2018 19:18:28 +0100

Hi,

I found out about this research group at the IRTF open meeting in March
and have since been reading about the subject matter.

One thing that I have come across is that various small networks have
already been built and trialled for QKD. The examples I have come
across are:

1. DARPA (Boston) - https://www.darpa.mil/about-us/timeline/quantum-key
-distribution-network
2. Tokyo - https://arxiv.org/abs/1103.3566
3. SECOQC - http://www.secoqc.net/index.html (althouh this seems to
have finished in 2010)

What I'm currently trying to understand is to what extent they formed
some form of a "quantum internet". I don't think that anyone considers
them to be a precursor of a quantum internet, but they all seem to have
needed to solve problems related to network resource sharing and
multiplexing and distributing entangled pairs over multiple hops.

What makes them different from a quantum internet?

How much of the work done in building those experiments is applicable
to the questions that this research group will attempt to answer?

I guess these are very broad questions so they might not have a
succinct answer. Any attempt to answer the above questions and/or point
me at relevant literature or reviews of existing state of the art
quantum networks for QKD (or other applications if such deployments
exist) would be greatly appreciated. 

I think this knowledge might be in general useful to the other
participants of this mailing list.

Thanks,
Wojciech

---

From: Joseph Fitzsimons <[email-masked]>
Date: Sun, 8 Apr 2018 19:05:07 +0000

Hi Wojciech,

One answer to this is simply the fact that a collection of point-to-point links which can transmit separable quantum states do not amount to a true quantum network, in the sense that quantum communication generally cannot pass through nodes without the use of some kind of quantum repeater, and these are still in their infancy. For some crypto scenarios it suffices to have trusted nodes, so that secure links are established between nodes in the network, but the nodes themselves are trusted not to snoop. This is clearly not the most general scenario you may wish to consider, but is the premise underlying many of the networks build to date. Furthermore, such networks are not suited to general purpose quantum communication, as entanglement cannot be established between arbitrary nodes, precluding applications such as distributed quantum computation. General networks appear to open up more complex questions than occur in the case of point-to-point links, and so there is quite a significant difference from a quantum internet. Stephanie and Rod (and others) have done a good job of classifying the different types of possible networks and architectural and routing issues involved, so I should probably let one of them give more details on the various distinctions between networks.

All the best,

Joe

> On 9 Apr 2018, at 2:18 AM, Wojciech Kozlowski <[email-masked]> wrote:
>
> Hi,
>
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

________________________________

Important: This email is confidential and may be privileged. If you are not the intended recipient, please delete it and notify us immediately; you should not copy or use it for any purpose, nor disclose its contents to any other person. Thank you.

---

From: Pacher Christoph <[email-masked]>
Date: Sun, 8 Apr 2018 19:49:18 +0000

Dear Wojciech,

SECOQC - and also the other networks you have mentioned - represent so-called trusted repeater QKD networks. 

In particular, that means that no entanglement is shared over multiple hops. However, SECOQC and the Tokyo network had each a single QKD link implemented with a QKD system based on (polarisation) entangled photons co-developed in our group at AIT.

You can find details of the networking aspects (and also all other details) of the SECOQC network in 
http://iopscience.iop.org/article/10.1088/1367-2630/11/7/075001 (open-access). In addition you might use google to find "QKD networks based on Q3P", a book chapter written by my colleague Oliver detailing the network protocol used in SECOQC. 

In fact on the network layer there might be strong similarities between quantum and trusted repeater networks: 
(a) a quantum internet for entanglement distribution needs quantum memories in each node (quantum repeater), in a trusted repeater QKD network you have in each node (trusted repeater) classical memories that hold the (classical) secret keys of individual QKD links.
(b) also the way how a secret key is generated in a trusted repeater network "hop-by-hop" is IMHO similar to entanglement distribution between two remote parties in a network with quantum repeaters.
(c) routing strategies (choosing the intermediate nodes in your end-to-end connection) might also be similar.
(d) and finally, I think, like in trusted repeater QKD networks, also quantum repeater networks need preshared keys for the purpose of authenticating the nodes in the network (at least if you want to do any crypto).

However, there might exist any number of new interesting network problems in entanglement distributing networks.

Hope that helps.

Cheers,
Christoph
________________________________________
From: Qirg [[email-masked]] on behalf of Wojciech Kozlowski [[email-masked]]
Sent: Sunday, April 08, 2018 8:18 PM
To: [email-masked]
Subject: [Qirg] Current state of the art

Hi,

Thanks,
Wojciech

---

From: Rodney Van Meter <[email-masked]>
Date: Mon, 9 Apr 2018 06:15:38 +0900

I think part of Wojciech’s question was, to what extent can routing and multiplexing/resource management schemes developed for these early QKD networks be repurposed for entanglement-based, general-purpose networks?

I would say the answer is, “Very little.” As others mentioned, entangled networks will use memories at the nodes.  Those memories hold states for at least one link RTT, and maybe for multiple end-to-end RTTs, so managing them is a very different process.

Additionally, we need to discuss the semantics of a request across the network — what does it mean to ask for the network to do something for you?  Is it just creating a Bell pair (two entangled qubits), or is there something else?  How do we manage purification (error checking), which is a distributed operation?

One thing I like very much in the SECOQC work that Pacher just cited is their three-plane model: the quantum plane, secrets plane, and data plane. However, it’s very QKD-specific. Can it serve as a basis for modeling more complex services? At least one of the authors of that paper is here on this list, perhaps she can explain the model better than I can.

—Rod

---

From: Jim Harrington <[email-masked]>
Date: Sun, 8 Apr 2018 17:40:13 -0700

At the very least, I would see a useful network request as consisting of a)
a number of Bell pairs to be established between two network nodes and b) a
lower bound on their fidelity.

--Jim

On Sun, Apr 8, 2018 at 2:15 PM, Rodney Van Meter <[email-masked]> wrote:

>
> Additionally, we need to discuss the semantics of a request across the
> network — *what does it mean to ask for the network to do something for
> you?*  Is it just creating a Bell pair (two entangled qubits), or is
> there something else?  How do we manage purification (error checking),
> which is a distributed operation?
>
> —Rod
>