Subject: Re: [QUIC] clarification on multi-path migration

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 12 Sep 2016 15:27:16 -0500

Hi, Zahed,

On Thu, Jul 21, 2016 at 8:30 AM, Zaheduzzaman Sarker <
[email-masked]> wrote:

> Hi,
>
> what exactly does “connection migration” mean in the charter in the
> context of current QUIC design?
>
> As I can see in the current QUIC design, a QUIC connection is identified
> by a connection ID. Hence, there will be no need to migrate the connection
> but change data send/receive over different interface/path.
>

My understanding is that the term was being used loosely to mean what you
are asking about.

I'm changing this to

The fourth focus area will extend core protocol facilities to enable
multipath
capabilities for connection migration between interfaces and load sharing
across multiple interfaces.

If that's not right, we should probably talk ...

> Also I would like to know what does the “migration” mean in the context of
> multi-path in the charter?
>

Does that help?

Spencer

> BR
>
> Zahed
>
>
> *===============================================================================*
>
>
> *ANM ZAHEDUZZAMAN SARKER *Services, Media and Network Features
> Eircsson Research
>
>
> *Ericsson *Laboratoriegränd 11
> 97128 Luleå, Sweden
> Phone +46 10 717 37 43
> Mobile +46 76 115 37 43
> Office +46 76 115 37 43
> Fax +46 920 996 21
> [email-masked]
> *www.ericsson.com* <http://www.ericsson.com/>
> ============================================================
> ===================
>
>
>
>
> _______________________________________________
> QUIC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/quic
>
>

---

From: Erik Kline <[email-masked]>
Date: Tue, 13 Sep 2016 05:31:50 +0900

I wonder if it's better to speak about migration among IP addresses,
since you could in theory, as an example, migrate a connection from
source IP address A to source IP address B on the same interface
(across address families even).

On 13 September 2016 at 05:27, Spencer Dawkins at IETF
<[email-masked]> wrote:
> Hi, Zahed,
>
> On Thu, Jul 21, 2016 at 8:30 AM, Zaheduzzaman Sarker
> <[email-masked]> wrote:
>>
>> Hi,
>>
>> ===============================================================================
>> ANM ZAHEDUZZAMAN SARKER
>>
>> Services, Media and Network Features
>> Eircsson Research
>>
>> Ericsson
>> Laboratoriegränd 11
>> 97128 Luleå, Sweden
>> Phone +46 10 717 37 43
>> Mobile +46 76 115 37 43
>> Office +46 76 115 37 43
>> Fax +46 920 996 21
>> www.ericsson.com
>> ===============================================================================
>>
>>
>>
>>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 12 Sep 2016 15:51:52 -0500

Erik,

> (across address families even).

When an AD hits himself in the forehead, it makes a noise like "doah". Same
as Homer Simpson(1). No idea why that is. Probably because Homer Simpson is
a nuclear safety engineer, and ... no, that can't be it.

BUT, yeah, of course you're right, and thank you for elbowing me while I'm
still chopping on the charter. I'll reflect that in what goes out for
community review.

Spencer

(1) https://en.wikipedia.org/wiki/Homer_Simpson

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Tue, 13 Sep 2016 08:43:30 +0000

Hi Spencer,

Thanks for picking it up.

When I look at https://datatracker.ietf.org/wg/quic/charter/ now , I can see the text says - “ The fourth focus area will extend core protocol facilities to enable multipath
capabilities for connection migration between paths and load sharing
across multiple paths.”. This is much better than what we had in https://github.com/IETF-QUIC/Charter/blob/master/quic-charter.md .

With “capabilities for connection migration between paths” the WG is geared to work with the discovery of newer and better path and/or the signaling required between QUIC and other means (like ICE) for such purpose.

BR

Zahed

From: Spencer Dawkins at IETF [mailto:[email-masked]]
Sent: den 12 september 2016 22:27
To: Zaheduzzaman Sarker <[email-masked]>
Cc: [email-masked]
Subject: Re: [QUIC] clarification on multi-path migration

Hi, Zahed,

On Thu, Jul 21, 2016 at 8:30 AM, Zaheduzzaman Sarker <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

what exactly does “connection migration” mean in the charter in the context of current QUIC design?

As I can see in the current QUIC design, a QUIC connection is identified by a connection ID. Hence, there will be no need to migrate the connection but change data send/receive over different interface/path.

My understanding is that the term was being used loosely to mean what you are asking about.

I'm changing this to

The fourth focus area will extend core protocol facilities to enable multipath
capabilities for connection migration between interfaces and load sharing
across multiple interfaces.

Also I would like to know what does the “migration” mean in the context of multi-path in the charter?

Does that help?

Spencer

BR

Zahed

Ericsson
Laboratoriegränd 11
97128 Luleå, Sweden
Phone +46 10 717 37 43<tel:%2B46%2010%20717%2037%2043>
Mobile +46 76 115 37 43<tel:%2B46%2076%20115%2037%2043>
Office +46 76 115 37 43<tel:%2B46%2076%20115%2037%2043>
Fax +46 920 996 21<tel:%2B46%20920%20996%2021>
[email-masked]<mailto:[email-masked]>
www.ericsson.com<http://www.ericsson.com/>
===============================================================================

_______________________________________________
QUIC mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/quic

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 13 Sep 2016 10:43:42 -0500

Hi, Zahed,

On Tue, Sep 13, 2016 at 3:43 AM, Zaheduzzaman Sarker <
[email-masked]> wrote:

> When I look at https://datatracker.ietf.org/wg/quic/charter/ now , I can
> see the text says - “ The fourth focus area will extend core protocol
> facilities to enable multipath
> across multiple paths.”. This is much better than what we had in
> https://github.com/IETF-QUIC/Charter/blob/master/quic-charter.md .
>

Thanks - I stole "paths" from the MPTCP work, which is where I should have
grabbed it from in the first place :-)

Spencer

> With “capabilities for connection migration between paths” the WG is
> geared to work with the discovery of newer and better path and/or the
> signaling required between QUIC and other means (like ICE) for such purpose.
>
>
>
> BR
>
>
>
> Zahed
>
>
>
> *From:* Spencer Dawkins at IETF [mailto:[email-masked]]
> *Sent:* den 12 september 2016 22:27
> *To:* Zaheduzzaman Sarker <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [QUIC] clarification on multi-path migration
>
>
>
> Hi, Zahed,
>
>
>