Subject: Who wants -10 drafts?

From: Martin Thomson <[email-masked]>
Date: Wed, 21 Feb 2018 12:00:40 +1100

I know, I know, you are probably still struggling your way through
interop with -09, but the editors want to know if people want a set of
drafts that reference the newly added QCRAM and invariants docs.

There would be no change to interop targets.

We were originally hoping to include fixes to the bigger open issues,
but those seem unlikely to resolve in time for the March 5 draft
submission cutoff.  And now there might be some people who want to try
out hq-10 now that it has a plausible header compression story.

---

From: Rui Paulo <[email-masked]>
Date: Tue, 20 Feb 2018 17:36:10 -0800

> drafts that reference the newly added QCRAM and invariants docs.

I wouldn’t mind and I think a published draft is reviewed by more people.

> out hq-10 now that it has a plausible header compression story.

For the purposes of the interop, I believe we were still doing HTTP 0.9.  Has that changed?

I’m not sure how many people will take advantage of hq-10 interop but I don’t see any harm in publishing -10 drafts.

—
Rui Paulo

---

From: Martin Thomson <[email-masked]>
Date: Wed, 21 Feb 2018 13:08:42 +1100

> For the purposes of the interop, I believe we were still doing HTTP 0.9.  Has that changed?

Yes, interop is QUIC -09 and HTTP 0.9 (no relation).

> I’m not sure how many people will take advantage of hq-10 interop but I don’t see any harm in publishing -10 drafts.

I might, but whether that is possible will depend on a great many
things.  Nor do I think my own implementation matters much in
determining this.

---

From: Christian Huitema <[email-masked]>
Date: Tue, 20 Feb 2018 19:06:41 -0800

> things.  Nor do I think my own implementation matters much in

I understand that at some point we must start moving up the stack and
test the HTTP mappings. I am not anywhere close to ready with that,
because I am not starting with an HTTP 2 implementation. If it is what
is takes to test the transport, I will do one, or port one. But no way I
can do that in the next 8 days.

-- Christian Huitema

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 20 Feb 2018 19:36:15 -0800

I would be very sad if we needed the H2 implementation to test QUIC. That
seems like it would be bad for layering.

-Ekr

On Tue, Feb 20, 2018 at 7:06 PM, Christian Huitema <[email-masked]>
wrote:

> On Wed, Feb 21, 2018 at 12:36 PM, Rui Paulo <[email-masked]> <[email-masked]> wrote:
>
> I understand that at some point we must start moving up the stack and test
> the HTTP mappings. I am not anywhere close to ready with that, because I am
> not starting with an HTTP 2 implementation. If it is what is takes to test
> the transport, I will do one, or port one. But no way I can do that in the
> next 8 days.
>
> -- Christian Huitema
>

---

From: Martin Thomson <[email-masked]>
Date: Wed, 21 Feb 2018 14:45:02 +1100

No risk of that.

Some people are looking to take the next step and get some experience
with a non-toy upper layer.  I agree that for the group as a whole,
that step is a little way away just yet.

On Wed, Feb 21, 2018 at 2:36 PM, Eric Rescorla <[email-masked]> wrote:
>> I’m not sure how many people will take advantage of hq-10 interop but I
>> don’t see any harm in publishing -10 drafts.
>>

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 21 Feb 2018 07:49:09 +0000

Hi,

> There would be no change to interop targets.

chair hat off, as an implementer: As long as we can agree to stay with 09 (aka 4th implementation draft) for London, I don't care.

Lars

---

From: Praveen Balasubramanian <[email-masked]>
Date: Wed, 21 Feb 2018 16:57:49 +0000

It would be nice to provide an ETA for when H2 over QUIC interop testing will begin. Let's please continue H0.9 over QUIC testing throughout all interop events so that core transport functionality is tested independently. 

-----Original Message-----
From: QUIC [mailto:[email-masked]] On Behalf Of Martin Thomson
Sent: Tuesday, February 20, 2018 7:45 PM
To: Eric Rescorla <[email-masked]>
Cc: QUIC WG <[email-masked]>; huitema <[email-masked]>; Rui Paulo <[email-masked]>
Subject: Re: Who wants -10 drafts?

No risk of that.

Some people are looking to take the next step and get some experience with a non-toy upper layer.  I agree that for the group as a whole, that step is a little way away just yet.

On Wed, Feb 21, 2018 at 2:36 PM, Eric Rescorla <[email-masked]> wrote:
> I would be very sad if we needed the H2 implementation to test QUIC. 
> That seems like it would be bad for layering.
>
> -Ekr
>
>
>> I’m not sure how many people will take advantage of hq-10 interop but 
>> I don’t see any harm in publishing -10 drafts.
>>
>> because I am not starting with an HTTP 2 implementation. If it is 
>> what is takes to test the transport, I will do one, or port one. But 
>> no way I can do that in the next 8 days.
>>
>> -- Christian Huitema
>
>