Subject: Weekly github digest (QUIC Working Group Specifications)

From: Github Notifications <[email-masked]>
Date: Sun, 18 Mar 2018 00:45:19 +0000 (UTC)

Events without label "editorial"

Issues
------
* quicwg/base-drafts (+4/-10/💬20)
  4 issues created:
  - don't apply congestion penalty for lost ack-only packets (by marten-seemann)
    https://github.com/quicwg/base-drafts/issues/1221 
  - inconsistent definition of the TLP duration (by marten-seemann)
    https://github.com/quicwg/base-drafts/issues/1220 
  - confusing Fast Retransmit modes (by marten-seemann)
    https://github.com/quicwg/base-drafts/issues/1212 
  - Use Conservative Initial Packet Size (by mikkelfj)
    https://github.com/quicwg/base-drafts/issues/1209 

  13 issues received 20 new comments:
  - #1197 Add unknown packet version handling to invariants (4 by martinthomson, mikkelfj)
    https://github.com/quicwg/base-drafts/issues/1197 [-invariants] [design] 
  - #1115 Server responses to multiple Initial packets (2 by martinthomson, MikeBishop)
    https://github.com/quicwg/base-drafts/issues/1115 [-transport] [design] 
  - #1148 Replace HPACK integer encoding (2 by krasic, MikeBishop)
    https://github.com/quicwg/base-drafts/issues/1148 [-qpack] [design] 
  - #1174 Packet Number Gap and Connection Probing (2 by janaiyengar, mikkelfj)
    https://github.com/quicwg/base-drafts/issues/1174 [-transport] [design] 
  - #1212 confusing Fast Retransmit modes (2 by siyengar, ianswett)
    https://github.com/quicwg/base-drafts/issues/1212 
  - #837 Padding ACK-only packets (1 by huitema)
    https://github.com/quicwg/base-drafts/issues/837 [-recovery] [-transport] [design] [needs-discussion] 
  - #1085 Handshake failure with Retry and multiple Initial packets (1 by martinthomson)
    https://github.com/quicwg/base-drafts/issues/1085 [-tls] [design] 
  - #941 Resume HTTP/2 TLS from QUIC ? (1 by martinthomson)
    https://github.com/quicwg/base-drafts/issues/941 [-http] [-tls] [design] [has-proposal] 
  - #829 Can a server use a Handshake packet for ACK of the last client Handshake packet (1 by huitema)
    https://github.com/quicwg/base-drafts/issues/829 [-tls] [-transport] [design] [needs-discussion] 
  - #1138 QCRAM encoding requires two passes (1 by afrind)
    https://github.com/quicwg/base-drafts/issues/1138 [-qpack] [design] 
  - #1177 Stateless Reset Concerns (1 by MikeBishop)
    https://github.com/quicwg/base-drafts/issues/1177 
  - #441 Priority grouping node ambiguity (1 by MikeBishop)
    https://github.com/quicwg/base-drafts/issues/441 [-http] [design] [needs-discussion] 
  - #602 End-to-Path Close Signal (1 by mnot)
    https://github.com/quicwg/base-drafts/issues/602 [-transport] [arch] [design] [parked] 

  10 issues closed:
  - Add unknown packet version handling to invariants https://github.com/quicwg/base-drafts/issues/1197 [-invariants] [design] 
  - Defaults for SETTINGS and 0-RTT https://github.com/quicwg/base-drafts/issues/1157 [-http] [design] [has-proposal] 
  - Ban trial decryption in TLS stream after rejected early data? https://github.com/quicwg/base-drafts/issues/1172 [-tls] [design] 
  - Stateless Reset Concerns https://github.com/quicwg/base-drafts/issues/1177 
  - Server responses to multiple Initial packets https://github.com/quicwg/base-drafts/issues/1115 [-transport] [design] 
  - Retry packet and PADDING https://github.com/quicwg/base-drafts/issues/1067 [-transport] [editor-ready] 
  - Signal from TLS that this needs to be a Retry https://github.com/quicwg/base-drafts/issues/1061 [-tls] [design] 
  - STOP_SENDING before stream open https://github.com/quicwg/base-drafts/issues/1050 [-transport] [design] 
  - min_rtt could stay 0 https://github.com/quicwg/base-drafts/issues/1169 [-recovery] 
  - Handshake failure with Retry and multiple Initial packets https://github.com/quicwg/base-drafts/issues/1085 [-tls] [design] 

Pull requests
-------------
* quicwg/base-drafts (+14/-18/💬19)
  14 pull requests submitted:
  - don't apply congestion penalty for lost ack-only packets (by marten-seemann)
    https://github.com/quicwg/base-drafts/pull/1223 
  - Only pace retransmittable packets (by ianswett)
    https://github.com/quicwg/base-drafts/pull/1222 
  - loss recovery timers are based on time of last retransmittable packet (by marten-seemann)
    https://github.com/quicwg/base-drafts/pull/1219 
  - use the kMinTLPTimeout constant in the TLP description (by marten-seemann)
    https://github.com/quicwg/base-drafts/pull/1218 
  - use the kMinRTOTimeout constant in the RTO description (by marten-seemann)
    https://github.com/quicwg/base-drafts/pull/1217 
  - Change CID after inactivity (by MikeBishop)
    https://github.com/quicwg/base-drafts/pull/1214 [-transport] 
  - Retransmit data, not frames (by ianswett)
    https://github.com/quicwg/base-drafts/pull/1213 
  - No more Retransmittable (by ianswett)
    https://github.com/quicwg/base-drafts/pull/1211 
  - 0rtt after retry (by martinthomson)
    https://github.com/quicwg/base-drafts/pull/1208 
  - Initial SETTINGS values (by MikeBishop)
    https://github.com/quicwg/base-drafts/pull/1207 [-http] 
  - Rename 'Open' to 'Ready' for send streams (by martinthomson)
    https://github.com/quicwg/base-drafts/pull/1205 
  - Move section on TLP to Congestion Control (by ianswett)
    https://github.com/quicwg/base-drafts/pull/1203 
  - Specify pacing in a bit more detail. (by janaiyengar)
    https://github.com/quicwg/base-drafts/pull/1202 
  - Addressing issue#1147 (by seanturner)
    https://github.com/quicwg/base-drafts/pull/1201 

  7 pull requests received 19 new comments:
  - #1219 loss recovery timers are based on time of last retransmittable packet (5 by siyengar, mikkelfj, marten-seemann, mcmanus, ianswett)
    https://github.com/quicwg/base-drafts/pull/1219 
  - #1211 No more Ackable (4 by martinthomson, ianswett)
    https://github.com/quicwg/base-drafts/pull/1211 
  - #1193 Remove implicit stream opening (3 by marten-seemann, ianswett)
    https://github.com/quicwg/base-drafts/pull/1193 
  - #882 require ACKs and allow PADDING in the Server Stateless Retry packet (3 by marten-seemann, janaiyengar, MikeBishop)
    https://github.com/quicwg/base-drafts/pull/882 
  - #1222 Only pace retransmittable packets (2 by mikkelfj, ianswett)
    https://github.com/quicwg/base-drafts/pull/1222 
  - #1201 Addressing issue#1147 (1 by seanturner)
    https://github.com/quicwg/base-drafts/pull/1201 
  - #1215 Remove confusing text about ports (1 by martinthomson)
    https://github.com/quicwg/base-drafts/pull/1215 [-http] 

  18 pull requests merged:
  - loss recovery timers are based on time of last retransmittable packet
    https://github.com/quicwg/base-drafts/pull/1219 
  - No more Ackable
    https://github.com/quicwg/base-drafts/pull/1211 
  - Don't imply that Version Negotiation is always sent
    https://github.com/quicwg/base-drafts/pull/1216 [-invariants] 
  - use the kMinRTOTimeout constant in the RTO description
    https://github.com/quicwg/base-drafts/pull/1217 
  - use the kMinTLPTimeout constant in the TLP description
    https://github.com/quicwg/base-drafts/pull/1218 
  - Remove confusing text about ports
    https://github.com/quicwg/base-drafts/pull/1215 [-http] 
  - Retransmit data, not frames
    https://github.com/quicwg/base-drafts/pull/1213 
  - Remove cross-protocol resumption
    https://github.com/quicwg/base-drafts/pull/1057 [-tls] 
  - Initial SETTINGS values
    https://github.com/quicwg/base-drafts/pull/1207 [-http] 
  - Transport parameters are stream counts, not IDs
    https://github.com/quicwg/base-drafts/pull/1065 
  - 0rtt after retry
    https://github.com/quicwg/base-drafts/pull/1208 
  - Rename 'Open' to 'Ready' for send streams
    https://github.com/quicwg/base-drafts/pull/1205 
  - require ACKs and allow PADDING in the Server Stateless Retry packet
    https://github.com/quicwg/base-drafts/pull/882 
  - Create a signal about HelloRetryRequest
    https://github.com/quicwg/base-drafts/pull/1199 
  - Remove discussion of entry overhead
    https://github.com/quicwg/base-drafts/pull/1200 [-qpack] [design] 
  - Specify pacing in a bit more detail.
    https://github.com/quicwg/base-drafts/pull/1202 
  - Move section on TLP to Congestion Control
    https://github.com/quicwg/base-drafts/pull/1203 
  - Addressing issue#1147
    https://github.com/quicwg/base-drafts/pull/1201 

Repositories tracked by this digest:
-----------------------------------
* https://github.com/quicwg/base-drafts

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 27 Mar 2018 09:19:29 +1100

FYI - in case people were wondering, this digest was not complete, because Github has a 300-event limit in its APIs. 

> On 18 Mar 2018, at 11:45 am, Github Notifications <[email-masked]> wrote:
> 
> Sunday March 18, 2018
> 
> quicwg/base-drafts (+4/-10/💬20)
> 4 issues created:
> 
> 	• #1221 don't apply congestion penalty for lost ack-only packets (by marten-seemann) 
> 	• #1220 inconsistent definition of the TLP duration (by marten-seemann) 
> 	• #1212 confusing Fast Retransmit modes (by marten-seemann) 
> 	• #1209 Use Conservative Initial Packet Size (by mikkelfj) 
> 	• #1197 Add unknown packet version handling to invariants (4 by martinthomson, mikkelfj) -invariants design
> 	• #1115 Server responses to multiple Initial packets (2 by martinthomson, MikeBishop) -transport design
> 	• #1148 Replace HPACK integer encoding (2 by krasic, MikeBishop) -qpack design
> 	• #1174 Packet Number Gap and Connection Probing (2 by janaiyengar, mikkelfj) -transport design
> 	• #1212 confusing Fast Retransmit modes (2 by siyengar, ianswett) 
> 	• #837 Padding ACK-only packets (1 by huitema) -recovery -transport design needs-discussion
> 	• #1085 Handshake failure with Retry and multiple Initial packets (1 by martinthomson) -tls design
> 	• #941 Resume HTTP/2 TLS from QUIC ? (1 by martinthomson) -http -tls design has-proposal
> 	• #829 Can a server use a Handshake packet for ACK of the last client Handshake packet (1 by huitema) -tls -transportdesign needs-discussion
> 	• #1138 QCRAM encoding requires two passes (1 by afrind) -qpack design
> 	• #1177 Stateless Reset Concerns (1 by MikeBishop) 
> 	• #441 Priority grouping node ambiguity (1 by MikeBishop) -http design needs-discussion
> 	• #602 End-to-Path Close Signal (1 by mnot) -transport arch design parked
> 10 issues closed:
> 
> 	• #1197 Add unknown packet version handling to invariants -invariants design
> 	• #1157 Defaults for SETTINGS and 0-RTT -http design has-proposal
> 	• #1172 Ban trial decryption in TLS stream after rejected early data? -tls design
> 	• #1177 Stateless Reset Concerns
> 	• #1115 Server responses to multiple Initial packets -transport design
> 	• #1067 Retry packet and PADDING -transport editor-ready
> 	• #1061 Signal from TLS that this needs to be a Retry -tls design
> 	• #1050 STOP_SENDING before stream open -transport design
> 	• #1169 min_rtt could stay 0 -recovery
> 	• #1085 Handshake failure with Retry and multiple Initial packets -tls design
> Pull requests
> 
> quicwg/base-drafts (+14/-18/💬19)
> 	• #1223 don't apply congestion penalty for lost ack-only packets (by marten-seemann) 
> 	• #1222 Only pace retransmittable packets (by ianswett) 
> 	• #1219 loss recovery timers are based on time of last retransmittable packet (by marten-seemann) 
> 	• #1218 use the kMinTLPTimeout constant in the TLP description (by marten-seemann) 
> 	• #1217 use the kMinRTOTimeout constant in the RTO description (by marten-seemann) 
> 	• #1214 Change CID after inactivity (by MikeBishop) -transport
> 	• #1213 Retransmit data, not frames (by ianswett) 
> 	• #1211 No more Retransmittable (by ianswett) 
> 	• #1208 0rtt after retry (by martinthomson) 
> 	• #1207 Initial SETTINGS values (by MikeBishop) -http
> 	• #1205 Rename 'Open' to 'Ready' for send streams (by martinthomson) 
> 	• #1203 Move section on TLP to Congestion Control (by ianswett) 
> 	• #1202 Specify pacing in a bit more detail. (by janaiyengar) 
> 	• #1201 Addressing issue#1147 (by seanturner) 
> 	• #1219 loss recovery timers are based on time of last retransmittable packet (5 by siyengar, mikkelfj, marten-seemann, mcmanus, ianswett) 
> 	• #1211 No more Ackable (4 by martinthomson, ianswett) 
> 	• #1193 Remove implicit stream opening (3 by marten-seemann, ianswett) 
> 	• #882 require ACKs and allow PADDING in the Server Stateless Retry packet (3 by marten-seemann, janaiyengar, MikeBishop) 
> 	• #1222 Only pace retransmittable packets (2 by mikkelfj, ianswett) 
> 	• #1201 Addressing issue#1147 (1 by seanturner) 
> 	• #1215 Remove confusing text about ports (1 by martinthomson) -http
> 18 pull requests merged:
> 
> 	• #1219 loss recovery timers are based on time of last retransmittable packet
> 	• #1211 No more Ackable
> 	• #1216 Don't imply that Version Negotiation is always sent -invariants
> 	• #1217 use the kMinRTOTimeout constant in the RTO description
> 	• #1218 use the kMinTLPTimeout constant in the TLP description
> 	• #1215 Remove confusing text about ports -http
> 	• #1213 Retransmit data, not frames
> 	• #1057 Remove cross-protocol resumption -tls
> 	• #1207 Initial SETTINGS values -http
> 	• #1065 Transport parameters are stream counts, not IDs
> 	• #1208 0rtt after retry
> 	• #1205 Rename 'Open' to 'Ready' for send streams
> 	• #882 require ACKs and allow PADDING in the Server Stateless Retry packet
> 	• #1199 Create a signal about HelloRetryRequest
> 	• #1200 Remove discussion of entry overhead -qpack design
> 	• #1202 Specify pacing in a bit more detail.
> 	• #1203 Move section on TLP to Congestion Control
> 	• #1201 Addressing issue#1147
> 	• https://github.com/quicwg/base-drafts

--
Mark Nottingham   https://www.mnot.net/