Subject: Discovering an HTTP/3 Endpoint in 302 Redirect

From: May Liu <[email-masked]>
Date: Fri, 19 Apr 2019 20:23:35 +0800

In draft-ietf-quic-http-19, we use response header "Alt-Svc" to discover an
HTTP/3 endpoint.
In 302 redirect case，which header should we use to recognize the target
endpoint support HTTP/3 ?

Thanks, May

---

From: Mike Bishop <[email-masked]>
Date: Fri, 19 Apr 2019 19:40:43 +0000

Using the HTTP/2 ALTSVC frame, an origin that was authoritative for both the old and new origins could advertise an Alt-Svc record for the target origin prior to sending the 302.  However, if the origin isn’t authoritative for the target of the redirect, there’s currently no defined way to do that – you’d connect to the target of the redirect and discover HTTP/3 support from your exchange with it.

From: QUIC <[email-masked]> On Behalf Of May Liu
Sent: Friday, April 19, 2019 5:24 AM
To: [email-masked]
Subject: Discovering an HTTP/3 Endpoint in 302 Redirect

In draft-ietf-quic-http-19, we use response header "Alt-Svc" to discover an HTTP/3 endpoint.
In 302 redirect case，which header should we use to recognize the target endpoint support HTTP/3 ?

Thanks, May