Subject: Retry across versions

From: Mikkel Fahnøe Jørgensen <[email-masked]>
Date: Fri, 19 Apr 2019 00:05:44 -0700

Do we have anything the relates Retry packets across versions?

A Retry can be used to verify a client address, but it can also be used to
route traffic to a new server via a change in DCID in the initial packet.

Since version aliasing makes it hard for load balancers to direct traffic
to a server handling a specific version, Retry might be a solution.
However, this only works to the extend that Retry works across versions.

Mikkel

---

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 19 Apr 2019 11:29:03 +0100

On 19/04/2019, 08:05, Mikkel Fahnøe Jørgensen wrote:
> A Retry can be used to verify a client address, but it can also be 
> used to route traffic to a new server via a change in DCID in the 
> initial packet.
>
> Since version aliasing makes it hard for load balancers to direct 
> traffic to a server handling a specific version, Retry might be a 
> solution. However, this only works to the extend that Retry works 
> across versions.
>
> Mikkel
>
Previoulsy,  I think we made the reset design specific to QUIC version 
1.  The more I think about alias of the version number, the more 
concerned I am. I'm think adds extra semantics to tray and "fix" a 
potential issue.

Gorry

---

From: Mike Bishop <[email-masked]>
Date: Fri, 19 Apr 2019 19:41:23 +0000

Retry is a version-specific packet.

From: QUIC <[email-masked]> On Behalf Of Mikkel Fahnøe Jørgensen
Sent: Friday, April 19, 2019 12:06 AM
To: IETF QUIC WG <[email-masked]>
Subject: Retry across versions

A Retry can be used to verify a client address, but it can also be used to route traffic to a new server via a change in DCID in the initial packet.

Since version aliasing makes it hard for load balancers to direct traffic to a server handling a specific version, Retry might be a solution. However, this only works to the extend that Retry works across versions.

Mikkel

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 19 Apr 2019 14:48:02 -0700

What Mike said. Though if version aliasing is incorporated, we may want to
add some text around the treatment of Reset with aliases.

On Fri, Apr 19, 2019 at 12:41 PM Mike Bishop <[email-masked]> wrote:

> *From:* QUIC <[email-masked]> *On Behalf Of * Mikkel Fahnøe
> Jørgensen
> *Sent:* Friday, April 19, 2019 12:06 AM
> *To:* IETF QUIC WG <[email-masked]>
> *Subject:* Retry across versions
>
>
>