Subject: Re: Connection ID Space

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 1 May 2019 08:33:06 -0400

On Tue, Apr 30, 2019 at 08:31:47PM -0400, Martin Thomson wrote:
> That's on the TODO list anyway, as we agreed to remove the
> 0/4-18 restriction for the short packet header a while back.

I do not recall -- when was that decided?

  - Dmitri.

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 01 May 2019 10:31:47 -0400

> I do not recall -- when was that decided?

It was in relation to a request for a *smaller* connection ID.  Marten might remember better than I.

---

From: Marten Seemann <[email-masked]>
Date: Wed, 1 May 2019 23:46:07 +0900

If I remember correctly, we made all the required changes for that to the
invariants. The connection ID lengths are only invariant for Long Header
packets. The connection ID for Short Header packets can have any length, so
a new QUIC version (or a QUIC extension) could define connection IDs in the
Short Header to have lengths that are not encodable in the 0/4-18 scheme.

---

From: Martin Duke <[email-masked]>
Date: Wed, 1 May 2019 10:53:22 -0700

Allowing longer CIDs in short headers at least partially mitigates this. Is
the theory that future versions would negotiate this in the handshake, so
every short header would have the longer CID?

---

From: Mike Bishop <[email-masked]>
Date: Wed, 1 May 2019 20:42:03 +0000

More like future QUIC versions can define anything they like in the definition of the version.  That might include a negotiation, or it might simply be that the version would declare that much larger CIDs are fine with appropriate ways of expressing them.  There just needs to be a transition path from the CIDs established in the handshake.  And yes, everything needed for this is already in -invariants.

From: QUIC <[email-masked]> On Behalf Of Martin Duke
Sent: Wednesday, May 1, 2019 10:53 AM
To: Marten Seemann <[email-masked]>
Cc: QUIC WG <[email-masked]>; Martin Thomson <[email-masked]>
Subject: Re: Connection ID Space

Allowing longer CIDs in short headers at least partially mitigates this. Is the theory that future versions would negotiate this in the handshake, so every short header would have the longer CID?

On Wed, May 1, 2019 at 7:46 AM Marten Seemann <[email-masked]<mailto:[email-masked]>> wrote:
If I remember correctly, we made all the required changes for that to the invariants. The connection ID lengths are only invariant for Long Header packets. The connection ID for Short Header packets can have any length, so a new QUIC version (or a QUIC extension) could define connection IDs in the Short Header to have lengths that are not encodable in the 0/4-18 scheme.

On Wed, May 1, 2019 at 11:31 PM Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote: