Subject: Cmts on ExtAttrs-05

From: "Greg Weber" <[email-masked]>
Date: Thu, 6 Nov 2008 17:55:52 -0500

Editorial cmts on ExtAttrs-05
Submitter name: Greg Weber
Submitter email address: [email-masked]
Date first submitted: Nov 6, '08
Reference: none
Document: draft-ietf-radext-extended-attributes-05.txt
Comment type:  'E'ditorial
Priority: 'S' Must fix
Section: various
Rationale/Explanation of issue:

A couple editorial comments on the current (-05) extended attributes draft:

Section 5, under More bit description:
   "exceeds 246 octets" -> "exceeds 245 octets"
Section 5, under Ext-Len description:
  ">=3." -> ">=4."
Figure 3: the second Ext-Type's value:
  "(0x00" -> "(0x01)"
Figure 4: I think the very last two octet values swapped.
Figure 4: The third attribute in this figure violates this earlier
MUST from section 4:
  "If an Extended Attribute contains more than one TLV then all of the
encapsulated
  TLVs MUST fit completely within the Extended Attribute."
  Not sure if this is a problem with the text or the example -or maybe
just wording.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/radiusext/>

---

From: "Glen Zorn" <[email-masked]>
Date: Thu, 6 Nov 2008 18:09:52 -0800

Greg Weber [mailto:[email-masked]] writes:

...

>    "exceeds 246 octets" -> "exceeds 245 octets"

Fixed.

> Section 5, under Ext-Len description:

Fixed.

> Figure 3: the second Ext-Type's value:

Fixed.

> Figure 4: I think the very last two octet values swapped.

Fixed.

> Figure 4: The third attribute in this figure violates this earlier

Yup.  Anybody happen to remember whose idea it was to put that restriction
in place?