Subject: I-D Action:draft-ietf-radext-extended-attributes-05.txt

From: [email-masked]
Date: Sun, 2 Nov 2008 16:30:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the RADIUS EXTensions Working Group of the IETF.

	Title           : Extended Remote Authentication Dial In User Service (RADIUS) Attributes
	Author(s)       : Y. Li, et al.
	Filename        : draft-ietf-radext-extended-attributes-05.txt
	Pages           : 13
	Date            : 2008-11-02

For the Remote Authentication Dial In User Service (RADIUS) protocol
to continue to support new applications, the RADIUS attribute type
space must be extended beyond the current limit of 255 possible
attribute types while maintaining backwards compatibility with the
existing protocol.  This document defines a mechanism to accomplish
that task, along with standard methods to group together related
attributes and to encode values that don't fit into 253 octets.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-radext-extended-attributes-05.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Glen Zorn" <[email-masked]>
Date: Sun, 2 Nov 2008 17:21:26 -0800

All known issues are resolved to my satisfaction but YMMV; complaints to me.
;-)

> -----Original Message-----
> From: [email-masked] [mailto:i-d-announce-
> [email-masked]] On Behalf Of [email-masked]
> Sent: Sunday, November 02, 2008 4:30 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action:draft-ietf-radext-extended-attributes-05.txt
> 
> For the Remote Authentication Dial In User Service (RADIUS) protocol to
> continue to support new applications, the RADIUS attribute type space
> must be extended beyond the current limit of 255 possible attribute
> types while maintaining backwards compatibility with the existing
> protocol.  This document defines a mechanism to accomplish that task,
> along with standard methods to group together related attributes and to
> encode values that don't fit into 253 octets.
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/radiusext/>

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 3 Nov 2008 16:06:11 -0800

Currently the RADEXT WG Issues tracker lists 6 open issues relating to the RADIUS Extended Attributes document.  Given that the editor now claims to have resolved open Issues from RADEXT WG last call, we are requesting that individuals who filed those issues read the current document, and send email to the list indicating whether their issue is resolved. 
 
The RADEXT WG Issues list is available here:
http://www.drizzle.com/~aboba/RADEXT/
 
The latest version of the Extended Attributes document can be found here:
http://tools.ietf.org/html/draft-ietf-radext-extended-attributes-05
 
The list of previously opened issues is as follows:

Extended Attributes 
Issue Number
Status
Type
Description
Owner

Issue 225
Pending
Technical
Review
Alan DeKok

Issue 250
Pending
Technical
Comments
Greg Weber

Issue 251
Pending
Technical
Review
Bernard Aboba

Issue 272
Pending
Technical
No overall type in Extended Attributes
Glen Zorn

Issue 278
Pending
Technical
Comments
Alan DeKok

Issue 279
No Discussion
Technical
Comments
Stefan Winter

> From: [email-masked]> To: [email-masked]> CC: [email-masked]> Subject: RE: I-D Action:draft-ietf-radext-extended-attributes-05.txt > Date: Sun, 2 Nov 2008 17:21:26 -0800> > All known issues are resolved to my satisfaction but YMMV; complaints to me.> ;-)

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 3 Nov 2008 17:19:34 -0800

Currently the RADEXT WG Issues tracker lists 6 open issues relating to the
RADIUS Extended Attributes document.  Given that the editor now claims to
have resolved open Issues from RADEXT WG last call, 

Just for the record, I made no such claim: I stated that the issues were
resolved to my satisfaction.  Certain elements of one of the issues I
disputed, but since the owner thereof hasn't bothered to respond to my
comments in over a month, I unilaterally marked it as resolved.  It is
possible (likely?) that the owner will now respond, helping to delay
publication further (inadvertently, no doubt).

we are requesting that individuals who filed those issues read the current
document, and send email to the list indicating whether their issue is
resolved. 

I apparently "own" Issue 272 although it was you, I believe, who brought it
up initially.  I withdraw it, since it's become quite apparent that it's not
really a problem at all (except, perhaps, for those poor souls who actually
try to _use_ Extended Attributes).  Oh, well.

 

Extended Attributes 

Issue Number

Status

Type

Description

Owner

Issue 225

Pending

Technical

 <http://www.drizzle.com/~aboba/RADEXT/radissues2.html#Issue 225> Review

 <mailto:[email-masked]> Alan DeKok

Issue 250

Pending

Technical

 <http://www.drizzle.com/~aboba/RADEXT/radissues2.html#Issue 250> Comments

 <mailto:[email-masked]> Greg Weber

Issue 251

Pending

Technical

 <http://www.drizzle.com/~aboba/RADEXT/radissues2.html#Issue 251> Review

 <mailto:[email-masked]> Bernard Aboba

Issue 272

Pending

Technical

 <http://www.drizzle.com/~aboba/RADEXT/radissues2.html#Issue 272> No overall
type in Extended Attributes

 <mailto:[email-masked]> Glen Zorn

Issue 278

Pending

Technical

 <http://www.drizzle.com/~aboba/RADEXT/radissues2.html#Issue 278> Comments

 <mailto:[email-masked]> Alan DeKok

Issue 279

No Discussion

Technical

 <http://www.drizzle.com/~aboba/RADEXT/radissues2.html#Issue 279> Comments

 <mailto:[email-masked]> Stefan Winter

> From: [email-masked]
> To: [email-masked]
> CC: [email-masked]
> Subject: RE: I-D Action:draft-ietf-radext-extended-attributes-05.txt 
> Date: Sun, 2 Nov 2008 17:21:26 -0800
>

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 3 Nov 2008 20:50:40 -0800

Glen Zorn said:

"I apparently "own" Issue 272 although it was you, I
believe, who brought it up initially."
 
Here is a link to your original post on the subject:
http://ops.ietf.org/lists/radiusext/2008/msg00458.html

Since you raised it, it was assigned to you. 

I withdraw it, since it's become
quite apparent that it's not really a problem at all (except, perhaps, for
those poor souls who actually try to _use_ Extended Attributes).  Oh, well…

Unless anyone raises an objection on the list, I'll mark Issue 272 as resolved. 

"It is
possible (likely?) that the owner will now respond, helping to delay
publication further (inadvertently, no doubt)."

Given the document's relatively modest size (13 pages) and scope,  if you can turn the remaining feedback around quickly, my expectation would be that it will take at most one more WG last call before the document is ready to go to IESG.   As a result, most of the remaining "delays" in publication are likely to come from the IESG, not from the WG.

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 3 Nov 2008 21:42:03 -0800

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Bernard Aboba
Sent: Monday, November 03, 2008 8:51 PM
To: Glen Zorn
Cc: [email-masked]
Subject: RE: Review Requested: draft-ietf-radext-extended-attributes-05.txt

Glen Zorn said:

"I apparently "own" Issue 272 although it was you, I believe, who brought it
up initially."

I withdraw it, since it's become quite apparent that it's not really a
problem at all (except, perhaps, for those poor souls who actually try to
_use_ Extended Attributes).  Oh, well.

Unless anyone raises an objection on the list, I'll mark Issue 272 as
resolved. 

Abandoned might be a better term.

"It is possible (likely?) that the owner will now respond, helping to delay
publication further (inadvertently, no doubt)."

Given the document's relatively modest size (13 pages) and scope,  if you
can turn the remaining feedback around quickly, my expectation would be that
it will take at most one more WG last call before the document is ready to
go to IESG.   As a result, most of the remaining "delays" in publication are
likely to come from the IESG, not from the WG.

---

From: Stefan Winter <[email-masked]>
Date: Tue, 04 Nov 2008 08:20:24 +0100

Hi,

> Just for the record, I made no such claim: I stated that the issues
> were resolved to my satisfaction.  Certain elements of one of the
> issues I disputed, but since the owner thereof hasn't bothered to
> respond to my comments in over a month, I unilaterally marked it as
> resolved.  It is possible (likely?) that the owner will now respond,
> helping to delay publication further (inadvertently, no doubt).
>

I hope you weren't thinking of me. Going through my list of comments,
the majority of items has been taken care of, with some exceptions.
Breakdown below:

- TLV encoding and M flag: not resolved. Discussion on the list resolved
in that we should make sure also morons are forced to split attributes
correctly (choice of words property of the original commenter). Proposed
text from Alan DeKok was: "The More Flag MUST NOT be set if the Length
is less than 255." I suggest to include that line.

- TLV encoding rules: not resolved. I suggest adding two words to the
sentence in question: "The next octet is the Ext-Len field, representing
the length of the entire TLV *in octets*, including ..."

- figure 3: resolved

- figure 4, other encodings possible: not resolved. I suggest adding
"Note that this encoding is only one out of several possibilities since
there is no strict order in attribute marshalling."

- figure 4, diagram: mostly resolved, one thing missed: Integer c of
value 0x12345678 is still depicted in the Value field as 0x12 0x34 0x78
0x56 (twist in the last two segments)

- nitbit in intro: resolved

- nitbit in first example: resolved

- security considerations: resolved

***
New issues with this -05 draft:
***

- figure 3: Ext-Type (cont) is listed as "(0x00" while it is actually
"(0x01)".

Greetings,

Stefan Winter
>
> we are requesting that individuals who filed those issues read the
> current document, and send email to the list indicating whether their
> issue is resolved.
>
> I apparently "own" Issue 272 although it was you, I believe, who
> brought it up initially.  I withdraw it, since it's become quite
> apparent that it's not really a problem at all (except, perhaps, for
> <http://www.drizzle.com/%7Eaboba/RADEXT/>
>  
> *Extended Attributes*
> *Issue Number*
> *Status*
> *Type*
> *Description*
> *Owner*
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20225>
>
> 	
>
> Alan DeKok <mailto:[email-masked]>
>
> Issue 250
>
> 	
>
> Pending
>
> 	
>
> Technical
>
> 	
>
> Comments
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20250>
>
> 	
>
> Greg Weber <mailto:[email-masked]>
>
> Issue 251
>
> 	
>
> Pending
>
> 	
>
> Technical
>
> 	
>
> Review
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20251>
>
> 	
>
> Bernard Aboba <mailto:[email-masked]>
>
> Issue 272
>
> 	
>
> Pending
>
> 	
>
> Technical
>
> 	
>
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20272>
>
> 	
>
> Glen Zorn <mailto:[email-masked]>
>
> Issue 278
>
> 	
>
> Pending
>
> 	
>
> Technical
>
> 	
>
> Comments
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20278>
>
> 	
>
> Alan DeKok <mailto:[email-masked]>
>
> Issue 279
>
> 	
>
> No Discussion
>
> 	
>
> Technical
>
> 	
>
> Comments
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20279>
>
> 	
>
> Stefan Winter <mailto:[email-masked]>
>
>  
>  

-- 
Stefan WINTER
Ingenieur de Recherche
Fondation RESTENA - Réseau Téléinformatique de l'Education Nationale et de la Recherche
6, rue Richard Coudenhove-Kalergi
L-1359 Luxembourg

Tel: +352 424409 1
Fax: +352 422473

---

From: "Greg Weber" <[email-masked]>
Date: Thu, 6 Nov 2008 17:57:36 -0500

I think Issue 250 can be closed.

Greg

On Mon, Nov 3, 2008 at 7:06 PM, Bernard Aboba <[email-masked]> wrote:
> have resolved open Issues from RADEXT WG last call, we are requesting that
> individuals who filed those issues read the current document, and send email
> to the list indicating whether their issue is resolved.
>
> Status Type Description Owner
> Issue 225 Pending Technical Review Alan DeKok
> Issue 250 Pending Technical Comments Greg Weber
> Issue 251 Pending Technical Review Bernard Aboba
> Issue 272 Pending Technical No overall type in Extended Attributes Glen Zorn
> Issue 278 Pending Technical Comments Alan DeKok
> Issue 279 No Discussion Technical Comments Stefan Winter
>
>