Subject: RADIUS over TCP Issues

From: Bernard Aboba <[email-masked]>
Date: Wed, 1 Apr 2009 13:11:25 -0700

The RADIUS Issues list shows the following unresolved comments on the RADIUS over TCP document.  Since many of these issues were first brought up by the Transport Area Director (Magnus Westerlund), we can assume that these comments need to be resolved prior to sending the document to the IESG.  Can the editor/submitters provide an updated status on these issues?

RADIUS over TCPIssue Number

    Status
    Type
    Description
    Owner
	
    Issue 291
    Pending
    Technical

	UDP/TCP Translation
    Alan 
	DeKok

    Issue 292
    Pending
    Technical

	Applicability
    Alan 
	DeKok

    Issue 293
    Pending
    Technical

	Watchdog Timer
    Alan 
	DeKok

    Issue 294
    No Discussion
    Technical

	Document Status
    Bernard 
	Aboba

    Issue 295
    Pending
    Technical

	Head of Line Blocking
    Alan 
	DeKok

---

From: Alan DeKok <[email-masked]>
Date: Thu, 02 Apr 2009 11:16:21 +0200

Bernard Aboba wrote:
> *RADIUS over TCP**Issue Number*
> 	*Status* 	*Type* 	*Description* 	*Owner*
> Issue 291 	Pending 	Technical 	UDP/TCP Translation
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20291>
> Alan DeKok <mailto:[email-masked]>

  Resolved.  Section 2.5 of the document discusses this.

> Issue 292 	Pending 	Technical 	Applicability
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20292>
> Alan DeKok <mailto:[email-masked]>

  Resolved.  Section 1.1 of the document contains the updated text.

> Issue 293 	Pending 	Technical 	Watchdog Timer
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20293>
> Alan DeKok <mailto:[email-masked]>

  Resolved.  Section 2.6.1 contains text about this issue.

> Issue 294 	No Discussion 	Technical 	Document Status
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20294>
> Bernard Aboba <mailto:[email-masked]>

  Resolved.  The document has been updated to be "experimental".
(Modulo one typo)

> Issue 295 	Pending 	Technical 	Head of Line Blocking
> <http://www.drizzle.com/%7Eaboba/RADEXT/radissues2.html#Issue%20295>
> Alan DeKok <mailto:[email-masked]>

  Resolved.  I've added some text to the document discussing this (see
below), and will issue a new revision shortly.

   When using UDP as a transport for RADIUS, there is no ordering of
   packets.  If a packet sent by a client is lost, that loss has no
   effect on subsequent packets sent by that client.

   Unlike UDP, TCP is subject to issues related to Head of Line (HoL)
   blocking.  This occurs when when a TCP segment is lost and a
   subsequent TCP segment arrives out of order.  While the RADIUS server
   can process RADIUS packets out of order, the semantics of TCP makes
   this impossible.  This limitation can lower the maximum packet
   processing rate of RADIUS over TCP.

  Alan DeKok.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/radiusext/>