Subject: [radext] WGLC #2 for draft-ietf-radext-ieee802ext-04

From: Jouni Korhonen <[email-masked]>
Date: Wed, 3 Apr 2013 10:41:50 +0300

Folks,

This email starts a quick one week WGLC #2 for "RADIUS Attributes for IEEE 802 Networks"
I-D (draft-ietf-radext-ieee802ext-04). The WGLC ends 10-Apr-2013. Send your comments to
the mailer and please also use the IssueTracker. No comments would this time also imply
that everybody agrees with the content.

- Jouni & Mauricio

---

From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 4 Apr 2013 19:55:13 +0000

There may be a couple of minor, mostly editorial issues in draft-ietf-radext-ieee802ext-04:

-	2.9. WLAN-SSID
The usage statement is missing.
>> add 'A single WLAN-SSID Attribute is permitted within an Access-Accept or Accounting-Request packet.'

-	2.10. WLAN-HESSID
The usage statement is missing.
>> add 'A single WLAN-HESSID Attribute is permitted within an Access-Accept or Accounting-Request packet.'
In line 763 the term 'subscription service provider network (SSPN)' is used without any indication, that the term has special meaning in IEEE 802.11
>> adding 'as described in [IEEE-802.11].' may provide more clarity. 

-	2.11. WLAN-Venue-Info
WLAN Venue Group and Venue Type is defined without binding dashes in IEEE 802.11, however shown as Venue-Group and Venue-Type in the radext-ieee802ext specification. Furthermore the Length of this attribute is 6 bytes instead of 4 as written.
>> correct Length to '6'
>> use 'Venue Group' and 'Venue Type' instead of 'Venue-Group' and 'Venue-Type', respectively.
>> probably it would be better to make direct reference to clause 8.4.1.34 of [IEEE-802.11] instead of re-specifying the attribute elements in radext-ieee802ext

-	2.12. WLAN-Venue-Language
The attribute may appear in Accounting-Request messages as well
>>add 'or Accounting-Request'

-	2.13. WLAN-Venue-Name
The attribute may appear in Accounting-Request messages as well
>>add 'or Accounting-Request'

-	2.14. WLAN-Reason-Code
The length of this attribute is 6 bytes instead of 4 bytes as written
The usage statement is missing.
>> add 'A single WLAN-Reason-Code Attribute is permitted within a RADIUS Access-Reject or Accounting-Request packet.'
>> correct Length to '6'

-	2.15. WLAN-Pairwise-Cipher
The length of this attribute is 6 bytes instead of 4 bytes as written
>> correct Length to '6'

-	2.16. WLAN-Group-Cipher
The length of this attribute is 6 bytes instead of 4 bytes as written
>> correct Length to '6'

-	2.17. WLAN-AKM-Suite
The length of this attribute is 6 bytes instead of 4 bytes as written
>> correct Length to '6'

-	2.18. WLAN-Group-Mgmt-Cipher
The length of this attribute is 6 bytes instead of 4 bytes as written
>> correct Length to '6'

-	2.19. WLAN-RF-Band
IEEE 802.11ad-2012 is meanwhile available. Therefore the note in lines 1185-1191 can be removed with insertion of the proper reference to IEEE 802.11ad-2012.
Furthermore the value field should be directly adopted from Table 8-53a of IEEE 802.11ad-2012 instead of defining specific values in the radext-ieee802ext specification. Please take into account that the Table 8-53a defines single octet values, while a 4 octets field is defined for this attribute.
How are access points handled supporting multiple bands? Shouldn't the attribute be allowed multiple times within an Access Request message?

-	3. Table of attributes
The definition of WLAN-Venue-Language and WLAN-Venue-Name allows multiple entries within an Access-Request or Accounting-Request message. The table states that zero or one are present is the Access-Request or Accounting-Request message

Bye
Max

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Jouni Korhonen
Sent: Wednesday, April 03, 2013 09:42
To: [email-masked]
Cc: [email-masked]
Subject: [radext] WGLC #2 for draft-ietf-radext-ieee802ext-04

Folks,

- Jouni & Mauricio
_______________________________________________
radext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/radext

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 12 Apr 2013 10:02:54 +0300

Folks,

The WGLC has completed successfully for this I-D. The next step will be
the Proto Write-Up within approximately one week. 

- Jouni & Mauricio

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 17 Apr 2013 09:01:53 -0700

Thank you, Max for this thorough review.  I have submitted an -05 which (partially) addresses these comments. 
However, given that the draft now references IEEE 802.11 for allocation of a number of the attribute values, the IANA considerations section will need to be rewritten.  This will be addressed in an -06 revision. 

> From: [email-masked]
> To: [email-masked]; [email-masked]
> Date: Thu, 4 Apr 2013 19:55:13 +0000
> CC: [email-masked]
> Subject: Re: [radext] WGLC #2 for draft-ietf-radext-ieee802ext-04
>