Subject: [radext] LoRaWAN Authentication in RADIUS

From: Dan García Carrillo <[email-masked]>
Date: Mon, 30 May 2016 23:41:33 +0200

Dear all,

We have uploaded a draft to show an initiative towards the integration of AAA infrastructures into LP-WAN. This document show an example of how the LoRaWAN join procedure can be used with RADIUS.

Comments are welcome. 

https://datatracker.ietf.org/doc/draft-garcia-radext-radius-lorawan/

Best Regards,
Dan.

---

From: Alan DeKok <[email-masked]>
Date: Tue, 31 May 2016 09:45:00 -0400

> https://datatracker.ietf.org/doc/draft-garcia-radext-radius-lorawan/

  My $0.02:

- Section 5 can probably be deleted.  We've worked through RADIUS to Diameter issues  Diameter just transports RADIUS attributes as-is

- Section 7 could talk about the security implications of sending keys over RADIUS

- Section 8 is wrong.  The document needs two RADIUS attributes, which means that there are actions for IANA.

- section 4 contains zero information about the contents of the attributes.

  I would suggest describing the contents in detail, and referencing the "data types" document for any format.  i.e. don't put in ASCII art.

- the reference to LoRaWAN is the URL of a marketing page.  This is not useful.  The reference should be to a technical specification.

  In short, the document describes an idea.  It doesn't contain any real technical content.

  Alan DeKok.

---

From: Dan García Carrillo <[email-masked]>
Date: Tue, 31 May 2016 18:19:53 +0200

> El 31 may 2016, a las 15:45, Alan DeKok <[email-masked]> escribió:
> 
Dear Alan, 

Thank you for taking the time to review the I-D, your comments are very valuable indeed and we will provide a more precise version based on your comments. Please see comments inline. 

> - Section 5 can probably be deleted.  We've worked through RADIUS to Diameter issues  Diameter just transports RADIUS attributes as-is

This is good to know, thank you.

> - Section 7 could talk about the security implications of sending keys over RADIUS
For sure, a consideration of how the key distribution is managed would be indeed both interesting and necessary. 

> - Section 8 is wrong.  The document needs two RADIUS attributes, which means that there are actions for IANA.
You are right, that is a mistake. 

>  I would suggest describing the contents in detail, and referencing the "data types" document for any format.  i.e. don't put in ASCII art.
As you well say, a better introduction about the parameters and the details of the exchange is needed. 

> - the reference to LoRaWAN is the URL of a marketing page.  This is not useful.  The reference should be to a technical specification.
Thank you for pointing that out.

Best Regards,
Dan.
> _______________________________________________
> radext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/radext