Subject: Re: [radext] Suresh Krishnan's No Objection on draft-ietf-radext-ip-port-radius-ext-11: (with COMMENT)

From: <[email-masked]>
Date: Wed, 5 Oct 2016 13:58:55 +0000

Hi Suresh, 

Thank you for the review. 

Please see inline for more details.

Cheers,
Med

> -----Message d'origine-----
> De : Suresh Krishnan [mailto:[email-masked]]
> Envoyé : jeudi 18 août 2016 05:54
> À : The IESG
> Cc : [email-masked]; [email-masked];
> [email-masked]; MORAND Lionel IMT/OLN; [email-masked]
> Objet : Suresh Krishnan's No Objection on draft-ietf-radext-ip-port-
> radius-ext-11: (with COMMENT)
> 
> Suresh Krishnan has entered the following ballot position for
> draft-ietf-radext-ip-port-radius-ext-11: No Objection
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> 
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-radext-ip-port-radius-ext/
> 
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> * Why are the the uint8 and unit16 based types getting stuffed into 32
> bit fields inside the TLVs? This feels like a complete waste. Is there
> any specific reason this is required?

[Med] Added this new text: 

The attribute is encoded in 32
   bits as per the recommendation in Appendix A.2.1 of [RFC6158].

> 
> * Does the IP-Port-Limit include the count of ports already allocated
> through the IP-Port-Forwarding-Map or not?

[Med] Added this clarification:

         This limit applies to all
         mappings that can be instantiated by an underlying address
         sharing device without soliciting any external entity.  In
         particular, this limit does not include the ports that are
         instructed by an AAA server.

A new revision integrating your comments is available online. FWIW, a diff to track the changes: https://www.ietf.org/rfcdiff?url1=draft-ietf-radext-ip-port-radius-ext-12&url2=draft-ietf-radext-ip-port-radius-ext-13   

> 
> * I agree with Alissa's DISCUSS points about the lack of error handling
> and the privacy issues and Mirja's DISCUSS point about restricting
> transport protocols to TCP and UDP.

[Med] Those are discussed in other threads.

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 5 Oct 2016 21:15:50 +0000

> Thank you for the review.

Thanks for addressing my comments Med. Your changes look good to me.

Regards
Suresh