Subject: Re: [radext] Alissa Cooper's Discuss on draft-ietf-radext-ip-port-radius-ext-11: (with DISCUSS and COMMENT)

From: <[email-masked]>
Date: Fri, 14 Oct 2016 15:16:13 +0000

Hi Alan,

Can you elaborate a little bit?
What do you call 'appropriate parent TLV'?

If a registry is defined to track allocated value for sub-TLV, how to avoid collision if "All other TLV parents are free to specify whatever sub-TLVs they want".

Regards,

Lionel

> -----Message d'origine-----
> De : Alan DeKok [mailto:[email-masked]]
> Envoyé : mardi 13 septembre 2016 15:40
> À : MORAND Lionel IMT/OLN
> Cc : [email-masked]; Alissa Cooper; draft-ietf-radext-ip-port-
> [email-masked]; [email-masked]; IESG; [email-masked]
> Objet : Re: [radext] Alissa Cooper's Discuss on draft-ietf-radext-ip-port-radius-
> ext-11: (with DISCUSS and COMMENT)
> 
> 
> > On Sep 13, 2016, at 9:23 AM, <[email-masked]>
> <[email-masked]> wrote:
> > If such a registry is defined by the WG and managed by the IANA, to ensure
> that a newly-defined sub-TLV can be reused in any parent TLV,
> 
>   No.  Those sub-TLVs can only be re-used in *appropriate* parent TLVs.  The
> parents need to specify that they are using the common registry.  All other TLV
> parents are free to specify whatever sub-TLVs they want.
> 
>   Alan DeKok.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Alan DeKok <[email-masked]>
Date: Fri, 14 Oct 2016 11:42:52 -0400

> On Oct 14, 2016, at 11:16 AM, <[email-masked]> <[email-masked]> wrote:

  The idea is that if you have a TLV, it can:

a) define it's own sub-TLVs

b) use a pre-defined registry for sub-TLVs.

  That's it.

  If a TLV is defined to use option (a), there's no conflict with other TLVs.  It's sub-TLVs are completely independent of all other sub-TLVs.  And it *cannot* use TLVs from a registry.

  If a TLV is defined to use option (b), then it *cannot* define it's own sub-TLVs.  It MUST use the registry.  Which means re-using sub-TLVs from the registry.  Because that's what registries are for.

  sub-TLVs defined in a registry can't conflict with other sub-TLVs, because each TLV space is entirely independent... unless you define them to overlap.

> If a registry is defined to track allocated value for sub-TLV, how to avoid collision if "All other TLV parents are free to specify whatever sub-TLVs they want".

  That question is based on assumptions I don't understand.  As such, it can't really be answered other than with "it doesn't work like that".

  If we have a registry, fine.  Use it.  If we don't have a registry, then attributes not using the registry... don't use the registry.  And there's no conflict.  Because they're not using the registry.

  There is no more conflict here than with Service-Type and Framed-Protocol.  Both are "integer" attributes.  Both define a registry.  But adding an entry to Service-Type doesn't mean that that number is now also defined for Framed-Protocol, much less have any special meaning for any other "integer" attribute.

  Perhaps you could explain why you think there would be any conflict between sub-TLVs?  

  Alan DeKok.

---

From: Kathleen Moriarty <[email-masked]>
Date: Fri, 14 Oct 2016 13:54:18 -0400

On Fri, Oct 14, 2016 at 11:42 AM, Alan DeKok <[email-masked]>
wrote:

>   If a TLV is defined to use option (a), there's no conflict with other
> TLVs.  It's sub-TLVs are completely independent of all other sub-TLVs.  And
> it *cannot* use TLVs from a registry.
>
>   If a TLV is defined to use option (b), then it *cannot* define it's own
> sub-TLVs.  It MUST use the registry.  Which means re-using sub-TLVs from
> the registry.  Because that's what registries are for.
>
>   sub-TLVs defined in a registry can't conflict with other sub-TLVs,
> because each TLV space is entirely independent... unless you define them to
> overlap.
>
> > If a registry is defined to track allocated value for sub-TLV, how to
> avoid collision if "All other TLV parents are free to specify whatever
> sub-TLVs they want".
>
>   That question is based on assumptions I don't understand.  As such, it
> can't really be answered other than with "it doesn't work like that".
>
>   If we have a registry, fine.  Use it.  If we don't have a registry, then
> attributes not using the registry... don't use the registry.  And there's
> no conflict.  Because they're not using the registry.
>
>   There is no more conflict here than with Service-Type and
> Framed-Protocol.  Both are "integer" attributes.  Both define a registry.
> But adding an entry to Service-Type doesn't mean that that number is now
> also defined for Framed-Protocol, much less have any special meaning for
> any other "integer" attribute.
>

It seems the WG is just down to a preference question as I don't see how
there would be conflicts except if different parties defined their own
sub-TLVs and they didn't match.  Could that occur?  I have to dig deeper to
make sure I'm not missing anything.

For the future, you can ask IANA these sorts of questions via email or at
meetings to work through preferences if you are looking for their opinion.
I should have caught that this was an issue and am not sure why I didn't
before putting it on a telechat.  So, that was my fault.

Thank you.

-- 

Best regards,
Kathleen

---

From: Alan DeKok <[email-masked]>
Date: Fri, 14 Oct 2016 14:02:13 -0400

On Oct 14, 2016, at 1:54 PM, Kathleen Moriarty <[email-masked]> wrote:
> It seems the WG is just down to a preference question as I don't see how there would be conflicts except if different parties defined their own sub-TLVs and they didn't match.  Could that occur?  I have to dig deeper to make sure I'm not missing anything.

  If all TLV allocations go through IANA, then the registration procedure should prevent conflict.

  If the IANA registration procedure is well documented, then that procedure should prevent conflict.

  I don't see a big difference between allowing TLVs to be of data type "integer", "ipv4 address", "sub-TLVs are OK", or "contents to be defined by sub-TLV registry FOO".

  There is simply no way to have any kind of conflict in the allocation.

> For the future, you can ask IANA these sorts of questions via email or at meetings to work through preferences if you are looking for their opinion.  I should have caught that this was an issue and am not sure why I didn't before putting it on a telechat.  So, that was my fault.

  I'm not sure IANA would have an opinion here.

  Alan DeKok.

---

From: Kathleen Moriarty <[email-masked]>
Date: Fri, 14 Oct 2016 15:08:59 -0400

On Fri, Oct 14, 2016 at 2:02 PM, Alan DeKok <[email-masked]>
wrote:

>   I don't see a big difference between allowing TLVs to be of data type
> "integer", "ipv4 address", "sub-TLVs are OK", or "contents to be defined by
> sub-TLV registry FOO".
>
> > For the future, you can ask IANA these sorts of questions via email or
> at meetings to work through preferences if you are looking for their
> opinion.  I should have caught that this was an issue and am not sure why I
> didn't before putting it on a telechat.  So, that was my fault.
>

OK, so in that case I may be the tie breaker as AD,  I'll just read through
everything again and respond, unless the WG participants start to show a
strong preference.

-- 

Best regards,
Kathleen

---

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 17 Oct 2016 13:07:48 -0400

Hello,

I read through the threads again.  There was not much on list discussion of
this point, so I had to rely on what I had for information and I also
received some private messages.  With this, I am leaning towards Alan's
suggestion.  Unless WG members disagree (you are really the ones to make
this decision, I was just asked to be a tie breaker), let's go ahead with
that change in the draft after a 2 day waiting period before the updated
draft is posted.  I am not expecting any or much more discussion on this
based on emails to date.

Thank you,
Kathleen

On Fri, Oct 14, 2016 at 3:08 PM, Kathleen Moriarty <
[email-masked]> wrote:

>> > It seems the WG is just down to a preference question as I don't see
>> how there would be conflicts except if different parties defined their own
> OK, so in that case I may be the tie breaker as AD,  I'll just read
> through everything again and respond, unless the WG participants start to
> show a strong preference.
>
>
>>
>>   Alan DeKok.
>>
>>
>
>
> --
>
> Best regards,
> Kathleen
>

-- 

Best regards,
Kathleen