Subject: (radius) Framed IP-Address Attibute

From: "ji choel park" <[email-masked]>
Date: Tue, 08 Dec 1998 14:37:25 +0900

I have a few questions on Framed IP-Address Attribute in RADIUS.

In  section 5.8 in rfc2138, there's description on Address field.

"The value 0xFFFFFFFF indicattes that the NAS should allow the user to select an address (e.g. Negotiated).  The value 0xFFFFFE indicates that the NAS should select an address for the user (e.g. Assigned from a pool of addresses kept by the NAS).  Other valid values indicate that the NAS should use that value as the user's IP address"

If the value of the Address field is 0xFFFFFF, could the NAS allow the user to be assigned the address request by the user?  For example, the user is a Mobile Host of Mobile IP, and it requests its Home Address to the NAS.  If so, can the NAS assign the requested Home Address to the Mobile Node?

Can the Frame-IP-Address Attribute be included in the Access-Accept packet, only when the previous Access-Request packet include the Attribute?  If not, what is the reason?

As more basical question, why is the Framed-IP-Address Attribute needed in RADIUS?

Regards,

Jicheol Park
Shinsegi Telecomm, Inc. Korea

-
To unsubscribe, email [email-masked]' with
'unsubscribe ietf-radius' in the body of the message.

---

From: "Russell J. LeBar" <[email-masked]>
Date: Tue, 8 Dec 1998 10:23:32 -0600

If I am not mistaken, one example would be if a user has paid for a static
IP Address.

-----Original Message-----
From: ji choel park <[email-masked]>

-

---

From: Koral Ilgun <[email-masked]>
Date: Tue, 08 Dec 1998 14:53:24 -0800

Or if the RADIUS server is doing IP address assignments from a defined
IP address pool.  Steel-Belted-Radius does this for instance.

Koral

-