Subject: Re: (radius) documents wedge over track confusion

From: Patrice Calhoun <[email-masked]>
Date: Tue, 21 Dec 1999 06:59:06 -0800

I really find this thread quite amusing. Nothing in the protocol even allows
for one to identify packet loss, so how can you get ANY guarantees that
you even KNOW what you've lost? Be it 0.00001 or 10%!

PatC
>>>> Phrased differently, billing is a statistical method of recouping costs.
>>>> Statistical errors in the data can be adequately corrected in the math.
>>> i anticipate a bit of a problem explaining this to the lawyers and
>>> accountants at the isp for which i work.
>> I think his point is that one of your routine business expences is .00001%
>> revenue loss from lost accounting packets, which is added into the
>> overhead and accounted for in the rate you quote customers. 
>
>and my point was how do i explain to the lawyers and accountants that they
>can have confidence that number is .00001% as opposed to 1%.
>
>randy
>-
>To unsubscribe, email [email-masked]' with
>'unsubscribe ietf-radius' in the body of the message.

-
To unsubscribe, email [email-masked]' with
'unsubscribe ietf-radius' in the body of the message.

---

From: Randy Bush <[email-masked]>
Date: Tue, 21 Dec 1999 07:22:43 -0800

> I really find this thread quite amusing. Nothing in the protocol even
> allows for one to identify packet loss, so how can you get ANY guarantees
> that you even KNOW what you've lost? Be it 0.00001 or 10%!

bingo!

well, we know it can't be over 100% :-)

randy
-

---

From: "Steven P. Crain" <[email-masked]>
Date: Tue, 21 Dec 1999 11:45:02 -0500 (EST)

> you even KNOW what you've lost? Be it 0.00001 or 10%!

[Misc note: the .00001 %  was revenue loss, based on the specifics of
how my company's revenue streams work out in practice.]

You can't tell how much packet loss you have had strictly by using radius,
of course.  However, you can get a very good idea by careful analysis and
comparison of other data sources.  I have made comparisons using:

	* snmp based data
	* information from the various NAS consoles
	* syslog-based NAS logs
	* check of radius accounting logs for internal consistency
(e.g. Stop packets with no corresponding Start or vice-versa)

One could also use phone company records, logs from the RADIUS server,
etc.

Its harder to tell on an ongoing basis, but a quick check now and then
should reveal any problems.

-- 
Steven P. Crain, Development
http://www.shore.net/~scrain
Shore.Net: Local Ties... World Class Connections

Like a bird that strays from its nest is a man who strays from his home.

-