Subject: Re: (radius) Re: Comments on Tunnel Draft

From: Ignacio Goyret <[email-masked]>
Date: Fri, 10 Dec 1999 11:40:15 -0800

At 11:38 AM 12/10/99 -0500, Ran Atkinson wrote:
>
>Based on Darran's note, I'd suggest:
>	- Formally deprecate Tunnel-Password with text explaining
>	  how it means that one gets ZERO effective security,
>	  but keep it documented.  Actually recommend that folks
>	  either not implement it or provide a configuration knob
>	  to disable it.
>
>This means existing users aren't completely hosed and that we've
>done our part to make it clear that the usage is insecure as heck
>and should go away in future.
>
>Ran
>[email-masked]

On the same tone, I presume you are also planning to "deprecate" the
Password attribute. After all, it is just as insecure.

There are lots of implementations depending on that attribute. If you
remove that attribute, you will force the creation of proprietary,
non-interoperable solutions to a problem that has already been solved.
Many, many customers are going to be quite upset.

If you like, add a "Security considerations" section with all the warnings
you want, but don't remove a very useful attribute unless you propose a
good alternative.

-Ignacio

----------
"When the only tool you have is a hammer, all the problems look like nails."

-
To unsubscribe, email [email-masked]' with
'unsubscribe ietf-radius' in the body of the message.

---

From: Ran Atkinson <[email-masked]>
Date: Fri, 10 Dec 1999 15:10:35 -0500

Ignacio,

	Please go back and actually READ what I wrote.
You reply made it crystal clear you were having trouble 
reading what I actually wrote.

Thank you very much,

Ran

-