Subject: [RAI] I-D's of former Sipping/Sip WG's

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 17 Jul 2009 21:58:42 -0400

Howdy,
I have a question with the mechanics of the closing of the SIPPING/SIP WG's and mailing lists, with regards to Individual Drafts (I-D's).  Some of us have I-D's we submitted to the previous WG's before the transition, which we'd like to update.  For example a fictitious I-D like draft-smith-spipping-good-idea-05.  If Mr. Smith updates them to the appropriate new WG's using the new WG names and new number space (.e.g, draft-smith-dispatch-good-idea-00), won't he lose the automatic links in the tools HTML view of the previous drafts?  

That linking was a rather nice feature, both because it allowed one to create a fixed HTTP URL which one could give others which would auto-update to the latest rev, and because it allowed one to view diffs and such easily.  So now Mr. Smith would have to change the URL he'd been giving folks for some time, and it would lose the history.

Is there a way to avoid this? (and no, I'm not asking to port all I-D's from the closed groups)

If this is a major pain in the #$%*&, like it requires tools changes, then forget it.  Just more wondering if something already exists which lets me^H^H Mr.Smith submit a revved draft without the break.

-hadriel

---

From: Dan York <[email-masked]>
Date: Fri, 17 Jul 2009 22:06:53 -0400

Hadriel,

It's a good question. (I'm in the same situation with http://tools.ietf.org/html/draft-york-sipping-p-charge-info 
  )

Or do we just continue to use "sipping" even though that WG is no  
longer there?

Dan

On Jul 17, 2009, at 9:58 PM, Hadriel Kaplan wrote:

> Howdy,
> I have a question with the mechanics of the closing of the SIPPING/ 
> SIP WG's and mailing lists, with regards to Individual Drafts (I- 
> D's).  Some of us have I-D's we submitted to the previous WG's  
> before the transition, which we'd like to update.  For example a  
> fictitious I-D like draft-smith-spipping-good-idea-05.  If Mr. Smith  
> updates them to the appropriate new WG's using the new WG names and  
> new number space (.e.g, draft-smith-dispatch-good-idea-00), won't he  
> lose the automatic links in the tools HTML view of the previous  
> drafts?
>
> That linking was a rather nice feature, both because it allowed one  
> to create a fixed HTTP URL which one could give others which would  
> auto-update to the latest rev, and because it allowed one to view  
> diffs and such easily.  So now Mr. Smith would have to change the  
> URL he'd been giving folks for some time, and it would lose the  
> history.
>
> If this is a major pain in the #$%*&, like it requires tools  
> changes, then forget it.  Just more wondering if something already  
> exists which lets me^H^H Mr.Smith submit a revved draft without the  
> break.
>
> -hadriel
> _______________________________________________
> RAI mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rai

-- 
Dan York, Director of Conversations
Voxeo Corporation   http://www.voxeo.com  [email-masked]
Phone: +1-407-455-5859    Skype: danyork

Join the Voxeo conversation:
Blogs: http://blogs.voxeo.com
Twitter: http://twitter.com/voxeo  http://twitter.com/danyork
Facebook: http://www.facebook.com/voxeo

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 17 Jul 2009 23:10:26 -0500

well ... there's nothing magic about the names of individual drafts, so 
continuing to use "sipping" would confuse a few people, but everything would 
just work.

"draft-ietf" draft names (working group drafts) ARE magic (with automatic 
verification of 00 versions, etc), but that's not your situation.

spencer, who wishes SIP and SIPPING were still open because some tools 
stopped working when they were closed :-(

----- Original Message ----- 
From: "Dan York" <[email-masked]>
To: "Hadriel Kaplan" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, July 17, 2009 9:06 PM
Subject: Re: [RAI] I-D's of former Sipping/Sip WG's

> Hadriel,
>
> It's a good question. (I'm in the same situation with 
> http://tools.ietf.org/html/draft-york-sipping-p-charge-info )
>
> Or do we just continue to use "sipping" even though that WG is no  longer 
> there?
>
> Dan
>
>> I have a question with the mechanics of the closing of the SIPPING/ SIP 
>> WG's and mailing lists, with regards to Individual Drafts (I- D's).  Some 
>> of us have I-D's we submitted to the previous WG's  before the 
>> transition, which we'd like to update.  For example a  fictitious I-D 
>> like draft-smith-spipping-good-idea-05.  If Mr. Smith  updates them to 
>> the appropriate new WG's using the new WG names and  new number space 
>> (.e.g, draft-smith-dispatch-good-idea-00), won't he  lose the automatic 
>> links in the tools HTML view of the previous  drafts?
>>
>> That linking was a rather nice feature, both because it allowed one  to 
>> create a fixed HTTP URL which one could give others which would 
>> auto-update to the latest rev, and because it allowed one to view  diffs 
>> and such easily.  So now Mr. Smith would have to change the  URL he'd 
>> been giving folks for some time, and it would lose the  history.
>>
>> Is there a way to avoid this? (and no, I'm not asking to port all I- D's 
>> from the closed groups)
>>
>> If this is a major pain in the #$%*&, like it requires tools  changes, 
>> then forget it.  Just more wondering if something already  exists which 
>> lets me^H^H Mr.Smith submit a revved draft without the  break.
>>
>> -hadriel

---

From: "James M. Polk" <[email-masked]>
Date: Sat, 18 Jul 2009 02:09:23 -0500

At 11:10 PM 7/17/2009, Spencer Dawkins wrote:
>well ... there's nothing magic about the names of individual drafts, 
>so continuing to use "sipping" would confuse a few people, but 
>everything would just work.
>
>"draft-ietf" draft names (working group drafts) ARE magic (with 
>automatic verification of 00 versions, etc), but that's not your situation.

well, then let's take this to a real example, with SIP Location Conveyance.

This was a SIP WG item, with the last being rev-13.

This doc moved directly to the SIPCORE WG, as SIPCORE Location 
Conveyance, and appeared to the casual observer as if this was the 
very first WG version in any WG.

Thus providing an example of how the -00 through -13 versions in SIP 
are now not linked to the SIPCORE versions -00 and -01.

BTW - the same thing happened when this moved from being a SIPPING WG 
item into the SIP WG (i.e., all past WG versions lost their links to 
the previous WG).

I agree with Hadriel - it would be nice to maintain continuity 
through the life of an ID that has been accepted by a WG, then moved 
to a new WG based upon IETF process.

If that link can't be done, or its too much of a hassle, that's ok, 
but it would be nice to know that's the case.

James

>spencer, who wishes SIP and SIPPING were still open because some 
>tools stopped working when they were closed :-(
>
>----- Original Message ----- From: "Dan York" <[email-masked]>
>>Or do we just continue to use "sipping" even though that WG is 
>>no  longer there?
>>
>>Dan
>>
>>>I have a question with the mechanics of the closing of the 
>>>SIPPING/ SIP WG's and mailing lists, with regards to Individual 
>>>Drafts (I- D's).  Some of us have I-D's we submitted to the 
>>>previous WG's  before the transition, which we'd like to 
>>>update.  For example a  fictitious I-D like 
>>>draft-smith-spipping-good-idea-05.  If Mr. Smith  updates them to 
>>>the appropriate new WG's using the new WG names and  new number 
>>>space (.e.g, draft-smith-dispatch-good-idea-00), won't he  lose 
>>>the automatic links in the tools HTML view of the previous  drafts?
>>>
>>>That linking was a rather nice feature, both because it allowed 
>>>one  to create a fixed HTTP URL which one could give others which 
>>>would auto-update to the latest rev, and because it allowed one to 
>>>view  diffs and such easily.  So now Mr. Smith would have to 
>>>change the  URL he'd been giving folks for some time, and it would 
>>>lose the  history.
>>>
>>>Is there a way to avoid this? (and no, I'm not asking to port all 
>>>I- D's from the closed groups)
>>>
>>>If this is a major pain in the #$%*&, like it requires 
>>>tools  changes, then forget it.  Just more wondering if something 
>>>already  exists which lets me^H^H Mr.Smith submit a revved draft 
>>>without the  break.
>>>
>>>-hadriel

---

From: Adam Roach <[email-masked]>
Date: Sat, 18 Jul 2009 05:05:14 -0500

> are now not linked to the SIPCORE versions -00 and -01.

The tools actually do allow for this. For example, if you look at 
<http://tools.ietf.org/html/draft-ietf-sipcore-subnot-etags>, you'll see 
that it links back to the draft-ietf-sip version in the "Versions" line.

Unfortunately, this linking is a manual process, and some drafts slip 
between the cracks. In this particular case, I dropped the ball, and I 
apologize. I will send an email to the drafts administrator to correct 
this problem momentarily.

/a

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 20 Jul 2009 19:18:32 +0200

If you notice, it does pick up some transitions, e.g. if draft-smith-sipping... became draft-ietf-sipping... 

I believe this is based on the information in the draft tracker database, which is administered by the IESG secretary, and this information is manually input by them.

regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Hadriel Kaplan
> Sent: Saturday, July 18, 2009 2:59 AM
> To: [email-masked]
> Subject: [RAI] I-D's of former Sipping/Sip WG's
> 
> Howdy,
> SIPPING/SIP WG's and mailing lists, with regards to 
> Individual Drafts (I-D's).  Some of us have I-D's we 
> submitted to the previous WG's before the transition, which 
> we'd like to update.  For example a fictitious I-D like 
> draft-smith-spipping-good-idea-05.  If Mr. Smith updates them 
> to the appropriate new WG's using the new WG names and new 
> number space (.e.g, draft-smith-dispatch-good-idea-00), won't 
> he lose the automatic links in the tools HTML view of the 
> previous drafts?  
> 
> That linking was a rather nice feature, both because it 
> allowed one to create a fixed HTTP URL which one could give 
> others which would auto-update to the latest rev, and because 
> it allowed one to view diffs and such easily.  So now Mr. 
> Smith would have to change the URL he'd been giving folks for 
> some time, and it would lose the history.
> 
> changes, then forget it.  Just more wondering if something 
> already exists which lets me^H^H Mr.Smith submit a revved 
> draft without the break.
> 
> -hadriel

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 20 Jul 2009 14:00:36 -0500

At 05:05 AM 7/18/2009, Adam Roach wrote:
>>Thus providing an example of how the -00 through -13 versions in 
>>SIP are now not linked to the SIPCORE versions -00 and -01.
>
>The tools actually do allow for this.

It hasn't been done for any draft I've ever looked at, but you look 
at more than I do, so I guess I never noticed this possibility.

That's awesome that this is doable - and don't worry about missing 
this, it's important that it happens.

Thanks Adam

James

>For example, if you look at 
><http://tools.ietf.org/html/draft-ietf-sipcore-subnot-etags>, you'll 
>see that it links back to the draft-ietf-sip version in the "Versions" line.
>
>Unfortunately, this linking is a manual process, and some drafts 
>slip between the cracks. In this particular case, I dropped the 
>ball, and I apologize. I will send an email to the drafts 
>administrator to correct this problem momentarily.
>
>/a

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 21 Jul 2009 21:38:09 -0700

If someone wants to form a list of the new draft names, and the old  
draft names i.e.

>> draft-smith-dispatch-good-idea-00 replaces draft-smith-spipping- 
>> good-idea-05

I can try to get that information added to the idtracker but I would  
rather do it in a batch of a bunch of drafts at once and not deal with  
each draft one at a time.

On Jul 20, 2009, at 10:18 , DRAGE, Keith (Keith) wrote:

> I believe this is based on the information in the draft tracker  
> database, which is administered by the IESG secretary, and this  
> information is manually input by them.
>
> regards
>
> Keith
>