Subject: RE: PIB Incarnation [sic]

From: "Da Silva, Pedro" <[email-masked]>
Date: Thu, 22 Nov 2001 11:49:27 -0000

Multiple PDPs may manage a PEP but not concurrently. The PEP can only make
requests to one and only one PDP at a given time.
There is also the scenario where the PEP has a local PDP. In this case, you
may actually have two entities concurrently providing decisions to the PEP.
Note that the PEP must relay all local decisions to the remote PDP, as it is
*the authoritative source* of decisions (LPDPDecision).

cheers,
Pedro

-----Original Message-----
From: Abdul Malick [mailto:[email-masked]]
Sent: Thursday, November 22, 2001 4:00 AM
To: Da Silva, Pedro; IETF RAP WG
Subject: RE: PIB Incarnation [sic]

Hello Pedro,

But can multiple PDPs manage a PEP at the same time?
Also to make a particular incarnation active, i think the PDP only has to
make the decision. In this case how is the activation of incarnations
co-ordinated among different PDPs given the fact that only one incarnation
can be active at the same time.

Regards,
Malick

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Da Silva, Pedro
Sent: Wednesday, 21 November 2001 8:15 PM
To: IETF RAP WG
Subject: RE: PIB Incarnation [sic]

Krishna,

The frwkPibIncarnationName identifies the PDP that provided the PIB instance
refered to by the frwkPibIncarnationId. It can be say 'Primary Manager', or
'Manager X' and/or an ip address or whatever, in your system, *uniquely*
identifies each PDP.
It is the responsibility of the PDP to populate the entry, it's effectively
part of the decision.

IHTH,
Pedro

-----Original Message-----
From: Krishna Prasad Akkineni [mailto:[email-masked]]
Sent: Wednesday, November 21, 2001 10:29 AM
To: IETF RAP WG
Subject: PIB Incarnation

Hi,
   This is a query with reference to ID on framework PIB.
>From the document, I could not understand how PDP & PEP
exchange PIB incarnation table details.

Specifically, What can be the name of "frwkPibIncarnationName"
attribute. Is it the responsibility of PDP to fill this
attribute?

For your reference, structure of  FrwkPibIncarnationEntry
is given below.

  FrwkPibIncarnationEntry ::= SEQUENCE

           frwkPibIncarnationPrid                InstanceId,
           frwkPibIncarnationName                SnmpAdminString,
           frwkPibIncarnationId                  OCTET STRING,
           frwkPibIncarnationLongevity           Unsigned32,
           frwkPibIncarnationTtl                 Unsigned32,
           frwkPibIncarnationActive              TruthValue
   }

Thanks & Regards
Krishna

---

From: "Abdul Malick" <[email-masked]>
Date: Thu, 22 Nov 2001 18:13:58 +0530

Is it then right to say that a PDP can manage more than one Incarnation and
when a PEP contact a PDP for provisioning the PDP can set the required
incarnation (among those it manages) as active and automatically the
incarnations created by other PDPs as well as other incarnations created by
this PDP will become inactive.

Malick

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Da Silva, Pedro
Sent: Thursday, 22 November 2001 5:19 PM
To: IETF RAP WG
Subject: RE: PIB Incarnation [sic]

cheers,
Pedro

-----Original Message-----
From: Abdul Malick [mailto:[email-masked]]
Sent: Thursday, November 22, 2001 4:00 AM
To: Da Silva, Pedro; IETF RAP WG
Subject: RE: PIB Incarnation [sic]

Hello Pedro,

Regards,
Malick

-----Original Message-----

Krishna,

IHTH,
Pedro

-----Original Message-----
From: Krishna Prasad Akkineni [mailto:[email-masked]]
Sent: Wednesday, November 21, 2001 10:29 AM
To: IETF RAP WG
Subject: PIB Incarnation

Hi,

Thanks & Regards
Krishna

---

From: "Krishna Prasad Akkineni" <[email-masked]>
Date: Thu, 22 Nov 2001 15:18:24 +0530

Thanks Pedro. Your explanation enhanced my
understanding of PIB incarnation Table usage.
cheers
Krishna