Subject: RE: PIB Incarnation [sic]

From: "Da Silva, Pedro" <[email-masked]>
Date: Wed, 21 Nov 2001 14:45:28 -0000

Krishna,

The frwkPibIncarnationName identifies the PDP that provided the PIB instance
refered to by the frwkPibIncarnationId. It can be say 'Primary Manager', or
'Manager X' and/or an ip address or whatever, in your system, *uniquely*
identifies each PDP.
It is the responsibility of the PDP to populate the entry, it's effectively
part of the decision.

IHTH,
Pedro

-----Original Message-----
From: Krishna Prasad Akkineni [mailto:[email-masked]]
Sent: Wednesday, November 21, 2001 10:29 AM
To: IETF RAP WG
Subject: PIB Incarnation

Hi,
   This is a query with reference to ID on framework PIB.
From the document, I could not understand how PDP & PEP
exchange PIB incarnation table details. 

Specifically, What can be the name of "frwkPibIncarnationName"
attribute. Is it the responsibility of PDP to fill this
attribute? 

For your reference, structure of  FrwkPibIncarnationEntry 
is given below.

  FrwkPibIncarnationEntry ::= SEQUENCE { 
           frwkPibIncarnationPrid                InstanceId, 
           frwkPibIncarnationName                SnmpAdminString, 
           frwkPibIncarnationId                  OCTET STRING, 
           frwkPibIncarnationLongevity           Unsigned32, 
           frwkPibIncarnationTtl                 Unsigned32, 
           frwkPibIncarnationActive              TruthValue 
   } 

Thanks & Regards
Krishna

---

From: "Abdul Malick" <[email-masked]>
Date: Thu, 22 Nov 2001 09:30:10 +0530

Hello Pedro,

But can multiple PDPs manage a PEP at the same time?
Also to make a particular incarnation active, i think the PDP only has to
make the decision. In this case how is the activation of incarnations
co-ordinated among different PDPs given the fact that only one incarnation
can be active at the same time.

Regards,
Malick

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Da Silva, Pedro
Sent: Wednesday, 21 November 2001 8:15 PM
To: IETF RAP WG
Subject: RE: PIB Incarnation [sic]

Krishna,

IHTH,
Pedro

-----Original Message-----
From: Krishna Prasad Akkineni [mailto:[email-masked]]
Sent: Wednesday, November 21, 2001 10:29 AM
To: IETF RAP WG
Subject: PIB Incarnation

Hi,

  FrwkPibIncarnationEntry ::= SEQUENCE

Thanks & Regards
Krishna

---

From: "Krishna Prasad Akkineni" <[email-masked]>
Date: Thu, 22 Nov 2001 09:00:32 +0530

Hi Pedro,
        It is now clear for me that it is PDP's responsibility
to set frwkPibIncarnationName. This will work well incase of
single PDP. But, how can PEP get managed by multiple PDP's and
still maintain uniqueness of frwkPibIncarnationName + frwkPibIncarnationId.

To summarize:
1. Is there an assumption that, multiple PDPs must belong to a single
administrative domain?
In such case there is no conflict in maintaining unique PDP names.

2. Is it true that, At any point of time a PEP gets managed by one and only
   one PDP (For a specific client type)(Even if multiple PDPs are under
   single administrative domain).

Thanks
Krishna