Subject: frameworkpib-06 comments

From: "Da Silva, Pedro" <[email-masked]>
Date: Thu, 15 Nov 2001 15:00:24 -0000

The scope of the document is to 'define a set of PRCs and textual
conventions that are common to all clients...'. Having a table that
determines a target via the ifIndex limits the applicability of the
framework pib across client types.

Shouldn't the frwkIfRoleComboTable table be more generic? The frwk PIB could
define PRCs that constitute a base on which each client type is able to
specify its particular target, be it an IfIndex+direction on a router or
slotX on a toaster.

Pedro

--
This communication contains confidential information intended solely for the use of the individual/s and/or entity or entities to whom it was intended to be addressed.  If you are not the intended recipient, be aware that any disclosure, copying, distribution, or use of the contents of this transmission is prohibited.  If you have received this communication in error, please contact the sender immediately, delete this communication from your system, and do not disclose its contents to any third party, or use its contents.  Any opinions expressed are solely those of the author and do not necessarily represent those of Orchestream Ltd or its group of companies unless otherwise specifically stated.

---

From: "Sahita, Ravi" <[email-masked]>
Date: Thu, 15 Nov 2001 16:01:54 -0800

Pedro,

The frwkIfRoleCombo table is only used to associate 
ifIndices on network devices with role-combinations. 
The actual policy targetting table would be in a domain-specific 
PIB (for example the qosDataPathTable in the diffserv PIB).

Note that in a hypothetical toaster PIB you can always 
define your own targetting table that contains SlotX,
role-combination, and you would'nt use the ifRoleComboTable
since in that case you would'nt need that association.

Ravi

>  -----Original Message-----
>  From: Da Silva, Pedro [mailto:[email-masked]]
>  Sent: Thursday, November 15, 2001 7:00 AM
>  To: [email-masked]
>  Subject: frameworkpib-06 comments
>  
>  
>  This communication contains confidential information 
>  intended solely for the use of the individual/s and/or 
>  entity or entities to whom it was intended to be addressed.  
>  If you are not the intended recipient, be aware that any 
>  disclosure, copying, distribution, or use of the contents of 
>  this transmission is prohibited.  If you have received this 
>  communication in error, please contact the sender 
>  immediately, delete this communication from your system, and 
>  do not disclose its contents to any third party, or use its 
>  contents.  Any opinions expressed are solely those of the 
>  author and do not necessarily represent those of Orchestream 
>  Ltd or its group of companies unless otherwise specifically stated.
>