Subject: RE: PIB Incarnation [sic]

From: "Da Silva, Pedro" <[email-masked]>
Date: Thu, 22 Nov 2001 12:40:56 -0000

1. A PDP must be within the administrative domain of a PEP in order to
*directly* manage that PEP. The assumption is that under an administrative
domain the PDPs administer, in a coordinated fashion, a common and
consistent set of policies. If policies come from outside a given domain,
then there will most likely have to be some form of policy negotiation
between inter-domain PDPs.
 
2.Yes. Good point, I forgot to mention that it's per client type in my
previous message to Abdul.
 
AFAIK,
Pedro

-----Original Message-----
From: Krishna Prasad Akkineni [mailto:[email-masked]]
Sent: Thursday, November 22, 2001 3:31 AM
To: Da Silva Pedro
Cc: Abdul Malick; [email-masked]
Subject: Re: PIB Incarnation [sic]

Hi Pedro, 
        It is now clear for me that it is PDP's responsibility 
to set frwkPibIncarnationName. This will work well incase of 
single PDP. But, how can PEP get managed by multiple PDP's and 
still maintain uniqueness of frwkPibIncarnationName + frwkPibIncarnationId. 

To summarize: 
1. Is there an assumption that, multiple PDPs must belong to a single 
administrative domain? 
In such case there is no conflict in maintaining unique PDP names. 
  
2. Is it true that, At any point of time a PEP gets managed by one and only 
   one PDP (For a specific client type)(Even if multiple PDPs are under 
   single administrative domain). 

Thanks 
Krishna 

"Da Silva, Pedro" wrote: 

Krishna, 

The frwkPibIncarnationName identifies the PDP that provided the PIB instance

refered to by the frwkPibIncarnationId. It can be say 'Primary Manager', or 
'Manager X' and/or an ip address or whatever, in your system, *uniquely* 
identifies each PDP. 
It is the responsibility of the PDP to populate the entry, it's effectively 
part of the decision. 

IHTH, 
Pedro 

-----Original Message----- 
From: Krishna Prasad Akkineni [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Wednesday, November 21, 2001 10:29 AM 
To: IETF RAP WG 
Subject: PIB Incarnation 

Hi, 
   This is a query with reference to ID on framework PIB. 
>From the document, I could not understand how PDP & PEP 
exchange PIB incarnation table details. 

Specifically, What can be the name of "frwkPibIncarnationName" 
attribute. Is it the responsibility of PDP to fill this 
attribute? 

For your reference, structure of  FrwkPibIncarnationEntry 
is given below. 

  FrwkPibIncarnationEntry ::= SEQUENCE { 
           frwkPibIncarnationPrid                InstanceId, 
           frwkPibIncarnationName                SnmpAdminString, 
           frwkPibIncarnationId                  OCTET STRING, 
           frwkPibIncarnationLongevity           Unsigned32, 
           frwkPibIncarnationTtl                 Unsigned32, 
           frwkPibIncarnationActive              TruthValue 
   } 

Thanks & Regards 
Krishna

---

From: "Da Silva, Pedro" <[email-masked]>
Date: Thu, 22 Nov 2001 12:55:04 -0000

Please note my previous message on administrative domains, in response to
Krishna.
I should add that the PEP is responsible for ensuring that there is only one
active pib instance, per client type.

Pedro

-----Original Message-----
From: Abdul Malick [mailto:[email-masked]]
Sent: Thursday, November 22, 2001 12:44 PM
To: Da Silva, Pedro; IETF RAP WG
Subject: RE: PIB Incarnation [sic]

Is it then right to say that a PDP can manage more than one Incarnation and
when a PEP contact a PDP for provisioning the PDP can set the required
incarnation (among those it manages) as active and automatically the
incarnations created by other PDPs as well as other incarnations created by
this PDP will become inactive.

Malick

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Da Silva, Pedro
Sent: Thursday, 22 November 2001 5:19 PM
To: IETF RAP WG
Subject: RE: PIB Incarnation [sic]

Multiple PDPs may manage a PEP but not concurrently. The PEP can only make
requests to one and only one PDP at a given time.
There is also the scenario where the PEP has a local PDP. In this case, you
may actually have two entities concurrently providing decisions to the PEP.
Note that the PEP must relay all local decisions to the remote PDP, as it is
*the authoritative source* of decisions (LPDPDecision).

cheers,
Pedro

-----Original Message-----
From: Abdul Malick [mailto:[email-masked]]
Sent: Thursday, November 22, 2001 4:00 AM
To: Da Silva, Pedro; IETF RAP WG
Subject: RE: PIB Incarnation [sic]

Hello Pedro,

But can multiple PDPs manage a PEP at the same time?
Also to make a particular incarnation active, i think the PDP only has to
make the decision. In this case how is the activation of incarnations
co-ordinated among different PDPs given the fact that only one incarnation
can be active at the same time.

Regards,
Malick

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Da Silva, Pedro
Sent: Wednesday, 21 November 2001 8:15 PM
To: IETF RAP WG
Subject: RE: PIB Incarnation [sic]

Krishna,

IHTH,
Pedro

-----Original Message-----
From: Krishna Prasad Akkineni [mailto:[email-masked]]
Sent: Wednesday, November 21, 2001 10:29 AM
To: IETF RAP WG
Subject: PIB Incarnation

Hi,

  FrwkPibIncarnationEntry ::= SEQUENCE

Thanks & Regards
Krishna