Subject: frameworkpib-06 - frwkErrorPrc / Instance

From: "Bokaemper, Martin" <[email-masked]>
Date: Wed, 21 Nov 2001 14:24:10 -0500

Hello!

I'm extremely happy with the new mechanisms in the
frameworkpib - incremental request state updates,
multiple active contexts, references between context -
great!

I have one small question regarding the FrwkErrorEntry
Prc: Why is the instance causing the error reported in
two sepeparate fields:
           frwkErrorPrc         PrcIdentifier, 
           frwkErrorInstance    InstanceId 
Unless there is a benefit to the split, I would suggest 
to replace these two fields with one:
           frwkErrorInstance    Prid

Martin.
--

---

From: "Sahita, Ravi" <[email-masked]>
Date: Wed, 21 Nov 2001 13:04:28 -0800

This was done so that the frwkError PRC
could be used to specify error conditions
that apply not only to PRC instances but 
to PRCs also. (for example COPS-PR error 
code unknownPrc(9))

Ravi

>  -----Original Message-----
>  From: Bokaemper, Martin [mailto:[email-masked]]
>  Sent: Wednesday, November 21, 2001 11:24 AM
>  To: [email-masked]'
>  Subject: frameworkpib-06 - frwkErrorPrc / Instance
>  
>  
>  Hello!
>