Subject: Re: [Rats] Call for Adoption: EAT draft

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Fri, 17 May 2019 03:43:16 +0000

Hi,
I support the adoption of this EAT draft.
It is a relative stable solution draft for RATS, which can be a good start for the other RATS work items and make this specific solution to meet the industry urgent needs.

I have a general comment: how about the claims definition in this draft? Should it be a more general and complete claim set definition for all covered use cases, and specified in one individual draft?

Thanks!

B.R.
Frank

This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

发件人: RATS [mailto:[email-masked]] 代表 Kathleen Moriarty
发送时间: 2019年5月10日 23:07
收件人: [email-masked]
主题: [Rats] Call for Adoption: EAT draft

Greetings!

At IETF 104, a poll was taken to determine interest in the RATS WG adopting:

The Entity Attestation Token (EAT)
https://datatracker.ietf.org/doc/draft-mandyam-rats-eat/

This begins a 2 week period to determine interest in adopting this draft as a working group item.  The poll will close on May 24th EOD PDT.

Minutes from IETF 104:
https://datatracker.ietf.org/doc/minutes-104-rats/
--

Best regards,
Kathleen

---

From: Jeremy O'Donoghue <[email-masked]>
Date: Fri, 17 May 2019 08:20:38 +0000

I support adoption of this draft.

To respond to the specific point from Frank, I do believe that additional claims will be necessary in the published specification, but we should be aware that EAT is deliberately intended to be extensible.

As such it is for me entirely expected that other specifications such as the PSA draft (https://tools.ietf.org/html/draft-tschofenig-rats-psa-token-00) or work undertaken in other bodies (GlobalPlatform, TCG, FIDO, ...) will define additional claims. IANA registration of claims IDs will be sufficient to ensure interoperability.

Point is, I would like to see the first release be fairly conservative in taking only the most general claims on which we have strong agreement and using additional documents where more use-case/vertical specific extensions are needed.

Best regards
Jeremy

---
Jeremy O’Donoghue                            email: [email-masked]<mailto:[email-masked]>
Director, Engineering                        tel:   +44 1252 363189
NFC & Secure Software and Systems

On 17 May 2019, at 04:43, Xialiang (Frank, Network Standard & Patent Dept) <[email-masked]<mailto:[email-masked]>> wrote:

CAUTION: This email originated from outside of the organization.

Hi,

Thanks!

B.R.
Frank

发件人: RATS [mailto:[email-masked]] 代表 Kathleen Moriarty
发送时间: 2019年5月10日 23:07
收件人: [email-masked]<mailto:[email-masked]>
主题: [Rats] Call for Adoption: EAT draft

Greetings!

Minutes from IETF 104:

Best regards,
Kathleen
_______________________________________________
RATS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rats