Subject: [Rats] draft-richardson-rats-usecases-00

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 8 May 2019 13:34:36 +0000

Hi Michael,

I read through your document.

I am confused about the mismatch between the title and the content. I am also not sure about the direction it should go.

Currently, the document is an attempt to survey existing technologies that contain attestation functionality. That's not a use case document. There is also an attempt to define terminology in the document.

Are you going to change the content of the document to turn it into a use case document or do you plan to change the title?

Which direction you go depends on what you want to accomplish.

Doing a technology survey is useful but of course only a snapshot in time because the organizations are still working on their protocols and mechanisms. Additionally, the most interesting information is very hard to collect (such as deployment information).

Doing use cases is useful if they let you identify design constraints or new requirements. Getting meaningful use cases is, as I had to learn the hard way myself, difficult.

What do you plan to do?

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 08 May 2019 15:22:24 -0400

> I am confused about the mismatch between the title and the content. I
    > am also not sure about the direction it should go.

    > Currently, the document is an attempt to survey existing technologies
    > that contain attestation functionality. That’s not a use case
    > document. There is also an attempt to define terminology in the
    > document.

I agree.
I am doing the survey in order to capture the terminology used, so that we
can discuss the use cases with unambiguous terminology.

    > Are you going to change the content of the document to turn it into a
    > use case document or do you plan to change the title?

Yes, I plan to adapt the document towards this.
I'm finding that it's very difficult to determine use cases from the
different technologies, and I'm finding that surprising.  But, there have
been quite a number of comments on the document since IETF104, and I will get
the document updated in the next ten days (or earlier if the virtual interim
date is the earlier dates)

    > Doing a technology survey is useful but of course only a snapshot in
    > time because the organizations are still working on their protocols and
    > mechanisms. Additionally, the most interesting information is very hard
    > to collect (such as deployment information).

    > Doing use cases is useful if they let you identify design constraints
    > or new requirements. Getting meaningful use cases is, as I had to learn
    > the hard way myself, difficult.

My aim is to help focus the WG by trying to elucidate the commonalities and
differences, and making the scope of each technology clear.    For that we
need use cases, and I agree the document is lacking.

Thank you for being appropriately grumpy :-)

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 8 May 2019 19:38:12 +0000

Thanks for the clarification. Happy to tell you what I know about FIDO attestation (from the time when I contributed to the FIDO specifications myself).

Ciao
Hannes

PS: My comment wasn't meant to be "grumpy". It is an Austrian style. Think about Arnold when you read my emails...

-----Original Message-----
From: Michael Richardson <[email-masked]>
Sent: Mittwoch, 8. Mai 2019 21:22
To: Hannes Tschofenig <[email-masked]>
Cc: [email-masked]
Subject: Re: [Rats] draft-richardson-rats-usecases-00

    > document. There is also an attempt to define terminology in the

I agree.
I am doing the survey in order to capture the terminology used, so that we can discuss the use cases with unambiguous terminology.

Yes, I plan to adapt the document towards this.
I'm finding that it's very difficult to determine use cases from the different technologies, and I'm finding that surprising.  But, there have been quite a number of comments on the document since IETF104, and I will get the document updated in the next ten days (or earlier if the virtual interim date is the earlier dates)

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.