Subject: Re: [Rats] Virtual Interim call for agenda

From: Laurence Lundblade <[email-masked]>
Date: Tue, 1 Oct 2019 06:39:19 -0700

Hi Ned,

Here’s two more topics that seem important:

EAT Draft Issues including additional claims
There are a bunch of open issues against the EAT draft. <https://github.com/ietf-rats-wg/eat/issues> I will do some clean up of them and be prepared to give an update on them.

The GitHub issues list is where I would like to track proposals for additional claims. I definitely think we need more than we have now, particularly around SW and measurement.

Info / Data Model
We still have the info / data model issue open in relation to https://tools.ietf.org/html/draft-birkholz-rats-information-model-00 <https://tools.ietf.org/html/draft-birkholz-rats-information-model-00>. I’d like to simply propose that the info / data model for claims be in the EAT draft and that the info / data model for the conveyance protocol be in Henk’s document. 

I believe the status on vendor claims is that we are OK with inheriting from CWT and JWT except one person, I can’t remember who, wanted to enhance CWT with a Collision-Resistant Name space like JWT has. I don’t think there is much to discuss until we have a written proposal for this and it has been initially vetted with the CWT folks. There is most certainly a means to support vendor claims today that works reasonably well. 

LL

> On Sep 28, 2019, at 12:35 PM, Smith, Ned <[email-masked]> wrote:
> 
> Hello all!
> I’m putting together the agenda for the RATS virtual interim scheduled for Tuesday, Oct 8th 2019 @ 14:30 UTC (7:30 PDT).
> Draft agenda so far:
> -          Milestones update (RATS chairs)
> -       Architecture draft - https://datatracker.ietf.org/doc/draft-birkholz-rats-architecture/ <https://datatracker.ietf.org/doc/draft-birkholz-rats-architecture/> - (Henk Birkholtz)
> -          Interaction model draft - https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/ <https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/> - (Henk Birkholtz)
> -       Yang module draft - https://datatracker.ietf.org/doc/draft-birkholz-rats-basic-yang-module/ <https://datatracker.ietf.org/doc/draft-birkholz-rats-basic-yang-module/> - (Henk Birkholtz)
>  
> Also, should there be more discussion around which claims RATS WG is going to define?
> Are there missing claims?
> Is there growing consensus that the claims we currently define are sufficiently understood and relevant?
> How will RATS support vendor defined claims?
>  
> _______________________________________________
> RATS mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rats <https://www.ietf.org/mailman/listinfo/rats>

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 1 Oct 2019 10:28:24 -0400

Sent from my mobile device

> On Oct 1, 2019, at 9:39 AM, Laurence Lundblade <[email-masked]> wrote:
> 
> Hi Ned,
> 
> There are a bunch of open issues against the EAT draft. I will do some clean up of them and be prepared to give an update on them.
> 
> We still have the info / data model issue open in relation to https://tools.ietf.org/html/draft-birkholz-rats-information-model-00. I’d like to simply propose that the info / data model for claims be in the EAT draft and that the info / data model for the conveyance protocol be in Henk’s document. 
> 
> 

This may have been Russ Housley and if so, we should discuss it further if he has a proposal or someone else submits one.

With no hats:
For the RATS architecture draft, my review wasn’t mentioned in Henk’s update.  Were my comments considered? I’m not going to review it unless they were as I spent a fair amount of time trying to help make the document more readable already. 

Thank you,
Kathleen 
>> -       Architecture draft - https://datatracker.ietf.org/doc/draft-birkholz-rats-architecture/ - (Henk Birkholtz)
>> -          Interaction model draft - https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/ - (Henk Birkholtz)
>> -       Yang module draft - https://datatracker.ietf.org/doc/draft-birkholz-rats-basic-yang-module/ - (Henk Birkholtz)
>>  
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rats
> 
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats

---

From: Henk Birkholz <[email-masked]>
Date: Tue, 1 Oct 2019 18:39:21 +0200

Hi Kathleen,

TL;DR In essence, yes, and I recommend to review now. But...

The significant portion of your comments was very 
text/paragraph/list/wording specific. As we basically refactored the 
whole document, we tried to retain the "intent/spirit" of you comments - 
including the notion of a "level of confidence" (which you then 
suggested to be named "level of assurance" in retrospect).

There might be occurrences where you find the same... systematic issue 
in different text again. That would be an oversight on our part. The I-D 
went through 4 passes of edits which created basically a new document, I 
think.

IHTH and is not too discouraging wrt to reviewing the I-D!

Viele Grüße,

Henk

On 01.10.19 16:28, Kathleen Moriarty wrote:
> On Oct 1, 2019, at 9:39 AM, Laurence Lundblade <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>> Hi Ned,
>>
>>     _EAT Draft Issues including additional claims_
>>     There are a bunch of open issues against the EAT draft.
>>     <https://github.com/ietf-rats-wg/eat/issues> I will do some clean
>>     up of them and be prepared to give an update on them.
>>
>>     The GitHub issues list is where I would like to track proposals
>>     for additional claims. I definitely think we need more than we
>>     have now, particularly around SW and measurement.
>>     _
>>     _
>>     _Info / Data Model_
>>     We still have the info / data model issue open in relation to
>>     https://tools.ietf.org/html/draft-birkholz-rats-information-model-00.
>>     I’d like to simply propose that the info / data model for claims
>>     be in the EAT draft and that the info / data model for the
>>     conveyance protocol be in Henk’s document. 
>>
>>
>>
>> I believe the status on vendor claims is that we are OK with 
>> inheriting from CWT and JWT except one person, I can’t remember who, 
>> wanted to enhance CWT with a Collision-Resistant Name space like JWT 
>> has. I don’t think there is much to discuss until we have a written 
>> proposal for this and it has been initially vetted with the CWT folks. 
>> There is most certainly a means to support vendor claims today that 
>> works reasonably well. 
> 
> This may have been Russ Housley and if so, we should discuss it further 
> if he has a proposal or someone else submits one.
> 
> With no hats:
> For the RATS architecture draft, my review wasn’t mentioned in Henk’s 
> update.  Were my comments considered? I’m not going to review it unless 
> they were as I spent a fair amount of time trying to help make the 
> document more readable already.
> 
> Thank you,
> Kathleen
>>
>> LL
>>
>>
>>
>>
>>> On Sep 28, 2019, at 12:35 PM, Smith, Ned <[email-masked] 
>>> <mailto:[email-masked]>> wrote:
>>>
>>> Hello all!
>>> I’m putting together the agenda for the RATS virtual interim 
>>> scheduled for Tuesday, Oct 8^th 2019 @ 14:30 UTC (7:30 PDT).
>>> Draft agenda so far:
>>>
>>> -Milestones update (RATS chairs)
>>>
>>> -       Architecture draft 
>>> -https://datatracker.ietf.org/doc/draft-birkholz-rats-architecture/- 
>>> (Henk Birkholtz)
>>>
>>> -Interaction model draft 
>>> -https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/- 
>>> (Henk Birkholtz)
>>>
>>> -       Yang module draft 
>>> -https://datatracker.ietf.org/doc/draft-birkholz-rats-basic-yang-module/- 
>>> (Henk Birkholtz)
>>>
>>>   * Are there missing claims?
>>>   * Is there growing consensus that the claims we currently define
>>>     are sufficiently understood and relevant?
>>>   * How will RATS support vendor defined claims?
>>>

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 1 Oct 2019 16:44:10 -0400

Thank you, Henk.

> On Oct 1, 2019, at 12:39 PM, Henk Birkholz <[email-masked]> wrote:
> 
> Hi Kathleen,
> 
> The significant portion of your comments was very text/paragraph/list/wording specific. As we basically refactored the whole document, we tried to retain the "intent/spirit" of you comments - including the notion of a "level of confidence" (which you then suggested to be named "level of assurance" in retrospect).
> 
> There might be occurrences where you find the same... systematic issue in different text again. That would be an oversight on our part. The I-D went through 4 passes of edits which created basically a new document, I think.
> 
>>> On Oct 1, 2019, at 9:39 AM, Laurence Lundblade <[email-masked] <mailto:[email-masked]>> wrote:
>>> Hi Ned,
>>> 
>>>> On Sep 28, 2019, at 12:35 PM, Smith, Ned <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> Hello all!
>>>> I’m putting together the agenda for the RATS virtual interim scheduled for Tuesday, Oct 8^th 2019 @ 14:30 UTC (7:30 PDT).
>>>> Draft agenda so far:
>>>> 
>>>> -       Architecture draft -https://datatracker.ietf.org/doc/draft-birkholz-rats-architecture/- (Henk Birkholtz)
>>>> 
>>>> -Interaction model draft -https://datatracker.ietf.org/doc/draft-birkholz-rats-reference-interaction-model/- (Henk Birkholtz)
>>>> 
>>>> -       Yang module draft -https://datatracker.ietf.org/doc/draft-birkholz-rats-basic-yang-module/- (Henk Birkholtz)
>>>>