Subject: Re: [Rats] RATS use cases review

From: Michael Richardson <[email-masked]>
Date: Mon, 07 Oct 2019 13:01:40 +0200

Jessica Fitzgerald-McKay <[email-masked]> wrote:
    > I took a careful read of the use cases document. I notices that
    > Sections 5.1 - 5.6.2 each are variations on the themes of attesting to
    > a device's:

...

    > In this light, the right approach is to organize the document around
    > the information that is being attested (the above list, plus end-user
    > information (section 5.6.3), geographic attestation (section 5.7), and
    > connectivity attestation (section 5.8)), with perhaps additional
    > information on how these types of attestation can be combined in
    > support of things like, say, critical infrastructure security, etc.

    > What does the work group think?

This thread didn't go very far, unfortunately.
I've spent quite a few hours since thinking about your suggestion.
In many ways, the Thursday morning side-meeting went in the other direction,
providing new situations which differed from existing use cases only in the
severity.

As I explain in another email, I have added a set of attributes to each use
case, being;
       - Who will use it:
       - Attestation type: (passport or background check)
       - Attesting Party
       - Relying Party
       - Claims used
       
The claims used are all TBD at this point.

As I said at the meeting in March, I don't want to do ontology up-front, but
rather to just collect all sorts of things, even if they seem to overlap.
Some of Guy's suggestions (in a PDF he sent me) also related to refactoring
some use cases, and while I actually agree with his suggestion, I still want
to avoid that.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Jessica Fitzgerald-McKay <[email-masked]>
Date: Fri, 11 Oct 2019 10:49:10 -0400

Michael,

That's fine, we can back-burner my suggestions until we a) finish
collecting all the use cases we want to include, and b) are ready to
address what claims are necessary to fulfill each use case.

As a potential "end user" of attestation standards, I want RATS to be able
to answer the question of whether or not I can trust a device on my
network. And, the answer to that question will depend a lot on what kind of
claims I can get and verify from the device. But I can see that being
outside the scope of the style use case document we are writing right now.

Thanks,
Jess

---

From: Michael Richardson <[email-masked]>
Date: Sat, 12 Oct 2019 22:59:26 +0200

> address what claims are necessary to fulfill each use case.

It's really not that I want to put stuff off!
I was trying to bring it back to the list for further thoughts from others.

    > As a potential "end user" of attestation standards, I want RATS to be
    > able to answer the question of whether or not I can trust a device on
    > my network. And, the answer to that question will depend a lot on what
    > kind of claims I can get and verify from the device. But I can see that
    > being outside the scope of the style use case document we are writing
    > right now.

This starts out like a well written agile User Story to me :-)
Maybe the I should be writing them more like User Stories, so let me see how
to work that in.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Laurence Lundblade <[email-masked]>
Date: Sat, 12 Oct 2019 15:59:29 -0700

On Oct 11, 2019, at 7:49 AM, Jessica Fitzgerald-McKay <[email-masked]> wrote:
> 
> As a potential "end user" of attestation standards, I want RATS to be able to answer the question of whether or not I can trust a device on my network. And, the answer to that question will depend a lot on what kind of claims I can get and verify from the device. But I can see that being outside the scope of the style use case document we are writing right now. 

Yes, outside of the use case document, but not outside the EAT draft <https://tools.ietf.org/html/draft-ietf-rats-eat-01>. The claims in it now that I think relate to device trust are:
OEM — who made the device, the chip, sub modules?
Boot and debug state — is it in a operationally secure mode? (Also see new PR  <https://github.com/ietf-rats-wg/eat/pull/36>for this one)

I’m tracking proposed new claims as issues in GitHub labeled “new claim” <https://github.com/ietf-rats-wg/eat/issues?q=is:open+is:issue+label:%22new+claim%22>. From the issues list these seem related:
Software measurement and/or integrity
Software inventory, particularly version compared to a known-good-values list of the latest security patched SW

What else?

LL