Subject: [Rats] I-D Action: draft-ietf-rats-architecture-00.txt

From: [email-masked]
Date: Tue, 17 Dec 2019 09:27:48 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Remote ATtestation ProcedureS WG of the IETF.

        Title           : Remote Attestation Procedures Architecture
        Authors         : Henk Birkholz
                          Dave Thaler
                          Michael Richardson
                          Ned Smith
	Filename        : draft-ietf-rats-architecture-00.txt
	Pages           : 8
	Date            : 2019-12-17

Abstract:
   In network protocol exchanges, it is often the case that one entity
   (a relying party) requires evidence about a remote peer to assess the
   peer's trustworthiness, and a way to appraise such evidence.  The
   evidence is typically a set of claims about its software and hardware
   platform.  This document describes an architecture for such remote
   attestation procedures (RATS).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rats-architecture/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rats-architecture-00
https://datatracker.ietf.org/doc/html/draft-ietf-rats-architecture-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Michael Richardson <[email-masked]>
Date: Tue, 17 Dec 2019 14:17:37 -0500

> attestation procedures (RATS).

While our -00 document posted today is far from complete, the design team
felt it was worthwhile putting an initial stake in the ground to show our
progress.

Our next meeting is January 7, 10am EST.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Simon Frost <[email-masked]>
Date: Wed, 18 Dec 2019 16:29:42 +0000

Congratulations to the design team, this draft is looking useful already.

> While our -00 document posted today is far from complete...
Perhaps you may be nearer to completion than you might think - the document will gain from being kept succinct!

A couple of comments.
Section 6: On the matter of Attested / Attesting environments: for readability, I agree that alternative names would help.  Suggestions to promote discussion: An 'Attesting Environment' could be called an 'Appraisal Environment' or 'Appraisal Context'. Justification: Appraisal rather than Attesting tries to capture the possibility that the component could potentially fail the appraisal, while Attesting suggests it will always make a statement. Using Context rather than Environment as the same component may alter role at a different point of execution.  Similarly, a suggestion for 'Attested Environment' to be called 'Examined Context'.

Section 7.
Can the document also note that trust must be established between the Verifier and the Endorser such that Endorsements are known to be valid.
The last paragraph, discussing the Verifier (policy) evaluation process might be better placed in the discussion of the Verifier in Section 4. With respect to the trust model, it should be sufficient to say that the basis of the Verifier trust in the Attester Evidence can be use case dependant but will need to be established based on the security available to the Attester.

Thanks
Simon

-----Original Message-----
From: Michael Richardson <[email-masked]>
Sent: 17 December 2019 19:18
To: [email-masked]
Subject: Re: [Rats] I-D Action: draft-ietf-rats-architecture-00.txt

    > attestation procedures (RATS).

While our -00 document posted today is far from complete, the design team felt it was worthwhile putting an initial stake in the ground to show our progress.

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.