Subject: [Rats] Durable link to approved TCG Algorithm Registry

From: Ira McDonald <[email-masked]>
Date: Tue, 28 Jul 2020 11:47:51 -0400

Hi,

Here's the link to that registry, for use in naming algorithms in various
RATS specs:

https://trustedcomputinggroup.org/resource/tcg-algorithm-registry/

I'm encouraging our TCG IT support team to put an obvious durable
link in the TPM WG home page.

Cheers,
- Ira

*Ira McDonald (Musician / Software Architect)Co-Chair - TCG Trusted
Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

---

From: Laurence Lundblade <[email-masked]>
Date: Tue, 28 Jul 2020 17:41:38 -0700

This would just be for TPM-specific RATS stuff. For protocols like CWT and EAT, the registry is the standard IANA COSE registry <https://www.iana.org/assignments/cose/cose.xhtml>.

LL

> On Jul 28, 2020, at 8:47 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> https://trustedcomputinggroup.org/resource/tcg-algorithm-registry/ <https://trustedcomputinggroup.org/resource/tcg-algorithm-registry/>
> 
> Ira McDonald (Musician / Software Architect)
> Co-Chair - TCG Trusted Mobility Solutions WG
> Co-Chair - TCG Metadata Access Protocol SG
> Chair - Linux Foundation Open Printing WG
> Secretary - IEEE-ISTO Printer Working Group
> Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
> IETF Designated Expert - IPP & Printer MIB
> Blue Roof Music / High North Inc
> http://sites.google..com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> (permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 29 Jul 2020 08:47:47 +0200

Hi Laurence,

I think that was a reference in support of the "YANG module algorithm 
identity" discussion in the meeting on Tuesday.

COSE of course uses the COSE registries.

YANG does not use COSE though. And quite some time was spend on trying 
to find out which registries to use here (in RATS) in the end. As we 
learn from NETCONF, using crypto algorithm (registries) in a convenient 
and universal manner can be very very hard.

Viele Grüße,

Henk

On 29.07.20 02:41, Laurence Lundblade wrote:
> This would just be for TPM-specific RATS stuff. For protocols like CWT 
> and EAT, the registry is the standard IANA COSE registry 
> <https://www.iana.org/assignments/cose/cose.xhtml>.
> 
> LL
> 
> 
>> On Jul 28, 2020, at 8:47 AM, Ira McDonald <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Hi,
>>
>> /Ira McDonald (Musician / Software Architect)
>> Co-Chair - TCG Trusted Mobility Solutions WG/
>> /Co-Chair - TCG Metadata Access Protocol SG
>> /
>> /Chair - Linux Foundation Open Printing WG
>> http://sites.google..com/site/blueroofmusic 
>> <http://sites.google.com/site/blueroofmusic>
>> http://sites.google.com/site/highnorthinc
>> (permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434/
>> [email-masked] <mailto:[email-masked]>