Subject: [Rats] Rats terminology capitalized or not?

From: Laurence Lundblade <[email-masked]>
Date: Wed, 25 Aug 2021 22:26:34 -0700

Are we capitalizing attester, verifier, attestation evidence…?

My recollection from an RFC editor comment is that we should not capitalize them. However the architecture document and others do capitalize them.

COSE does not capitalize “header parameter” or other terms. CBOR doesn’t capitalized “data item”, “well-formed”...

ONTH, CWT and JWT do capitalize “Claim Key”, “Claim Name”...

LL

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 26 Aug 2021 10:44:53 +0200

Hi Laurence,

scoping your question to the RATS Architecture:

If we want to have specific key words capitalized, then the RFCEd must 
be informed about that and must be okay with that. That happens on a 
regular basis and is absolutely okay.

One can "over-do" capitalizing - to a point where is starts to impact 
readability. We are not doing that, I think. In contrast, it helps a 
reader to realize that specific terms diverge from a typical every-day 
meaning or that these key words are... well key to the whole concept 
conveyed.

Coming back to your examples, "well-formed" or "data item" are used 
relatively close to their typical meaning in CBOR and are not 
capitalized. "Claim" has a very specific meaning in JWT/CWT which splits 
it off from its common (typically every-day) synonym "assertion" and so 
is capitalized. That reads good to me.

In essence, the capitalization used in the current Architecture document 
looks good to me.

Viele Grüße,

Henk

On 26.08.21 07:26, Laurence Lundblade wrote:
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

---

From: Ira McDonald <[email-masked]>
Date: Thu, 26 Aug 2021 08:11:18 -0400

Hi Laurence,

I agree with Henk that moderate use of capitalization (i.e., title case) for
terms that have a RATS-specific meaning is appropriate and helps the
reader.  The current use in the Architecture document is fine.

Cheers,
- Ira

*Ira McDonald (Musician / Software Architect)*

*Chair - SAE Trust Anchors and Authentication TF*
*Co-Chair - TCG Trusted Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

On Thu, Aug 26, 2021 at 4:45 AM Henk Birkholz <
[email-masked]> wrote:

> > My recollection from an RFC editor comment is that we should not
> capitalize them. However the architecture document and others do capitalize
> them.
> >
> > COSE does not capitalize “header parameter” or other terms. CBOR doesn’t
> capitalized “data item”, “well-formed”...
> >

---

From: Laurence Lundblade <[email-masked]>
Date: Thu, 26 Aug 2021 19:48:32 -0700

Good clear answer. Thx. Will capitalize RATS architecture terms in EAT document.

LL

> On Aug 26, 2021, at 5:11 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Laurence,
> 
> Ira McDonald (Musician / Software Architect)
> Chair - SAE Trust Anchors and Authentication TF
> Co-Chair - TCG Trusted Mobility Solutions WG
> Co-Chair - TCG Metadata Access Protocol SG
> Chair - Linux Foundation Open Printing WG
> Secretary - IEEE-ISTO Printer Working Group
> Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
> IETF Designated Expert - IPP & Printer MIB
> Blue Roof Music / High North Inc
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> (permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434
> 
> 
> On Thu, Aug 26, 2021 at 4:45 AM Henk Birkholz <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Laurence,
> 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/rats <https://www.ietf.org/mailman/listinfo/rats>
> > 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rats <https://www.ietf.org/mailman/listinfo/rats>