Subject: Re: [Rats] Fwd: IETF WG state changed for draft-ietf-rats-architecture

From: "Smith, Ned" <[email-masked]>
Date: Mon, 2 Aug 2021 19:03:29 +0000

I took a run at reworking the diagram. Consensus however seemed to favor keeping the original.

The details of whether Evidence is monolithic or discrete isn’t called out explicitly in the Arch. The reader should interpret this to mean that the architecture doesn’t have an opinion on the matter. It could be either / both. It is up to IDs to sort it out IMO.

The only constraint is that “Claims” describe the properties of the various environments (layered or not) and that Evidence contains Claims that are integrity protected prior to leaving the “Attester”; which implies, at least, that the last environment to touch Claims before being conveyed beyond the endpoint is responsible for applying integrity protection (if not already applied).

Beyond that, both layering and composite device patterns are using the terminology of “environments” and “root of trust” to describe ways of decomposing the Attester into smaller parts. A sequence of environments is a common pattern – aka bootstrap (as the diagram suggests) and environments as peers is also a common pattern (e.g. composite device). These two patterns (and hybrids of both) can describe the majority of possible ways to decompose an Attester. I don’t think it is a goal of the architecture to try to apply the roles and artifacts concepts to Attester decompositions.

That doesn’t mean an ID couldn’t do so IMO.

It doesn’t mean that an ID couldn’t define more sophisticated structures that relate groups of Claims or groups of Evidence. For example, EAT submods are a grouping of claims and nested EATs are a grouping of Evidence IMO.

In general, I think the RATS Arch draft does a good job of capturing concepts, terminology and framework of attestation without going too far in overprescribing architecture and implementation. It is intended to allow flexibility.

-Ned

From: RATS <[email-masked]> on behalf of Kathleen Moriarty <[email-masked]>
Date: Friday, July 30, 2021 at 11:39 AM
To: "[email-masked]" <[email-masked]>
Subject: [Rats] Fwd: IETF WG state changed for draft-ietf-rats-architecture

Greetings!

I am about ready to move this document into the IESG for ROman's review and just finished looking at the last outstanding item for the document: https://mailarchive.ietf.org/arch/msg/rats/UuFwOfLnRitCbnfKpE-IgZ9ANcU/

I agree that the diagram may not be the best one, but do think demonstrating layers is helpful at an architectural level. The document, IMO< should not go in depth, but I am wondering if the diagram can be improved. In the diagram, evidence is coming from an endorser and Laurence asks about evidence always coming from an attester. I find the diagram a little confusing as it looks like a join of evidence as opposed to layered.

Hopefully, this can be cleared up quickly and then we'll progress the document. It may be fine to have it addressed during the last call, but I'd like to see if some level of explanation might help or an alternate diagram. Thank you and great work!

Best regards,
Kathleen
---------- Forwarded message ---------
From: IETF Secretariat <[email-masked]<mailto:[email-masked]>>
Date: Fri, Jul 30, 2021 at 2:32 PM
Subject: IETF WG state changed for draft-ietf-rats-architecture
To: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>

The IETF WG state of draft-ietf-rats-architecture has been changed to
"Waiting for WG Chair Go-Ahead" from "WG Document" by Kathleen Moriarty:

https://datatracker.ietf.org/doc/draft-ietf-rats-architecture/

--

Best regards,
Kathleen

---

From: Michael Richardson <[email-masked]>
Date: Mon, 02 Aug 2021 16:02:49 -0400

Smith, Ned <[email-masked]> wrote:
    > The only constraint is that “Claims” describe the properties of the
    > various environments (layered or not) and that Evidence contains Claims
    > that are integrity protected prior to leaving the “Attester”; which
    > implies, at least, that the last environment to touch Claims before
    > being conveyed beyond the endpoint is responsible for applying
    > integrity protection (if not already applied).

...

    > Beyond that, both layering and composite device patterns are using the
    > terminology of “environments” and “root of trust” to describe ways of
    > decomposing the Attester into smaller parts. A sequence of environments
    > is a common pattern – aka bootstrap (as the diagram suggests) and
    > environments as peers is also a common pattern (e.g. composite
    > device). These two patterns (and hybrids of both) can describe the
    > majority of possible ways to decompose an Attester. I don’t think it is
    > a goal of the architecture to try to apply the roles and artifacts
    > concepts to Attester decompositions.

    > That doesn’t mean an ID couldn’t do so IMO.

Agreed.

...

    > In general, I think the RATS Arch draft does a good job of capturing
    > concepts, terminology and framework of attestation without going too
    > far in overprescribing architecture and implementation. It is intended
    > to allow flexibility.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide