Subject: [Rats] FW: New Version Notification for draft-ietf-rats-tpm-based-network-device-attest-13.txt

From: Guy Fedorkow <[email-masked]>
Date: Tue, 1 Mar 2022 20:03:16 +0000

Greetings Fellow RATS!
  The TCG Canonical Event Log document has been officially published now, so I've submitted Version 13 of the RIV draft with the corrected link.  Some of the formatting for other TCG reference documents was inconsistent; I've fixed some of those too.
  While I was at it, I applied Meiling's simple clarification of "TPM compatible" in place of "TPM Compliant", given that TCG does not have a formal compliance program for TPMs.
  Of course it's my belief that these changes were all deep into Editorial country, and non-substantive.

  Let me know if there are further questions,
/guy

Juniper Business Use Only

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Tuesday, March 1, 2022 2:15 PM
To: Eric Voit <[email-masked]>; Guy Fedorkow <[email-masked]>; Jessica Fitzgerald-McKay <[email-masked]>
Subject: New Version Notification for draft-ietf-rats-tpm-based-network-device-attest-13.txt

[External Email. Be cautious of content]

A new version of I-D, draft-ietf-rats-tpm-based-network-device-attest-13.txt
has been successfully submitted by Guy Fedorkow and posted to the IETF repository.

Name:           draft-ietf-rats-tpm-based-network-device-attest
Revision:       13
Title:          TPM-based Network Device Remote Integrity Verification
Document date:  2022-03-01
Group:          rats
Pages:          45
URL:            https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-ietf-rats-tpm-based-network-device-attest-13.txt__;!!NEt6yMaO-gk!RXSdCtJ8iFRM1ioQ9U5tAT3AQ29R9ZGBVzS9HEJ4Q188DYR4Q74Cy-9y7TSJTIQTyW4$
Status:         https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-rats-tpm-based-network-device-attest/__;!!NEt6yMaO-gk!RXSdCtJ8iFRM1ioQ9U5tAT3AQ29R9ZGBVzS9HEJ4Q188DYR4Q74Cy-9y7TSJ2h67AOs$
Htmlized:       https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-ietf-rats-tpm-based-network-device-attest__;!!NEt6yMaO-gk!RXSdCtJ8iFRM1ioQ9U5tAT3AQ29R9ZGBVzS9HEJ4Q188DYR4Q74Cy-9y7TSJ1VWW9Dg$
Diff:           https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-rats-tpm-based-network-device-attest-13__;!!NEt6yMaO-gk!RXSdCtJ8iFRM1ioQ9U5tAT3AQ29R9ZGBVzS9HEJ4Q188DYR4Q74Cy-9y7TSJO6Yode0$

Abstract:
   This document describes a workflow for remote attestation of the
   integrity of firmware and software installed on network devices that
   contain Trusted Platform Modules [TPM1.2], [TPM2.0], as defined by
   the Trusted Computing Group (TCG)), or equivalent hardware
   implementations that include the protected capabilities, as provided
   by TPMs.

The IETF Secretariat

---

From: "Meiling Chen" <[email-masked]>
Date: Wed, 2 Mar 2022 11:23:04 +0800

Hi Guy,
I have reviewed the new version, it looks good that the comments are adopted and written.

Best,
Meiling

From: Guy Fedorkow
Date: 2022-03-02 04:03
To: [email-masked]; Benjamin Kaduk; Meiling Chen
CC: [email-masked]; Eric Voit (evoit)
Subject: FW: New Version Notification for draft-ietf-rats-tpm-based-network-device-attest-13.txt
Greetings Fellow RATS!
  The TCG Canonical Event Log document has been officially published now, so I've submitted Version 13 of the RIV draft with the corrected link.  Some of the formatting for other TCG reference documents was inconsistent; I've fixed some of those too.
  While I was at it, I applied Meiling's simple clarification of "TPM compatible" in place of "TPM Compliant", given that TCG does not have a formal compliance program for TPMs.
  Of course it's my belief that these changes were all deep into Editorial country, and non-substantive.

 
 
-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Tuesday, March 1, 2022 2:15 PM
To: Eric Voit <[email-masked]>; Guy Fedorkow <[email-masked]>; Jessica Fitzgerald-McKay <[email-masked]>
Subject: New Version Notification for draft-ietf-rats-tpm-based-network-device-attest-13.txt

 
 
Abstract:

 
The IETF Secretariat

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 10 Mar 2022 17:56:14 -0800

Hi Guy,

Thanks for posting the updates.  The changes look good (modulo a typo that
the RFC Editor will surely fix), and I've updated my ballot position in the
datatracker [1] to remove the blocking DISCUSS.  It looks like there were a
couple points from my other comments that may still be applicable, but
those were non-blocking to begin with.

Thanks again,

Ben

[1] listed at
https://datatracker.ietf.org/doc/draft-ietf-rats-tpm-based-network-device-attest/ballot/