Subject: [Raw] Charter alignment of WG documents

From: Rick Taylor <[email-masked]>
Date: Tue, 14 Jul 2020 09:11:22 +0000

Hi All,

The chairs are currently putting together that agenda for IETF-108, and one of the topics we would like to discuss on-list and during the meeting is the alignment of the current selection of WG drafts and the WG charter.

As it currently stands, we have a number of drafts that describe the architecture, use-cases, details of various RAW technologies, and OAM.  However, the charter discusses documents describing technical evaluation, requirements, etc.

We are interested in the opinion of the various draft authors and the WG as a whole to the idea of either reorganising the content of documents to match those described by the charter, or updating the charter to match our mental model of the RAW drafts needed.  At the same time, we wonder if it is important for the RAW WG documents to mimic the structure of the DetNet foundational docs (Problem Statement, Use Cases, Architecture) more closely.

We understand that there would be pain and delay involved in reworking these documents and/or the charter, and we would like the WG to balance the pain against any perceived benefit.  We also do not want to discourage the current author teams - we greatly value all their current input, and want to maintain that momentum.

We hope this starts a productive conversation, and we are looking to reach some consensus shortly after IETF-108.

Cheers,

Rick & Eve

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 14 Jul 2020 11:44:55 +0000

Hello Rick

The problem statement draft was not listed in the final charter and slowly evolved into a combination of requirements, framework and architecture to march the charter. We also have a use case draft. For those we are mostly in line.

The gap analysis can only be done when the above are well agreed upon.

We do not have a charter item for the technologies we want to cover. That went away during the IESG negotiations and though the term “technologies” was conserved, the goal has completely derived. Even without a charter item the work is plainly in scope considering the first paragraph that lists the core technologies. How can the WG work on them without providing an informational description of what they are?

Up to the AD but I trust we can adopt without a recharter.

So we are not that far off are we?

Pascal

Le 14 juil. 2020 à 11:11, Rick Taylor <[email-masked]> a écrit :

Hi All,

We understand that there would be pain and delay involved in reworking these documents and/or the charter, and we would like the WG to balance the pain against any perceived benefit.  We also do not want to discourage the current author teams – we greatly value all their current input, and want to maintain that momentum.

Cheers,

Rick & Eve

--
RAW mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/raw

---

From: Rick Taylor <[email-masked]>
Date: Tue, 14 Jul 2020 16:09:24 +0000

Hi Pascal,

(sorry for the top-post)

*Not* speaking as a co-chair.

I am in agreement with you, I do not feel a re-charter is appropriate, and would prefer to ‘massage’ our existing set of documents to capture the spirit of the charter and the needs to the WG.  However, as I am not an author of any of these documents and understand the amount of work that goes into a draft, so I am cautious about asking authors to start reorganising documents without a compelling reason.

I don’t believe we are far off at all.  Eve and my question to the WG group was based on this assumption.  Before too long I feel we will have many documents adopted, reviewed and ready for the IESG, so we just wanted to ensure that there is consensus in the WG about the relationship between the content of the documents, the charter and associated WGs such as DetNet before we get too far along this process.

Cheers,

Rick

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: 14 July 2020 12:45
To: Rick Taylor
Cc: [email-masked]
Subject: Re: [Raw] Charter alignment of WG documents

Hello Rick

Pascal

Hi All,

Cheers,

Rick & Eve