Subject: [rddp] Increasing TO order?

From: Caitlin Bestler <[email-masked]>
Date: Thu, 21 Nov 2002 19:15:47 -0600

In Hemal's DDP presentation, slide 6 refers to "Increasing
TO order for Tagged DDP Message".

The sole discussion on the list related to untagged
messages. In fact one argument presented for not having a MO
order requirement was that tagged deliveries could be in any
order anyway.

A tagged transfer can be quite large, the sender cannot be
expected to assemble the contents in one location so as to
allow them to be sent in order.

Both SAN and NAS servers will want to transfer data from
scattered disks in whatever order the data becomes
available, which is dependent on queues and head positions.

The only place TO ordering would be relevant is that it
might make sense to require the local interface to break
apart a single ULP tagged send in order. However, because
the peer does not know or care what the original ULP request
was this would hardly be an interoperability issue. I don't
see why it would be worth specifying.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Vadim Makhervaks" <[email-masked]>
Date: Fri, 22 Nov 2002 07:43:54 +0200

Agree, no need to have ordering restrictions for Tagged segments, still
think that ordering of Untagged segments does affect receiver
implementation.

Vadim

|---------+---------------------------->
|         |           Caitlin Bestler  |
|         |           <[email-masked]> |
|         |           Sent by:         |
|         |           [email-masked]|
|         |           rg               |
|         |                            |
|         |                            |
|         |           22/11/02 03:15 AM|
|         |                            |
|---------+---------------------------->
  >------------------------------------------------------------------------------------------------------------------------------|
  |                                                                                                                              |
  |       To:       [email-masked]                                                                                                |
  |       cc:                                                                                                                    |
  |       Subject:  [rddp] Increasing TO order?                                                                                  |
  |                                                                                                                              |
  |                                                                                                                              |
  >------------------------------------------------------------------------------------------------------------------------------|

Caitlin Bestler