Subject: [rddp] Re: [Tsvwg] Another Possible Argument for IFT over MPA

From: Joe Touch <[email-masked]>
Date: Thu, 31 Oct 2002 10:39:21 -0800

Williams, Jim wrote:
>>-----Original Message-----
>>From: Joe Touch [mailto:[email-masked]]
>>
>>[...]
>>
>>A secondary reason is that IP does not guarantee in-order delivery.
> 
> 
> True.  But I am assuming that it is quite rare
> in practice that IP actually delivers out of order.  Is
> this correct?

It depends on the link. Some links are multiplexed or do load balancing; 
on those links, the out-of-order could be nontrivial. Either way, it's 
certainly a non-zero number.

There's at least some info at:
http://www-iepm.slac.stanford.edu/monitoring/reorder/

>>[...]
>>
>>Down != 0. Even ECN drops packets.
> 
> 
> True again.  But if dropped packets are sufficiently
> rare, the endpoint can handle them inefficiently
> (but correctly) without significantly affecting
> overall performance.  Hence my concern about
> how rare they will actually be.

See:

http://www.internettrafficreport.com/main.htm

(not rare enough, IMO).

----

Granted, the above are both selected 'anecdotally' from Google searches; 
if there are broader claims on which these assumptions are to be based 
in an ID, it would be useful to substantiate them with cited data, 
rather than speculation.

Joe

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 31 Oct 2002 12:56:39 -0600

Jim,

Does the path you're using touch the Internet? There are a number of "whoops, the Internet DOES reorder packets" papers available, if so.

(signed) curious

-----Original Message-----
From: Williams, Jim [mailto:[email-masked]]
Sent: Thursday, October 31, 2002 11:55 AM
To: 'Joe Touch'
Cc: [email-masked]; [email-masked]
Subject: RE: [Tsvwg] Another Possible Argument for IFT over MPA

tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: [email-masked]
Date: Fri, 1 Nov 2002 17:47:06 -0700

Jim,

I don't see how you can assume that out of order arrival will be rare. One cause of out of order delivery is TCP's congestion control. Any time congestion control is operating, there is a control loop where a drop causes the window to be decreased, then the window is increased until a drop causes it to be decreased again. Therefore, one can not count on packet drops being rare. When data flows are heavy and congestion causes packet drops, it isn't a good time to react inefficiently. 

Pat