Subject: [rddp] DDP: Protocol Overview (3.2) Untagged Receive Buffers

From: Caitlin Bestler <[email-masked]>
Date: Tue, 5 Nov 2002 13:15:03 -0600

Draft 00 had the following language:

> If the Data Source sends a DDP Message payload larger
> than the receive buffer, it results in an error.  

Draft 01 replaced it with the following

> If the Data Source sends a DDP Message payload larger
> than the receive ULP buffer, it results in an error.  

This change implies that untagged buffers MUST belong to the
ULP and that they CANNOT be system buffers. In my opinion
this is a topic that the DDP draft should be silent on.

When we specify the requirements for the local interface, I
would suggest the following:

--  The ULP MUST be allowed to prepost ULP buffers for 
    receive operations on a specific DDP stream.
    
--  A DDP implementation MAY require the ULP to prepost
    buffers for receive operations.
    
--  A DDP implementation MAY automatically allocate buffer
    space for incoming receives to untagged messages.
    
Rationale: there are some specialized environements where
the number of streams is quite large relative to the number
of untagged messages that actually could be received in a
short time. A web server is a classic example. In such
environments it ispossible that some implementations would
prefer to allocate from a common pool for untagged messages.
As that this would not interfere with interoperability,  it
is a local implemetnation option that should be allowed.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Culley, Paul" <[email-masked]>
Date: Wed, 6 Nov 2002 08:14:57 -0600

Unfortunately you are seeing some side effects of out expected upper interface, which of course is not described in the current DDP document.

Our current thinking is that the upper interface goes more like this:

--  The ULP MUST prepost the ULP buffer prior to the arrival of the associated DDP message on the DDP stream.  If the message arrives before a buffer is posted, a "MSN-Invalid, no buffer available"

Your suggested text may be appropriate for the main DDP document, (any other opinions?) but I think a separate upper interface document should be more specific and probably won't contain capabilities like your third rule.

Paul Culley
HP Sr. Fellow
281-514-5543

-----Original Message-----
From: Caitlin Bestler [mailto:[email-masked]]
Sent: Tuesday, November 05, 2002 1:15 PM
To: [email-masked]
Subject: [rddp] DDP: Protocol Overview (3.2) Untagged Receive Buffers

    

Caitlin Bestler