Subject: RE: [rddp] One vs Two CRCs

From: "Shah, Hemal" <[email-masked]>
Date: Thu, 21 Nov 2002 18:36:23 -0800

Jim,

With based on all the discussion on the reflector and at the IETF meeting, I
am in favor of one CRC covering the entire DDP Segment. Among the NIC vendor
representatives active in rddp group, I see more people in favor of one CRC
(Uri, Pat, and me) vs. two CRCs (you and Somesh).

I would encourage other NIC vendor representatives to express their opinions
on this particular issue.

Hemal

-----Original Message-----
From: Williams, Jim [mailto:[email-masked]] 
Sent: Thursday, November 21, 2002 7:31 PM
To: [email-masked]
Subject: RE: [rddp] One vs Two CRCs

> -----Original Message-----
> From: Uri Elzur [mailto:[email-masked]]
> Sent: Thursday, November 21, 2002 6:51 PM
> To: Somesh Gupta; [email-masked]
> Subject: RE: [rddp] One vs Two CRCs
> 
> 
> There has not been any argument as for the benefit of the 
> additional CRC.

I believe there is an argument both in my draft and my
presentation.  If there is a flaw in this argument,
it would be preferable for you to point out what
aspect of the argument is flawed, rather than
claim the argument doesn't exist.

> The only argument I hear is implementation. 

That is true for may of the features defined in 
the protocols under discussion in this WG.
Implementation issues are valid considerations
as long as they are generic to the protocol
and not a narrow implication of one possible
implementation.

> "After listening to many NIC vendors" in the same meeting, 
> one must reach the conclusion that many other vendors feel it 
> is easier to implement one CRC.

I don't think this should degenerate into a vote, but so
far the NIC vendor representatives I am aware of
are Uri, Pat, Somesh, and myself.  And that looks
like an even split.

------

Having said that, though, I think the source of the
disagreement is a different model of how an RNIC is 
implemented.  It is probably worth drilling into that
a little, and I will attempt to do that at some point
in the near future.  It may boil down to an assessment
of which model is more generic, and which is more
of a point solution. 

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Somesh Gupta" <[email-masked]>
Date: Thu, 21 Nov 2002 22:26:52 -0800

I think it is very unnecessary and premature to start
voting at this point. I would much prefer the technical
debate to resolve the entire framing issue.

However if you can show me why 2 CRCs (one for header
and the other for the payload) are more complicated
than 1, I am willing to listen. I think two CRCs allow
for much more implementation flexibility than 1 CRC.

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Shah,
> Hemal
> Sent: Thursday, November 21, 2002 6:36 PM
> To: 'Williams, Jim'; [email-masked]