Subject: [rddp] RDDP header format

From: "Williams, Jim" <[email-masked]>
Date: Mon, 11 Nov 2002 10:50:48 -0500

I had some basic questions about the DDP header format.
and defined in draft-shah-iwarp-ddp-01.txt.
I am sure others have given this a lot more thought
and have some good answers here.

For untagged buffers, the header defines a 32 bit field
called "RsvdULP[8:39]".  The RDMA layer uses this
for STag invalidate.  Just curious why this field
should be in the DDP header rather than the RDMA
header.

For layering simplicity it seems more appropriate
for the field to be in the layer that uses it,
and also it would be nice if the DDP header were
the same size for tagged and untagged versions.
Not a huge issue, but just curious as to the thinking.

Also, in the untagged buffer DDP header is a 32 bit
field defining the queue number.  Why does this
require 32 bits?  It looks like RDMA uses only
three queues numbered 0, 1, and 2.  If the number
of queues expected to be used is small, one
could potentially eliminate this field and use
two or three reserved bits to indicate the 
queue number.

There might be a usage model where a large number
of queues would be required, but is not obvious
to me what that would be, and it was not clear
to me from a quick reading of the draft.

Thanks, Jim

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Michael Krause <[email-masked]>
Date: Mon, 11 Nov 2002 08:21:55 -0800

>should be in the DDP header rather than the RDMA

Standard field location for multiple ULP to use without having to re-invent 
the wheel

>two or three reserved bits to indicate the

Pre-enablement for new services where a large QN space might be 
desirable.  The associated motivation discussion was not included in the 
text to avoid any confusion.  In general, defining a larger space allows 
for future flexibility.