Subject: [rddp] RE: [Tsvwg] Another Possible Argument for IFT over MPA

From: "Raghurama 'REDDY'" <[email-masked]>
Date: Thu, 31 Oct 2002 13:08:19 -0500

>> True.  But I am assuming that it is quite rare
>> in practice that IP actually delivers out of order.  Is
>> this correct?

some of the newer routers with parallel routing engines reorder packets
quite a lot.

--rr

From:	SMTP%"[email-masked]"  "Williams, Jim" 31-OCT-2002 13:02:31.76
To:	[email-masked]
CC:	[email-masked], [email-masked]
Subj:	RE: [Tsvwg] Another Possible Argument for IFT over MPA

> -----Original Message-----
> From: Joe Touch [mailto:[email-masked]]
> 
> [...]
>
> A secondary reason is that IP does not guarantee in-order delivery.

True.  But I am assuming that it is quite rare
in practice that IP actually delivers out of order.  Is
this correct?

> [...]
> 
> Down != 0. Even ECN drops packets.

True again.  But if dropped packets are sufficiently
rare, the endpoint can handle them inefficiently
(but correctly) without significantly affecting
overall performance.  Hence my concern about
how rare they will actually be.
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Somesh Gupta" <[email-masked]>
Date: Fri, 1 Nov 2002 08:54:09 -0800

It is a very undesirable property and modern routers almost never
get packets out of order. It was more of a property of older
processor based routers. Perhaps people from the major
router companies can comment.

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Raghurama 'REDDY'
> Sent: Thursday, October 31, 2002 10:08 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [rddp] RE: [Tsvwg] Another Possible Argument for IFT over MPA
> 
>