Subject: Re: [rddp] DDP: Ordering Among DDP Messages (7.3) Data Source rules

From: "Vadim Makhervaks" <[email-masked]>
Date: Wed, 6 Nov 2002 11:01:01 +0200

inline

|---------+---------------------------->
|         |           Caitlin Bestler  |
|         |           <[email-masked]> |
|         |           Sent by:         |
|         |           [email-masked]|
|         |           rg               |
|         |                            |
|         |                            |
|         |           05/11/02 09:32 PM|
|         |                            |
|---------+---------------------------->
  >-------------------------------------------------------------------------------------------------------------------------------|
  |                                                                                                                               |
  |       To:       [email-masked]                                                                                                 |
  |       cc:                                                                                                                     |
  |       Subject:  [rddp] DDP: Ordering Among DDP Messages (7.3) Data Source rules                                               |
  |                                                                                                                               |
  |                                                                                                                               |
  >-------------------------------------------------------------------------------------------------------------------------------|

The following rule was added:

> At the Data Source, DDP:
>
> ...
>
> * SHOULD transmit DDP Segments within a DDP Message in
> increasing MO order for Untagged DDP Messages and in
> increasing TO order for Tagged DDP Messages.

I believe this topic was thoroughly discussed, and that was
NOT the consensus. While it may seem innocuous, I do not
believe that a SHOULD clause is appropriate when there are
known valid reasons for at least some implementations not to
do so.

Further, in this case, there is absolutely no benefit to
this clause. It will only encourage sloppy implementations
to add extraneous "error checking" code looking for
"incorrectly" sequences segments.

As previously covered, a simple compliant receiver will not
even *notice* when segments are not in a natural order. It
has no *need* to examine their relative offsets at all.

<VM> disagree. It much more difficult to receiver to efficiently handle
reordered DDP segments of Untagged DDP message. TCP ooo can be easily
handled, because the information stored by receiver to allow efficient
implementation is proportional to the number of supported holes. Regarding
the DDP re-ordering, the information required for the similar-efficient
implementation is proportional to the number of the segments in the DDP
message, which can be pretty unlimited from the implementation perspective
(say 2GB message, with 1K MSS, gives 2M of segments). This problem is
relevant to Untagged DDP messages only<VM>.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Wed, 6 Nov 2002 10:12:07 -0600

On 11/6/02, Vadim Makhervaks wrote:

>
><VM> disagree. It much more difficult to receiver to
>efficiently handle reordered DDP segments of Untagged DDP
>message. TCP ooo can be easily handled, because the
>information stored by receiver to allow efficient
>implementation is proportional to the number of supported
>holes. Regarding the DDP re-ordering, the information
>required for the similar-efficient implementation is
>proportional to the number of the segments in the DDP
>message, which can be pretty unlimited from the
>implementation perspective (say 2GB message, with 1K MSS,
>gives 2M of segments). This problem is relevant to
>Untagged DDP messages only<VM>.
>

Could you provide some substantiation for the claim that
unordered message offsets creates ANY difficulty for the
receiver.

As I see it, the receiver logic is simple:

    Place the data at the message offset within the 
    target buffer (whether untagged or tagged).
    
    Segments with the 'L' bit are subject to eventual
    completion processing. The completion reported will
    take the size of the untagged message based upon the
    message offset and size of the last segment.

Note, there is no impact to the receiver on the ordering of
any segment other than the last one.

Do you have a contrary algorithm with some citable benefit?

Caitlin Bestler