Subject: RE: [rddp] Framing and TCP changes

From: "Williams, Jim" <[email-masked]>
Date: Wed, 4 Dec 2002 16:53:22 -0500

> -----Original Message-----
> From: Caitlin Bestler [mailto:[email-masked]]
> Sent: Wednesday, December 04, 2002 3:27 PM
> To: [email-masked]; [email-masked]
> Subject: Re: [rddp] Framing and TCP changes
>
> [...]
> 
> Arguments against markers:
> 
> - They are complex.
> 
> - They waste bandwidth.

I think this is a little bit of a straw man.
The important arguments I have seen against markers are:

  They are complex not because the solve
  a complex problem, but because they solve
  a very simple problem in a complex way.

  Markers combined with alignment and out of
  order data placement change TCP semantics
  in ways that are undesirable.

  Markers don't work.  They don't achieve the
  proposed objective of enabling lower cost
  RNICs.

  They do, however, make pre-existing hardware
  and software implementations considerably
  less efficient, thereby giving new marker
  aware hardware implementations a competitive
  advantage.  This alone is not a disqualifier,
  but it does create a reasonably high burden
  of proof on marker proponents.
 
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Charles Monia <[email-masked]>
Date: Wed, 4 Dec 2002 16:26:52 -0800

>   in ways that are undesirable.

Has this issue been settled? From what went on at the transport WG last
month, I thought one work item was to agree on ground rules for assessing
MPA's effect on TCP semantics.

....Back to the shadows again.
-- Charles
-----------------------------------------
Charles Monia
Senior Technology Consultant
Nishan Systems
email: [email-masked]
voice: (408) 519-3986
fax:   (408) 435-8385
 
> From: Williams, Jim [mailto:[email-masked]]
> Sent: Wednesday, December 04, 2002 1:53 PM
> To: 'Caitlin Bestler'; [email-masked]; [email-masked]
> Subject: RE: [rddp] Framing and TCP changes
> 
> 
> 
>

---

From: "Uri Elzur" <[email-masked]>
Date: Wed, 4 Dec 2002 16:31:34 -0800

Seems like we have 2 camps:  one camp (Jim, anyone else?) claiming RNIC can not be made cheaper with Markers and a larger group claiming it does simplify the RNIC and makes it cheaper. 
Should we keep re hashing it again and again on this list?

Citing a vendor specific existing implementation as a reason to stop any progress essential for the feasibility of high speed (10G+) NICs, is not a compelling reason.

Uri