Subject: RE: [rddp] Adaption Indication for TCP

From: [email-masked]
Date: Mon, 9 Dec 2002 17:44:24 -0500

> David Black wrote:
> > One could also use an adaption indication class of mechanism as
> > a safeguard - if it's not provided by the other side, any attempt
> > to go into DDP mode fails (enforced by the DDP protocol on the side
> > that wants to go into DDP mode).
> 
> Not sure I know what "an adaption indication class of mechanism" is.
> You are perhaps suggesting an in band double check for what the
> ULP has negotiated.  For instance:
> 
>   A and B negotiate use of DDP.  MPA or equivalent layer does following
>   transition to DDP mode.
> 
>   A -> B:   X       -- X is randomly selected value sent from A to B
>   B -> A:   F(X)    -- F is non-trivial function defined by MPA
>   A -> B:   G(F(X)) -- G is non-trivial function (possible same as F)
> 
>       A transitions to framed mode transmit on receipt of F(X)
>       B transitions to framed mode transmit on receipt of G(F(X))
> 
>   Seems pretty unlikely that either end will transition to MPA mode
>   without the knowledge and cooperation of the other.

That works, although I was thinking of something else to be done
immediately on connection setup - exchange SCTP-like adaption
indications meaning "I can do MPA" as the first bytes on the
connection (details of formatting this are TBD) without (necessarily)
going into MPA mode at that point.  The ULP can subsequently
decide when to put the connection into MPA mode, but if the adaption
indications have not been sent and received, the local MPA implementation
is required to reject any attempt to put the connection into MPA mode.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953 **NEW**     FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Mon, 9 Dec 2002 17:07:02 -0600

On 12/9/02, [email-masked] wrote:

>
>That works, although I was thinking of something else to
>be done immediately on connection setup - exchange
>SCTP-like adaption indications meaning "I can do MPA" as
>the first bytes on the connection (details of formatting
>this are TBD) without (necessarily) going into MPA mode at
>that point.  The ULP can subsequently decide when to put
>the connection into MPA mode, but if the adaption
>indications have not been sent and received, the local MPA
>implementation is required to reject any attempt to put
>the connection into MPA mode.
>

A confirming message as the first message to be received in
MPA mode makes a lot of sense. Particularly if packing is
allowed and therefore it does not automatically waste a
distinct transmission.

Considering that the first message sent will typically be
untagged, and not necessarily full sized, the chance of a
first "mode confirming message" being 'free' is good.

And even if a confirming message uses an extra transmission,
there is no round-trip confirmation required. It would not
have an adverse impact on getting to work. Requiring a MPA
layer ack for entry would not be a good.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp