Subject: [rddp] MPA/TCP Buffer Ownership rules

From: Caitlin Bestler <[email-masked]>
Date: Thu, 26 Dec 2002 16:09:14 -0600

There are a clear set of buffer ownership rules between the
ULP and DDP. Further, each ULP defines its own peer-to-peer
buffer ownerhsip rules.

The DDP/LLP interface does not explicitly deal with buffer
ownership. Instead the LLP has the option of presenting DDP
Segments to the DDP layer in whatever order they are
validated, but most report the original LLP order.

With these rules, it is clear who has permission to access
what buffers at any given time. These rules are also
compatible with multiple implementation strategies.

That leads to the question of what rules, if any, should be
specified for the MPA / TCP interface. What seems to be
currently suggested would allow two choices:

-- have a clean seperation between the MPA and TCP layers,
   and thereby prevent out-of-order placement.
-- declare the MPA and TCP layers to be an integrated 
   black box, and thereby refuse all information on how
   MPA and TCP interact.
   
Now obviously the second option is compatible with efficient
implementation. Its compatible with any implementation. Even
cleanly layered MPA and TCP implementations can declare
themselves to be a black box.

But wouldn't it make sense to also define a clean layering
based upon out-of-order delivery for placement? Not doing so
does not prevent MPA/TCP entanglement. Rather it forces it
to run up the "black box" flag, and encourages creation of
other interdepencies, proprietary undocumented dependencies.

I believe it would be a benefit to long term interoperabilty
to define a reference interface between the MPA and TCP
layers based upon TCP supplying data out-of-order for
placement purposes only, followed by final in-order
delivery.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Williams, Jim" <[email-masked]>
Date: Fri, 27 Dec 2002 12:28:36 -0500

> -----Original Message-----
> From: Caitlin Bestler [mailto:[email-masked]]
> Sent: Thursday, December 26, 2002 5:09 PM
> To: [email-masked]; [email-masked]
> Subject: [Tsvwg] MPA/TCP Buffer Ownership rules
> 
> 

I think you are glossing over something that is not at all clear.
In my view, the goal of such a set of rules is to insure that
ULPs do not behave in a way that violates the transport
semantics, or break when out of order placement is done.
A second goal is to minimize the extent
to which complexity is exported to the ULP, and
each ULP must re-implement buffer management in order
to get it right.

It's hard to discuss this in much detail until one or
more written proposals are on the table.

> [...]

Redefining TCP to provide out-of-order data is a clear
change to TCP definition, and not what's been proposed
in the current RDDP WG drafts.  It's an interesting
discussion point, but I am not sure the WG will
be allowed to proceed in that direction.