Subject: RE: [rddp] "DO IT RIGHT", or "DON'T DO IT AT ALL"

From: "Williams, Jim" <[email-masked]>
Date: Fri, 6 Dec 2002 11:38:19 -0500

> Realistically, however, if DDP relied solely upon SCTP it
> would *not* meet the objective to work with IP networks *as
> they are*. There are too many environments where middleboxes
> have no SCTP capability, or at least no SCTP ability that
> has been enabled.

SCTP has a multi-year head start on RDDP and is fundamentally
a less complex protocol to implement.  RDDP has a longer
road to acceptance because of the interaction at multiple
system levels, whereas SCTP is just a transport layer 
protocol.  To assume that
RDDP will see wide spread deployment before SCTP
strikes me as a bit of wishful thinking.  

On the other hand, there is some risk that SCTP
will fail to gain acceptance at all.  So it probably
makes sense to have a fall back position using TCP.

But I do find the argument a little strange that
we should avoid SCTP because it does not play
well with middle boxes, and instead we should use TCP
in a non-standard way that causes it to play
less well with middle boxes.  But I suppose
that if you make just the right assumptions
about how middle-boxes behave, this strategy
does make sense.
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Fri, 6 Dec 2002 11:21:16 -0600

On 12/6/02, Williams, Jim wrote:

>> Realistically, however, if DDP relied solely upon SCTP
>> it would *not* meet the objective to work with IP
>> networks *as they are*. There are too many environments
>> where middleboxes have no SCTP capability, or at least
>> no SCTP ability that has been enabled.
>
>SCTP has a multi-year head start on RDDP and is
>fundamentally a less complex protocol to implement.  RDDP
>has a longer road to acceptance because of the interaction
>at multiple system levels, whereas SCTP is just a
>transport layer protocol.  To assume that RDDP will see
>wide spread deployment before SCTP strikes me as a bit of
>wishful thinking.  
>

The point is that we must use TCP in a way that complies
with middle-boxes as they are now.

RDDP can be deployed more quickly than SCTP for the simple
reason that it is *NOT* a transport protocol. It can be
deployed on two hosts that have need for the service,
without any support  from network administrators (other than
enabling the application through the firewall, as must be
done for any new application).

One very concrete example of a middlebox that does not
support SCTP is your typical cable/dsl NAT router sold at
retail. DDP/MPA/TCP will go through these hardwired
middleboxes with no problems, they do no resegment.
However, I have yet to see a single one with an option to
open a specific SCTP port for inbound connections.

Suppose I wanted to use DAFS for a distributed file system
as opposed to WEBDAV? I could not even consider it unless I
ran DAFS over DDP/whatever/TCP.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Qiaobing Xie <[email-masked]>
Date: Fri, 06 Dec 2002 15:17:44 -0600

Once up a time in IETF, when the participation was less industry-oriented, I
remembered often hearing advice like "take your time, do it right and make it
architecturally correct." I still think it is a good advice...

-Qiaobing

Caitlin Bestler wrote:
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg