Subject: RE: [rddp] The Case Against Bufferless NICs

From: "Williams, Jim" <[email-masked]>
Date: Mon, 2 Dec 2002 11:37:24 -0500

> -----Original Message-----
> From: John Hufferd [mailto:[email-masked]]
> Sent: Wednesday, November 27, 2002 3:11 PM
> 
> Jim,
> In what way would you adjust your comments if you also took 
> into account,
> that these same RNICs are suppose to be able to use their 
> TOEs for normal
> NIC processing?  That is, not only can the RNIC support RDMA, 
> it is also
> suppose to handle regular TCP/IP processing via its TOE, and 
> perform the
> normal acceleration function such as TCP checksum processing, 
> etc.  I would
> expect in that case that on chip or on card reordering 
> buffers would be
> required.

This discussion is hindered by the lack of agreement
on what a TOE to host interface would look like.  For 
most reasonable assumptions about this interface, I think
your assessment is correct.  Reordering on the card
with in order transfer to the host probably makes sense.

> What I have been attempting to determine is if an RNIC is 
> going to support
> this normal (accelerated) NIC operation, will there be any savings in
> chip/card buffers especially in the early days when there is few RDMA
> applications and many normal socket applications using the 
> RNIC and its
> TOE.  What are your thoughts?

Interesting question.  I expect there are many different
opinions regarding how this market will develop.

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Michael Krause <[email-masked]>
Date: Mon, 02 Dec 2002 12:00:55 -0800

>with in order transfer to the host probably makes sense.

TOE is outside the charter as I understand it and it is really a vendor / 
OSV issue as to how they export their usage models.  One might define TOE 
verbs if the charter allowed if this was really an issue.  In general, I 
don't see why the card would do re-ordering - it can place and then order 
only the completion events independent of whether this is a TOE interface 
or a RDMA interface being used.

>opinions regarding how this market will develop.

Sockets Direct Protocol allows any existing sockets application to 
transparently operate over a RNIC.  The advent of Sockets extensions (see 
the OpenGroup work for Unix / Linux) will allow new sockets applications to 
fully exploit if they desire all RDMA services directly without an 
intervening ULP.  Same applies to MPI applications which already have a 
concept of RDMA (put / get).  In addition, iSCSI could also be ported over 
RDMA with minimal effort as this was discussed in IPS quite some time back 
as a logical progression for storage.

Mike

---

From: "Talpey, Thomas" <[email-masked]>
Date: Tue, 03 Dec 2002 09:31:17 -0500

>on what a TOE to host interface would look like.  For 

An RDMA API is the best kind of TOE-to-host interface!

Besides, if reassembly buffering is NOT on-chip or on-card,
then the RDMA goal of avoiding bus crossings is completely
lost as reassembly is performed. We are simply arguing over
meta-issues in how much buffering is needed, which is clearly
implementation.

Tom.