Subject: RE: [rddp] The Case Against Bufferless NICs

From: "Williams, Jim" <[email-masked]>
Date: Mon, 2 Dec 2002 12:09:22 -0500

> -----Original Message-----
> From: Herbert, Howard C [mailto:[email-masked]]
> Sent: Wednesday, November 27, 2002 8:52 PM
> To: Michael Krause; [email-masked]
> Subject: RE: [rddp] The Case Against Bufferless NICs
> 
> 
> I agree with Mike.  Jim's email seems to be trying to defend 
> a particular (current?) implementation approach.  In the end, 
> the marketplace will decide the success of bufferless NICs or 
> any other implementation.

Some important features (markers and alignment) have been
proposed specifically to enable certain types of
implementations.  This is OK, but it opens to door to
discussion of the pros and cons of implementations
that exploit these features.  These architectural and
implementation costs of these features needs to be
justified by implementation benefits.

> It seems we should focus our time 
> on getting the "wire" protocols done rather than debating how 
> difficult/complex a given implementation will be.  And we 
> should not be using this process to legislate what 
> implementations can or can not be built.

It was not my intent to do that.  Sorry if my tone suggested
otherwise.  The "wire protocol" works just fine without
markers and alignment.  Those features are clearly 
implementation driven.   I am not suggesting that they
should be ruled out because they are implementation
driven, just that it now becomes fair to discuss
implementation issues in some detail.

> Howard

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Williams, Jim" <[email-masked]>
Date: Mon, 2 Dec 2002 14:53:17 -0500

> From: Uri Elzur [mailto:[email-masked]]
> Sent: Wednesday, November 27, 2002 10:35 PM
> To: Williams, Jim; [email-masked]
> Regardless of the design point every NIC vendor chooses, I 
> don't see any architectural reason to limit the use of 
> so-called bufferless NICs. As a matter of fact, I suspect you 
> were not spending that much energy trying to shut it down, 
> unless you thought this is actually POSSIBLE (and compliant)!

Uri,

I think you give me too much credit (or maybe not enough
depending on your perspective :-).

Maybe it's too much energy, but motivation at this
point is pride of authorship, annoyance at being
bullied by the big guys, and a deep dislike of markers
for both philosophical and practical reasons.  The
only admittedly selfish reason is a desire not
to have to implement markers (especially when
I question whether they will achieve their desired
objective in the first place).

I don't imagine I do any better or worse than 
anyone else on a "purity of motives" test,
but it is hoped that won't factor into the
decision either way, and we can stick to the
technical arguments.