Subject: [rddp] Re:"DO IT RIGHT", or "DON'T DO IT AT ALL"

From: "Williams, Jim" <[email-masked]>
Date: Fri, 6 Dec 2002 11:06:56 -0500

Some observations on some of the responses to this.

1.  It seems that the perceived behavior of middle-boxes
    is playing a particularly large role in the protocol
    design decisions.

2.  People who have an agenda and whose agenda is helped
    by being paranoid about middle-boxes tend to be 
    very paranoid indeed.  (On the other hand, just
    because you are paranoid doesn't mean people really
    aren't out to get you :-)

3.  It's a lot easier to spread FUD (fear, uncertainty and 
    doubt) than to dispel it.

Although I don't necessarily disagree, I am a little concerned
by the attitude that it's absolutely essential that protocols
must run correctly and not ever close in error when faced
with an RSM (resegmenting middle-box), but it's perfectly OK
to suffer a dramatic performance drop in this case.  Many
applications and users will regard a dramatic performance
drop as being broken.

I would point out that a conventional TCP implementation
will suffer no significant performance drop in the presence
of an RSM.  So if RSMs are to be regarded as common and 
important, we should be cautious about proliferating
technology that suffers significant performance degradation
in their presence.  If RSMs are regarded as rare and aberrant,
we should be cautions about allowing them to be a driver
for major protocol complexity.

Anyway, I am no expert on middle-boxes and don't pretend to
be.  It would be highly beneficial if any cooler heads
without an overriding agenda, who have some knowledge in
the area of middle-boxes would help us out here.
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Fri, 6 Dec 2002 11:09:21 -0600

On 12/6/02, Williams, Jim wrote:

>
>Although I don't necessarily disagree, I am a little
>concerned by the attitude that it's absolutely essential
>that protocols must run correctly and not ever close in
>error when faced with an RSM (resegmenting middle-box),
>but it's perfectly OK to suffer a dramatic performance
>drop in this case.  Many applications and users will
>regard a dramatic performance drop as being broken.
>
>will suffer no significant performance drop in the
>presence of an RSM.  So if RSMs are to be regarded as
>common and important, we should be cautious about
>proliferating technology that suffers significant
>performance degradation in their presence.  If RSMs are
>regarded as rare and aberrant, we should be cautions about
>allowing them to be a driver for major protocol complexity.
>
I believe that a reasonable design goal is that an RDDP
implementation should not degrade below TCP performance in
the presence of an RSM. However, it would be fully
acceptable if optimizations were limited to alignment
maintaining environments.

My assumption is that the overwhelming majority of
connections will be free of RSMs, but that some clients will
be stuck behind them with no alternate path available.

This is partially based on my knowledge of environments
where RSMs are desirable: specifically over shared media
where carrier sense is not feasible (Cable plants,
broadcast, etc.) I am doubtful that anyone would deploy a
RSM by accident on one path into a private network.

>the area of middle-boxes would help us out here.

I doubt that we have many active middle-box makers
participating in the working group. My knowledge relates to
two specific environments and is a few years out of date.
Unfortunately I don't think we are on their radar screen as
of yet. For that reason I tend to favor caution. I would be
reluctant to design a protocol based on the assumption that
"nobody would do that" without doing a *thorough* probe of
that assumption.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp