Subject: RE: [rddp] CRC - rough consensus update

From: "Barron, Dwight" <[email-masked]>
Date: Mon, 2 Jun 2003 15:26:23 -0500

While I believe there is consensus on that point in this group, I don't know how this workgroup can make such a binding decision on other workgroups that would be defining the
ULPs. We do hereby solemnly swear that RDDP will provide data integrity equivalent to end-to-end CRC-32, unless and until it is optionally turned off. 

Regards,
Dwight

> -----Original Message-----
> From: Caitlin Bestler [mailto:[email-masked]]
> Sent: Monday, June 02, 2003 3:11 PM
> To: Barron, Dwight
> Cc: Stephen Bailey; [email-masked]
> Subject: RE: [rddp] CRC - rough consensus update 
> 
> 
> On 6/2/03, Barron, Dwight wrote:
> 
> >Unfortunately, I don't believe we avoid having the
> >argument. It will get re-argued in every ULP working
> >group, with the same ratio of people thinking RDDP
> >end-to-end data integrity needs to be better than TCP
> >checksums to those thinking the performance issues
> >overwhelm adoption. Then they too will want to have an
> >optional CRC.
> 
> It's worse than that.
> 
> The farther up you go, the less efficient a CRC
> implementation *can* be.
> 
> But as they are installed anyway you end up with
> *more* CRC implementations, *none* of which are as
> efficient as they could have been at the lowest layer
> with end-to-end semantics.
> 
> That is why I thought we had a consensus that nothing
> done in the way of making CRCs optional should ever
> cause a ULP to consider adding its own.
> 
> The only reason for a ULP to add its own integrity checking
> should be if they require something *more* than an
> end-to-end CRC32 check.
> 
> Do we have agreement on that objective?
> 
> Caitlin Bestler
> http://asomi.com/CaitlinBestler/
> 
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: [email-masked]
Date: Tue, 3 Jun 2003 01:18:24 +0000 (UTC)

On Mon, 2 Jun 2003, Barron, Dwight wrote:

> While I believe there is consensus on that point in this group, I don't
> know how this workgroup can make such a binding decision on other
> workgroups that would be defining the ULPs. We do hereby solemnly swear
> that RDDP will provide data integrity equivalent to end-to-end CRC-32,
> unless and until it is optionally turned off.

And we further note that the CRCs being off indicates that the admin(s)
governing the connection believe/promise that the connection has data
integrity equivalent to end-to-end CRC-32 even without the CRC-32.

It took me a while to get exactly what Caitlin was saying with it, but
this latter part is important. If we don't do this, then ULPs will be
likely to add their own CRCs, making a mess.

True, we can't _force_ the admin to not play fast&loose, but at least we
can indicate she or he is doing something wrong. The main thing is that
such a promise will do is indicate that ULPs that they can depend on CRC-
level protection.

Take care,

Bill