Subject: RE: [rddp] CRC - rough consensus update

From: "Teisberg, Robert" <[email-masked]>
Date: Sun, 1 Jun 2003 16:52:59 -0500

>  Software implementations are most likely to be 
> `cleanly layered' which means TCP and MPA (and IPSec) will 
> probably all have different touches of the data.

While not disagreeing with Steph's prediction, I'd like to point out
that extra data touches are relatively cheap (though not free) in
modern processor architectures.  As Somesh has obliquely reminded
us, the expensive touch is the first one.  Subsequently, the data are
"hot" in cache and cost much less to touch a second time.  "Cleanly
layered" software implementations are guaranteed to touch the data
at least once.
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Somesh Gupta" <[email-masked]>
Date: Mon, 2 Jun 2003 13:50:33 -0700

Robert,

Varying degrees of offload are quite common these days. So
any additional touch may be the only one. As an example,
a sendfile does not require any data touch even today.

Somesh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Teisberg, Robert
> Sent: Sunday, June 01, 2003 2:53 PM
> To: Stephen Bailey; [email-masked]
> Subject: RE: [rddp] CRC - rough consensus update 
> 
>