Subject: Re: [rddp] [Ips] Storage Maintenance (storm) BOF reminder & requests

From: Caitlin Bestler <[email-masked]>
Date: Tue, 24 Mar 2009 13:34:10 PDT

>On Tue Mar 24  8:26 , Bernard Metzler <[email-masked]> wrote:
>Hi Robert,
>
>an RNIC would be happy to transition an established
>socket into RDMA mode if the user wants to. No problem -
>as far as i know - to transition from TOE mode to RDMA mode at least.
>It is a question of envrionmental support to allow that. To allow that,
>the environment (aka OFED) wold have to integrate
>late socket translation, which allows RNIC drivers to officially
>do TOE to RDMA mode transition or to take over a socket
>
>(where the OS would have to expose a well-defined
>TCP context reallocation scheme).
>Maybe it is not a good idea to change an end-to-end
>protocol because a host environment has functional limitations
>which may stem from historical transport (IB) limitations
>or OS considerations.
>

I agree with Bernard.

Conventional RNICs are indeed transitioning streaming mode TCP connections
to MPA for iWARP in full compliance with the existing RFCs.

What Linux has not implemented is transitioning a host-created streaming mode
TCP connection to an offload device held streaming mode TCP connection.
That is a very complex issue, which fortunately for this forum, is out of scope.

---

From: Caitlin Bestler <[email-masked]>
Date: Tue, 24 Mar 2009 16:46:04 -0700

Robert D. Russell wrote:
> 
> 
> In any case, it might be useful to have a "Standard"
> way of bringing up initial connections in RDMA mode
> without the necessity to go through the negotiation.
> This may be faster, and in many situations it is
> already known that RDMA mode will be used, so the
> transition is just an extra, unnecessary step.
> 

Any extra unnecesary step is strictly in the local API.
Setting up an RDMA connection requires some exchange of
ULP information so that the two RDMA endpoints can be
configured compatibly (the server end, for example would
not know which Protection Domain to assign until it knew
who it was connecting with).

There is no real overhead in allowing an indefinite amount
of TCP exchange before the MPA Request/Response if you don't
use it.

In retrospect, if we had been confident that iSER would be
the only ULP requesting this capability then it might have
made sense to have iSER change. But the complexity of this
option will always be there, so the only real issue is if
it is adding round-trips or network bandwidth.

If the ULP wants to jump directly to the MPA Request/Response
it is free to do so, and there aren't any real optimizations
from that exchange that would justify a change.

The one exception is the one David already identified: MPI
and other cluster protocols really need a "nop" at the MPA
layer so that the first message from the active side requirement
of MPA can be met without involving the application.

---

From: "Robert D. Russell" <[email-masked]>
Date: Tue, 24 Mar 2009 17:08:37 -0400 (EDT)

Ok, so this is a Linux problem, not an iWARP problem.
Does this mean iSCSI/iSER currently runs with the transition on Windows?
What are some other Operating Systems that also do it the "right" way?

If nothing else, having such a Standard would bring
InfiniBand, and perhaps other technologies, into
compliance -- as far as I know, InfiniBand cannot
do the transition on any operating system.
Please let me know if that is incorrect.

Thanks,
Bob Russell

On Tue, 24 Mar 2009, Caitlin Bestler wrote:

> _______________________________________________
> rddp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rddp
>