Subject: [regext] reseller status & reseller name reference

From: "Linlin Zhou" <[email-masked]>
Date: Tue, 12 Apr 2016 17:55:55 +0800

Dear WG, 
As discussed in IETF meeting, I post this thread to list all the comments we have until now for us to have a further discussion about reseller status values. In my opinion, we have 4 options, 
-Status defined in the draft: ok, readonly and terminated 
-Reuse contact status values 
-SIDN example: linked, ok and pendingUpdate 
-other suggestions 
Personally, I do not prefer to reuse contact status values which are a little overweight for reseller as I said in the meeting. I'd like to hear more opinions from WG. 

In the latest version of reseller drafts, the reseller name was removed by WG comments, as there's no reseller name reference at the highest level of XML structure defined in reseller mapping draft. Some other comments suggested that it is better to keep the reseller name there for it is required by ICANN. If retaining the reseller name, the XML
should be modified accordingly. If we simply remove the name, there will be no big change for the XML structure. For this issue, I would also like to get some more ideas from WG. Thanks.

Regards,

Linlin Zhou

---

From: Rik Ribbers <[email-masked]>
Date: Tue, 12 Apr 2016 18:49:00 +0000

Linlin,

Dear WG,

Given you presentation in Buenos Aires and the feedback there I agree that the status values should be light weight. Given the SIDN statuses:

- The linked status in our SRS is a **personal hat on** non-epp-conformant status I would like the get rid off  ** personal hat off ** It is used for reseller objects that are linked/labelled with a domain object. When a reseller has no linked status set the reseller exists in our database but is not linked to any domain object. We use the linked status on all our objects except the domain object.
- The pendingUpdate is no longer used. It was used in the past for some reason I cannot recall.

Conclusion: I can live with the current statusses as provided; The linked status is SIDN specific and does not belong in the standard. If we decide to update our reseller implementation to match this I-D we will only use the ok and linked status.

I am not aware of any ICANN requirements in EPP for resellers, there might be for resellers in WHOIS though. so +1 for removing the name.

Regards,
________________________________
Linlin Zhou
_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/regext

---

From: "Linlin Zhou" <[email-masked]>
Date: Mon, 25 Apr 2016 14:32:04 +0800

Hi Rik,
Thanks for your comments. Please see my feedback inline start with [Linlin]. Any other suggestions are welcome.

Regards,

Linlin Zhou
 
From: Rik Ribbers
Date: 2016-04-13 02:49
To: Linlin Zhou
CC: regext
Subject: Re: [regext] reseller status & reseller name reference
Linlin,

Dear WG, 

Conclusion: I can live with the current statusses as provided; The linked status is SIDN specific and does not belong in the standard. If we decide to update our reseller implementation to match this I-D we will only use the ok and linked status.
[Linlin] OK. So I will not change the status defined in the document unless strong objection is submitted.

I am not aware of any ICANN requirements in EPP for resellers, there might be for resellers in WHOIS though. so +1 for removing the name.
[Linlin] Probably you are right. Reseller in whois is mentioned in ICANN requirement which is not the same thing with reseller name reference. So I still plan to remove it.

Regards,

Linlin Zhou
[email-masked]