Subject: [regext] I-D Action: draft-ietf-regext-org-04.txt

From: [email-masked]
Date: Thu, 03 May 2018 22:51:17 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Registration Protocols Extensions WG of the IETF.

        Title           : Extensible Provisioning Protocol (EPP) Organization Mapping
        Authors         : Linlin Zhou
                          Ning Kong
                          Guiqing Zhou
                          Xiaodong Lee
                          James Gould
	Filename        : draft-ietf-regext-org-04.txt
	Pages           : 41
	Date            : 2018-05-03

Abstract:
   This document describes an Extensible Provisioning Protocol (EPP)
   mapping for provisioning and management of organization objects
   stored in a shared central repository.  Specified in Extensible
   Markup Language (XML), this extended mapping is applied to provide
   additional features required for the provisioning of organizations.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-regext-org/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-regext-org-04
https://datatracker.ietf.org/doc/html/draft-ietf-regext-org-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-org-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Linlin Zhou" <[email-masked]>
Date: Fri, 4 May 2018 14:55:54 +0800

Dear all,
The org drafts have been updated to version 04 to address all the received comments during WGLC. And a new section of implemetation status was added.  We'd like to have the chairs' instruction to the next step for these two drafts.

Regards,
Linlin

[email-masked]
 
From: internet-drafts
Date: 2018-05-04 13:51
To: [email-masked]
CC: regext
Subject: [regext] I-D Action: draft-ietf-regext-org-04.txt

 
Abstract:

 

 
_______________________________________________
regext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/regext

---

From: "Gould, James" <[email-masked]>
Date: Fri, 4 May 2018 12:59:03 +0000

Hi,

In reviewing the draft-ietf-regext-org changes in draft-ietf-regext-org-04, I have the following feedback:

  1.  The description of the <org:status> element in 4.2.1 should be “One or more <org:role> elements that contain the role statuses” instead of “Zero or more <org:status> elements that contains the role type”.  I believe the info response should always include at least one role status value.
  2.  The description of the <org:status> element in 4.2.5 should be “Zero or more <org:role> elements that contain the role statuses” instead of “Zero or more <org:status> elements that contains the role type”.
  3.  In 4.2.5, change “A OPTIONAL <org:chg> element” to “An OPTIONAL <org:chg> element”.
  4.  I recommend removing the third paragraph of section 8 “Implementation Status”, since the sub-sections explicitly define the specific implementation status information.  At a minimum, I would like the sentence “Verisign has already implemented this object mapping” to be removed.  There is the misspelling of “objecct” in that third paragraph.
  5.  I also recommend removing section 8.3, since I don’t believe implementation of the Reseller Extension is relevant to the Organization Mapping.
  6.  I would remove the Informative Reference to draft-ietf-regext-reseller from the draft (e.g., section 11.2).

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://verisigninc.com/>
From: regext <[email-masked]> on behalf of Linlin Zhou <[email-masked]>
Date: Friday, May 4, 2018 at 2:56 AM
To: regext <[email-masked]>
Subject: [EXTERNAL] Re: [regext] I-D Action: draft-ietf-regext-org-04.txt

Dear all,

Regards,
Linlin
________________________________
[email-masked]

From: internet-drafts<mailto:[email-masked]>
Date: 2018-05-04 13:51
To: [email-masked]<mailto:[email-masked]>
CC: regext<mailto:[email-masked]>
Subject: [regext] I-D Action: draft-ietf-regext-org-04.txt

Abstract:

---

From: "Gould, James" <[email-masked]>
Date: Fri, 4 May 2018 14:40:57 +0000

Linlin,

In reviewing the draft-ietf-regext-org-ext changes in draft-ietf-regext-org-ext-04, I have the following feedback:

  1.  The minOccurs=”0” needs to be removed from the addRemChgType type of the XML schema to match the description “One or more <orgext:id> element..” in section 4.2.5 “EPP <update> Command” and to ensure that there is not an empty <orgext:add>, <orgext:rem>, or <orgext:chg> element.  The <orgext:add>, <orgext:rem>, and <orgext> elements are optional, but if provided must have at least one <orgext:id> child element.
  2.  Change “One or more <orgext:id> element that contains…” to “One or more <orgext:id> elements that contain…” in section 4.2.5 “EPP <update> Command”.
  3.  I recommend removing the third paragraph of section 8 “Implementation Status”, since the sub-sections explicitly define the specific implementation status information.  At a minimum, I would like the sentence “Verisign has already implemented this extension” to be removed.
  4.  I also recommend removing section 8.3, since I don’t believe implementation of the Reseller Extension is relevant to the Organization Extension.
  5.  I would remove the Informative Reference to draft-ietf-regext-reseller-ext from the draft (e.g., section 11.2).

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Dear all,

Regards,
Linlin

Abstract:

---

From: "Linlin Zhou" <[email-masked]>
Date: Mon, 7 May 2018 09:09:53 +0800

Thanks James.
I will have a quick update today for version 05.

Regards,
Linlin

[email-masked]
 
From: Gould, James
Date: 2018-05-04 22:40
To: Linlin Zhou; regext
Subject: Re: [regext] I-D Action: draft-ietf-regext-org-04.txt
Linlin, 

The minOccurs=”0” needs to be removed from the addRemChgType type of the XML schema to match the description “One or more <orgext:id> element..” in section 4.2.5 “EPP <update> Command” and to ensure that there is not an empty <orgext:add>, <orgext:rem>, or <orgext:chg> element.  The <orgext:add>, <orgext:rem>, and <orgext> elements are optional, but if provided must have at least one <orgext:id> child element.   
Change “One or more <orgext:id> element that contains…” to “One or more <orgext:id> elements that contain…” in section 4.2.5 “EPP <update> Command”. 
I recommend removing the third paragraph of section 8 “Implementation Status”, since the sub-sections explicitly define the specific implementation status information.  At a minimum, I would like the sentence “Verisign has already implemented this extension” to be removed.
I also recommend removing section 8.3, since I don’t believe implementation of the Reseller Extension is relevant to the Organization Extension. 
I would remove the Informative Reference to draft-ietf-regext-reseller-ext from the draft (e.g., section 11.2).
  
—
 
JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com 
 
Dear all,
 
Regards,
Linlin

[email-masked]
 
From: internet-drafts
Date: 2018-05-04 13:51

 
Abstract:

---

From: "Linlin Zhou" <[email-masked]>
Date: Mon, 7 May 2018 10:47:00 +0800

Dear James,
I think the <info> response is in the section 4.1.2. So it should be 
The description of the <org:status> element in 4.1.2 should be “One or more <org:status> elements that contain the role statuses” instead of “Zero or more <org:status> elements that contains the role type”.  I believe the info response should always include at least one role status value.

Linlin

[email-masked]
 
From: Gould, James
Date: 2018-05-04 20:59
To: Linlin Zhou; regext

The description of the <org:status> element in 4.2.1 should be “One or more <org:role> elements that contain the role statuses” instead of “Zero or more <org:status> elements that contains the role type”.  I believe the info response should always include at least one role status value.  
The description of the <org:status> element in 4.2.5 should be “Zero or more <org:role> elements that contain the role statuses” instead of “Zero or more <org:status> elements that contains the role type”.  
In 4.2.5, change “A OPTIONAL <org:chg> element” to “An OPTIONAL <org:chg> element”.
I recommend removing the third paragraph of section 8 “Implementation Status”, since the sub-sections explicitly define the specific implementation status information.  At a minimum, I would like the sentence “Verisign has already implemented this object mapping” to be removed.  There is the misspelling of “objecct” in that third paragraph.    
I also recommend removing section 8.3, since I don’t believe implementation of the Reseller Extension is relevant to the Organization Mapping.  
I would remove the Informative Reference to draft-ietf-regext-reseller from the draft (e.g., section 11.2). 
  
—
 
JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com 
 
Dear all,
 
Regards,
Linlin

[email-masked]
 
From: internet-drafts
Date: 2018-05-04 13:51

 
Abstract: