Subject: [regext] "epp"-scoped XML namespace in the REGEXT EPP Drafts

From: "Gould, James" <[email-masked]>
Date: Thu, 16 Aug 2018 18:23:37 +0000

Hi,

During the IANA expert review of draft-ietf-regext-allocation-token a request was made to scope the XML namespaces to include “epp”.   The request was to change urn:ietf:params:xml:ns:allocationToken-1.0 to urn:ietf:params:xml:ns:epp:allocationToken-1.0.  It was agreed to progress draft-ietf-regext-allocation-token with the existing XML namespace, but with the expectation that future REGEXT EPP drafts will scope the XML namespace with “epp”.  This means considering the following REGEXT working group EPP XML namespace and schema changes.  I believe that all new EPP drafts must follow the new “epp”-scoped XML namespace pattern, and the existing REGEXT EPP drafts should follow the “epp”-scoped XML namespace pattern unless there is an undesired impact.  The new pattern is urn:ietf:params:xml:ns:epp:extension-1.0 for the XML namespace and urn:ietf:params:xml:schema:epp:extension-1.0 for the XML schema.

1.     draft-ietf-regext-epp-fees

a.       urn:ietf:params:xml:ns:fee-1.0 to urn:ietf:params:xml:ns:epp:fee-1.0

b.      urn:ietf:params:xml:schema:fee-1.0 to urn:ietf:params:xml:schema:epp:fee-1.0

c.       I don’t believe changing the XML namespace will have a big impact for draft-ietf-regext-epp-fees, so my recommendation is to change it in draft-ietf-regext-epp-fees-12.

2.     draft-ietf-regext-change-poll

a.       urn:ietf:params:xml:ns:changePoll-1.0 to urn:ietf:params:xml:ns:epp:changePoll -1.0

b.      urn:ietf:params:xml:schema:changePoll-1.0 to urn:ietf:params:xml:schema:epp:changePoll -1.0

                                                                      i.       Currently the schema registration is incorrectly set to urn:ietf:params:xml:ns:changePoll-1.0.  I will take care of this.

c.       I believe this will have a negative impact to existing implementations, since urn:ietf:params:xml:ns:changePoll-1.0 is a mature XML namespace and its associated with poll messages.  Changing the poll message XML namespace will get into the unhandled XML namespace issue.  My recommendation is to keep the existing namespace based on the maturity of the namespace, unless there is a known conflict.

3.     draft-ietf-regext-org

a.       urn:ietf:params:xml:ns:org-1.0 to urn:ietf:params:xml:ns:epp:org-1.0

b.      urn:ietf:params:xml:schema:org-1.0 to urn:ietf:params:xml:schema:epp:org-1.0

                                                                      i.       Currently the schema registration is incorrectly set to urn:ietf:params:xml:ns:org-1.0

c.       I don’t believe change the XML namespace will have a big impact for draft-ietf-regext-org, so my recommendation is to change it in draft-ietf-regext-org-09.

4.     draft-ietf-regext-org-ext

a.       urn:ietf:params:xml:ns:orgext-1.0 to urn:ietf:params:xml:ns:epp:orgext-1.0

b.      urn:ietf:params:xml:schema:orgext-1.0 to urn:ietf:params:xml:schema:epp:orgext-1.0

                                                                      i.       Currently the schema registration is missing, so it needs to be added.

c.       I don’t believe change the XML namespace will have a big impact for draft-ietf-regext-org-ext, so my recommendation is to change it in draft-ietf-regext-org-ext-08.

5.     draft-ietf-regext-bundling-registration

a.       urn:ietf:params:xml:ns:b-dn-1.0 to urn:ietf:params:xml:ns:epp:b-dn-1.0

b.      urn:ietf:params:xml:schema:b-dn-1.0 to urn:ietf:params:xml:schema:epp:b-dn-1.0

c.       I don’t know the impacts of changing the XML namespace for draft-ietf-regext-bundling-registration.

6.     draft-ietf-regext-verificationcode

a.       urn:ietf:params:xml:ns:verificationCode-1.0 to urn:ietf:params:xml:ns:epp:verificationCode-1.0

                                                                      i.       The draft is missing the “urn:” URI prefix in the registration request.  I will take care of this.

b.      urn:ietf:params:xml:schema:verificationCode-1.0 to urn:ietf:params:xml:schema:epp:verificationCode-1.0

                                                                      i.       The draft is missing the “urn:” URI prefix and needs to replace “:ns:” with “:schema:”.  I will take care of this.

c.       Based on Production systems in place leveraging this XML namespace, my recommendation is to keep the existing namespace unless there is a known conflict.

7.     draft-ietf-regext-validate

a.       urn:ietf:params:xml:ns:validate-1.0 to urn:ietf:params:xml:ns:epp:validate-1.0

                                                                      i.       The draft is missing the “urn:” URI prefix in the registration request.

b.      urn:ietf:params:xml:schema:validate-1.0 to urn:ietf:params:xml:schema:epp:validate-1.0

                                                                      i.       The draft is missing the XML schema registration.

c.       I don’t know the impacts of changing the XML namespace for draft-ietf-regext-validate.

8.     draft-sattler-epp-registry-maintenance

a.       urn:ietf:params:xml:ns:maintenance-0.N to urn:ietf:params:xml:ns:epp:maintenance-0.N

                                                                      i.       The draft is missing the XML namespace registration

b.      urn:ietf:params:xml:schema:maintenance-0.N to urn:ietf:params:xml:schema:epp:maintenance-0.N

c.       This draft is setup to support new XML schema namespaces, so my recommendation is to include the “epp”-scoped XML namespace with urn:ietf:params:xml:ns:epp:maintenance-0.3.

I took the action item to bring this up with the working group, so please respond with your thoughts on the new requested pattern and the impacts for the existing drafts.

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://verisigninc.com/>

---

From: "Linlin Zhou" <[email-masked]>
Date: Mon, 20 Aug 2018 10:38:16 +0800

Hi James,
I am going to include this update in the next version.

Regards,
Linlin

[email-masked]
 
From: Gould, James
Date: 2018-08-17 02:23
To: [email-masked]
Subject: [regext] "epp"-scoped XML namespace in the REGEXT EPP Drafts
Hi,
 
During the IANA expert review of draft-ietf-regext-allocation-token a request was made to scope the XML namespaces to include “epp”.   The request was to change urn:ietf:params:xml:ns:allocationToken-1.0 to urn:ietf:params:xml:ns:epp:allocationToken-1.0.  It was agreed to progress draft-ietf-regext-allocation-token with the existing XML namespace, but with the expectation that future REGEXT EPP drafts will scope the XML namespace with “epp”.  This means considering the following REGEXT working group EPP XML namespace and schema changes.  I believe that all new EPP drafts must follow the new “epp”-scoped XML namespace pattern, and the existing REGEXT EPP drafts should follow the “epp”-scoped XML namespace pattern unless there is an undesired impact.  The new pattern is urn:ietf:params:xml:ns:epp:extension-1.0 for the XML namespace and urn:ietf:params:xml:schema:epp:extension-1.0 for the XML schema.   1.     draft-ietf-regext-epp-feesa.       urn:ietf:params:xml:ns:fee-1.0 to urn:ietf:params:xml:ns:epp:fee-1.0b.      urn:ietf:params:xml:schema:fee-1.0 to urn:ietf:params:xml:schema:epp:fee-1.0c.       I don’t believe changing the XML namespace will have a big impact for draft-ietf-regext-epp-fees, so my recommendation is to change it in draft-ietf-regext-epp-fees-12.2.     draft-ietf-regext-change-polla.       urn:ietf:params:xml:ns:changePoll-1.0 to urn:ietf:params:xml:ns:epp:changePoll -1.0b.      urn:ietf:params:xml:schema:changePoll-1.0 to urn:ietf:params:xml:schema:epp:changePoll -1.0                                                                      i.       Currently the schema registration is incorrectly set to urn:ietf:params:xml:ns:changePoll-1.0.  I will take care of this.  c.       I believe this will have a negative impact to existing implementations, since urn:ietf:params:xml:ns:changePoll-1.0 is a mature XML namespace and its associated with poll messages.  Changing the poll message XML namespace will get into the unhandled XML namespace issue.  My recommendation is to keep the existing namespace based on the maturity of the namespace, unless there is a known conflict.3.     draft-ietf-regext-orga.       urn:ietf:params:xml:ns:org-1.0 to urn:ietf:params:xml:ns:epp:org-1.0b.      urn:ietf:params:xml:schema:org-1.0 to urn:ietf:params:xml:schema:epp:org-1.0                                                                      i.       Currently the schema registration is incorrectly set to urn:ietf:params:xml:ns:org-1.0c.       I don’t believe change the XML namespace will have a big impact for draft-ietf-regext-org, so my recommendation is to change it in draft-ietf-regext-org-09.4.     draft-ietf-regext-org-exta.       urn:ietf:params:xml:ns:orgext-1.0 to urn:ietf:params:xml:ns:epp:orgext-1.0b.      urn:ietf:params:xml:schema:orgext-1.0 to urn:ietf:params:xml:schema:epp:orgext-1.0                                                                      i.       Currently the schema registration is missing, so it needs to be added.c.       I don’t believe change the XML namespace will have a big impact for draft-ietf-regext-org-ext, so my recommendation is to change it in draft-ietf-regext-org-ext-08.5.     draft-ietf-regext-bundling-registrationa.       urn:ietf:params:xml:ns:b-dn-1.0 to urn:ietf:params:xml:ns:epp:b-dn-1.0b.      urn:ietf:params:xml:schema:b-dn-1.0 to urn:ietf:params:xml:schema:epp:b-dn-1.0c.       I don’t know the impacts of changing the XML namespace for draft-ietf-regext-bundling-registration.6.     draft-ietf-regext-verificationcodea.       urn:ietf:params:xml:ns:verificationCode-1.0 to urn:ietf:params:xml:ns:epp:verificationCode-1.0                                                                      i.       The draft is missing the “urn:” URI prefix in the registration request.  I will take care of this.b.      urn:ietf:params:xml:schema:verificationCode-1.0 to urn:ietf:params:xml:schema:epp:verificationCode-1.0                                                                      i.       The draft is missing the “urn:” URI prefix and needs to replace “:ns:” with “:schema:”.  I will take care of this.c.       Based on Production systems in place leveraging this XML namespace, my recommendation is to keep the existing namespace unless there is a known conflict.7.     draft-ietf-regext-validatea.       urn:ietf:params:xml:ns:validate-1.0 to urn:ietf:params:xml:ns:epp:validate-1.0                                                                      i.       The draft is missing the “urn:” URI prefix in the registration request.b.      urn:ietf:params:xml:schema:validate-1.0 to urn:ietf:params:xml:schema:epp:validate-1.0                                                                      i.       The draft is missing the XML schema registration.c.       I don’t know the impacts of changing the XML namespace for draft-ietf-regext-validate.8.     draft-sattler-epp-registry-maintenancea.       urn:ietf:params:xml:ns:maintenance-0.N to urn:ietf:params:xml:ns:epp:maintenance-0.N                                                                      i.       The draft is missing the XML namespace registrationb.      urn:ietf:params:xml:schema:maintenance-0.N to urn:ietf:params:xml:schema:epp:maintenance-0.Nc.       This draft is setup to support new XML schema namespaces, so my recommendation is to include the “epp”-scoped XML namespace with urn:ietf:params:xml:ns:epp:maintenance-0.3.

Thanks,
  
—
 
JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com