Subject: [regext] [Editorial Errata Reported] RFC7484 (5461)

From: RFC Errata System <[email-masked]>
Date: Tue, 14 Aug 2018 05:14:14 -0700 (PDT)

The following errata report has been submitted for RFC7484,
"Finding the Authoritative Registration Data (RDAP) Service".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5461

--------------------------------------
Type: Editorial
Reported by: Pieter Vandepitte <[email-masked]>

Section: 4

Original Text
-------------
{
       "version": "1.0",
       "publication": "YYYY-MM-DDTHH:MM:SSZ",
       "description": "Some text",
       "services": [
         [
           ["net", "com"],
           [
             "https://registry.example.com/myrdap/"
           ]
         ],
         [
           ["org", "mytld"],
           [
             "http://example.org/"
           ]
         ],
         [
           ["xn--zckzah"],
           [
             "https://example.net/rdapxn--zckzah/",
             "http://example.net/rdapxn--zckzah/"
           ]
         ]
       ]
   }

Corrected Text
--------------
{
       "version": "1.0",
       "publication": "YYYY-MM-DDTHH:MM:SSZ",
       "description": "Some text",
       "services": [
         [
           ["net", "com"],
           [
             "https://registry.example.com/myrdap/"
           ]
         ],
         [
           ["org", "mytld"],
           [
             "http://example.org/"
           ]
         ],
         [
           ["xn--zckzah"],
           [
             "https://example.net/rdap/xn--zckzah/",
             "http://example.net/rdap/xn--zckzah/"
           ]
         ]
       ]
   }

Notes
-----
Include a slash between rdap and xn--zckzah. rdapxn--zckzah is not a valid a-label

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7484 (draft-ietf-weirds-bootstrap-11)
--------------------------------------
Title               : Finding the Authoritative Registration Data (RDAP) Service
Publication Date    : March 2015
Author(s)           : M. Blanchet
Category            : PROPOSED STANDARD
Source              : Web Extensible Internet Registration Data Service
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: "Marc Blanchet" <[email-masked]>
Date: Tue, 14 Aug 2018 08:29:22 -0400

Thanks for reporting this. You are right that the intent of the example 
was not as written. It should have been as you pointed:
https://example.net/rdap/xn--zckzah

So I would agree with the proposed change.

Regards, Marc.

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 14 Aug 2018 12:33:09 +0000

> -----Original Message-----
> From: regext <[email-masked]> On Behalf Of Marc Blanchet
> Sent: Tuesday, August 14, 2018 8:29 AM
> To: RFC Errata System <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: [EXTERNAL] Re: [regext] [Editorial Errata Reported] RFC7484
> (5461)
>

I agree. It's not syntactically invalid, but the corrected text represents the intent of the example.

Scott

> > The following errata report has been submitted for RFC7484, "Finding
> > the Authoritative Registration Data (RDAP) Service".
> >
> > use "Reply All" to discuss whether it should be verified or rejected.
> > When a decision is reached, the verifying party can log in to change
> > the status and edit the report, if necessary.
> >
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext