Subject: Re: [renum] I-D Action:draft-liu-ipv6-renum-conflicts-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Mon, 14 Mar 2011 15:33:03 +1300

Hi,

A few personal comments.

>    the host may even receive both the RA messages and DHCP-v6
>    reconfiguration messages and finds the prefixes in the two protocols
>    are different. This means serious network configuration error
>    occurring.

It's possible that this indicates a configuration error. It's
equally possible that it is a perfectly normal situation. If the
site is connected twice to the Internet via different CPEs, and
one of them allocates addresses using SLAAC and the other one
using DHCP, this is exactly what would happen. Each host would
get two addresses and everything would work normally.

I think you need to explain exactly which case is an error that
would cause problems, and how a host or router could tell
automatically that there is a problem, rather than a normal case
of multiple prefixes and multiple exit routers.

So let's say that what the host will report is a *possible*
conflict, not a definite conflict.

> 3  Conflict Report Mechanism 
> 
>    As analyzed above, while renumbering, hosts received address  
>    configuration messages (either ND or DHCP protocol messages), if the 
>     messages conflict with existing/previous configuration mechanism,  
>    hosts report address configuration policy conflict information to the
>    network.

Again - how do you know there is a conflict? Maybe the DHCP
service has crashed, so the network falls back automatically
to SLAAC? Also, how large is the time interval for detecting a
possible conflict? SLAAC followed by DHCP within one minute?
One hour? One month?

One case that definitely would seem strange would be if
an RA deprecates a prefix received from DHCP, or if DHCP
deprecates a prefix received in an RA. That would certainly
suggest that something very funny is happening.

Regards
   Brian

---

From: Jiangsheng <[email-masked]>
Date: Mon, 14 Mar 2011 03:11:45 +0000

Hi, Brian,

Thanks for your valuable comments. It is helpful to improve our draft and our understanding for the issues.

However, the draft submission tool is now closed. We are not able to make an update before the Prague meeting. We will try to address your comments in the meeting presentation and integrated into the next version after Prague meeting.

Regards,

Sheng
________________________________________
From: [email-masked] [[email-masked]] on behalf of Brian E Carpenter [[email-masked]]
Sent: 14 March 2011 10:33
To: [email-masked]
Subject: Re: [renum] I-D Action:draft-liu-ipv6-renum-conflicts-00.txt

Hi,

A few personal comments.

Regards
   Brian
_______________________________________________
renum mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/renum